[Last Call] Learn how to a build a cloud-first strategyRegister Now

x

Networking Protocols

11K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hi all, please am submitting a CRQ for a simple static route via vrf
i.e.
ip route vrf  (vrf name) <ip address/mask> next hop.
I know it will not be approve if I did not put a statement about testing.
Please can anyone suggest any simple testing statement for static routing?
0
Fill in the form and get your FREE NFR key NOW!
LVL 1
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Good Day,

We have a Canon MX 920 Series printer on one IP Range, and the user on another IP Range.

When installing the printer software/driver it does a scan for printers on the Computer's subnet but finds none. It does not give the option to enter the IP Address, how do I setup/install a Canon MX 920 Series printer on a PC using the WSD (Web Services on Devices) protocol for printing if the two are on different IP Ranges?

Thank you for assistance.

Reinhard.
0
Anyone have an idea what this event ID means can find much on it.  

Team NIC /DEVICE/{7EAB1532-1AE7-400F-8D25-EE398702FF2A} (Friendly Name: Mellanox ConnectX-3 Pro Ethernet Adapter #2) has inconsistent consolidated NDIS QoS settings
0
What lower-layer protocol encapsulates SNMP messages?
0
any of you ever seen a lan ip that starts with 205.162.2.x ?   is this normal?
0
Hi,

Specs:
Server 2016
Java (32bit) Version 8 Update 151

We installed Atlassian Confluence on premises and would like to communicate to it using SSL.
Atlassian has a nice manual that we carried out.
We have a wildcard certificate (Comodo) that we wanted to use for this.

So, we created a keystore, imported the certificate (.crt) and pointed the server configfile to it:

<Connector port="8443" maxHttpHeaderSize="8192"
                   maxThreads="150" minSpareThreads="25"
                   protocol="org.apache.coyote.http11.Http11NioProtocol"
                   enableLookups="false" disableUploadTimeout="true"
                   acceptCount="100" scheme="https" secure="true"
                   clientAuth="false" sslProtocols="TLSv1,TLSv1.1,TLSv1.2" sslEnabledProtocols="TLSv1,TLSv1.1,TLSv1.2" SSLEnabled="true"
                   URIEncoding="UTF-8" keystorePass="password"
				   keystoreFile="D:\somepath\atlassian"
				   />

Open in new window


Than we downloaded the root and intermediate certificates from Comodo and imported them in the cacerts store.
After that we restarted the Atlassian Confluence service.

We connect to Confluence using this url: https://app##.domain.local:8443

When we use Chrome we get an: ERR_SSL_VERSION_OR_CIPHER_MISMATCH error
When we use Firefox we get a: …
0
I am writing a netflow collector in .net, which has lots of interesting challenges including reading the RFC!

However, I need a specific piece of information  

Here is a link to a copy of the RFC:

https://www.ietf.org/rfc/rfc3954.txt


From this I read this excerpt:
The life of a template at the Collector is limited to a fixed refresh
   timeout.  Templates not refreshed from the Exporter within the
   timeout are expired at the Collector.  The Collector MUST NOT attempt
   to decode the Flow or Options Data Records with an expired Template.

I cannot find any default expiry timeframe for a netflow Flowset Template.  

It says it must be configurable at the exporter and the collector.  When I set up a PRTG to collect netflow packets, there was not an option to specify the template expiry.  I can't see any record in the RFC that the exported can use to tell the collector when to expire templates.  PRTG works though.  

Therefore there must be a reasonable default value for how long to keep an un-refreshed template before expiring it.  

My question is, what is the default timeframe to expire a template - OR - how else can the collector learn this from the exporter? (someone manually configuring it is not the answer I want)

There must be some way in which netflow collectors work out of the box without the user specifying the template expiry.  I need to do this.
0
Hello all, this is my 1st questions in this forum.  hopefully, I am in the correct place.  if not, my apologies.

Hoping to get some guidance on dual WAN links configuration... here goes...

I presently have 1 x 100mb fibre from Rogers as our main WAN link.  actually, I also have 100mb BELL MPLS as well, soon to be decommissioned.  Also have 2 x 3750 cisco - stacked.

We recently got another 100mb link to be used as our backup link if the primary fails.

Rogers primary - EIGRP
Bell - OSPF
Rogers Backup - will be EIGRP

presently have VLAN 340 carved out for PRIMARY link.  will use VLAN 350 for BACKUP.

like to get some guidance how to configure the 2nd link to be a failover link in case the PRIMARY goes down.

I am no way a routing expert...
what would be an acceptable configuration that I can apply?  Nothing fancy, just wanted to make backup link available as quickly as possible when primary goes down.

this is what I presently have in my PRIMARY EIGRP:
router eigrp 1
 network 10.30.0.7 0.0.0.0
 network 192.168.30.1 0.0.0.0
 network 192.168.31.1 0.0.0.0
 network 192.168.32.1 0.0.0.0
 network 192.168.33.1 0.0.0.0
 network 192.168.36.1 0.0.0.0
 network 192.168.37.1 0.0.0.0
 network 192.168.130.1 0.0.0.0
 redistribute ospf 1 metric 1500 20000 255 1 1500
 redistribute static
 passive-interface default
 no passive-interface Vlan340

the OSPF lines will go away eventually.


is it best to use VLAN or L3 interface?  does it matter or is …
0
My server admin is asking of me to open up 1000 ports for a server to run passive FTP. Is there any other way to have passive FTP without opening up all those ports?
What concerns should I be aware of security wise in doing this?
0
I am using file Zilla to connect an ftp server but unfortunately unable to do so below is the error

Status:      Resolving address of ftp2.churchs.com
06:38:14      Status:      Connecting to 209.208.247.23:21...
06:38:14      Status:      Connection established, waiting for welcome message...
06:38:15      Status:      Insecure server, it does not support FTP over TLS.
06:38:15      Status:      Logged in
06:38:15      Status:      Retrieving directory listing...
06:38:34      Command:      PWD
06:38:34      Response:      257 "/CFC-Analytics" is current directory.
06:38:34      Command:      TYPE I
06:38:34      Response:      200 Type set to I.
06:38:34      Command:      PORT 10,139,105,11,209,15
06:38:34      Error:      Disconnected from server: ECONNABORTED - Connection aborted
06:38:34      Error:      Failed to retrieve directory listing
0
What does it mean to be "Always On"?
LVL 5
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

show ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable


Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                                                                 Prio/Mode
10.0.0.193        TenGigabitEthernet1/2    11w1d/00:01:29    v2    1 / S P G
10.0.0.209        TenGigabitEthernet3/1    11w0d/00:01:41    v2    1 / S P G
10.0.16.13        TenGigabitEthernet4/7    11w2d/00:01:25    v2    1 / G
10.0.16.9         TenGigabitEthernet4/8    11w2d/00:01:27    v2    1 / G


What does it mean when I only have the G in the mode column?

The link at 4/7 and 4/8 is eBGP peer.
0
I am using this Arris NVG443 router in conjunction with an Obitalk 200 to use internet (DSL)  VOIP to make and receive phone calls. The problem is no matter what service I use ie. Google voice (free), Onesuite (subscription),  ALL calls made and received drop within minutes. Using Onesuite provider  all calls drop at exactly 9 minutes every time. Obitalk support says to configure my router to this:
In order for your OBi to be able to send packets w/o interruption, please configure your router as follows:

Allow Outgoing:
TCP Ports: 6800, 5222, 5223
UDP Ports: 5060, 5061, 10000 to 11000, 16600 to 16998, 19305
Allow Incoming on UDP Port: 10000

Problem is: There is nowhere to enter all these ports? Just one range.
 Router has port forwarding and port triggering . In port forwarding there is only a global port range  one port # to another port #, and one base port.
In port triggering there is just a trigger range same as above, one port to one port, and one open port range same as above.

Not sure what to enter into router and can't seem to find any answers ?
0
Hi, I want to open connection from RHEL to FTPS server, receive "Fatal error: gnutls_handshake: A TLS packet with unexpected length was received" error when start to transfer file to the FTPS server.

Any idea?

 lftp -v
LFTP | Version 4.0.9 | Copyright (c) 1996-2010 Alexander V. Lukyanov

LFTP is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with LFTP.  If not, see <http://www.gnu.org/licenses/>.

Send bug reports and questions to the mailing list <lftp@uniyar.ac.ru>.

Libraries used: Readline 6.0


FileCopy(0xbcd2c0) enters state INITIAL
FileCopy(0xbcd2c0) enters state DO_COPY
---- dns cache hit
---- Connecting to x.com (10.0.0.1) port 21
copy: get hit eof
copy: waiting for put confirmation
FileCopy(0xbcd2c0) enters state CONFIRM_WAIT
GNUTLS: HSK[0xbfc2c0]: Keeping ciphersuite: DHE_RSA_AES_128_CBC_SHA1
GNUTLS: HSK[0xbfc2c0]: Keeping ciphersuite: DHE_RSA_CAMELLIA_128_CBC_SHA1
GNUTLS: HSK[0xbfc2c0]: Keeping ciphersuite: DHE_RSA_AES_256_CBC_SHA1
GNUTLS: HSK[0xbfc2c0]: 

Open in new window

0
Hello Experts,
Please suggest how to configure Precision Time Protocol (PTP) client with Mellanox (driver: mlx4_en, version: 4.1-1.0.2 (27 Jun 2017), firmware-version: 2.40.7000) on Centos 6.8 64bit system.
0
Hi All,

Could you all help with this config I'd like to implement OSPF ?& if this is the correct configuration to implement?



MAN(config-if)# ip address 10.10.12.13 255.255.255.0
MAN(config-if)# no shut

BEL(config-if)# ip address 10.10.12.12 255.255.255.0
BEL(config-if)# no shut

2. The routing OSPF between routers:
MAN(config)# router OSPF 1
MAN(config-router)# network 10.10.14.0 0.0.0.255 a 0
MAN(config-router)# network 10.10.12.0 0.0.0.255 a 0
MAN(config-router)# network 10.200.3.0 0.0.0.255 a 0

BEL(config)# router OSPF 1
BEL(config-router)# network 10.10.120 0.0.0.255 a 0
BEL(config-router)# network 10.10.11.0 0.0.0.255 a 0
BEL(config-router)# network 10.202.3.0 0.0.0.255 a 0

LON(config)# router OSPF 1
LON(config-router)# network 10.10.0.0 0.0.0.255 a 0
LON(config-router)# network 10.10.0.0 0.0.0.255 a 0
LON(config-router)# network 10.0.3.0 0.0.0.255 a 0

BATH(config)# router OSPF 1
BATH(config-router)# network 10.0.14.0 0.0.0.255 a 0
BATH(config-router)# network 10.0.10.0 0.0.0.255 a 0
BATH(config-router)# network 10.0.3.0 0.0.0.255 a 0
OSPF-NEW.PNG
0
Hello, I have Windows 10 and Windows 7 systems  in a SBS2011 domain environment and at least once a day the windows explorer freezes and I have to reboot. After selecting reboot it hangs at reboot mode. I have to force it to shutdown and and start it again for it to work.  Most of the time windows explorer does not work and also internet access goes away too. I even can not access the C-Drive and the Network Drives. Nothing at all.  I have Symantec Endpoint and Malware Byte endpoint protection installed on these systems. Please help.

Thank you
0
Can someone explain how to configure VB.net so receive data from a push API using the WAMP protocol?

I have tried several different configurations under the vb.net data sources, but none seem to pickup the data?
 

https://poloniex.com/support/api/
0
I need to see the DNS resolution requests of my applications audited and if necessary modified before being sent. I suppose the easiest would be a local resolver that would review my requests before forwarding them to the resolver of my ISP? Another way would be to monitor and be able to override UDP/53 traffi (something I have no clue about). Is there an open source I could use?
Also, I would need this on all OS.
How would you do that? Or would there be a free solution that exists?
Need: support of iDNs as per RFC 5895 for the wole machine (transparent to applications), management of variants, parental control, typos correction. Etc.
Thank you!
0
Hi,

Bit of an odd one, I have set the correct NTP servers up on the config of a yealink T23G phone, having run a pcap I can see that it's dns queries to the NTP server are being refused. The phones are on a segmented VLAN network, as far as I know other handsets on different VLANs are not having this problem and there is nothing unique about how this is set up compared to others.

I have tried upgrading the firmware and different NTP time servers. This is affecting multiple handsets

The message I'm seeing a lot in the capture is that "The Server is not an authority for the domain"

I've attached a sample of the queries I'm seeing in the PCAP.

Any ideas guys?

Many thanks,
Tim
0
Industry Leaders: We Want Your Opinion!
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Hi !

Is there any way to force the HSRP election process ? I want to change the Standby router to become Active. I am changing the priority value but it s not falling over to the other device.
1
Hi All,
I have been at this all day to no avail.
I am using Yealink IP Phones. The customer now wants to run his laptops with the phones. So the PC's run through the phones.
The phones use their own gateway on port 1 and the PC's use their own on port 24.
In addition to VID 1 created VID 20 for the Data on all ports and Voice on VID 50 Voice as per this example I found.
Phones and PC's are on all the ports except 1 and 24.
AlI really want to do is give priority to the IP Phones.

[url="http://www.dlink.com/uk/en/support/faq/switches/layer-2-gigabit/dgs-series/es_dgs-1210_como-configurar-voice-vlan"]

The phones don't work and neither do the PC's when activated.
I have also setup the phones WAN port with VID 50 and the PC port with VID20.

Any help is welcome
I have not tried tagging P1 and P24 on all 3 the VLANS.  

Thanks
Ken
0
I am using the following query to get the CNAME record to load my site properly. The issue: The code below works ... but only if refreshed a couple of times.

Query ::

$recsDNS = dns_get_record($_SERVER['HTTP_HOST'], DNS_CNAME );
print_r($recsDNS);

Not getting CNAME records Properly, SOme times coming and some times Not.

If I use DNS_ALL :: After refreshing 3 to 4 times i am getting CNAME records.
0
Hi Experts,

Is it possible to filter a source AS Path? Situation I have is that BGP was set up under AS 1 and instead of reconfiguring it (because I have a few VRFs that would be affected) I was wondering If I could just filter AS1 on my advertisements?

Thanks,
0
hi team
I have couple of question on packet loss
1.  what all steps we need to take for packet loss
2. what are avialbale tools for checking packet loss
3. what are possibilities  of packet loss
4. what are the parameters to check packet loss
0
I want to configure 1 ISP that delivers two MPLS circuits via different routers that i need to connected to a cisco 3750 layer 3 switch or single router. The provider is delivering me two MPLS circuits but i been challenge to get the circuits configure on a L3 Cisco switch or router, that when a circuit is very busy it can use the second circuit.

attach is a topology. if a good configuration is out there please help me on this.

hope the topology is good.
Topology.docx
0

Networking Protocols

11K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.