Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.

Share tech news, updates, or what's on your mind.

Sign up to Post

I have a scenario where I need a load balancer
When a new tcp connection is initiated from the client, the load balancer much assign a server, and always route all traffic from that that to the server it initially picked

When I netstat, I see and ipaddress and port for the client. (connection) so it makes sense to use this as the identifier for that client

Is there any software in exisitance to do this? Or do. I need to write my own?
0
ASBR Without Valid Area

I have noticed when I redistribute connected subnets  on OSPF Stub Area I get the message below :

R3(config-router)#redistribute connected subnets
R3(config-router)#
*May 20 21:12:59.726: %OSPF-4-ASBR_WITHOUT_VALID_AREA: Router is currently an ASBR while having only one area which is a stub area

Open in new window


However OSPF will still take that command as shown below:

R3#sh run | sec ospf
router ospf 1
 area 1 stub
 redistribute connected subnets
 network 192.168.23.0 0.0.0.255 area 1
R3#

Open in new window


So any one can explain the meaning of that message ?

Thank you
0
ABR in Stub area not blocking External Routes
ar
In the topology above I have configured R2 area 1 as stub the same for R3
R3 is blocking External Routes E2 and injecting IA default routes, but R2 is still allowing E2 [External routes]

R2#sh run | sec ospf
router ospf 1
 area 1 stub
 network 192.168.12.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 1
R2#

Open in new window



R3#sh run | sec ospf
router ospf 1
 area 1 stub
 network 192.168.23.0 0.0.0.255 area 1
R3#

Open in new window


R2#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      7.0.0.0/32 is subnetted, 1 subnets
O E2     7.7.7.7 [110/20] via 192.168.12.1, 00:41:55, Ethernet0/0
      9.0.0.0/32 is subnetted, 1 subnets
O E2     9.9.9.9 [110/20] via 192.168.12.1, 00:41:55, Ethernet0/0
      11.0.0.0/32 is subnetted, 1 subnets
O E2     11.11.11.11 [110/20] via 192.168.12.1, 00:41:55, Ethernet0/0
O     

Open in new window

0
NSSA Default-Information-Originate

I would like to know  the OSPF area type where we use  the command NSS Default-Information-Originate

---On Stub area : we configure all routers inside the are with : Area X  Stub
--- On Totally Stub : we configure all routers inside the area with :Area X Stub, and the ABR with Area X Stub Non-Summary
---On NSSA area  : We configure all routers inside the are with : Area X NSSA
--- On Totally NSSA: We configure all router inside the are with : Area X NSSA and the ABR with Area X NSSA Non-Summary

However I am not sure how we call the area type where we configure :NSS Default-Information-Originate


Thank you
0
OSPF Routing table not showing OSPF Routes
os
in the topology above

I have configured ospf on R5,R6,R8,R9 in Area3 , however the OSPF routes show only on R5 and R6 but not for Area3 ,  R8 and R9 do not show OSPF routes in their table
I can ping between all 4 routers

Though every now and then a message about OSPF Adjacency comes up on the console
*May 17 21:46:07.003: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.99.9 on Ethernet0/0 from LOADING to FULL, Loading Done
but when I run Show IP Route , no OSPF routes show up

R8#  sh ip route
      192.168.99.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.99.0/24 is directly connected, Ethernet0/0
L        192.168.99.8/32 is directly connected, Ethernet0/0
R8#

Open in new window



R9#show ip route
      192.168.99.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.99.0/24 is directly connected, Ethernet0/0
L        192.168.99.9/32 is directly connected, Ethernet0/0
R9#

Open in new window


it looks like that there is also Neighborship formed:
R8#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.99.5      1   2WAY/DROTHER    00:00:35    192.168.99.5    Ethernet0/0
192.168.99.6      1   FULL/DR         00:00:33    192.168.99.6    Ethernet0/0
192.168.99.9      1   FULL/BDR        00:00:[code]

Open in new window

[/code]

R5 and R6 OSPF table does not show the OSPF routes for Area 3 which is the Network 192.168.99.0/24

R5#sh ip …
0
IP OSPF Network Point to Point on Frame Relay

os
I have configured IP OSPF Network Point to Point on R1,R2,R3 serial0 Interfaces.

however from R1 , I do not see both neighbors together, it keeps showing sometimes the 2.2.2.2 which is R2 and sometimes 3.3.3.3 which is R3
I am not sure why it is doing this flapping.

Any help will be very appreciated

Thank you

R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:00:38    123.0.0.3       Serial0/0
R1#

Open in new window


R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:00:38    123.0.0.2       Serial0/0

Open in new window



I wonder if the reason that neighborship is flapping because all 3 routers are in the same subnet, and Point to point requires that they need to be in separate subnets ?
0
I am just curious if every ISPs will accept a /24 subnet for BGP advertisement.  If not, is there a way to find out what they do accept and/or who doesn't accept this?

Secondly, we have a primary ISP that is advertise a /16 and on the secondary ISP, we advertised a /24 subnet (that is included in the /16 of the primary ISP) to test speed and throughout..etc to avoid having to bring out the primary circuit.

We're seeing some different throughput when testing with speedtest.net and when changing the server to a local city, we're getting latency error so not sure about this.

The /24 is a local subnet on the second ISP router and I Just advertised this under the BGP statement and we have a default route out with a next hop of our second ISP.  The second ISP has a static route for this /24 to us and a default route out to the internet.

Not sure what might be causing some latency errors when changing the speedtest to some local servers.   It seems to be fine if we change the server to Seattle, Washington for example and I'm located in SF.

thank you!
0
OSPF LSA  Updates and Hellos

on the Screenshot below , we have DR and BDR

I want to know if other routers will have to send an update(LSA type 1) to DR and BDR, or they will send an update (LSA type 1) just to the DR, and the DR will send (LSA type2) to all the routers including the BDR

OR

Other Routers  will  send an update(LSA type 1) to 224.0.0.6 then DR and BDR will get the Update but only the DR that will send (LSA type 2) to 224.0.0.5 (where all other routers are listening to)

in case of the second case , I wonder how does BDR get LSA type 2 from DR

Thank you

DR
0
Understanding IP OSPF Network Types.

On the screenshot below, it shows a table of IP OSPF Network Types.
Regardless of how neighbors are discovered, if DR/BDR are elected,etc...
I would like to know in which scenario should I use one type and not the other.

Thank you

ospf
1
I've been examining the network routing table on my Windows computer, and I'm wondering why there are 3 entries instead of just 2.

At a command prompt I type "route print".

The resulting display has columns "Network Destination | Netmask", "Gateway", "Interface".

I'm wondering what the difference is between a Gateway and an Interface.

I'm thinking of a very simple Dial-Up Network setup:
Network AdapterThe Network Adapter has the following IP address:
Network Adapter IP addressIs this the "Gateway" IP address, or the "Interface" IP address? And what would the other IP address be for

If I wanted my program to send some data to IP 1.1.1.1, and I want this data to go out over Network Adapter 7.7.7.7, I could add to the network routing table a line with: 1.1.1.1   255.255.255.255 for Destination and Mask, then would I add 7.7.7.7 to the "Gateway" or to the "Interface"?
0
I've usually tried to attract inbound traffic to one edge router over another by prepending AS numbers on the less preferred edge router. Are there other common methods to suggest that you'd prefer traffic at one edge bgp router than another?
0
My understanding is for sockets, connect sets the destination IP address, and bind sets the return IP address.

What would happen if I created two sockets, socka and sockb, and did:
socka.connect(10.1.1.2);
socka.bind(99.0.0.1);
sockb.connect(99.0.0.1);

Open in new window

If I now send some data to sockb, will the data go to socka and then will socka forward that data to IP address 10.1.1.2?
0
vSphere HA Agent on this Host[Esx 6.5] Could not Reach Isolation Address 10.X.X.X  ie Gateway IP

Raised with Network Team saying all fine from Network end while we are not able to ping anything except Host IP ,No result in traceroute too

Please assist for required action plan to fix the issue
0
Does anyone know what RADB routes are?  We are requesting a LAN public IP from the Internet carrier that was promised.  Now they give us run around saying the route set belongs to RADB and they cannot update RADB route sets.  If the customer wants their prefix [1.1.1.0/24] to be routed via BGP, they would need to contact RADB to have them update their route set.  
We do not need a BGP.  Just requesting a public LAN IP address.

Does anyone know what does prefix belongs to radb mean?  I'm running the Whois and looks like the prefix belongs to my internet carrier.  Not to radb some sort.
Does the carrier give me a BS runaround on this?  It feels like it :)
0
Env: Cisco Nexus 9508 with an 10Gbase-LR SFP connecting to the carrier. For the last few days the interface has been racking up input errors and CRC. Hundreds ever few seconds. We've replaced the SFP and we replaced the fiber from the SFP to the patch panel.

What trouble-shooting methods do I have my disposal once the carrier gets on site? I've had these maddening all night affairs where the vendor says "we're all clean to our next device in Deluth (or wherever). Besides replacing optics, shutting/no shutting the interface, what other tools would help to isolate the cause of these errors? Thank you.

(BTW A tech at the data center tried to throw us a loop but the interface went down from UDLD. If there's a way to make a hard loop to us more informative that would be good to know too)
0
Reading BGP Routing table

In BGP Routing table displayed below, I would like to know the meaning of "i" .
there is "i" under Network column and another "i" under Path column.

Thank you

BGProuting.JPG
0
I am setting up our infrastructure to enable remote phones on a new phone system we installed. The phone vendor requirements were fairly simple, port forward UDP 443 to a device on our DMZ(the virtual machine). Easy, or so I thought.



Everything looks good from the Firewall end. If I plug in the phone, I can see the traffic hit the firewall, and be forwarded to the device lets say is 11.11.11.11. No issues I can see from the firewall end. It's a Barracuda NG F280, I have gone over it over and over with Barracuda support and they see nothing from their end.



The issue is that traffic never hits 11.11.11.11. I have set up a monitoring VM on my DMZ with wireshark, never see the traffic. The VM has a packet monitor built in so I can create packet captures on the interface directly, never see the traffic. If I run a netcat cmd for UDP 443, I see nothing. I see other traffic. If I ping 11.11.11.11 from anywhere else on the network, I see it. There is nothing between this device and the Firewall, except the VMWare hypervisor.



I am at a loss at this point. My Firewall vendor says it isn't on their end, my phone vendor says it isn't on theirs. I believe that to be the truth, but I don't know what else it could be. Does anyone have any ideas? Only thing I can think of is something in VMWare, but I have never seen VMWare block traffic like that before.

Some more info:

Seems localized in some way to port number. If I change my forwarding rule to port 3300 instead…
0
I'm trying to understand the concept of port.

I know the standard port number for http is 80.

is a particular protocol, such as http , tied to a particular port and it doesn't work in any other port?
0
Spanning tree and working production environment.

Greetings, my work place has spanning tree and I have limited experience with Spanning tree.  I was charged with setting up new Wireless controllers and to route internet only traffic through a specific "Internet Only" VLan.  I have setup the configuration how the vendor suggested.  Basically:

- Create DHCP scope and assign the DHCP Gateway to a VLAN on the controller (created for the Guest VLan).  
- Then create a Vlan for Internet Only and assign an IP address to that VLAN(From the DHCP Scope).  
- Then assign that Internet Only VLAN to an available untagged port on the Wireless Controller.
- The assign an available IP address from the Internet only VLAN on teh wireless controller.
- Then connect that port (0/0/3) to the Internet Only VLAN with its own separate connection.

The problem, is that the Wireless controller is showing that port 0/0/3 is blocking.  Port 0/0/3 is the port connected to the Internet Only VLan.

Port Status
-----------
Slot-Port  PortType  AdminState  OperState  PoE  Trusted  SpanningTree  PortMode  Speed   Duplex  PortError
---------  --------  ----------  ---------  ---  -------  ------------  --------  -----   ------  ---------
0/0/0      GE        Enabled     Down       N/A  Yes      Disabled      Trunk     Auto    Auto    -
0/0/1      GE        Enabled     Up         N/A  Yes      Forwarding    Trunk     1 Gbps  Full    -
0/0/3      GE        Enabled     Up         N/A  Yes  …
0
I am looking to upgrade my router to a router that can handle a higher volume and faster, but the number is confusing me a little.

I currently have a Ubiquiti ER-X and looking at the ERPoe‑5, I compared all the specs [RAM, Storage size, 1518 byte packets] and the ERPoe‑5 is higher or same, except for 64 bytes packets which the EX-R the throughput and pps, same is with the CPU frequency on theses 2 the EX-R is higher [EX-R throughput 957 Mbps pps 1,400,000 and the ERPoe‑5 throughput 490 Mbps pps 730,000, CPU frequency ER-X 880 MHz ERPoe‑5 500 MHz both CPU core count 2]

Please help.
0
I had this question after viewing Stuck in INIT/DROTHER.

I have the same problem? OSPF INIT/Drother between Cisco Switch L3 and Cisco Firewall ASA?
I checked everything all the configuration.It looks good however it doesn’t work? I don’t really understand why?
0
Hi Experts,

     I want to configure elasticsearch to a new IP address.  Currently, it is on a dev machine.  But I want to configure to a new IP address.

currently, in my elasticsearch.yml the current settings are

network.host:0.0.0.0

path.data : /var/lib/elasticsearch

path.logs: /var/logs/

inside /var/lib/  elasticsearch is link file to links to /mnt/elasticsearch

I want to install elasticsearch to new machine.  machine ipaddress is eg., 5*.25*.22*.1*,  

My questions are,

Do I have to install elastic search on this new IP address,

or can I set this new IP address as network.host path in the existing dev machine?

or do I have backup and restore to the new ipaddress?

Please suggest how to configure?

I had tried changing the network host to the new IP address, and copied elasticsearch folder to the new machine and set the path to path.data and I had set path.logs to new machine folder paths and restarted elastic search from the existing dev machine.

elastic search failed to start.

Please suggest how to configure the elastic search on this new machine.

With many thanks,

Bharath AK
0
How does a website (or podcast) send out notification of updates?

I have subscribed to a sample podcast and see that I do get alerts (upper right corner of screen) on my MacBook. I have not yet verified those alerts only show up when I have Chrome opened, but that because I always have Chrome open.

Here is what I see under Settings as the Allowed sites.

Screen-Shot-2018-11-26-at-11.48.02-A.png
What is port 443?

Does this mean my port 443 is open to alerts from these two websites?

Please let me know how this works, since I am considering using this for my podcast. Or, if you give me the name of this type of communications, I can look for solutions which I can adopt to have this behavior.

Thanks.
0
picI have router on a stick fa0/0.10 10.10.10.1/30 on R1 and an IP address assigned to R2 f0/0 10.10.10.2/30. I am trying to understand why I cannot ping R2 from R1?

pic
R1 config:
interface FastEthernet0/0
 no ip address
 duplex full
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.10.10.1 255.255.255.252
!

Open in new window


R2 config:
interface FastEthernet0/0
 ip address 10.10.10.2 255.255.255.252

Open in new window

0
Wonder your folks opinion.  How do you approach this questions from executives.  
 "what do you think is better 74Mb DSL or 60Mb cable?"  :)
0

Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.