Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.

Share tech news, updates, or what's on your mind.

Sign up to Post

I would like to have an Expert explain line by line (in plain English) the configuration below.

Thank you in advance.

Hub(config)#ip route 0.0.0.0 0.0.0.0 null 0
Hub(config)#ip prefix-list DEFAULT_ROUTE permit 0.0.0.0/0
Hub(config)#route-map SPOKE_ROUTERS permit 10
Hub(config-route-map)#match ip address prefix-list DEFAULT_ROUTE

Hub(config)#router bgp 65001
Hub(config-router)#bgp listen range 172.16.123.0/24 peer-group DMVPN_SPOKES
Hub(config-router)#neighbor DMVPN_SPOKES peer-group 
Hub(config-router)#neighbor DMVPN_SPOKES remote-as 65023
Hub(config-router)#neighbor DMVPN_SPOKES route-map SPOKE_ROUTERS out
Hub(config-router)#network 0.0.0.0 mask 0.0.0.0

Open in new window

0
Hello EE, We have Honeywell handhelds and we've set them down in the warehouse and lost them.
I'm looking at the following: https://www.thetileapp.com/store/tiles/mate?defaultproduct=mate-1-pack&utm_campaign=702894687&utm_source=google&utm_medium=cpc&utm_content=213401926926&utm_term=-&adgroup=47867352387&gclid=EAIaIQobChMI_JjI3JLs2AIVkhuBCh3SqgB7EAYYASABEgLEnvD_BwE

but concerned if the Bluetooth will interfere with the handhelds ability to connect to WIFI if they are fixed to the handheld.
Anyone use these and can speak to it?
0
We have a Window 10 that has smb protocol negotiation problem. We find that it can establish a smb connection with a multi-function printer for file scanning.

The printer has initial a SMB session with Window 10 and Window 10 firewall has logged the request. However, it never response and no packet is dropped on Window firewall log.

Any idea ?

Thx
smb.png
0
when running the command : show ip ospf neighbors, I can see in some configurations
Full/Drother
and in other configurations
Full/-

I would like to know the difference between  OSPF  Full/Drother and  Full / -

Thank you
0
Dear all,

I am an IT support for a small company consist of 5 users. I assigned a static IP address on each computer.
Around 3 weeks one of my colleague was not able to browse the connection or see the shared folder on the server until I changed his PC's IP address. This issue reoccurred again today on his PC and on another PC.
I have done a lot of troubleshooting and the last step was changing the IP address. After changing the IP address on two PCs they were able to browse the internet connection and see the shared drives.

I am wondering what is the magician with changing the IP address. Please assist me because I am looking for a solution to avoid keep changing the IP addresses form time to time.
0
Hi Guys,

We have an IP block from the ISP
Thus a couple of public IP's assigned, example:
196.31.231.80
196.31.231.81
196.31.231.82

Our NAT policies on 196.31.231.80 over X1 interface is working well.

I've been trying to setup additional NAT policies on 196.31.231.81, but experiencing a connection issue.
Which brings me to the following questions:

1.  Is it necessary to setup a Virtual Interface for 196.31.231.82 on X1?
(255.255.255.0)
Or could the NAT rules simply refer to X1?

2.  I tried setting up a Virtual Interface on X1 for 196.31.231.82, but it complains about the same subnet used,
What should the subnet for the Virtual Interface be?
0
Suppose I have a WAN switch with SVI interface vlan 777 and ip address 192.168.99.97/28. If I want that specific address to advertise to the other side of the WAN connection (another interface) what ne.eds to be in the router process?

router ospf 1
router-id 192.168.99.0
no passive-interface 777
network 192.168.99.97 0.0.0.15 area 192.168.99.0
network 192.168.99.0 0.0.0.63 area 0

Should that be enough to get 192.168.99.97 advertised into ospf? Thank you.
0
In:
https://www.experts-exchange.com/questions/29078131/Peer-to-peer-network-names.html#a42433873

art lee said:
build a samba wins server on and old pc using Linux distro with a sambal gui
and make it the master browser

So, I researched the idea a bit and, it appears that if one were to introduce such a server, it could be connected to the network and take over name service.

Could it be turned off to return to the original "normal"?  That would seem to suggest a very low-risk approach in dealing with LAN single-subnet name service that would be reversible.

Could such a server be set up on a virtual machine?
I have thoughts of setting up a virtual machine on an existing Windows workstation for this purpose.
Seems like this would be the least intrusive approach to a critical system that's in production.

Your thoughts and suggestions would be appreciated.
0
Hi Here is Opengear IM4216. I could not find relative document on it. Is it layer2 or layer3 device? What kind of device is it? Thank you
0
Ping: 34 ms
Download: 16.46 Mbps
Upload: 16.63

Thanks.
0
Hello,

I am trying to research this question but not getting any concrete answers. I have multiple hub locations (none MPLS) connected to HQ via DMVPN. My bandwidth circuits at those external locations varies between 5Mb up to 100,Mb. My questions is, with SD-WAN, those sites with only 5Mb, will they see performance increase? Will I be able to manage this bandwidth? Or will I be cancelling the circuit with.. let's say Comcast and get a SD-WAN provider and thus leverage the speed? Also, if thats the case, will I be signing up for certain speed with the SD-WAN provider or no?
0
I am trying to understand the effect of configuring  ip summary-address rip 0.0.0.0 0.0.0.0  on the Hub router in DMVPN Network.
per the  book, Spokes should see in their routing tables the RIP default Route 0.0.0.0, but it is not the case in my LAB

Hub#sh run 
Building configuration...

Current configuration : 1636 bytes
!
! Last configuration change at 12:59:12 UTC Sat Dec 30 2017
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Hub
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
!
interface Tunnel0
 ip address 172.16.123.1 255.255.255.0
 no ip redirects
 ip nhrp authentication DMVPN
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 ip summary-address rip 0.0.0.0 0.0.0.0
 tunnel source FastEthernet0/1
 tunnel mode gre multipoint
 !
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 ip address 192.168.123.1 255.255.255.0
 duplex auto
 speed auto
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!

Open in new window

0
Hello - we have noticed that when we bind our 4 ports together to achieve 4GB speed on our Server 2016, and then perform a speed test with a network utility, that the results are slower for some reason.  Are there settings or some type of trick to allowing for faster speed to actually be achieved through a binded network interface?
0
If a router run a BGP with neighbors, will it use the BGP Path attributes and Best-Path algoritm to determine the best route to particular network and then put it into routing table ?  Or, does the router only check its BGP routing table only and decide which path to go for a particular network ?

Thx
0
Feb. 28 2019 update:

DUID in order to insist RCF3315 , to have replaced motherboard computers Vista 2012, and windows 10pro by Dec 2018, Physical mac keep 2 mac address as 2 interfaces to the upper R, Wan, ISP .

                      - Adaptor created at DUIDv6 mac IPv6 network , won't be controlled by IPv4 new mac 2nd address
                      - One PC can be shared on both IPv4 and IPv6 networks, shared Anti license, download app can be
                        forged ones , sync to their web, mail servers can be impacted …


Please let know the protocols and polices how to be manageable and broadcasted accurately in the compromised two interfaces by one computer strictly ?

Furthermore , for those vswitch , vwan, valn, vm all of interfered into the networking during these years … make the case more and more day by day getting unsolved like complex dilemma.



=                =               =                 =                =               =              =                =               =                =                =               =

I had this question after viewing UUID for OEM Bios no embedded Ethernet mac address , after vista II OS , is it protecting or abnormal ?.


Yes,

This topic case can be closed as:

UUID is modifiable feature as many as no limited with …
0
I configure 3 routers in a line each with their own addresses and loopbacks. I then create bgp neighborship between them and advertise their loopbacks. I can ping from R1 to R2's loopback or R2 to R3's loopback but I am unable to ping from R3 to R1's loopback.

Did I miss some configuration or is that just how it is by nature?

Thanks!
0
BGP Best path algorithm state that "Locally injected is better than iBGP/eBGP learned".

However, based on the Administrative distance :

EIGRP summary route        5
eBGP                                20
EIGRP                                 90
IGRP                              100
OSPF                             110

For "Locally injected ", does it exclude "redistribution" ?

Thx
0
Hello Experts,
I just installed sonicwall tz400w and everthing is going well except printer. Printer disconnect automatically after few minutes. I have to connect them manually again and again. I am using commercial printer by konica minolta and i use fiery app on Konica. Its working fine without the firewall.  Please help
0
Hi just using IMC on a trial basis

How exactly does it help with vlan management and ACL management can anyone outline ways in which it help us support switches is it just useful in terms of deployment etc

Any good learning material available?
0
Hi  all, please help me on this.
in the palo alto monitoring I see the ip is allowed by policy but the session end reason showing" tcp-rst-fromclient" means pls advice me this is the issue causing due to firewall denying or dropping traffic or issue on the client end.
0
I am looking to create an IP strategy for a hybrid environment (VMware on prem and Azure public integrated). I am wondering if anyone has best practice on best practices for IP strategy and more importantly on IPv6 implementation in Azure. Anything to watch out for with IP addressing, in particular IPv6.

Your help is appreciated.

Regards,
J
1
Hi all, please am submitting a CRQ for a simple static route via vrf
i.e.
ip route vrf  (vrf name) <ip address/mask> next hop.
I know it will not be approve if I did not put a statement about testing.
Please can anyone suggest any simple testing statement for static routing?
0
When issuing the summary-address in EIGRP, does it require at least one subnet existed under 10.16.0.0/16 ?


ip summary-address eigrp 1  10.16.0.0 255.255.0.0 5.
0
Locally injected routed is better than iBGP / eBGP learned. What is locally injected routed ? Is it the network specified by command network under BGP process ?

What is the difference between Origin "i" and Neighbor Type "i" ? Are they both refer to neighbor type ?

Thx

BGP.pngP
1
Hello All,

I found "IPsec (ESP) packet dropped" events in attempts section in Sonicwall GMS.
Can anyone help me to resolve this issue.

Thanks
Yogiraj Pattani
0

Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.