We help IT Professionals succeed at work.


Plesk is the leading WebOps platform to run, automate and grow applications, websites and hosting businesses. Being an OS agnostic platform, Plesk is running on more than 377,000 servers, automating 11M+ websites and 19M mail boxes. Available in more than 32 languages across 140 countries, 50% of the top 100 service providers worldwide are partnering with Plesk today.

Build, secure and run apps and websites

Spend less time spent on tedious admin and manual server tasks. Gain freedom to code, design or grow your hosting business.
- Multi Server functionality
- WordPress Management Tools
- Integration with Docker, Git, Node.js
- Full Ruby support

Try For Free
Sorry for such a general question
I am experiencing various errors with my wordpress site after a migration
The wordpress site on my Ionos host keeps showing errors when I navigate to it in the Plesk panel
Is there a way of trying to locate all errors in the wordpress site rather than having to check each one individually from the details panel (see attached image), or get the website to at least load up
I did not create the site and I do not have much experience with wordpress
I am using a Plesk control panel
I am not so familiar with this type of control panel
I Click on the domain name I want to work on
I then Click on the Wordpress link in the top right hand side of the Plesk panel
I then Click on the database tab - I see the current database name associated with this wordpress site

If I have another site in the httpdocs folder in a sub folder called wordpress2 with wordpress files
How do I associate a database with this second site

If I navigate to this site I get a error:
"error establishing a database connection"

If I look at the database name currently associated with the site parent (If I am in the parent site - clicked on domain name) and click on the wordpress link in the top right), the associated database name is slightly different from the name in phpmyadmin
If I am in the parent site (click on domain name)  and add a database it is not being associated with anything

Sorry to be so vague but I am not sure how plesk is actually working
Help please?
Hi All,

Please advise on the best way in a module to select query from a MSSQL db.
I have enabled ODBC etc... in PHP settings.
Have setup the DSN.
Not having much joy at all. Can query MySQL DB's of course .. but do not think I can get MSSQL to work.
Possibly I am missing an extension.

Do not want to post any code as I have tried all sorts.
I am happy with the Select.. just need to get the MSSQL connection right.

Would like to see an example I can drop into my custom extension within a module.

PHP 7.3.9
Joomla 3.9.12
Plesk 17.8.11
OS: Windows 2016.

Many thanks in advance

I've purchased a new domain and want to redirect people visiting my old domain.com to my new domain.com.au. The end game is to retire domain.com.

I did some research on SEO and I'm led to believe I need a 301 redirect.

I tried using the core redirect function of Joomla but it didn't work. The web host is Plesk, and I've located the .htaccess file. Looking around the internet, there seems to be alot of different ways to achieve this redirect. I've had some help from my web host provider, and it looks like domain.com.au has been added as an alias in Plesk. It doesn't look like I have full access to Plesk, so I might need to pay my web host provider to do these things for me.... which is what I am trying to avoid, as they have quoted me a massive amount.

What is the best way for me to move all traffic away from domain.com to domain.com.au, while keeping the SEO bots happy.

Joomla version 3.9.5
Plesk version ??? (the user account I have doesn't seem to allow me to see that info....)

Need to create an ability to transfer files via a web browser.

Can do FTP in the background. But must be a web front end that we can skin up.

Currently use Joomla for most web projects. Installed eDocMan and JDownloads etc..

Server is running Windows and Plesk. This is not changeable. Could be pure IIS if we use another box.. However, want to use the PLESK box as Nirvana.

Can upload ZIP as 1.99GB successfully now as eDocMan. Cannot do larger ISOs. Can do 700MB not 2GB.

Need a solution to do 15GB+.

Please advise what I can use to achieve a customisable front web interface that can take single large files.


So as far as I can see all should be fine.
I know browser upload on big files historically are hard. But using Chrome which exceeds 2GB limit.
I know IIS can have an issue bc the max size is 4GB something. However, need to know how hard a limit this is.

Need some guidance please.

Cannot just use FTP or FTP in windows address bar. Needs to be a "delivered solution"

Please advise.

Many thanks in advance.
Hi Guys
I have an e-commerce website using classic ASP and running with  Microsoft platform
I do not use PHP in my code at all but  my hosting company  is using PHP  for its mail handling
In other words I cannot disable The PHP  interpreter in my Plesk
My website  however all of a sudden is being bombarded with php script  files.  thousands  of them each 24 hours
So far I've had no problems  But......
I am a strong believer that a hacker will not  waste all this time and effort without expecting a reward.
My question is:
Is there anything I can do to combat this situation?
Hi Guys
I am running an eCommerce website using Microsoft  platform
My website is hosted on a  VPS  ( Plesk )
i am using  Classic Asp
I lam looking to  prevent  remote access to a  website folder  ( My  Image folder)
What are my alternatives?
Any help is appreciated
Hi, I need help troubleshooting the last 2 errors on the results of a PCI compliance scan for my server web.vacationpeople.net for my SSL certificate on port 21:

"One or more certificates in the chain cannot be validated."

"The certificate's issuer certificate could not be identified. Errors in the certificate chain prevent the certificate from being verified."

The certificate passes all tests in all other ports but port 21.

My server configuration:

Red Hat Enterprise Linux Server 7.6 (Maipo)
Plesk Onyx

Could you please give me some assistance as to how I can resolve this to be able complete validation on this scan?


Jorge Batres

I change the Plesk (windows) backup folder from C drive into our NAS drive. I map the NAS drive as P drive and run the "Change Plesk Backup Data location" under 'Plesk Reconfigurator' to change the path. Current backup data move into P drive (NAS) and path also changed.

When client, re-seller and administrator (me) is not able to take the backup. We received an error:
Error: The backup process failed: (3, 'GetDiskFreeSpaceEx', 'The system cannot find the path specified.')

Please also review the logs. Please let me know whats actually i am missing? I need to assign permission on NAS drive. Currently only administrator have rights to access NAS drive (P) but i am not able to take backup via administrator account. Same error.  


[2019-04-14 00:00:08.375|8528] DEBUG: LOG: custom log C:\Program Files (x86)\Plesk\PMM\logs\backup-2019-04-14-00-00-08-375\backup.log
[2019-04-14 00:00:08.375|8528] CRITICAL: Runtime error in pmmcli: 
<class 'pywintypes.error'> (3, 'GetDiskFreeSpaceEx', 'The system cannot find the path specified.')
Traceback (most recent call last):
  File "C:\Program Files (x86)\Plesk\admin\share\pmmcli\pmmcli.py", line 2560, in main
    data_action_response, errcode_response, error_message = actions.get(sys.argv[1][2:])(parameters)
  File "C:\Program Files (x86)\Plesk\admin\share\pmmcli\pmmcli.py", line 2455, in make_dump
    return ActionRunner(MakeDumpAction, backup_task_description, None).doActivity()
  File "C:\Program 

Open in new window

Hey everyone

Two requests please:


a) DomainA.com listed on Plesk. NO MAIL SERVICE. MX SETUP AS EXTERNAL ETC...
DomainB.com listed on same Plesk box cannot deliver to anyone with an address of DomainA even though everything is pointed to Microsoft Office 365.

Have tried setting MX to external 365 service.
Disabling and Enabling mail.

DomainA.com email is handled by Microsoft Office 365 and I can create a press@domaina.com on my PLESK box that allows outbound mail. NO INCOMING... not interested.. purely outbound.

My hosting support cannot help me, however, I have got around this before on other hosts. But do not know what they did.

Please advise.

Many thanks in advance.

We're having issues with a client's Wordpress web site that we've 'adopted'. This site worked fine but we've installed a new theme and we're having issues with it. It works fine on our testing server which happens to be a Cpanel-based host. However, when placed on our live server (Plesk) it throws errors on and off (a bit randomly, it seems).

We're getting sporadic Internal Server 500 errors which, when we look at the logs, shows us this:
(104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server

We've tried switching from Fast CGI, to just CGI and FPM but then we get this error:
Unable to allocate shared memory segment of 67108864 bytes: mmap: Cannot allocate memory (12)

Lots of Googling has been done but we've not found a solution yet.

OS:      ‪CentOS 6.10 (Final)‬
Product:      Plesk Onyx
Version: 17.8.11 Update #38,

CPU      Intel(R) Xeon(R) CPU E5649 @ 2.53GHz (2 core(s))
3GB RAM (looking at it now, it's using 35% of that)

Any ideas we can look at would be appreciated please!
Hi, I need help building PHP 7.3.0 with gd.so module with WebP support on a Linux server RHEL 7.6. I tried running
yum install make gcc plesk-php73-devel libjpeg-turbo-devel libpng-devel libXpm-devel freetype-devel libwebp-devel

Open in new window

but libwebp-devel is not available from subscription-manager.

Please help!

Hello, I'm in need of some assistance to compile PHP gd.so module with WebP support on my server.

I started following the instruction provided here:


The original instructions refer to PHP version 7.1.11 however, I changed mine to 7.2.13 which is the current version on my Plesk Server.

This is the result of the first 2 commands so far, and I had to stop because I saw the packages required were not available. I didn't want to continue because I don't want to break my current PHP version, but I need PHP gd.so module with WebP support on my server.

Could somebody please take a look and give me so guidance? Should I continue?

yum install make gcc plesk-php72-devel libjpeg-turbo-devel libpng-devel libXpm-devel freetype-devel libwebp-devel

wget http://be2.php.net/get/php-7.2.13.tar.gz/from/this/mirror

[root@web ~]# yum install make gcc plesk-php72-devel libjpeg-turbo-devel libpng-devel libXpm-devel freetype-devel libwebp-devel
Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
PLESK_17_8_11-extras                                                                                                                                       | 2.9 kB  00:00:00    
PLESK_17_PHP52                                                                         …
Hi, I was wondering if someone could please help me figure out a way to change the template's theme name as shown below, on the urls in the head section of my site without actually renaming the folders/directories on the template itself.

If I were to rename the folders on the actual template structure, everything would break, and even if it didn't, the automatic theme updates would not work, and for that reason, I need to figure out a way to mask, or rewrite the urls without breaking the theme template.

I have been searching online for a way to do this on my server, but no luck so far. Please help.

<link href="/templates/template-name/css/theme.9.css?v=1537979830" rel="stylesheet" id="theme-style-css" />
      <link href="/templates/template-name/css/theme.update.css?v=1.15.7" rel="stylesheet" id="theme-style-update-css" />
      <script src="/media/jui/js/jquery.min.js"></script>
      <script src="/media/jui/js/jquery-noconflict.js"></script>
      <script src="media/system/js/copyright.js"></script>
      <script src="/templates/template-name/vendor/assets/uikit/dist/js/uikit.min.js?v=1.15.7"></script>
      <script src="/templates/template-name/vendor/assets/uikit/dist/js/uikit-icons-fjord.min.js?v=1.15.7"></script>
      <script src="/templates/template-name/js/theme.js?v=1.15.7"></script>

My server configuration is as follows:

Red Hat Enterprise Linux Server 7.5

Plesk Onyx Version 17.8.11

PHP 7.2.11

Apache and FPM Application served by Nginx
With the new GoDaddy Plesk MSSQL database is there any way to import CSV data?
Before I post my question, please be aware that I am not very familiar with this stuff so please be gentle with me!

I have my store website hosted on Debian OS 8.11 with Plesk Onyx 17.8.11. I got a warning from Jetpack this morning that my website was down so I tried to load it and got a 502 bad gateway error.

When I logged into Plesk, I see this message:

"New configuration files for the Apache web server were not created due to the errors in configuration templates: Can not restart web server: . Detailed error descriptions were sent to you by email. Please resolve the issues and click here to generate broken configuration files once again or here to generate all configuration files. See the details in Configuration Troubleshooter"

I try generating new configuration files but no success. I then get this email in my inbox.

Template_Exception: Can not restart web server:
file: /opt/psa/admin/plib/Service/Driver/Web/Server/Apache.php
line: 109
code: 0

I am not sure what to do next..Please help!

Thanks in advance.
I look after a website that is hosted on EUKHost. I do not have access to the server, my only level of access is via a Plesk web host edition portal.

Up to yesterday the site was working fine, but today I am getting the following error:

This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidOperationException: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.

I have already done some research, and found that this is normally fixed by adding the following into web.config:

<machineKey validationKey="AutoGenerate,IsolateApps" decryptionKey="AutoGenerate,IsolateApps" validation="3DES" decryption="3DES"/>

However this was already in the <system.web> section of the web.config file.

I have also tried changing



<pages enableEventValidation="false" viewStateEncryptionMode="Never">

but this didn't help either.

Many solutions involve changing a registry key to turn the checking off, but this obviously isn't an option for this site, as I don't have access to the underlying server.

Any ideas?

I have created a php script for individuals to add a url to their calendar application such as outlook/ google calendar.

 I have validated the output on https://icalendar.org/ and get a header warning about the content type being text/html


Problem is when i add
           header('Content-Type: text/calendar; charset=utf-8');
	//		header('Content-Disposition: inline; filename=calendar.ics');

Open in new window

i get

firefox -> file not found
ie -> i get a download prompt that could not be downloaded if save is clicked

if i add the URL to outlook it throws an invalid url error

Not sure whats going on here because i had it working last night

i am using plesk on my centos 7 server

I currently have a VPS with RDP at my provider CWH, but my domains are with GoDaddy with A-Records pointing to CWH; and Emails with Microsoft Exchange.  Whenever I need to create a subdomain, I first log into GoDaddy create a new A-Record, then log into Plesk at CWH and create my sub domain there.  

As I’m releasing anew service, I’m hoping to automate this, so I had the following questions.

1.      Can I host my own DNS on my VPS? I

a)      If yes, could I use an API or SDK to create and delete A-Records?

b)      If no, do you know if GoDaddy or another provider has such interface?

2.      Within Plesk, or IIS directly, how can I Create/Suspend/Delete subdomains… again by code? Plesk is PHP-based, so there must be a way.

Obvoiusly my VPS is IIS, but can get Linux.

Any advice would be appreciated.

I am using subdomains to organize logged in  / not.

I have configured the php.ini file within plesk and set
session.save_path = "/var/lib/php/session/wesbite"
session.cookie_domain = "website.com"

Open in new window

In chrome,the redirect to the subdomain is file and the session data is maintained
in firefox, the session data is empty

How can i get the session to be shared amongst all subdomains?
Which Control Panel is Better For WordPress - Plesk VS cPanel
I'm considering switching over to Plesk (linux). Is there a cPanel Wordpress toolkit? The reason is that all my clients are all Wordpress users and so I'm considering to make this switch. Your thoughts?
I have Plesk Onyx Version 17.8.9 on a Windows 2016 server.

I would like to use the Plesk Backup Manager to ONLY backup all MS SQL 2016 databases within a Subscription. I do not want to include any site files, just the MS SQL databases. The backup options only allow for User files and databases but not just the databases.

If this cannot be done within Plesk then it would be appreciated if you can show how it can be done using other means such as a batch file command or from MS SQL Server Management Studio.

I am curious if it is a security risk to keep internal files within the same level of the accessible directory. I am using Plesk to manage my server.

Plesk sets up the directory structure as such
  1. vhost
    1. example.com
      1. error_docs
      2. http
      3. logs

Within the example.com directory, the http directory is accessible to the public via www.example.com

i have added additional directories within the example.com directory to keep everything in the same spot. The additional folders contain sensitive information.

I know that these folders are not directly accessible to standard users but im curious if i should move them up the directory hierarchy so i only have the public http directory.  Or is this something i dont have to even worry about
Hi, I need some help installing OpenSSH-7.6.p1 in my Linux Server. My current configuration is Red Hat Enterprise Linux Server 6.9 (Santiago)‬ with Plesk Onyx Version 17.5.3.

Up until a few days ago, I was running OpenSSH-7.5.p1 for the entire last year, and then I tried to upgrade to the latest version.  I realized I had OpenSSL 1.0.1 and the installation required OpenSSL-1.1.0g, so I went ahead and tried to install it, but when I ran "make test" after the installation as indicated here: http://www.linuxfromscratch.org/blfs/view/svn/postlfs/openssl.html  I ran into some errors and I ran "yum update" and that reversed my OpenSSH-7.5.p1 back to version 5.3.

I have been trying to get back to a new installation but when I install OpenSSL-1.1.0g and run the "make test" command, I guest the following output (attached). I know I need to correct this first before I can even proceed to install OpenSSH. Please help.


I have godaddy VPS. Its windows server with plesk. Two websites are hosted. for one of them email function works for the other one it gives 503 error, smtp authentication, This mail server requires authentication when attempting to send to a non-local e-mail address.


Plesk is the leading WebOps platform to run, automate and grow applications, websites and hosting businesses. Being an OS agnostic platform, Plesk is running on more than 377,000 servers, automating 11M+ websites and 19M mail boxes. Available in more than 32 languages across 140 countries, 50% of the top 100 service providers worldwide are partnering with Plesk today.