Plesk

Plesk is the leading WebOps platform to run, automate and grow applications, websites and hosting businesses. Being an OS agnostic platform, Plesk is running on more than 377,000 servers, automating 11M+ websites and 19M mail boxes. Available in more than 32 languages across 140 countries, 50% of the top 100 service providers worldwide are partnering with Plesk today.

Share tech news, updates, or what's on your mind.

Sign up to Post

Build, secure and run apps and websites

Spend less time spent on tedious admin and manual server tasks. Gain freedom to code, design or grow your hosting business.
 
- Multi Server functionality
- WordPress Management Tools
- Integration with Docker, Git, Node.js
- Full Ruby support

Try For Free
Hi,

I change the Plesk (windows) backup folder from C drive into our NAS drive. I map the NAS drive as P drive and run the "Change Plesk Backup Data location" under 'Plesk Reconfigurator' to change the path. Current backup data move into P drive (NAS) and path also changed.

Issue:
When client, re-seller and administrator (me) is not able to take the backup. We received an error:
Error: The backup process failed: (3, 'GetDiskFreeSpaceEx', 'The system cannot find the path specified.')

Please also review the logs. Please let me know whats actually i am missing? I need to assign permission on NAS drive. Currently only administrator have rights to access NAS drive (P) but i am not able to take backup via administrator account. Same error.  

Logs:

[2019-04-14 00:00:08.375|8528] DEBUG: LOG: custom log C:\Program Files (x86)\Plesk\PMM\logs\backup-2019-04-14-00-00-08-375\backup.log
[2019-04-14 00:00:08.375|8528] CRITICAL: Runtime error in pmmcli: 
<class 'pywintypes.error'> (3, 'GetDiskFreeSpaceEx', 'The system cannot find the path specified.')
Traceback (most recent call last):
  File "C:\Program Files (x86)\Plesk\admin\share\pmmcli\pmmcli.py", line 2560, in main
    data_action_response, errcode_response, error_message = actions.get(sys.argv[1][2:])(parameters)
  File "C:\Program Files (x86)\Plesk\admin\share\pmmcli\pmmcli.py", line 2455, in make_dump
    return ActionRunner(MakeDumpAction, backup_task_description, None).doActivity()
  File "C:\Program 

Open in new window

0
I have a Windows Server 2016 hosted on AWS EC2 using Plesk Onyx as a hosting control panel. It is a shared server and hosts multiple websites.

We have a requirement for one of our shared hosting clients to make their website and therefore our server PCI compliant in order to host a credit card payment page. One of the requirements is to disable the following outdated or vulnerable ciphers:

TLS_RSA_WITH_AES_256_GCM_SHA384 (0x9d)
TLS_RSA_WITH_AES_128_GCM_SHA256 (0x9c)
TLS_RSA_WITH_AES_256_CBC_SHA256 (0x3d)
TLS_RSA_WITH_AES_128_CBC_SHA256 (0x3c)
TLS_RSA_WITH_AES_256_CBC_SHA (0x35)
TLS_RSA_WITH_AES_128_CBC_SHA (0x2f)
TLS_RSA_WITH_3DES_EDE_CBC_SHA (0xa)
It is also a requirement to disable TLS 1.1.

However, I have the following concerns if the above changes are applied:

1. Disabling 3DES will create an issue accessing my server via remote desktop (RDP)
2. Disabling TLS 1.1 will break Plesk (latest version) Admin interface
3. Disabling the ciphers and TLS 1.1 will cause issues for visitors using Windows XP or outdated browsers.

I'm not too concerned about the last issue but am very concerned about not being able to access RDP and Plesk. Indeed applying these changes will likely lock me out of my server completely which can only be resolved through direct physical server access.

Is anyone aware of a workaround to resolve these issues? If need be we will consider a dedicated server just to satisfy our PCI compliant websites.
0
Hey everyone

Two requests please:

Either

a) DomainA.com listed on Plesk. NO MAIL SERVICE. MX SETUP AS EXTERNAL ETC...
DomainB.com listed on same Plesk box cannot deliver to anyone with an address of DomainA even though everything is pointed to Microsoft Office 365.

Have tried setting MX to external 365 service.
Disabling and Enabling mail.

b) MY PREFERENCE..
DomainA.com email is handled by Microsoft Office 365 and I can create a press@domaina.com on my PLESK box that allows outbound mail. NO INCOMING... not interested.. purely outbound.

My hosting support cannot help me, however, I have got around this before on other hosts. But do not know what they did.

Please advise.

Many thanks in advance.

R
0
We're having issues with a client's Wordpress web site that we've 'adopted'. This site worked fine but we've installed a new theme and we're having issues with it. It works fine on our testing server which happens to be a Cpanel-based host. However, when placed on our live server (Plesk) it throws errors on and off (a bit randomly, it seems).

We're getting sporadic Internal Server 500 errors which, when we look at the logs, shows us this:
(104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server

We've tried switching from Fast CGI, to just CGI and FPM but then we get this error:
Unable to allocate shared memory segment of 67108864 bytes: mmap: Cannot allocate memory (12)

Lots of Googling has been done but we've not found a solution yet.

OS:      ‪CentOS 6.10 (Final)‬
Product:      Plesk Onyx
Version: 17.8.11 Update #38,

CPU      Intel(R) Xeon(R) CPU E5649 @ 2.53GHz (2 core(s))
3GB RAM (looking at it now, it's using 35% of that)

Any ideas we can look at would be appreciated please!
0
set up plesk with ssl but won't automatically  display https:
0
Hello,
I have ubuntu 14.04 server with plesk web admin on it.
I am facing a problem with all my hosted services:
- when I access a php web service sometimes they dont work, and after recalling it it work perfectly.
- when I download a file on server form http, it freuqet get disconnected.
Any idea on how to solve these issues?
0
Hi,

I am trying to connect MySQL workbench to my database in plesk. I have tried entering my user credentials and domain ip/port without any luck

Any suggestions would be greatly appreciated
0
I am running a Windows 2016 server with Plesk and as part of the Plesk statistics I am able to capture the bandwidth of each hosted website and produce monthly reports.

Is there a way in which I can capture average CPU usage of websites and produce reports in a similar manner? I can only do so in real time but I would like this captured for use in my monthly reports. Perhaps an ideal statistic is to log how many times the CPU goes over a specific percentage CPU threshold.
0
How to block outgoing SMTP-connections from one IP on a Linux server.

Scenario:
I have a Linux server (Running Plesk) with 2 IP's
IP1 is used for website
IP2 is used for mail

I want to block users from creating script to send mail directly (spam).
All mail are supposed to be send via the mailserver on IP2

In the Plesk Firewall, I can block incoming connections on ex. port 25, but not (as far as I can see) outgoing.

I found this suggestion:
iptables -I OUTPUT -m owner ! --uid-owner postfix -m tcp -p tcp --dport 25 -j REJECT


How can this be done?

/Jan
0
Hello

I have tried a number of times to reduce the size of my EBS volume. I keep running into problems.

I am using Centos 7.3.1611 and Plesk (set up through Amazon marketplace)

I have managed to copy all the files over from the old server to the new using the instructions here (https://superuser.com/questions/1123799/how-to-decrease-size-the-ebs-root-volume-of-the-rhel-instance-in-aws) - as well as similar other guides.

The only difference is because I am using xfs instead of ext4 I was unable to do the e2label

When I attach the new volume to the instance as /dev/sda1 it does not load. I cannot connect to it using SSH and websites do not load.

I am at a loss now. I have tried so many times. I made a mistake making my initial EBS volume size way too big and it is costing me quite a bit of money every day.

I am unsure if the problem is because I am formatting my drive is XFS. This was the format of the original drive when I first set up the instance. I have not been able to find a guide that details how to shrink an EBS volume that is formatted in XFS, they are all for ext4.


If any one could provide some assistance that would be much appreciated.
0

Plesk

Plesk is the leading WebOps platform to run, automate and grow applications, websites and hosting businesses. Being an OS agnostic platform, Plesk is running on more than 377,000 servers, automating 11M+ websites and 19M mail boxes. Available in more than 32 languages across 140 countries, 50% of the top 100 service providers worldwide are partnering with Plesk today.