RAID stands for Redundant Array of Independent Disks.

RAID is data storage technology that allows multiple drives to be used together as a single virtual drive for reasons such as fault tolerance, reliability and performance.

There are several different levels of RAID that determine how the data is stored and the level of redundancy achieved across the drives.

Share tech news, updates, or what's on your mind.

Sign up to Post


I have HP DL380 G7 server that has 6 drives. Each two drives working under RAID1 configuration. One of hard drive failed (start to blink yellow color).  I want to replace it with a new one. I have same size hard drive but I do not know how to build RAID 1 configuration again for the failed drive.

All drives are SAS and hot swap. Are there any documents or video that can help me to do that?

Thank you in advance.
We are contemplating purchasing some used SAS SSDs and would like to be able to verify the health of the drives before deploying them.  We use Crystal Diskinfo for SATA drives, connected via the motherboard controller, and it works great, but SAS SSDs are connected to RAID controllers (PERC 6i, H700, or H710) and CDI isn't able to display any information.  We've even tried configuring the SAS drives as JBOD or leaving them unconfigured, figuring that might do the trick, but it doesn't.  

As far as I know, none of our spare servers have onboard SAS.  Are there passthrough SAS cards that will allow CDI to read from attached SSDs?  

What's the best / easiest / most efficient way to check TBW (terabytes written) or health remaining on SAS SSDs?
My Problem is RAID50 slow speed.

Initial RAID Configuration:

  • Disk Drives: 6 HDD TOSHIBA MBF2600RC (600 Gb, 16 Mb, 10025 RPM, SAS, 600 Mb/s)
  • 2 Spans
  • Motherboard: SuperMicro X8DTU-6F+/6TF
  • RAID Controller: SuperMicro SMC2108
  • Virtual Group: RAID50
  • Polices:
    1. Access: RW
    2. Read: Normal
    3. Disk Cache: Enable
    4. I/O: Cached
    5. Disable BGI: NO
    6. Default Write: Write Through
    7. Used Operation System: Windows Server 2016


CrystalDiskMark Metrics:
Read [MB/s]: 221.5
Write [MB/s]: 38.30

Ubuntu Live CD Metrics:
Read [MB/s]: 270.1
Write [MB/s]: 49.5

What can I attempt to increase Write Speed?
Should I reconfigure RAID50 settings, or configure different type of RAID?
I am betting that an expert here has the answer that Dell cannot solve. It probably will not be easy but I want to see if anyone is up the challenge. I had a Dell 5810 workstation. It failed and Dell could not fix it. They sent me a new 5820 workstation. 32 gigs ram and a one TB ssd. The ssd was supposed to be a class 40 1TB m.2 type drive. They had none in stock so they decided to install a class 20 1TB NOT m.2 type. I refused the lower performance class 20 due to the fact that I paid for a class 40 drive. The class 20 is in an enclosure that slips into a caddy that fits into one of four slot bays in what Dell calls the "Flex System". They decided to send me a 1tb m.2 ssd. I removed the class 20 drive from  the flex bays and installed the 1tb M.2 drive on a daughter board, That seems to work fine EXCEPT that I am getting an error sequence of 4 amber and 6 white flashes on the power led. That indicates a failure having to do with raid. I do not use raid at this time. Dell has no idea  how to fix this error indication.  The computer seems to think it wants to see a raid array. I have no raid. I do not want a raid system. They had me reset the bios to factory. That did nothing. I updated the bios 4 days ago. Yet, there was another bios revision posted today. I loaded that one also with no apparent difference. I feel confident that it is simply a setting that is wrong. When I put the class 20 ssd in and boot from that there is no error light sequence. Dell does not have any more…
Hi. I am attempting to install 16.04 server on a hardware raid 1 array. I created a boot partition (1 mb - I also tried larger, but same error), main disk (3.8 TB) and a swap partition (.2 TB). I am able to install on this configuration, but when the system boots for the first time I receive the error:

"error attempt to read or write outside of disk 'hd0'"

Then, it dumps me to the grub rescue prompt. At this prompt, I have tried setting the root and path to the boot partition, but I am never able to ls see anything in that directory, nor can I get back to the grub menu.

I have read several others with the same problem, but have not been able to recover from this error. Is the main disk too big, possibly? Should I install on a smaller partition? Thanks.

I am running several VMware 5.5 hosts on OEM servers, with each using a MegaRAID LSI 9260-4i SATA RAID controller card with accompanying battery backup unit.   Hosts are managed by a VCenter 5.5  virtual server.  Drive configurations on each host are SATA drives paired in RAID-1 configurations.  I recently got an alarm sounding on one of the servers that 1 of the SATA drives had failed.  I installed the Avago StorCLI utility, and using a  SHOW HEALTH command saw that the state of the virtual drive was degraded, and that the failed drive was on the LSI controller's connector P1.  I shut the system down, pulled out the failed SATA drive, and replaced it with a same-size SATA drive.  On startup the controller card began to beep again, as it was still detecting the degraded virtual drive.  I hit CTRL-H to enter the LSI controller's WEB BIOS and went to add the replacement drive to the degraded virtual drive.  Unfortunately, I could not remove the failed drive from the original RAID-1 Drive Group 0, as it still showed the failed drive in the original mirror setup, as a MISSING PD.  As such I could not add the replacement drive into the original Drive Group 0.  When I tried to add the replacement drive into the Logical Drive setups, the interface created a new Drive Group 1 and wanted to add the new drive to that.  Ultimately I had to declare the new drive as a Global Hot Spare, and I then saw the system start  to rebuild the Drive Group 0 using the new hot spare …
Last night our SBS 2011 server (with Exchange 2010) had a RAID failure. Would not boot but I could run repair / command prompt and actually copy all of the data to an external drive. RAID drive status is "uninitialized".

 I setup a new SBS server and recreated the 20 or so user mailboxes. The users are back to receiving and sending email on their phones. Outlook clients are the next thing to look at...

I have the entire Mailbox Database folder on an external hard drive. Is there someway that I can dismount the Exchange Store; empty the mailbox Database folder; copy everything from the external drive and mount the Store again?

I also have multiple Server Backups but they are from 11/30 and before.
I have a client who set up a Seagate Blackarmor NAS box a number of years back.  It has 4 Seagate 4T SAS drives in a RAID-5 configuration.
I was in their office last week and took a look at the device as it was running very slowly.  I looked at the front panel information (scrolled through the menus) and all four drives were listed as "Good".  The volume was listed as "degraded".

I looked at the web interface and saw that drive 3 was no longer part of the array (not sure if it said offline or bad).  I used the Action button to remove it.

I have since rebooted the box and now the volume is shown (on the front panel) as "Failed".  All four drives show as "good".  On the web interface, all four drives are listed as "good" but there is no volume shown.  I'm hearing no odd noises from any of the drives.

The client's backup is not as recent as he'd like, so he is very interested in trying to get this back up.  I realize that the safest option is to go to a (rather expensive) data recovery service.  He's not likely to want to go that route.

If these were NTFS-formatted drives, I'd have numerous options to analyze and possibly recover the data.  I'm assuming that the box runs Linux and that's not something I deal with except in very rare situations.

One option is to replace the drive that was removed from the array and see if it will recreate the volume.

I'd appreciate any suggestions on how to proceed.
What is the difference between Partitioned one RAID array separating the disks  Vs partitioning the drives onto separate arrays?
Dell Server Administrator Icon on DesktopDELL OMSMError in opening OMSMI have been runing DELL Server Administrator program to check on DELL T320 RAID Controller/hard drives for a few years without a problem.
All of a sudden, this morning, it would not let me log in after I provide IP address of VMWare Host, root and its password. Basically authentication failed for no good reason.
So I downloaded a new version and installed it. (BTW I did not remove the old version)
Now when I run "Server Administrator", it does not give me the logon screen. It even fails to load the Logon screen.
I tried Https://VSphere:1311 in Internet Explorer and Firefox, but to no avail. (Default browser is Chrome).
VSphere is the name of the Win10 PC that I use to connect to ESXi Host using vSphere Client which still runs fine.

Can you help?
We run VMware 6.0 on a Cisco UCS host. There are  6 X 1.2TB HDD in RAID10 giving 3.4ish TB and we are running low on space on Datastore1.  The LSI RAID controller wont let us add disks to the existing RAID so we've created a new RAID1 with 2 x 1.2TB drives.  

Using VCSA, we have moved 3 of our VMs to Datastore2, freeing up 400GB on Datastore1 and now we are trying to extend the size of the virtual disk of our exchange server by 50GB but we get the error

Insufficient disk space on datastore ''.

When we look at the error stack we see "The disk extend operation failed: msg.disklib.NOSPACE"

We cant understand why we are not allow to increase a vdisk when it is reporting that there is more than enough space free.  Any help much appreciated.
I am running a Dell PowerEdge T310.  I have 2(qty) RAID 1 setups.  The Hard Drives are Hot Swap.  The first RAID runs the O/S and the second my data.  One of the drives in the first RAID has a blinking amber light and states there is a predictive failure.  I can see this through the Dell Server Admin login on the Server O/S.  I am purchasing a new drive that is the same model, size and speed. My question is do I simply just pull the Hard Drive with the Predictive Failure out and insert the new one or should I run the Dell Server Admin and set the Predictive Failure drive to offline and then replace?  What would be the safest/proper way to replace this drive?
I am trying to replace a failed disk in a raid 1 under windows 7 pro. I had to physically remove the disk before the machine would boot up properly. I then went to disk management and removed the failed mirror. I then installed the new disk, initialized it as a MBR disk and converted it to Dynamic.  I set up a partition of the same size as the original disk, but when I right click the original disk, "Add Mirror" is greyed out. If I delete the partition "Add Mirror" becomes available but when I try to add the  unallotted space to the mirror, I get an error message that the disks have to have the same partition size and sector size and type.  What am I doing wrong. Thanks for any and all help.
I have a Perc 6/i integrated raid controller. Its a raid 5 with about 2tb of storage. There are 4 disk and I replaced each drive one at a time with 4tb drives. I thought the volume was supposed to expand, but im obviously wrong. Am I going to have to copy all the data to a separate drive and reconfigure this thing?

I see in Open Manage there is a reconfigure option for that Virtual Disk.

Here is the physical disk information.
Physical Disks
ID      0:0:2
Status      OK
Name      Physical Disk 0:0:2
State      Online
Bus Protocol      SATA
Media      HDD
Revision      00.0NS05
T10 PI Capable      No
Capacity      2,047.38GB
Used RAID Disk Space      931.00GB
Available RAID Disk Space      1,116.38GB
Hot Spare      No
Vendor ID      
Product ID      WDC WD4000FYYZ-05UL1B0
Serial No.      WD-WMC130E7MAVD
Sector Size      512B
SAS Address      1221000002000000
Non-RAID HDD Disk Cache Policy      Not Applicable
Hello I have a Dell Poweredge T320 and I want to upgrade my 300gb 3.5 15k SAS drives.  I want to upgrade them and am considering SSDs.  Can anyone recommend SAS SSD with storage size around 600gb or higher.   Currently I have a RAID 10 and the T320 has a PERC H310.
Hi there,

I´m struggling with an issue on my exchange server 2007 regarding a database that is in a dirty state. the problem is that this DB file is on a server with a RAID 0 and one of the disks is failing. I´ve managed to force the disk to "malfunction" in order to be able to get the file from it. If I manage to get a copy of the file (db.edb) (the log files are in another drive) will it be possible after rebuilding the RAID with another disk and restoring the volume name and file to access the exchange console and do an ESEUTIL to try to repair the excahnge DB? how can I recover my mailboxes? this is URGENT as we only work with emails and as I write this everything is stopped
Hi Guys,

I have an interesting issue, after replacing a faulty HDD and allowing the RAID to rebuild successfully, a single user mailbox acted weirdly and i had to investigate and follow the usual routes and causes. Ultimately nothing worked an i created a new user in AD with a new mailbox account which was working correctly,

The disconnected mailbox will not reconnect to any other user account and i am afraid it may be corrupted, but before i pull the plug i thought of asking for help. Following is a shortened version of the message i got on the user pc, in hindsight i should have gone offline end exported all to PST but........
"Your mailbox has been temporarily moved to ... A temporary mailbox exists, but might not have all of your previous data. You can connect to the temporary mailbox or work offline with all of you"

Any solutions or suggestions or even is there a fee tool to convert an ost to pst??

I am trying to diagnose an occasional paging file error I am receiving on an HP Proliant ML150 Gen 9 server running Windows 2012 Server R2 Standard.  The warning message is:

warning:  eventid 51
An error was detected on device \Device\Harddisk3\DR291 during a paging operation.

I am trying to figure out which physical or logical device this is pointing to on the server.   Note that the number following DR changes every time there is an entry for this paging error in the system logs.

 I took over administering this server earlier this year.  The server uses an embedded B140i RAID controller for the physical drive connections. The physical disks are set up as follows:

4 X 1 TB SATA drives in RAID-5 array, total available storage c. 2.7 TB
array is split into 2 logical drives:  

  drive C: at c. 400 GB
  remainder is drive N: at c. 2.3 TB

There is also an external Seagate USB 5 TB drive, total available storage c. 4. 7 TB, split into 2 logical drives:

  drive X: at 2.3 TB
  remainder is drive Y: at c. 2.4 TB

I'm attaching a PDF with screen shots of the DISKPART  screen showing disks and volumes as the server sees them, Computer Management / Disk Management screen, My Computer / Drives screen, a Device Manager disk drives summary, and also a tech doc at the beginning of the PDF that provides some decent info on this message but doesn't quite solve it for me.  As per the recommendation of the tech doc I also ran a WMOBJ listing of the …
I have 5 Kingston KC300 240 GB SSDs.  I have a LSI Megaraid 9285CV-8e RAID card version 5.5.  My motherboard is ASRock E3C204-4L with latest available BIOS.  

The SSDs are not detected by the RAID card.  I also tried a Seagate 1 TB HDD and also did not detect it.   I loaded the UEFI defaults in the BIOS but they are still not detected.  On bootup the POST screen says 0 logical drives detected and after logging into the server and launching ServerView RAID Manager, it sees the card but no drives.  All 5 drives are connected to the ports using SFF8087 cables.

Any suggestions?
Hi I have some servers that are using software raid on Server 2012 R2.  I was looking for a software program to email me if one of the drives goes south.

Thanks all.
Please provide me with guides on where to download and how to configure HP ProLiant DL360 Generation 10 servers so I can view and configure their RAID settings within Server 2016.
Dell PowerEdge T620 Failed Disk. The server boots up to a foreign configuration. Asking to select "C" or "F". The system will boot up after selecting F to import foreign config. Server 2012r2 boots up then blue screens critical process died. The system config shows that the virtual disk is offline and 1 disk is ready and 1 is foreign. I am attaching pics of the config page. I have a new drive to install for the one that has the amber light  flashing on it. Any help on getting the RAID fixed and server started would be awesome. IMG_3141.JPGIMG_3142.JPGIMG_3143.JPGIMG_3144.JPG
I have a server 2012 with a Raid 1 hosting a virtual machine. Total allocated disk is 460 gb and the virtual machine disk space was filled up somehow very fast. Hyper.v machine wont boot as a result. Can I pop another hard drive in that server to reallocate a larger raid disk size to increase the space? If I put a 2tb in there can I somehow fix this?
I have a new LSI 9381-8i with 8-7200rpm  NAS drives running on windows 10 and my throughput is ~ 30 MB/s. If I copy to a single SATA drive on the same system, I get about 110 MB/sec.

Writing to 8 drives in raid 5 should be a lot faster even with parity calculations. Why is my raid set so slow compared to a single drive? Does LSI require some kind of configuration setting I'm unaware of? At that speed my system can't cope with the video feeds I'm sending to it.

Thank you for any help.

Lots of comments I have read on EE and Googleiiinggg about Hardware SSD Raid 1 is a massive performance hit because the TRIM feature is lost.

As a means to keep redundancy, software RAID in Server 2016 is seen as a serious option. Still supports TRIM for the fast performance.

Please can I have some comments as I am about to commit to this in a 2x SSD and 2x SAS drive config in a server.




RAID stands for Redundant Array of Independent Disks.

RAID is data storage technology that allows multiple drives to be used together as a single virtual drive for reasons such as fault tolerance, reliability and performance.

There are several different levels of RAID that determine how the data is stored and the level of redundancy achieved across the drives.