We help IT Professionals succeed at work.


RAID stands for Redundant Array of Independent Disks.

RAID is data storage technology that allows multiple drives to be used together as a single virtual drive for reasons such as fault tolerance, reliability and performance.

There are several different levels of RAID that determine how the data is stored and the level of redundancy achieved across the drives.

Dell 2950 lost it's RAID configuration.  It has a Perc 6 i controller and an eight drive array.  The operator cleared a foreign configuration so that option is off the board.
 It was originally in a RAID 10 configuration.  All drives are showing as operational.  
I've already chastised the local IT guy for thinking a server would run for 11 years :(
What are the chances of putting all the drives into a RAID 10 configuration and having it operational? Other options?
 This was a domain controller in addition to several other programs.  The data for the other programs was backed up, however the IT guy didn't make a mirror backup of the server :(

Thanks in advance
Hello All;

I was adding another VM in ESXi when I lost connection to it.
Looking over at the server, I noticed all the lights were off of the hard drives, except for 1 drive.
Which would be, I THINK, the 2nd drive. I really did not pay much attention to it, once I noticed the other lights were off.
I brought open the Remote Management console and shut down the server, and then booted it back up.
Going into the Adaptec 6805T Config properties, then into Manage Arrays.
The below screenshot is what I am looking at.
Adaptec 6805T Rebuilding RAID 5
The question(s) I have is as follows.
Q1: The grayed out drive, is this the drive that could potentially be bad?
Q2: They are out of sync in following the regular number pattern. (00,01,02,03)

When I connected the cables to the board. I connected like so.
1 - First (Top first drive)
2 - Second
3 - Third
4 - forth (the bottom drive of the second row, not really sure why I did that for?)
(I removed the cover and checked my cables and they are in fact connected as described above)

The rebuilding % went pretty quickly from 1 to 7, in about 10 minutes.
However, it has been on 7% for about, 10 minutes on its own. Which kind of worries me.
So, it might be that the greyed out drive is in fact bad.
Which in that case, I have two spares, I can replace it with.
I just need some guidance on this one.
Which drive would I remove from the tray and replace it?
And should I shut down the server first, or, keep it on, while it is …
Hi, I am trying to fix boot of a physical server (OS: Windows 2016), I am stuck at screen "choose an option".
I tried with Troubleshooting option, chkdsk /f /r. Task went completely but without solving the issue.
I tried with 1 to 4 methods listed here:


again, without solving.
Any suggestion?
Server has 3 SAS hard disks (raid 5), and raid volume is OK.

Thank you
Hello Experts

I was having internet issues and had to connect directly to my COX Panoramic router, bypassing my Linksys Router.  They are on separate networks (Linksys 192.168.1.xxx ;

COX  192.168.0.xxx)

Now that I have it all back together, I can't access my Buffalo NAS Drives.  They are LS220DE housings with 2ea 1TB RAID Drives

I pulled the drives and held the reset button for 10 seconds like the quick setup said to do. I still can;t access the drives.  They show in a scan with DHCP addresses, but the connection times out.

Any ideas?


I have a Hyper V environment using Windows 2016 Std as the host with 512GB of ram, four RAID 10 configurations with 10GB NICs. Roughly 4-5 workstations/servers OSes in 2 of the RAID 10 locations. This VM server that's having the issue is just a file server set with 32GB of ram, using one of the 10G NICs and 4 virtual processors, plenty of power. Other server VMs are getting 300-400/MBs read/write using crystaldiskmark with the same or even less resources. This server is getting 20-30/MBs. I noticed it when the backups started to take much longer for this server. What's interesting is that I would copy a 4GB file from the C: to the D: and it'll start the copy around 400-500/MBs then around 30% it drops to under 10/MBs and crawls.Tried that to bypass any issues with the network. I wish there were some differences in my set up here but so far I can't find any. Other servers are on the same NIC, same RAID, same OS, same updates applied, One's a file server and the other is a print server. Both Windows Server 2012 Std. I'm stumped, if anyone has any insight on where I could look, I'd appreciate the help.
Hi Guys,
I bought a ml310e gen8 (not v2)for my lab.
I want to upgrade:

Now it have:
-Intel CPU G540 2.50 GHz
-2 stick 4gb ECC ram
-HP Sata 4tb disk
-HP B120i Raid controller
-HP P222 Smart array raid contoller -> on this are attached a 4 bay cage disk

I want to put in a:
-Xeon cpu
-4 stick 8gb ECC ram
-4 x 4 HP Sata 4 tb disk
-1 tb samsung QVO sata SSD
-2 x 256 ssd sata

I can't find what Xeon cpu are supported
I find that is support DDR3 ECC but I don't know what is max speed supported (it depends on cpu)
HP Sata disk are supported, I buy 1 for test and for now it works
I don't know if P222 controller support samsung consumer sata ssd disk, any advice?

I have a server with raid card megaraid SAS 9265-8i and when I created a Raid 5, one of the new hard drives failed and then I replaced the hard drive with other new and after rebuild and pass a week the same bay failed with the new hard drive  any suggestion why always the same bay ?
I am getting ready to purchase a new Dell T340 server with a PERC 730P (Windows Server 2019 Standard) for a small business client with 15 users.  They use Sage 50 application as well.

Anyway, I have been reading several articles about RAID 6 and RAID 10 and also 10K RPM vs 15K RPM drives, etc.  I will stick with spindle drive than opt for SSDs for this install.  

I am looking at purchasing (2) 300Gb 10K drives for the OS, and (6) 600Gbs 10K RPM drives for the company data/VM files.
Not sure whether its necessary to virtualize for this client or not.  I understand it would not be a good idea with a physical server deployment of have AD, DNS, DHCP on it and then also host company data files and a Sage 50 Database, but there current config has been setup that way for over 5 years without issue.

Anyway, I read several articles the other day where they are saying that RAID 10 is "safer" and faster than RAID6.  I find that hard to believe since RAID10 can only incur a maximum of (1) drive) failure but the RAID6 array can sustain (2) disk failure without crippling the whole server.  RAID10 is definitely faster than RAID6, but I think for this sort of deployment the speed differences would not matter or be noticeable.
There is the warning flashing indicator light on the MD3200, and it is a failed battery for the cache on
one of the raid controllers. I just received the replacement battery from Dell (and not sure how to replace it). Somebody would give me the instruction to do it safely please.

We have an older LSI MR9240-4i in our server. It has got 2 RAID-1 (SSD) systems. One with Samsung 840 PRO (512 MB) and the other one with: Crucial_CT1050MX (1000 MB).
The Crucial-based-RAID1 is 3 times faster as the Samsung-based-RAID1.
hdparm -t (Crucial-RAID): 478.22 MB/sec
hdparm -t (Samsung-RAID): 160.35 MB/sec

Has anybody a clue what could cause this ?
I have thought about ugrading the firmware in the Samsung SSDs.
I have an older Dell server that I am now responsible for.

The box is a Dell PowerEdge 2950 with a SAS 6/iR

It has two drive configured for RAID-1. One of the virtual drives is degraded. My only options on the tasks for that drive are blink and unblink. I was looking for a way to rebuild this drive. If I check on the Enclosure/physical disks in the openmanage server administrator, the problem drive's state is listed as Foreign with Failure predicted. The client has replaced this drive twice and we get the same notification.

On the alert log for that drive, there is the following description:
SAS port report: SAS wide port 0 lost link on PHY 0.: Controller 0 (SAS 6/iR Intergrated)
that's followed by
SAS port report: SAS wide port 0 restored link on PHY 0.: Controller 0 (SAS 6/iR Intergrated)
After my login to the openmanage server we get
(with a green checkmark)
A foreign configuration has been detected.: Control 0
Virtual disk degraded: Virtual Disk 0
Predictive failure reported: Physical Disk 0:0:0 Controller 0, Connector 0

predictive failure sounds like a failing / failed drive but two new drive in a row? Seems a little strange.

I'm not very versed in Raid controllers. Most times when I have an issue, I've replaced the failing drive, it rebuilt itself and life went on.

Any assistance on how to resolve this for the client would be greatly appreciated.

At this point I only have remote access to the server via RDP. I can get to it onsite if…
I have a Dell Precision workstation that needed a new RAID controller. The closest match available to the one in the system would not recognize the foreign drives and array from the old controller. I created a new 9TB array, downloaded the OS (Windows 7 Ultimate) to a flash drive. That's how Dell shipped the system. I can boot the OS with an MBR-formatted USB stick that sees UEFI. I have the driver for the RAID controller, and the computer sees the controller and the drives after the driver's loaded. However, it won't see a partition larger than 2TB, and won't format/install WIndows on any partition/space on this array.
Questions: Using Rufus or some other such tool, how do I put the OS on a stick that'll allow it to see and USE one large partition (or maybe two smaller ones, but use the entire 9 TB)? THANKS! :)
Good morning,

Can someone point me to a primer on defining an ISCSI datastore in VCSA 6.7?  I created a target in Windows 2012 R2 sitting on top of a RAID 6 cluster using ReFS.  Would like to see how it performs.


Hello folks! Glad to be back asking you a question!
I need your help on this very small production system, that is currently down.

Only 1 ESXi physical host present (no VCenter), configured to boot ESXi from an USB drive and VMs data are into the RAID built with SAS HDDs of the server itself.
No VM backups since 1 year (I know....I know.....bad sysadmins, but what can we do now). There is a VEEAM VM that "was" backing up the VMs into a Ethernet NAS, but from logs backups are not happening since 1 year or so.
Not much environment configuration (I don't even know the ESXi version deployed on this unique host, but at least I have physical access to it).
According to sysadmins, installation happened back in May 2015 and no updates to platform got performed, so I suspect it should be ESXi 5.5 (mostly) or 5.1.


  Host stopped booting from the USB because of Fatal error: 33 (Inconsistent data).
I started following this https://www.experts-exchange.com/articles/13595/HOW-TO-Fix-the-Error-loading-s-v00-Fatal-error-33-Inconsistent-data-in-the-VMware-vSphere-Hypervisor.html ,
I created an image of the "faulty USB" using the tool suggested in that Wiki and I've restored it into 2 different Kingstone USB flash drives 16GB/32GB (to be sure to avoid any potential hardware problem on the new flash drives I chose).
I followed Step2 (Confirm the USB flash drive or SD card is Faulty using a virtual machine), that was suggesting to confirm if …
For data recovery, I need to reinstall Windows 2003 server to a set of new drives on a Dell Poweredge 2600 server.   During install it asks for the drivers (F6) on a floppy drive to do the installation.   Don't have any of the original Dell disks.   I have tried downloading from Dell but cannot find what is needed.
Dear Experts,

We have a Suse Linux server running on Raid 5 and due to some disk issue (which is now fixed) we are unable to boot the linux server and are being forced to emergency mode. I understood that this is due to some bad block based on the error.

Google and tried few but don't want to try unless it is clear to avoid loss of data

Can someone throw some light what could be the resolution to this



[7.112162] blkupdaterequest: 1/0 error, dev fd0, sector 0
[ 8.636019] XFS (sda3): Internal error xlogclearstale_blocks(2) at line 1365 of file ../fs/xfs/xfs_log_recover.c. Caller xlogfindtail d0/0x3a0 [xfs]

Generating "/run/initranfs/rdsosreport.txt”
[ 8.704187] blkupdaterequest: I/0 error, dev £d0, sector 0 9.3641871 blkupdaterequest: I/0 error, dev fd0, sector 0
ntering emergency mode. Exit the shell to continue.

Type “journalctl“ to view system logs.

You might want to save “/run/initranfs/rdsosreport.txt” to a USB stick or /boot
after mounting them and attach it to a bug report.

Recovery of xfs file systems is not automated. We suggest using the 'xf's_repair’ tool to repair any damage to the file system. If that
doesn’t work you may zero the xfs log with the ’-L’ option to xfs_repair, however this can cause the loss of user files and/or data.
I have a problem with network access.  Running a network which has four servers, 5 workstations, and a VPN. Suddenly we have lost the ability to access one of the windows 7 servers.  One of the other servers provides DHCP for the local network so the network is still running.

Of course this server holds holds our order entry DB and the CAD file archives.  The server is running windows 7, and RAID.   I can access all files from the server itself.  I also can access other systems from this server.  

All of the other systems have the appropriate server files mapped as a network drives, which they can no longer access.

I have checked the settings, but I thought I would throw it out there to see If I have missed anything before I replace the system.
  I have a relatively old server that I am  trying to use as Hyper-V replica server.
  It has Intel® Server Board S5500BC,  Xeon E5645 2.4GHZ 12M (6 core) CPU, 32GB RAM, LSI Logic SAS9260-8I SGL.
  I am going to set up Hyper-V OS on two SSD drives on RAID 1  and looking for enterprise grade SATA 7200rpm Hard Drives by either Seagate or WD. Preferred capacity is 8, 12, 14 or 16TB on RAID 1.
 What make/model hard drive have best track record? What make/model would you recommend?

What my suggested RAID performance design for Domain Controller, File server, Email server and database server ? Are there any difference ?
My client has a 12-bay Synology DiskStation DS3617xs NAS filled with 14TB Seagate IronWolf Pros.  It will be used in an adjacent building with Active Backup for Business to backup the server and 40 workstations.

Sadly, according to support, triple parity isn't an option with Synology, so I'm trying to decide whether it's reasonably safe to go with RAID6 or if the only logical choice is RAID10.

I've understood for a while that the size of modern hard drives makes RAID5 a bad idea due to the likelihood of an unrecoverable read error during a rebuild.  I've seen a small amount of discussion on whether RAID6 is a good idea, but haven't come across any details other than rebuild time.  I have no first-hand experience for what kind of duration to expect when rebuilding a 140TB array.

My own take on whether RAID6 is reasonably safe is that a rebuild would only fail with a single drive failure if two of the remaining drives both had UREs on sectors that contain the exact same data.  Granted, if you have two concurrent drive failures, you're in the same boat as with one drive failure on RAID5, nervously biting your nails and praying that the rebuild finishes.

Is my understanding of the minimal risk involved with UREs and RAID6 accurate?  How much time is it likely to take to rebuild after a drive failure?

I wanted to know if it would be smart to run Seagate Nytro Enterprise SSD mixed use drives in Raid 5
I have read mixed reviews about running ssd's in Raid 5 on a server. The server will have a few VM's and be a file server as well.
The drive I was looking at is the XA1920ME10063
Hi I have a new Poweredge T440 with a Perc MPT2 (bios) that I put in, installed 4 drives and all the cables.  Durring POST, I can see the controller go by, and it sees all the drives, but I cannot figure out how to get into the BIOS of the controller.  When I had no drives connected, it allowed me in, but now that they are in, I tried Ctrl + R, but just can't get in.

Thanks all.

This question is for product recommendations for LSI MegaRaid cards.  I have been using the Megaraid LSI 9260-4i SATA RAID card with BBU for c. 5 years with great success and, knock on wood, 0 card failures or issues.  Unfortunately, the card has been out of production and EOL for c. 5 or 6 years now, so I figure for future setups I need to move on to another card that is in production, being supported by Broadcom, and getting ongoing firmware updates.  I called into Broadcom storage support and was advised to look into using the 9361-4i RAID card with CacheVault daughtercard for future setups.

Street pricing for the 9260-4i was typically $260 for the card and $160 for the BBU.
I'm seeing pricing for the 9361-4i at c. $350 and c. $120 for the CacheVault daughtercard.

Note that I use the MegaRAID cards for mostly in-house operations, or for secondary and peripheral client servers.  For primary client operations - SQL, Exchange etc. - I always use Dell servers.

My typical server setup when using MegaRAID is a simple one - SATA drives, either RAID-1 or RAID-5, though RAID-6 is possible where justified.  Add an additional drive as a hot spare and ensure email notifications for status updates and it's a reliable setup.

I'd appreciate any feedback and recommendations from pros who have experience with these cards as to whether the 9361-4i / 8i is the way to go, or if you recommend I standardize on a different adapter, and which one you've had good …
I just purchased a HP ProLiant DL380 Gen10. I have 6 2.4TB drives configured with RAID10 ADM. When I load Windows, I only show I am getting just under 5TB. If my calculations are correct, shouldn't I get over 7?ILO RAID Config
Am I wrong in my calculations?
Hi, we have a new Dell PowerEdge R540 and I'm looking for opinions on how best to configure the RAID(s). The system has 12 - 8TB SATA drives, PERC controller and has 512GB of RAM. The system will be a Hyper-V Host and will have many (probably a dozen or more) Hyper-V Virtual Machines on it. Some will be database servers like Oracle and SQL and others will be application servers and file servers. The OS will be Windows 2016. The VMs will be mostly 2016/2012 servers with a couple of W10 workstations sprinkled in. Interested in knowing how you would configure those drives. I usually like to use the hot spare option especially if the RAID only allows one drive failure. Years ago we had a RAID (5 I believe) with no hot spare and we lost two drives at the same time and all of our VMs … definitely would not want to go through that again. Thanks for your input.


RAID stands for Redundant Array of Independent Disks.

RAID is data storage technology that allows multiple drives to be used together as a single virtual drive for reasons such as fault tolerance, reliability and performance.

There are several different levels of RAID that determine how the data is stored and the level of redundancy achieved across the drives.

Top Experts In

No Top Experts for this time period. Answer questions to earn the title!