Raspberry Pi

170

Solutions

289

Contributors

The Raspberry Pi Foundation works to put the power of digital making into the hands of people all over the world, so they are capable of understanding and shaping our increasingly digital world, able to solve the problems that matter to them, and equipped for the jobs of the future.

We provide low-cost, high-performance computers that people use to learn, solve problems and have fun. We provide outreach and education to help more people access computing and digital making. We develop free resources to help people learn about computing and how to make things with computers, and train educators who can guide other people to learn.

Share tech news, updates, or what's on your mind.

Sign up to Post

I would like learn the assembly bare-metal programming for ARM systems,  would a Raspberry Pi be a good choice for this?

I would like to be able to write codes that blink the LEDs on the pi, without any operating systems -- just my codes  and making the pi  work like a microcontroller. Is this  easily possible with Raspberry? If the answer is yes, I would appreciate some guidance on what's the bestapproach, as far as cross compilers, platforms, and tools/hardware needed.

Thank you for your comments.
0
Hi all,

I try to establish passwords-less communication between mpi of my notes by using some video tutorial. However, at some point what I saw at the screen of the tutorial differ from from what I saw on my screen. As a result I fault to establish needed connection. I guess is that video tutorial missed some steps therefore I didn't get expected result. Let me guide you through the steps.
White screen will be screen of the tutor and black will be mine.

So I successfully establish connection between mpiu of notes I can enter exit ssh ls -la and do other things between my notes and mpiu of the notes. However, each time when I enter to the mpiu the system ask me the passwd so this step I wanna get rid of. For that matter:
1.  I generate RSA key for the rpi0 ( my first note ) and ssh-copy it to the rpi1 ( my second note )
2. I checked that RSA key located on the both notes for mpiu@rpi1 it will be authorized_key file (as far as i'm understand )
for the mpiu@rpi0 it will be files id_rsa and id_rsa_pub
3. Now I need to make changes in rpi0 .bashrc file to establish key chain ( here problems begun )
3.1. So I went to home directory,  I used vim in order to to edit file
3.2. Here I notice some difference in the file of tutor and mine - the tutor said that in the very end I should add some logic. However, in my file there are two fi , the tutor .bashrc file has only one fi at the end.
3.3. So I added logic after the second fi ( I saw that fi it states from finish => "}" - …
0
Hi ,
I use some video tutorial for setting Setting up Static IP Address on Raspberry Pi but get problems. Please use this shared pdf for more info Setting-up-static-IP-problem.pdf.
White background - tutorial
Black background - I'm

1 page of pdf  - ifconfig and netstat from tutorial
2 page of pdf  - ifconfig and netstat from mine
3 page of pdf  - results from sudo vim /etc/network/interfaces - from tuturial
4 page of pdf   - results from sudo vim /etc/network/interfaces - mine ( differ significantly - there are not dhcp )
5 page of pdf - what he ( tutorial man ) change in the file to get static ip for rpi
6 page of pdf - I do the same
7 page - what receive tutor when he run .../init.d/networking restart
8 page - what receive I receive  ( some code ... I guess this is a clue where could me source of the problem ??? )

Please help.


What could be the source of the problem
I 'm using D-link DIR-300 router
FileZilla and putty work fine ( run some code in remote session - work fine + I can reach google/internet through Rpi )

Many thx in advance
0
PuTTY-Configuration.jpg192.168.0.151---PuTTY.jpg192.168.0.151---1-PuTTY.jpg192.168.0.151---2-PuTTY.jpg


I cannot enable communication between my Windows 8.1. and RaspBerry pi 2 model B ( which is using LXPanel 0.7.2 ) Please use this shared pdf for more info to help me. I did all what you said SSH enable - done ( was by default ) ; Plug-in Rb pi to router ( I use D-Link DIR 300 )  - done ; My windows plugged in to the router ( I can access to the internet wo Wi-Fi ) ; both cables are working and etc . I also tried through the switcher NetGear GS 105 -unfortunately connection failed too. Please, tell me what could be the source of the problem ?

There is also "eth0" configured address (169.254.57.173/16) ( take a look in the shared pdf ) may be I should use it for getting connection ? what do you think ?
0
I'm following the instruction and stuck
https://github.com/userexec/Pi-Kitchen-Dashboard

Auto-starting Unclutter and Midori

Create a new directory at ~/.config/autostart if it does not exist
cd ~/.config/autostart - cd into this directory
nano unclutterAuto.desktop - Create a new .desktop file

I can't find the directory. would you guide me?

also how to take a screen capture on this os?
0
I've got two ASAs, one with version 9.1(6)8 and the other running version 9.1(6)11

I'm test benching a site-to-site configuration, and have set up a router to simulate the wan:
[F1 outside 172.16.1.2] ------ [172.16.1.1  router  172.16.2.1] ------ [172.16.2.2 F2 outside]

The tunnel builds and transitions to MM_Active if I ping from either inside network, and I see pkts encaps increase as expected with each icmp packet on the firewall connected to the sending device. However, I never see the decrypt packets increase on the either firewall and packet captures on the client machines do not show any traffic whatsoever from the corresponding remote network.

#pkts encaps: 1204, #pkts encrypt: 1204, #pkts digest: 1204
      #pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0

F1 client machine: Windows 7 with firewall configured to allow all traffic to and from 10.0.1.0/24 and 10.0.2.0/24 and a route set:
Destination        Netmask          Gateway       Interface  Metric
 10.0.2.0    255.255.255.0         10.0.1.1        10.0.1.10     21

F2 client: I'm using a Raspberry Pi without firewall implemented on F2 inside network (10.0.2.10):
10.0.1.0        10.0.2.1        255.255.255.0   UG    0      0        0 eth0
10.0.2.0        *                   255.255.255.0   U       0      0        0 eth0

If I capture packets on the client machines I can see their gateways ping them, but pinging from the opposite firewall or the opposite client machines I get nothing.

Here's F1's config

Open in new window

0
Sometimes when I run a server such as mosquitto
mosquitto -c /etc/mosquitto/mosquitto.conf

Open in new window

or Flask
python app.py

Open in new window

, it is only running when the terminal which is running the ssh is alive.
1. Is there a way to run it on the background no matter the terminal is shutdown or not? (Rebooting is not considered)
2. What if I want it to automatically start when the Pi reboot?

Thanks!
0
Hi there,
I do not have any problem I just want to know a fee opinions regarding home LAN.
 Currently I have internet provider modem and Linksys router (dd-wrt) connected to it. Router makes DHCP, DDNS, wifi&wifi guest (2 separate SSID with configuration that guest SSID can reach only onternet), PXE. Other network devices I have:
Raspberry pi - wired connection directly to Linksys (physically next to each other)
Raspberry pi - wireless
1Gbit switch - wired connection to Linksys
PC - wired connection to switch
NAS - wirec connection to switch
wifi - SSID & guest SSID

Now I am going to connect Zywall USG 20. Because there is no wifi in Zywall I have to still use Linksys as well.

What would you recommand me, how to design LAN? Separate VLAN for wifi clients (DHCP relay on Linksys). Make DMZ from NAS? Separate VLAN for RasPi with allowed only a few ports (80, 443, 53)?

I will appreciate some hints, ideas based on your experience. But would liek to stay in home network dimenstion rasher that enterprie :) but maybe enterprise wifi with certificates as well as VPN secured with certs would be also nice :D
0
In order to use Sense Hat https://www.raspberrypi.org/products/sense-hat/ under Python 3, I tried to run "sudo pip-3.2 install pillow" because that was what I was told when I tried to run "sudo apt-get install sense-hat" (http://pythonhosted.org/sense-hat/). However, below error happened. Does any one know how to solve this problem? Thanks!

...If I2C was disabled prior to this installation, a reboot is required.
To work under Python 3, the Sense HAT library requires pillow.
This can be installed by running 'sudo pip-3.2 install pillow'.
pi@raspberrypi ~ $ sudo pip-3.2 install pillow
Downloading/unpacking pillow
  Downloading Pillow-3.0.0.tar.gz (9.6Mb): 9.6Mb downloaded
  Running setup.py egg_info for package pillow

Installing collected packages: pillow
  Running setup.py install for pillow

    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/home/pi/build/pillow/setup.py", line 767, in <module>
        zip_safe=not debug_build(),
      File "/usr/lib/python3.2/distutils/core.py", line 148, in setup
        dist.run_commands()
      File "/usr/lib/python3.2/distutils/dist.py", line 917, in run_commands
        self.run_command(cmd)
      File "/usr/lib/python3.2/distutils/dist.py", line 936, in run_command
        cmd_obj.run()
      File "/usr/lib/python3/dist-packages/setuptools/command/install.py", line 53, in run
     

Open in new window

0
With this command
dd bs=4M if=2015-09-24-raspbian-jessie.img of=/dev/sdd

Open in new window

, I am writing an image (https://www.raspberrypi.org/downloads/raspbian/) about 3.28GB to a 8GB SD card. After the writing, I checked the SD card with the Disk Utility on my Mac, I can only see about 3.2GB of space. So, where did the rest of the space go? How can I recover them so that I can use them in the Raspberry Pi Raspian system?
Screen-Shot-2015-10-19-at-3.40.38-PM.png
0
The Raspberry Pi SD card has two partitions. One is Linux and the other is W95 FAT32. Now I'd like to use the other Raspberry Pi (Running Raspbian) to format this SD card to FAT32, so that I can use it as a normal USB stick on Windows PCs?
0
Hi , I am using a raspberry pi as a Nas and running rasbian.
I connected and mounted the drive . I launched samba can read the files from both Mac and OSX but i cannot delete any files .
I checked permissions and I should be able to but yet nothing . I do not know what I am missing .
I am new to Linux permissions and im learning CLI so any help would be appreciated

ther result of ls-l is

drwxr-xr-x 4 root root 32768 Sep 17 18:43 $RECYCLE.BIN
drwxr-xr-x 6 root root 32768 Oct 12 18:00 shares
drwxr-xr-x 2 root root 32768 Sep 17 18:42 System Volume Information
drwxr-xr-x 2 root root 32768 Oct  9 05:04 Video Server

I am also unable to change ownership due to permissions denied .
My end point is to have a NAs where i can store and delete files from MAC Clients , Windows Clients and other Debian clients


I have attached my smb.conf
smb.txt
0
I am using Debian on a Raspberry Pi 2 device.  I want to do networking over bluetooth.   So that I can SSH into the device from a laptop, iPad or Android phone ("remotes").
SSH works right now over WiFi but I need 2 different ways to access the device.
A static IP and the need to reconfigure networking manually on the remotes is OK with me, if it is necessary.

I've googled and tried a wide variety of solutions, none seem to work.  
- Bluetooth BLE dongle works fine on the Pi, I can pair with a few Android phones.
- But I cannot start Personal Area Networking or any other option I've tried.  Further it seems that whatever I try screws up the WiFi.
- I have a standard and latest Debian installed (not NOOB).

Could you please provide a definite way to get it working?
0
Hello!

I am a consulter and started shortly in a project where we have to use both the OPC DA & the REST API. But in a first step, we decided to install Eclipse SCADA & make a communication with an OPC DA simulator. The first job is to install an Eclipse SCADA project, because SCADA includes both interfaces with pure Java & does not need any OS-specific code/resources like DLLs etc.

On the Web, I found a tutorial, but the page seems to be outdated. The enlisted resources such as this does not exist (anymore).
Eclipse-SCADA-IDE-error.PNGWhat I need is a simple tutorial that creates an appropriate Eclipse project & communicates with an OPC DA simulator.

What we have done sofar:
Installed the Oracle VM VirtualBox Linux Debian to run near to Raspberry Pi
Installed the Oracle VM VirtualBox Windows 7 to run the
Installed a Windows 7 virtual machine to run the Matrikon OPC Simultor
Installed Eclipse Kepler 4.3, a it is said that Eclipse SCADA is running there
The Java 1.8 SE & its JDK

Do you know resources for an OPC DA newbie?

Thank you in advance!
0
I am looking to build and subsequently sell a IPTV box. The purchase price should be approximately $100.00. My business model will include a monthly subscription of less than $15.00 per month or $150.00 per year recurring every year to sell in my shop. If the customer does not pay then the subscription stops.

1.

Can we make a IPTV  box from Raspberry Pi, with XBMC which fits my objective.

2.

Is something like this legal in USA and Canada

Another reference point is http://iptvtalk.org/
0
I have an Windows universal app (u.app) that needs to pull a dataset from a web service.  The dataset contains the names of tables in a SQL db that will be used to create and label buttons in the mainpage of the u.app.  The web service is working as expected and returning the names of the tables in the SQL db.  I have included the web service as a service reference in the u.app.  My question is this, how do I get the data from the service reference in the u.app?  I am writing this solution in VB.Net any example code would be appreciated.

This u.app is running on a Raspberry PI 2 with Windows iOT Core
0
I'd like to run a small emailrelay application for the network printer which could not use SSL/TLS to communicate with the mail server. After considering a lot of options, I think raspberry could be a good choice but I am not sure. Any suggestion ? Thank you!
0
I am trying to create a kiosk that will boot to a webpage and give the viewer (touchscreen monitor) the ability to select a pdf and swipe browse it using an existing apache server and php/mysql/java/flash scripting.  The pdf rendering should be full screen and the ability to swipe right or left to "flip the pages" like a real book would be a must.  If the screen had a navigation section that would allow for pdf selection from a small list and page up/down options that would probably work as well as the whole "swipe" method.

I have another post here trying to solve this problem with a local pdf viewer application but I am thinking my web server might be a better way to serve up the content to multiple raspberry pi's like this first one.

Thank you in advance for any thoughts/directions/scripts anyone has to offer.
0
Hi all!

I would like to build a tool with Python that allows me to show on the screen multiple static ads / videos (the screen can be divided in 4, 5, 7 parts or similar).

The application will run on a Raspberry Pi connected to the tv and it will simple show the content of a specific folder (I'll put there 1.jpg, 2.3gp, 4.png and so on and those will populate the slices of monitor available)

Which kind of tool you suggest me to learn and use for the job?

Thanks!
0
Hello all,

Thanks for reading this.

We have a Raspberry Pi 2 and the audio output from the jack is popping. USB and HDMI are fine.

Is this fixable?

Much appreciated!
0
I have an image of raspian that boots great on my raspberry pi model a, but not on my model b+ or my pi 2. When i try to boot on pi B+ or pi 2 i get a constant green light that stays on which tells me they are not reading the bootcode i would think. This is more about learning to me. What im asking for is a list of numbered steps in which one would take to manually create a raspian boot sd from a debian command line with an emphasis on the following: 1) format the sd correctly with fdisk or any other good commands. 2) get the right MBR code and add it to the disk using dd or another good command. 3) how to check the MBR code for correctness. 4) how to make sure the rest of the boot code is ok. 5) transfer the raspbian.img to the sd card. 6) important things to look for when examining the sd boot card after i think its finished. 7) which boot logs to look at for a thorough review of what the pi is doing while it boots.
Im mainly after a good list of ordered steps and the commands. I do not necessarily need an explanation for each step as i will research each command and step myself. Any explanation of a step is extra and much appreciated.
0
I’m running a Raspberry PI B+<br>
Raspbian GNU/Linux 7 (wheezy)<br>
Linux raspberrypi 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux<br>

I've only just discovered both SANE and scanbd

I’ve installed SANE with a Canoscan 210 and, by itself, it works. <br>
The scanner identifies as  “genesys:libusb:001:005” <br>
“scanimage -x 210 -y 297 --format=tiff --mode color --resolution 300 > "/tmp/filename.tiff" works fine. <br>

I’ve installed and configured scanbd 1.4.2

**Although it is polling the scanner, recognizing all the buttons, and calling the right script when pressed (acccording to the syslog)…the scanner never activates and scans.**

I’m not sure if this is an issue with the saned configuration or startup, or an issue with the scanbd config. I’ve included all the config files.

I used the steps from [Here][1]…

…while also referencing [Archlinux][2] …

Here were the steps...<br>
SANE
<br>1.      apt-get install sane
<br>2.      (Configure sane for manual)
<br>3.      usermod -a pi -G scanner
<br>4.      # scanimage –L
<br>device `genesys:libusb:001:005' is a Canon LiDE 210 flatbed scanner

<br>scanbd
<br>1.      Download // svn. code. sf. net /p /scanbd /code /releases /1.4.2/
<br>2.      ./configure
<br>3.      make
<br>4.      make install
<br>5.      tar cvf - /etc/sane.d/* | (cd /usr/local/etc/scanbd; tar xvf - )

<br>6.      vi /usr/local/etc/scanbd/dll.conf
<br>left only the line “net”

<br>7.      vi /usr/local/etc/net.conf
<br> (only two lines)
<br>connect_timeout = 3
<br>“localhost # scanbm is …
0
Hi guys,

I am having trouble getting my software to work on a Raspberry Pi. The application runs fine but when i execute the code that has an external dll import attached to it I receive an error that it cant find the dll.

Here is my code:

[DllImport("UHFReader18_1.dll", CallingConvention = CallingConvention.StdCall)]

I am not sure where to go from here. can i place the dll in a certain path to find it or use something else to communicate with the dll?

btw this is a normal win form application.

Im lost please help i am new to Linux.

Regards
0
Is it possible to enable an auto login to Google Drive on a Raspberry Pi.  My goal is to have the machine boot directly to Google Drive on start up.  Any suggestions would help.
0
I have ordered Raspberry Pi 2 and would like to setup new project.

(1) Should I develop app in Window 8 and suitable IDE (JAVA or C)?, what the benefits this approach

(2) Which OS and IDE that work best for Java

(3) Which OS and IDE that work best for C

I'm familiar with Ellipse (TI and NXP) and Netbean (MPLABX). Im keen to get into Java platform including form and windows.

How fast Java on newer Rapsberry Pi 2 (1GB).
0

Raspberry Pi

170

Solutions

289

Contributors

The Raspberry Pi Foundation works to put the power of digital making into the hands of people all over the world, so they are capable of understanding and shaping our increasingly digital world, able to solve the problems that matter to them, and equipped for the jobs of the future.

We provide low-cost, high-performance computers that people use to learn, solve problems and have fun. We provide outreach and education to help more people access computing and digital making. We develop free resources to help people learn about computing and how to make things with computers, and train educators who can guide other people to learn.