We help IT Professionals succeed at work.
Hi All,

I have set up SSSD in a CentOS and RHEL, authentication with AD users is succeeding as expected and without any issues.

So when an AD logs in to any of this Linux distributions is receiving a shell in this format:

- [username@domain@linuxhostname ~]

I'd like to know if it is or not possible to set up the shell to this format after successful authentication with an AD account:

- [username@linuxhostname ~]

The users are mentioning that is a little bit confusing to have the shell in this format

- [username@domain@linuxhostname ~].

I already google it, made some changes to the sssd.conf file but none seems to work.

I already tried the following:
- use_fully_qualified_names = False
- full_name_format = %1$s
- re_expression = (?P<name>.+)
- Change default shell

Unfortunately, none as worked, probably I'm missing something.

> realm list
  type: kerberos
  realm-name: mydomain
  domain-name: mydomain
  configured: kerberos-member
  server-software: active-directory
  client-software: sssd
  required-package: oddjob
  required-package: oddjob-mkhomedir
  required-package: sssd
  required-package: adcli
  required-package: samba-common-tools
  login-formats: %U
  login-policy: allow-realm-logins

default_domain_suffix = mydomain
domains = mydomain
config_file_version = 2
services = nss, pam

ad_domain = mydomain
krb5_realm = MYDOMAIN
realmd_tags = manages-system …
Having problems getting postfix set up correctly.
In my case the server has several virtual domains. I have a system API that sends out emails and I want any bouncebacks to come to it.  It's not the primary domain for the server.

Assuming abc.com is the primary domain and def.com is the one I need work, I have the following entries in various configuration files:


def.com OK

mail_notifier@def.com mail_notifier@localhost
(I've also tried)
mail_notifier@def.com mail_notifier

I can't use the primary domain because we use office 365 and the mail MX record points to microsoft not our server.  This is also our web server, so I can't mess with the primary domain address.

The error I get back is
Recipient address rejected. User unknown in virtual alias table.

All I want to do is collect the bouncebacks from the mail_notifier account so I can automate handling for the end users.  Any help is appreciated.
How do I create a user in Linux and grant them remote access via ssh ?

I am using the Redhat version of the Linux distribution.

I am new to Linux and is learning this OS as I go.

Alos any recommendations on how to master this OS would be appreciated.
Dear Gurus
We are planning to have a 10 TB capacity Oracle 12 C Database hosted on a Virtual BL660 servers.
Typically the number of users/apps who will connect is around 200 max at any given time.
Was looking to find out how much vCPU and vRAM should I request for the same.

IS there any simple thumb rule to follow for this.?

Red Hat liunx 6.4 show (core dumped) error
SAN disk with multipath and mounted path not running
multipath -ll show this error:
 /lib64/multipath/libcheckdirectio.soAborted (core dumped)

Attached pic show other errors
I hv an urgent need to install aide & syslog-ng on
my RHEL 7 VMs (going live on Mon) but somehow
my RHEL account can't download packages from RHN.

Can I use those packages meant for CentOS 7 &
Fedora  from pbone.net ?

Also, for the following, is a subscription-manager rpm required to be installed?
$ subscription-manager identity
This system is not yet registered. Try 'subscription-manager register --help' for more information.
I wanted to set 'nosuid,noexec,nodev'  on /dev/shm partition
so that the settings stay across reboots.  However, can't see
this partition being listed in my fstab as shown below:

What should I add into fstab? Or this is done in another file?

$ cat fstab
# /etc/fstab
# Created by anaconda on Thu Nov  1 22:13:57 2018
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
/dev/mapper/rhel-root   /                       xfs     defaults        0 0
UUID=023c84eb-dcc5-4ea9-9841-fc936246dd98 /boot                   xfs     defaults        0 0
/dev/mapper/rhel-home   /home                   xfs     defaults,nodev,relatime        0 0
/dev/mapper/rhel-tmp    /tmp                    xfs     defaults,nodev,nosuid,noexec        0 0
/dev/mapper/rhel-var    /var                    xfs     defaults        0 0
/dev/mapper/rhel-swap   swap                    swap    defaults        0 0
# NFS Shared drive from Bootstrap node    /efs   nfs    defaults 0 0

$ df
Filesystem            1K-blocks    Used Available Use% Mounted on
/dev/mapper/rhel-root  30254660 3818732  26435928  13% /
devtmpfs                8121512       0   8121512   0% /dev
tmpfs                   8133368       0   8133368   0% /dev/shm         <==
tmpfs                   8133368  786484   7346884  10% /run
tmpfs                   8133368       0   8133368   0% /sys/fs/cgroup
We got some threshold alert on CPU usage sometimes. Thus we want to find out which process caused high CPU utilization on Linux.
After we use top and ntop command, all processes used only 0.7 to 1% CPU resources from time to time. We have no idea which process caused the issue.
Any command or tools could help us with this problem? Thank you.

RedHat and Ubuntu.
How do I check a history of commands executed by sudo?
I checked /home/username/.bash_history file but it contains only commands executed by the user.
I use RedHat 7.4. It's appreciate if I can know how to check sudo command history.
1. How to resolve issue below?

[code][root@28-218-217-172-on-nets home]# chown -R smb01 ~/home/share
chown: cannot access ‘/root/home/share’: No such file or directory
[root@28-218-217-172-on-nets home]#

Open in new window

I want to grant write permission to user smb01.

2. Is "ls -l" enough to list out all rights of user smb01 on folder /home/share? Is there any other command?
Was told by one of the vendor selling Ivanti (LanDesk related)
patch mgmt product that RedHat had since controlled it such
that any products that do patching for RHEL must have a
Satellite server with valid subscriptions for each RHEL endpoints
to be patched.

We don't want to do 'yum' (ie permit backend servers' connecting
to RHEL).

So without Satellite, is there any products our there that could
do patching of RHEL endpoints?  

Is this requirement to have Satellite something that Bigfix also
require?  Seems like the vendor selling Satellite is not aware.

Is there any scripts or tools out there that could pull all the
patches down with a single RHEL subscription, build a patch
repository which can be propagated down to our RHEL
endpoints?   I recall an ex-colleague who has built an RHEL
VM that could do something like this but I've lost touch with

Some years ago, a member in SunManagers list shared with
me that Satellite could patch Solaris as well (possibly that's
in the days of RHEL Ver 4.x): is this still the case today that
Satellite could patch Solaris?   What about Ubuntu, Debian,
& CentOS Linuxes?
Hi Expert

good day

i having issue to export the IPSEC certifcation , i have try to follow the following steps;

# pk12util -o <certoutputname>.pfx -n <name of certifcate to be extracted> -d sql:/etc/ipsec.d
Enter password for PKCS12 file:
Re-enter password:

Question refer to the above, where can i find "<certoutputname.pfx>" and <name of certifcate to be extracted> ?

Many thanks
Hello Experts,

We have inherited a RHEL 5.4 server and need to setup cloud backup, however I am not able to install anything because of a certificate issue, if I try to install anything or do an update I get the error below, is there a way to bypass this certificate message? The time and date on the server are correct and the system is registered, I was wondering if someone could point me into the right direction.


[root@brick ~]# yum update
Loaded plugins: rhnplugin, security
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 157, in main
  File "/usr/share/yum-cli/cli.py", line 187, in getOptionsConfig
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 664, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 253, in _getConf                                              ig
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 111, in init_hook
    login_info = up2dateAuth.getLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", …
Oracle Virtual Machine installed from this website virtual - installed the oracle virtual machine successfully accepted all defaults

downloaded winzip 7

https://www.linuxtrainingacademy.com/vdi/ download linux vertical disk image  Centos version 7

Extracted Centos version 7 successfully, it is 64 bit

unable to open due to the fact that my virtual machine settings do not go beyond 32 bit I have no idea why?
I have rebooted no change please see screen shots
Hi all,

 I have to install libfuse for development on rhel 6.

 how to install? I tried with "yum install fuse-devel".  But, I couldn't find /etc/fuse.conf to configure fuse on my local machine.

Can you help me with the correct syntax for getting a getfacl  report for all files and folders within the /etc/ directory, written to a text file. I appreciate this will need to be ran under the context of a root account, so I will log the request with the admin.

I also wanted to use ls -l command to get an inventory of all files stored in all users /home/ directory, again written out to text file, so if someone could help me with the correct syntax to run ls -l over all files/users in the /home/ directory that would be most useful.

this is on a red hat linux 6.8 system.

I need some assistance if writing a script that will produce a log file and send an e-mail notification if a CRON job fails to start
To ensure consistent upgrades across multiple hosts over a period of several weeks.We would like to update our non-production hosts several weeks before we upgrade
our production hosts, but would like to ensure the same version for both regardless of new updates being released within that time period. But I don't have satellite. Is it possible to download to a local depot and upgrade from there?
I am trying to join the domain for readhat server to our current Windows AD. The software using realm, to be honest I am not really familiar.

I installed the software needed but still have problem to connect/register to the domain.

This is what i did (server name I changed)

RHEL 7.4 server name: stl01
AD name: K1.LOCAL
AD server:  kocdc01.k1.local

The command:
# hostname
# realm join --user=adm_narahariak@K1.LOCAL --computer-ou="OU=Linux,OU=K1 Servers,DC=m1,DC=local kocdc01.k1.local" --verbose
 * Created computer account: CN=STL01,OU=Linux,OU=K1 Servers,DC=k1,DC=local
 * Sending netlogon pings to domain controller: cldap://
 * Received NetLogon info from: KOCDC01.k1.local
 ! Couldn't set password for computer account: STL01$: Cannot contact any KDC for requested realm
adcli: joining domain k1.local failed: Couldn't set password for computer account: STL01$: Cannot contact any KDC for requested realm
 ! Failed to join the domain
realm: Couldn't join realm: Failed to join the domain

It failed. But I checked in the OU, the name STL01 has been register (after i run the realm join command). Anyone experience with this?

Thank you,
Iwan Tamimi
How to specify/setup root certificate with the parameter "deployment.user.security.cacerts" for jave (current version: java-1.8.0-oracle-1.8.0.xxx) on Linux (Red Hat 2.6.32-754.9.1.xxx.x86_64)?  Since the java version is often upgraded, would like to place the root certificate in an unchangeable place. Can any gurus shed some light to it? Thanks a lot.
Hi, I need help building PHP 7.3.0 with gd.so module with WebP support on a Linux server RHEL 7.6. I tried running
yum install make gcc plesk-php73-devel libjpeg-turbo-devel libpng-devel libXpm-devel freetype-devel libwebp-devel

Open in new window

but libwebp-devel is not available from subscription-manager.

Please help!

"/u11/nfs-server0" is a mount point for an nfs connection.  Redhat v 6.9 apps "du" & "df" counts the nfs mount “/u11/nfs-server0” as local disk consumed.

Here are the examples.
[chill@server0 u11]$ du -h --max-depth=1
121G    ./nfs-server0
207G    ./archive
93G     ./backup
421G    .

[chill@server0 u11]$ df-hP
Filesystem                                Size  Used  Avail  Use% Mounted on
/dev/sda14                                1.0T  421G  552G  44% /u11

Am I correct assuming that file system /u11 actually using only 300 GB of space and has about 675 GB of free space?
What will happened if I attempt to put 600 GB of data on /u11.  Per du/df /u11 would be out of space.
Hi, we are receiving RX errors on one port to storage, we have changed the cable and the port on the switch, there are no errors on the switch only on this side.

i have read this could be due to the kernel which is 2.6 not being able to keep up.

is there a way to resolve this?

eth5      Link encap:Ethernet  HWaddr 94:F1:28:A4:04:28
          inet addr:
          inet6 addr: fe80::96g1:28ff:fea2:428/64 Scope:Link
          RX packets:49090224 errors:171 dropped:0 overruns:171 frame:0
          TX packets:64057242 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:45259514804 (42.1 GiB)  TX bytes:75797694806 (70.5 GiB)
          Interrupt:193 Memory:94000000-947fffff

I have a weird issue that is happening sometimes on my linux machines. I try to run a job using autosys and it fails throwing a error code -655 (see attached file).
We are running Autosys agent 11.3.6 and on most machines it works very well. Our agent is running as "root".  OS is Redhat 7.4. No autosys job has ever run on the machine.

What I understand from the log I get from the running job, it's like autosys thinks my machine is a Windows machine and it wants to login directly with my user. So I need to store my username/pass in the autosys password database (autosys_secure). It's not normal from what I know. The Linux autosys agent should execute the job as the user specified in the job definition.

We compared the job on 2 machines (it works on one and not in the other). They are identical. My "jboss" user exists on the machine, I'm able to sudo su - jboss. I don't know the password of it, which is irrelevant. My script has the proper rights (I can execute my script on the machine as "jboss")

We checked the agent configuration and it seems there is no difference between a functionnal and disfunctional machine.

Does anyone have any idea on this?


In RHEL, CentOS, Ubuntu, etc. There are many locations to set the hostname, but how can I verify where and how "hostname" actually and truly pulled the data from?

Right now we consistently are checking the /etc/hostname, /etc/sysconfig/network, and /etc/hosts files and I'm sure that there are other locations, but I'd like to confirm where hostname actually picked the name to populate that command.

I do not see any log files that can confirm that a valid host name was found and then placed into the hostname space.

Thank you
Top Experts In

No Top Experts for this time period. Answer questions to earn the title!