Routers

46K

Solutions

30K

Contributors

A router is a networking device that forwards data packets between computer networks. Routers perform the "traffic directing" functions on the Internet. The most familiar type of routers are home and small office cable or DSL routers that simply pass data, such as web pages, email, IM, and videos between computers and the Internet. More sophisticated routers, such as enterprise routers, connect large business or ISP networks up to the powerful core routers that forward data at high speed along the optical fiber lines of the Internet backbone. Though routers are typically dedicated hardware devices, use of software-based routers has grown increasingly common.

Share tech news, updates, or what's on your mind.

Sign up to Post

Have an ASA with firesight installed, it appears that streaming out is being blocked.  We use a boxcaster device, Was wondering how i can allow the IP or Mac outside unrestricted
0
Independent Software Vendors: We Want Your Opinion
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Hello all. I have a client with a EA-3500 router that I installed a while back. Since the, lots of port customization's were made by another individual. I don't have a record of those modifications. I need to get in and adjust a port. Is there a way of getting in without resetting the device? I have misplaced the UN and PW.  Thanks
0
Router wired to computer nic
Wireless card in computer to communicate with 2  gopros to stream live feed to internet........

can the cameras talk to wireless card w/o ssid... or can create fake "ssid" for cameras and wireless to communicate on .....
Or maybe I am over complicating and should configure router ssid and have cameras talk to server through router and not directly to computer wireless nic......

Was thinking 2 cameras talk wirelessly to wireless card of computer (10.0.0.0) route traffic through wired nic (192.168.69.0) to router - streaming to internet......

Feel like Alice and the Looking Glass.
Sorry for dumb question, just need to bounce this off another geek.  Just feel like there is a piece missing in thought process.

Thanks
0
Hello,
I have a customer that wants to extend their wifi network connection to various houses on their land. Each house is about 50 to 80 ft apart. they are using linksys wrt54g routers and repeating their wireless signal from one house to another. so from left to right at-least four houses using wrt54g in each house repeating the ssid. They keep telling me I didn't set it up correctly because they cannot get signal at the last house. I did mention to dig cable not an option and I am not sure how to tell them that the device is obsolete and repeaters through walls and repeating 2500 plus yds wont work unless we dig one cable to center house form first house with router. I just need some words or ideas to inform them that it will not work in easy to understand terms. My explenation of obsolete device, weak frequency channel, this walls and distance is not clear enough I guess. I am not sure anybody has been through this, but i just need some advise on how to inform the customer that the only option is to order more dsl service to their guest houses or dig cable. Also, am i correct for telling them that the devices are old and not reliable? I am installed dd-wrt firmware. I hope this makes sense. thanks for any suggestions
0
Screen-Shot-2017-08-06-at-11.30.59-A.png
on the topology above , I have R1 and R6 on AS 1, R5 on AS3 , R2,R3,R4 on AS2

I would like to have Routers on AS1 (R1 and R6) Not take route through AS3 to reach routers inside AS2, instead I want AS1 routers to go straight to AS2 through R1 using BGP Default Local Preference command on R1

you can see in the config below on R1 :
bgp default local-preference 600


Below is the BGP route configuration on R1, R6, R3. As you can see R6 is going through AS3 to reach routers in AS2 instead of going straight to AS2 through R1

If you need more info , please feel free to ask.


Thank you

R1#sh run | beg router bgp
 bgp default local-preference 600
 network 1.1.1.0 mask 255.255.255.0
 neighbor 192.168.12.2 remote-as 2
 neighbor 192.168.16.6 remote-as 1

Open in new window


R6#sh run | beg router bgp
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.16.1 remote-as 1
 neighbor 192.168.56.5 remote-as 3

Open in new window


R5#sh run | beg router bgp
router bgp 3
 network 5.5.5.0 mask 255.255.255.0
 neighbor 192.168.35.3 remote-as 2
 neighbor 192.168.56.6 remote-as 1

Open in new window


R1# sh ip bgp
BGP table version is 13, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
* i2.2.2.0/24       192.168.56.5             0    100      0 3 2 i
*>                  192.168.12.2             0             0 2 i
* i3.3.3.0/24       192.168.56.5             0    100      0 3 2 i
*>                  192.168.12.2                           0 2 i
* i4.4.4.0/24       192.168.56.5             0    100      0 3 2 i
*>                  192.168.12.2                           0 2 i
* i5.5.5.0/24       192.168.56.5             0    100      0 3 i
R1#

Open in new window


R6#sh ip bgp              
BGP table version is 6, local router ID is 192.168.56.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       192.168.16.1             0    600      0 i
* i2.2.2.0/24       192.168.12.2             0    600      0 2 i
*>                  192.168.56.5                           0 3 2 i
* i3.3.3.0/24       192.168.12.2             0    600      0 2 i
*>                  192.168.56.5                           0 3 2 i
* i4.4.4.0/24       192.168.12.2             0    600      0 2 i
*>                  192.168.56.5                           0 3 2 i
*> 5.5.5.0/24       192.168.56.5             0             0 3 i

Open in new window



R5# sh ip bgp             
BGP table version is 10, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       192.168.56.6                           0 1 i
*> 2.2.2.0/24       192.168.35.3                           0 2 i
*> 3.3.3.0/24       192.168.35.3             0             0 2 i
*> 4.4.4.0/24       192.168.35.3                           0 2 i
*> 5.5.5.0/24       0.0.0.0                  0         32768 i
R5#

Open in new window

0
bgp
on the topology above  I have R1 and R2 on AS12 and R3 on AS3

I am using Next-Hop-Self on R2 to tell R1 "in order to reach R3 come to me", but does not seem to work.

Here is the configuration  of BGP on each router.
R1#sh run | beg router bgp
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 192.168.12.2 remote-as 12

Open in new window


R2#sh run | beg router bgp
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.12.1 remote-as 12
 neighbor 192.168.12.1 next-hop-self
 neighbor 192.168.23.3 remote-as 3
 neighbor 192.168.23.3 next-hop-self

Open in new window


R3#sh run | beg router bgp
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 neighbor 192.168.23.2 remote-as 12

Open in new window


I cannot ping from R1 to R3 and vice-versa

If I advertize networks 192.168.12.0 and 192.168.23.0 From R2 then I will be able to ping from R1 to R3 and back

Any idea ?

Thanks
0
What is the process to logon to or reset the logon username and password for a SonicWALL TZ600 router when the logon information isn't known?

We don't want to reset any information on the router we simply want to logon to it or reset the username and password.

We have physical access to this router.

How can this be done?
0
What is the default username & password for a Dell SonicWALL TZ600 router?
0
bgpon the topology above I configured Route-Reflector on R5 to get full reachability.
My Confusion is I have seen some examples where they configure Next-hop-self.
for instance this :https://www.youtube.com/watch?v=QMkJfnMNZm8

Any BGP expert out there to clarify when Route-Reflector should be used and when Next-hop-self should be used ? If I had used Next-hop-self in my scenario, will that work fine just as Route-reflector did ?

Thank you

======


R2,R5,R3 are on the same AS  (AS2), they are IBGP Routers
 R1 is in AS1 and R4 in AS3



R1#sh run | beg router bgp
router bgp 1
 network 1.1.1.0 mask 255.255.255.0
 network 192.168.12.0
 neighbor 192.168.12.2 remote-as 2

R2#sh run | beg router bgp
router bgp 2
 network 2.2.2.0 mask 255.255.255.0
 network 192.168.12.0
 network 192.168.25.0
 neighbor 192.168.12.1 remote-as 1
 neighbor 192.168.25.5 remote-as 2

R3#sh run | beg router bgp
router bgp 2
 network 3.3.3.0 mask 255.255.255.0
 network 192.168.34.0
 network 192.168.35.0
 neighbor 192.168.34.4 remote-as 3
 neighbor 192.168.35.5 remote-as 2

R4#sh run | beg router bgp
router bgp 3
 network 4.4.4.0 mask 255.255.255.0
 network 192.168.34.0
 neighbor 192.168.34.3 remote-as 2

R5#sh run | beg router bgp
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 network 5.5.5.0 mask 255.255.255.0
 network 192.168.25.0
 network 192.168.35.0
 neighbor 192.168.25.2 remote-as 2
 neighbor 192.168.25.2 …
0
bgp

I have the topology above.
I configured BGP on R1:AS1  ,R2: AS2  and R4:AS2 ,R5:AS3 , I have also configured OSPF on R2,R4,R3
BGP is not configured on R3, just OSPF

Now when I  try to ping R5 from R2 or the R1 from R4 I get the UUUUU

Below is the configuration of all 5 Routers

R1#sh run
Building configuration...

Current configuration : 1385 bytes
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!         
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!
!         
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 !
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex half
 !
!
interface Ethernet1/0
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/1
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/2
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/3
 no ip address
 shutdown
 duplex half
 !
!
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 192.168.12.2 remote-as 2
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!

Open in new window

0
New feature and membership benefit!
LVL 9
New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

I'm attempting to set up a Pfsense router on an old notebook with one NIC.
I've configured 2 VLANs on the notebook, VLAN100(WAN) and VLAN200(LAN).
On the Dell switch I want the Cable Modem to go in port 1 and the Pfsense notebook to go in port 2. I've reserver port 24 for managing the switch. Ports 3-23 are for LAN traffic.
On the switch I've set VLAN100 on ports 1 and 2, both Tagged.
VLAN200 ports 1 and 2 Tagged, ports 3-23 Untagged.
VLAN1 port 24 untagged.
PVID for ports 1 and 2 is 100, ports 3-23 is 200, and port 24 is 1.
With a notebook plugged into any port 3-23 I can access Pfsense GUI Management.
The problem is that I cannot get an IP from the Modem from DHCP on VLAN100.
I've rebooted the Modem multiple times, but still do not get an IP address from the Modem.
I'm pretty sure the problem is in my configuration on the switch.
What should I change?
1
bgpI have the topology shown  above.  R1 and R5 are running BGP, R2  and R4 are  running BGP and OSPF , R3 is running just OSPF

I would like to know if I need to run BGP on R3 in addition to OSPF, or just redistribute BGP into OSPF and OSPF into BGP on R2 and R4


Thank you
Screen-Shot-2017-07-27-at-2.33.23-PM.png
1
Hi,

I am trialling a Cisco CSR 1000v (2 nic) in Azure. I have setup VPN's to the external interfaces and these are up and running and I can ping the internal IP of the 1000v.

Office A: 192.168.1.1/24  (can ping 172.16.31.1 and 172.17.31.1. Cannot  ping 172.17.31.4 )
1000v WAN interface internal IP: 172.16.31.1
1000v  LAN interface: 172.17.31.1
VM IP: 172.17.31.4 (firewall Disabled and can ping 172.16.31.1 and 172.17.31.1. Cannot ping internal IP of office firewall)

I have set up a test VM and connected to the internal interface and I can ping the VM from the 1000v. I can't seem to ping the VM from the office. I can ping the 1000v from the office and if I run a traceroute I can see the traffic for the VM being sent to the 1000v so I know the route is setup correctly.

 Can someone tell me what I need to do to allow access. I have added both interfaces to the Crypto Map (below)

Cisco1000v#show crypto map

Crypto Map IPv4 "OfficeMAP" 102 ipsec-isakmp
        Peer = XXX.XXX.XXX.XXX
        Extended IP access list 102
            access-list 102 permit ip 172.16.31.0 0.0.0.255 192.168.1.0 0.0.0.255
            access-list 102 permit ip 172.17.31.0 0.0.0.255 192.168.1.0 0.0.0.255
        Current peer: XXX.XXX.XXX.XXX
        Security association lifetime: 4608000 kilobytes/3600 seconds
        Responder-Only (Y/N): N
        PFS (Y/N): N
        Mixed-mode : Disabled
        Transform sets={
                T1:  { XXXXXXXXXXXXX} ,
        }
        …
0
bgp
I have the topology shown above. I have configured BGP on R1 which is in AS1 and on R2 which is in AS2
now when I run Show Ip BGP command on each router I get the output shown below. I need an Expert to explain the meaning of the Output  below. especially the lines :
r> 2.2.2.2/32       192.168.12.2             0             0 2 i
*  192.168.12.0     192.168.12.2             0             0 2 i
*>                  0.0.0.0                  0         32768 i




R1#sh ip bgp              
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       0.0.0.0                  0         32768 i
r> 2.2.2.2/32       192.168.12.2             0             0 2 i
*  192.168.12.0     192.168.12.2             0             0 2 i
*>                  0.0.0.0                  0         32768 i
R1#

Open in new window


R2#sh ip bgp         
BGP table version is 5, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 1.1.1.1/32       192.168.12.1             0             0 1 i
*> 2.2.2.2/32       0.0.0.0                  0         32768 i
*  192.168.12.0     192.168.12.1             0             0 1 i
*>                  0.0.0.0                  0         32768 i
R2#

Open in new window

0
I set up a Linksys LRT224 router about a year ago
it does some pass-throughs ti the following
-security camera NVR only two users can access

-Windows Server 2012 running an SQL database about 10 users

-VPN connection so users can get to all servers and appliances
This was suppose to be for only two users, but now they want all 10 users to be able to use VPN

Question?
should I continue to use this router? will is start to degrade in speed
some users say the VPN is starting to slow down

any suggestions are appreciated
0
Hello experts. I am trying to setup a VLAN in a test environment and I am not able to get it to work so far. I have searched this board and researched online but just can't seem to get it to work.

Right now I have two Comcast internet circuits coming into a peplink balance 20 (will be upgraded to the balance 305) I have one cat 6 patch cable going from the router lan port 1 to Switch 1, port 1. I have a total of 5 sg200 switches, all connected by 4 port LAGS and fiber.

I want to have 3 VLANS. On the peplink under LAN--->network settings I created the VLANS as 10 with an IP of 192.168.10.1 with DHCP enabled for 192.168.10.2 - 192.168.10.250, VLAN 20 as 192.168.20.1, VLAN 30 as 192.168.30.1 all with DHCP enabled. Under LAN--> port settings I have port 1 set to trunk and tagged the 3 VLANS.

I have the VLANS setup on all of the switches. On Switch 1, port 1 where the router is connected I have it set to tag the 3 VLANS I created.

On Switch 1, port 5 I have a laptop connected to test. I have that port set to access and VLAN1 to exclude, VLAN10 as untagged. From this point I am unable to get a dhcp address and if I enter a static ip I am unable to get internet access.

Is everything correctly configured so far? Right now everything is operating from the one switch. I haven't tried other ports on other switches.

What do I configure the LAGs as?

Any help will be VERY much appreciated!

Thanks in advanced,
CJ
0
Greetings,

We have a setup with users that change out 3 times a day. Each meeting is about ~150 users of so. The problem that we run into is that we only have a Centurylink c2100 modem and it is not always handing out DHCP addresses even after a reboot. It has the latest firmware. We have even upgraded to this modem as it also does 5ghz wireless. Is there an enterprise device to fix this situation?

DHCP scope time is 4 hours currently

Current setup -
C2100z Zyxel

Planned on doing -
C2100z -> Fortinet 60e -> Ubiquiti AC PRO
Static IP on WAN for Fortinet, Fortinet serves as DHCP server for hosts, Ubiquiti does wireless

Hoping to do -
Reliable DSL Enterprise Router -> Ubiquiti AC PRO

I know that if this were cable or fiber there are many choices, but with DSL I have not found a stable solution yet.

Thank you for looking at this
0
bgp
On the  screenshot above R1 is in AS1 and R2 in AS 2
I advertised Loopback networks from both Routers, but cannot see it in each other router BGP table

R1#sh run
Building configuration...

Current configuration : 1519 bytes
!
! Last configuration change at 19:08:12 UTC Tue Jul 25 2017
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex half
 !
!
interface Ethernet1/0
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/1
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/2
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/3
 no ip address
 shutdown
 duplex half
 !
!
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 network 192.168.12.0
 neighbor 192.168.12.2 remote-as 2
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 2.2.2.2 255.255.255.255 192.168.12.2
!
no cdp log mismatch duplex
!
!
!
!
!
!

Open in new window

0
Dear, we found an old switch Cisco 2960 in warehouse, it still works when we plug in the power but we 'd like to make sure it will not suddenly die. So how can I check the health of that switch? Can anyone please suggest some commands to check:
- When was it used for the first time?
- How long can it be used?

We want to utilize it for a new project so please help! Many thanks!
0
Free Tool: IP Lookup
LVL 9
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

I have this lingering doubt: There are BWs associated w/ each class of service. If the BW is NOT used in one class, can it be used by other? My guess is "NO", as each packet in individual class is marked w/ specific priority (dscp). BUT, there is this "remaining Bandwidth" statement in Cisco, so that any leftover BW is relinquished over to other classes to use. THis is my doubt, please let me know what you think.
0
Hi All,
What's a good way to practice your skills on firewalls, like ASA, palo alto or any other.
It seems like you can do labs on routers and switches and build your own topology in GNS3 or packettracer but I don't know how to get familiar with firewalls, is it just a matter of you just have to get thrown in fire to learn.
thanks for your input..
0
Dear All,

I would like to configure the connectivity on my home but I'm having some doubts and would like your help in order to configure the best way possible.

Devices:
Modem:  TPLink (TD-W8901N)
Router: Linksys (WRT1900ACS)

Currently I have two different options to configure internet connectivity:

1- Allow the TPLink to connect using PPoE on PV2 and specify user and password on the Modem and connect the cable from the TPLink to the internet connection on the Router Linksys (WRT1900ACS), so using this way we will receive internal IP Address from the TPLink instead of the WAN IP on the Internet Connection in the Linksys router.

2- Set the TPLink as Bridge Connection and connect the cable to the Internet Port on WRT1900ACS and configure the Router to connect using the PPoE on the Linksys and just use the TPLink as bridge.

Can you help me to understand the best recommended configuration and some explanation why just to understand?

Also would like to know if there any required configuration on the TPLink like VCI or VPI or something specific to have better performanc from the ISP?

I'm currently having performance issue on the connectivity and wanted to undertand the best way to setup the connectivity.

Thanks in advance,
0
Hello,

SonicWALL NSA routers

I have a network with 10 site to site vpn's. We switched providers on two of our sites. The buildings are on the same street and I got these IP's

Site A -   X.X.49.53
Site B -  X.X.49.52

I was able to recreate all of the tunnels with the exception of Site A to Site B. I'm wondering if it has to do with the fact that they are on the same .49 network. Any idea if this is the case?

Thanks in advanced
0
Dear Zealots, is there any method to observe, monitor the traffic from one (or multiple) IP address (es) to a IP address?
We are using Cisco Router 3925, Switch 3560, 3750, 2960
Many thanks in advance,
0
Hello,

I'm trying to understand the basic route concept on cisco router.

ip route 0.0.0.0  0.0.0.0  10.10.10.1

If I do the above command, would all the traffic will  forward it to 10.10.10.1 ?
0

Routers

46K

Solutions

30K

Contributors

A router is a networking device that forwards data packets between computer networks. Routers perform the "traffic directing" functions on the Internet. The most familiar type of routers are home and small office cable or DSL routers that simply pass data, such as web pages, email, IM, and videos between computers and the Internet. More sophisticated routers, such as enterprise routers, connect large business or ISP networks up to the powerful core routers that forward data at high speed along the optical fiber lines of the Internet backbone. Though routers are typically dedicated hardware devices, use of software-based routers has grown increasingly common.