SBS

58K

Solutions

28K

Contributors

Small Business Server (SBS) is a line of server operating systems targeted at small businesses by bundling the operating system with a number of other Microsoft products that would normally need to be purchased or licensed separately. The most notable inclusions are Exchange, SQL Server, SharePoint and ISA/TMG (Microsoft's firewall and proxy server).

Share tech news, updates, or what's on your mind.

Sign up to Post

I am migrating a SBS 2011 Server to a 2019 Standard. Going well but hit a problem with the Group Policy Management Console on the 2019 Server. See attached screen shot. I can still user GPMC on the SBS 2011 Server. Just not on the 2019 Server.
Capture.PNG
0
Just to make sure I have it right I can join this 2019 Standard as a member and promote it to a DC. Then there is no time limit. I can take all the time I need. At the tail end take the FSMO roles and demote the SBS 2011. That pretty much it? Any pitfalls I need to know about?
0
Hello.

I have this SBS 2011 server which is retaining a whole lot of previous versions of files, more than a month's worth.

So System Volume Information takes up about 120GB of space. I was wondering, which way would be the best to reduce this space, say by about 20%?

Thanks, y'all.
0
We are going to start migrating sbs2011 to server 2016 STD.
We are trying to backup the system state using Windows server backup utility.
we have tried running CMD Wbadmin start backupsystemstate -backuptarget:L:    we are using a external usb Drive
it will always fail with The filename, directory name, or volume label syntax is incorrect.

I also tried backing up to a network share and to a different partition on the server.

I also setup the Server Backup utility to manually backup the system state also. Still fails with same error
Does anyone have any ideas as to why this is happening or a workaround?

We also have Datto backup which uses storagecraft shadowcopy which is a service that datto uses to backup the server.

Not sure if that will stop the server backup to run. I also checked the VSS writers and they are all stable.
0
Good morning,
I receive this error when i try to remote into my office computer from home. " Can't connect securely to this page" This might be because the site uses outdated or unsafe TLS security settings.

My server is SBS 2003 R2. Remote access worked great until today.

Please help, very urgent.
0
Hello All,

I am trying to remove an old SBS DC that is no longer online.  I was able to remove it from ADSS and ADUC but when I run the ntdsutil and clean the metadata I get the error in the attached file.  The new server is 2016 and it is the DC and holds all the operations masters and is the GC.  I can't remember if 2016 cleans up all metadata once the DC is removed from ADSS or not - I thought it did hence the reason I am getting the error???  I have also already manually removed everything from DNS for the old server.

Any suggestions if the metadata is still there.

Regards,

Rob
0
Old PCs listed in Remote Web Access 2011 when users log in
We use SBS2011 my users use Remote Web Access when they need to log onto their office computer remotely (away from LAN)
the problem is that the computer list will list old computers that are no longer on the network, they have been replaced with new PCs which can be confusing for users. Example user Steve had a computer name Steve, he now has a replacement computer named Steve-New. When steve logs in he sees Steve and Steve-new
where do I go to clear our computer Steve? I did go onto our DNS server and deleted Steve but that does not seem to work
0
I have an SBS2011 server that it did a scheduled reboot this morning and when it did so, DNS will not start and Exchange services would start.

I have done some research and it seems that the DC/DNS server has lost its Secure channel with itself or PDC.

I have disabled IPV6 and also stopped the KDC service and ran the "netdom resetpwd /server:192.168.1.2 /userd:<Domain\domain_admin> /passwordd:*"

I get this error:
The command failed to complete successfully.

I cannot get the command to complete!  I need help.

Here are dcdiag results and ipconfig /all

nltest/sc_query:SBSDomainC.local
I_NetLogonControl failed: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN

Since this an SBS Server I don't know where to turn beside restoring the OS drive with last nights backup using a BareMetalRestore.  Any suggestions??
DCDiag.txt
IPConfigAll.txt
0
Hello All - I have a new 2016 Server that was a migration from an old SBS 2011 server.  All the roles have been moved and the old server is turned off.  I want to get rid of the WSUS roles since I am not installing it on the new server.  In GP I see the Update Services Common Settings and Client Computer Settings is still there from the migration.  I would like this all turned off so I modified the common settings gp and disabled the intranet option in Windows Updates so that the systems would go directly to the MS site for updates.  But the server will not download updates.  It starts and gets to about 9% and then stops with the error that I have attached.  Any thoughts as to why this might be happening?

Regards,

Rob
0
I have an SBS 2011 which runs exchange/DNS/DHCP/VPN but I had to remove the DHCP from it and use the routers DHCP for reasons that I cannot explain. Everything works fine but I cannot find anything online that says that VPN will work with an external DHCP.

I've just had my first remote user complain that she cannot connect so I rerun the fix my network and setup the vpn again and she appears to be connected fine. Is there anything else I need to check/do on the server or the router to ensure proper operation of the VPN?
0
Windows SBS 2008 with Exchange 2007. We have just come on as the IT for a small company and they have been hammered with email issues. Found that thier Forefront for Exchange which has been expired since 2015 was blocking a lot of email with attachments to only specific users.

Did some research and spoke with a tech from Microsoft and was recommended to uninstall Forefront for Exchange but only after stopping all Exchange services first. That was completed and the server was running fine.

This morning Exchange is not working, services are just hanging and no mail is flowing as the Store service is not running.

Attempted to reinstall Forefront and the installation just hangs at Preparing Installation and eventually will fail is you wait long enough.

So I decided to just restore the server to yesterdays backup before any changes were made however now I am getting an error from the Windows Server Recovery of Error code 0x80070057; "the parameter is incorrect"

Any help is much appreciated.

Since this OS is EOL and Exchagne is as well I may have to resort to the $499 Microsoft call. Hope you all can assist.
0
In clients network, users keep losing network connectivity.

On WIndows SBS 2011 server, client keeps seeing these messages in the event log.

Error MSExchangeFBPulish EvenID 8213
Warning ASP.NET .050727.0
Warning MSExchange ADAccess 2080
Warning MSExchange ADAccess 2106

DCDIAG:

Performing initial setup:
 Trying to find home server...
 Homeserver = SERVERNAME
 *Identified AD Forest.
 Done gathering initial info.

Doing initial required tests
Testing server: Default-First-Site-Name\SERVERNAME
Starting test: Connectivity
the host ._msdcs.domain.local could not be resolved to an IP address. Check the DNS server DHCP, server name etc.

What would be the logical steps to find / solve this issue?

Thx for your help
0
A client is looking to do a migration from their SBS 2011 server - i have never worked with SBS but people i talked to tell me its difficult to work with. Basically the client wants to not only migrate\upgrade to Windows Server 2016 Active Directory but they want to migrate to a new domain as the company has been bought out and they want to start fresh.

Is this doable? Would ADMT be the best route to migrate users, computers, servers? Exchange would also need to be migrated to Exchange 2016 on-premise. We suggested O365 but they are pushing back.

Thanks
0
I know there are a lot of posts here about the size of the winsxs folder, but nothing has given me a way to address the size.

I have a client running SBS2011 Essentials, SP1. Their C:\ drive is about 60GB, and 28GB of it is taken up by winsxs. Some files in winsxs are dated as old as July 2009. I can't believe there is a valid reason to have files saved here that are almost 10 years old. C:\ is down to 2GB free. Nothing else is taking "unusual" space... the closest folder is system32 at 5GB. I've tried disk cleanup (including system files), I tried "DISM /online /Cleanup-Image /SpSuperseded"... nothing has touched the size of this folder. I just can't believe Microsoft thinks continuing to grow the size of this folder indefinitely is a good design.

There are about 100 files in C:\Windows\winsxs\Temp\PendingDeletes dating all the way back to 2009... why are they still "pending"?  There is almost 1GB in C:\Windows\winsxs\Backup with dates from 2009 to current.

There has to be a way to remove 10+GB from this folder without causing potential system issues. There are lots of warnings about not deleting files from this folder because that might make the system have problems with future updates, or worse... but I find it hard to believe that 28GB of 1000s of multi-year-old files are needed to ensure successful operation.

Any help on how to free up some of the space taken up by winsxs would be appreciated.
0
Hi, I have an SBS 2011 Server and PCs with Outlook 2010 that connect over the LAN to the exchange Server. One of the PCs keeps changing the connection details for exchange to connect over http, does anyone know how I can stop Outlook ticking that box?
0
I am using SBS 2011 and getting a message about "The certificate that is helping to secure your website traffic will expire in less than two weeks. Before then, run the "Fix My Network Wizard" from the connectivity subtab on the network page of the Windows SBS console.
I did that but I am still getting the error message. I checked the certificate tool and I see the list in the attached file.  It looks like I have multiple certificates that I may not need and that may be keeping me from fixing this problem.  I uploaded that file.
CertificateIssues.rtf
0
WSUS server was setup on my Microsoft Small Business Server 2011 (serverA), the downloads are stored onto another Microsoft Server 2008 R2 (serverB)
this serverB is off-line now, corrupted O.S.
Questions
1. Where is the setting that tells serverA where to download the updates?
2. I would like to now download the updates locally on serverA (I add more space)

Most importantly: I want to know where I tell WSUS where to store the downloads, they used to go to a second server but that is not corrupted, so I want to know how to change where WSUS store the updates from serverB to serverA.
0
Hello All,

I have been having a problem getting WSUS installed on Server 2016.  It keeps telling that it fails because of a reboot that is neeed.  The reboot goes through, it looks like it is reconfiguring something then doe the same thing again and again.  This is a migration away from an SBS 2011 box and I really don't need WSUS since there are not that many users and I can have them download updates directly.  But I am not sure how to turn off the GPOs linked to updates.  Do I just change all of the settings to disable in the Updates Services Common Settings GPO or is there somewhere else I need to change some things.  The SBS box is going away.

I have already tried running RSOP to see what GPO is controlling the login as service - it was the default domain controllers policy.  So I went into that GPO and added NT SERVICES\ALL SERVICES to it.  i had just migrated another SBS 2011 to Server 2016 and had not problems installing WSUS.  Not sure why this box is giving me problems since I am logged in as an admin.

So, how can either point directly to MS for updates and forget about WSUS or get it installed?

Regards,

Rob
0
Domain12.com
Domain1.local



Our public facing domain has domain12.com but our Small Business Server 2011 is set to domain1.local. We have a valid certificate having a common name of domain12.com and SANS Server01.domain12.com and Server02.domain12.com.  I have domain12.com setup as one of the accepted (True) domains on Exchange 2010 (Rollup 26), domain12.mail.onmicrosoft.com (False) and domain1.local (False).  We subscribed to Office 365 and successfully passed the Office 365 Hybrid Configuration Wizard using Azure AD Connect and other tools. We validated the connection both incoming and outgoing at Office 365 Admin Console. For extra measure, we added an alternate UPN domain12.com suffix on the On-Premise AD Domains and Trusts to reflect the right usernames synched on the Office 365 Admin console that defaulted to user@domain12.com instead of user@domain12.onmicrosoft.com. We tried to migrate one user with 10 items on the mailbox and each attempt failed. Next, we utilized Exchange Connectivity Analyzer to test autodiscover and that failed as well. I PShell Get-AutodiscoverVirtualDirectory | fl Name, Server, InternalUrl, ExternalUrl, Identity. The results gave a blank InternalURL and ExternalURL. Could this be causing the hybrid migration failure of Office 365 and Exchange 2010? If I need to supply the ExternalURL and InternalURL value, do I use server.domain12.com?  We are also thinking of purchasing the domain1.com and binding it with the domain1.local …
0
Hi

For the last few days, we have been unable to log in to SBS 2011 server that we have at home.

When we try to log in, we get :-

"There are currently no logon servers available to service the logon request." (A)

This is true whether I attempt to log on using a domain or a local account, at the server's console or over the LAN.

Other salient (?) factors:-

-Although we cannot actually log in, RDP'ing to the server, using the current domain credentials DOES establish an RDP session - even though it then fails to actually login (and thus repeats the message shown in (A) above).

- When trying to log in to the server console, it seems to suggest that the server's machine name might have changed, because when I click on "How do I log on to another domain", the proposed local domain name looks like nothing that we would have set (e.g. WIN--EM52P6N....), rather than the expected HToo-Alpha01.

Now given the fact that both we cannot login AND that the machine name appears to have changed, then we cannot rule out that the server has been compromised. However, there is very little 'visible' externally (no ports forwarded to the server etc) and nobody in the family is admitting, say, to clicking on a 'dodgy' link....

So the question is - where do I go from here ?

Obviously, I can (and given the time, will) unplug the server's HDD and scan it for infections, but thereafter, how do I get access back to this machine and domain ?

To compound things, I am …
0
Good morning,
                  I need to configure an exchange 2010 (SBS 2011 product) with two ISP providers to send and recieve mails from. Send part is easy because i add a second A record on my AD DNS and it works. But i don't know how i can recieve from second ISP because i can't use 587 port for both ISP. Should i create a FW rule on my router? External record are created with both MX records.

Thank you very much,
Regards,
Martín Averame
0
Have a client with a SBS 2008 server. In the upgrade process to get to Exchange 2019 primarily so they can use Outlook 2016. Have done the interim upgrade to Exchange 2013. Have the mailboxes moved. Public folders moved. Outlook 2007 connects to 2013 fine. Outlook 2016 tells me that the resource is on an unsupported version of Exchange.  I wanted to test this to make sure all was going to work before uninstalling Exchange from the SBS. Do I have to do that before Outlook 2016 will work? I should be able to figure this out, but I'm a little brain dead today. Thanks in advance.
0
Restoring a ShadowProtect backup on to a new RAID5 array. This is Thinkserver TS430 with LSI Megaraid 9240-8i controller (no cache or battery backup) supporting a 3-drive RAID 5 with 450 GB Cheetah drives. Original array has been having issues, and We decided to replace with a set of 3 identical but "refurbished" drives from ServerSupply.
Backup of full 650 GB system volume (server only has one voluem) on to a SATA drive on same controller takes 2.2 hours. We attempted a restore to the new array and found that restore times were a full day or more- the transfer rate was only 5.75 MB/s.  Is this normal for this hardware or are we missing something in our configuration of Shadowprotect?  We have a bootable USB stick that is allowing us to do the restore.
My options are
1. Stick with the original plan and do the restore over a weekend to not have business impact to customer
2. Change configuration for restoring to another destination, like a Single or RAID-1 SSD
THe server is 5 yrs old and needs to work for another year. It has Small Business Server 2011 with Exchange and SQL Server for produciton use by 7 people office.
0
I am in the process of deploying a new server, running Server 2016 Standard, to replace our SBS 2011.  Exchange is long gone, in favor of Office 365, so I'm down to applications, data and some AD infrastructure, most significantly DNS, DHCP and CA.  I have promoted to new machine to a DC and moved the FSMO roles to it, which means I now have 2 DC's (at least until my SBS melts down from the licensing issue).  Last weekend, I attempted to shut down the SBS as a name server, so DNS would only run on the new server.  I configured the zones to be identical on the new box to the old, reconfigured the new machine to point to itself as the name server and disabled DNS on the old one. My clients are configured to "Obtain DNS server address automatically."  After disabling the service on the old server, the clients were unable to find a DNS server, unless I configured them with the IP address of the new server.  I did not switch DHCP to the new server yet.  I have a few questions.  Must DHCP be running on the same server as DNS, in order for clients to find the DNS server?  Is there any real relationship between the two? Based on the process I describe, does it appear I missed any obvious steps?  The grace period on my SBS license is rapidly disappearing.  Thanks in advance!
0
I have a Strange issue with a Small Business Server 2011 Premium.

Users are complaining of very low performance when they try to search on network And open pdf files.

When examining server I find everything to be fine. No heavy CPU load approx 5% and 18 of 32 gigs of ram available. No heavy hd load.
The server is running virtual in hyper V with 32 gigs ram and 8 cores.

Any ideas?
0

SBS

58K

Solutions

28K

Contributors

Small Business Server (SBS) is a line of server operating systems targeted at small businesses by bundling the operating system with a number of other Microsoft products that would normally need to be purchased or licensed separately. The most notable inclusions are Exchange, SQL Server, SharePoint and ISA/TMG (Microsoft's firewall and proxy server).