Server Hardware





Servers are computing devices that are similar to desktop computers in that they have the same basic components, but are significantly different in size, configuration and purpose. Servers are usually accessed over a network, and many run unattended, without a computer monitor, input device, audio hardware or USB interfaces. Many servers do not have a graphical user interface (GUI), and are configured and managed remotely. Servers typically include hardware redundancy such as dual power supplies, RAID disk systems, and ECC memory, along with extensive pre-boot memory testing and verification. Critical components might be hot swappable, and to guard against overheating, servers might have more powerful fans or use water cooling.

Share tech news, updates, or what's on your mind.

Sign up to Post

We are searching for a new fileserver system.

The conditions are:

1. We need redundancy I.e HA/mirroring/etc. (we currently have a single overloaded file server)

2. Increasing the bandwidth from the server to the building infrastructure. The building infrastructure is limited to 1Gb in the walls. We are looking at a multiple server solution with distributed data delivery to overcome this limitation.

3. Improved performance on the server itself

4. Data is often large individual files ( > 10GB )

5. Sharing is done via CIFS, NFS and Samba/cifs

We currently have a bid for the following hardware.

Question: Is there a better hardware solution than the one offered?

Proposed page 1
proposed page 2
proposed page 3
Become a CompTIA Certified Healthcare IT Tech
LVL 13
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

we have a windows 2008 domain controller that is also the CA server for the domain.  if we demote the server, is it going to affect the CA functionality?
I am working on our MS domain Disaster Recovery plan, and want to ensure our MS server 2012 CA causes minimal initial issues when it's not available if DR scenario occurs. Working off of a week recovery time for our primary datacenter to come back up (may be optimistic, but i want to at least give myself time to worry about more important business impacting items for the first few days), i see my CRL for my main domain cert from our CA currently has a validity time of 24hrs. I want to increase that to 1 week to give us time to worry about other issues instead of the internal CA server at first.

i see this URL with PS commands and want to extend the URL from 24hrs to 7 days so it will be almost a week before servers/apps start complaining about not having the CA available.

is this the right way to do it? am i wrong in this thought? if this line of thinking is correct, what would the command be if the CRL cert name was DomainCertificate?
I'm using a DELL server with iDRAC6 firmware ver. 1.97
After Updating Java from7u79 to Java 8, the virtual console doesn't run.

If only the java version 1.7.0 up 79 is installed on the PC, the virtual console works.
If I install the 1.8.0 up 201 on the PC it does not work.
I have configured the security exceptions (List Sites ...) and I have overcome the security problems.
Start the virtual console, Java 7 start up and then:
the error message is "Unable to Launch the application"
In details error: "Found an unsigned resource item:
https: // ......: 443 / software / avctKM.jar"
hi guys

We've got problems connecting from our PC's to the Vcentre server that is on our own local LAN. The version of Vmware we are running is 5.5 which we upgraded around a year ago. Ever since, we have had a lot of performance issues on it. So the Vcentre itself sits on a physical IBM X3550 M3 server with around 8GB of ram. We can't even ping it. RDP'ing is just now impossible. However, once we restart the server manually, we can RDP and then after like 10mins, our session times out.

We were told that Vmware 5.5 and above should really be virtual and therefore sitting on the physical entity could well be causing problems. We can connect without any issues to the servers within the virtual infrastructure.

Is there a diagnosis for this? Is it a bug?

Thanks for  helping
Clients gets randomly error H202 in Quickbooks. The users are in single user mode. Restarting the server resolves the issue. How to fix this error permanently?
HP Proliant ML350p Generation 8 Server, I can't seem to figure out why it won't boot to a USB stick. In the one time option it says USB Key but when I select that it immediately tries to boot of the raid volume I created. Stumped big time. Anybody run into this ..

The setup is pretty simple, 4 drives 2 raid one configurations. I have looked in BIOS and I don't see any sort of legacy option..

Any help would be appreciated ..
My developers like to test locally and I'm planning a new hybrid architecture and was wondering if anyone has some advice on what open source technologies I could use so that I could best replicate a serverless system?
Hi All,

I had a question from a client today relating to hardware and I am really not a hardware guy, so I figured I would just see what others think.

They have a server that has two SAS 600GB 15K drives mirrored for the OS / Apps, and three SAS 600GB 15K drives in RAID5 for Data.

One of the drives is failing, and they have a spare drive sitting around, totally new, but some years old.

The failing drive is a:

Dell Cheetah 15K 7 (Part Number:  9FN066-150)

The new spare drive is a:

Seagate ST600MM0208 600 GB Internal Hard Drive - SAS - 10000rpm - 128 MB Buffer

I said I thought that the only implication was that the array would run at the speed of the slower (10K) drive, but then realised that the old drive is rated 6GB/s and the new one 12GB/s.

Even if it ran slower, that would not be any real issue anyway.

Can they do that replacement?  If so, would there be any likely implications?


Hi Guys,

I just wanted to know something, we're going to be deploying HP Proliant servers at our remote sites which will hosts VMs like a DC and SCCM DP.

I will have NIC 1 and NIC 2 in a 'HOSTNIC' team for management but then i'd like to utilize NIC 3 and NIC 4 for the 'Hyper-V Virtual Switch'.

How would I configure the Team for NIC 3 and NIC 4? The remote site only has one VLAN configured. I will have the 'HOSTNIC' Team configured in a LACP, Dynamic Load Balancing.
Bootstrap 4: Exploring New Features
LVL 13
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.


I have a windows 2012 r2 server that has begun running incredibly slow. It take 30 seconds just to open google chrome from a fresh boot. HD response times are sitting at 20-70 right now but if i open something they jump up to around 200-500ms. I have check all of the hardware with open manage and nothing shows to be failing. I have defragged, cleanup up junk and temp files, also run chkdsk /r. Im not sure where to go from here. This is a Dell T320 with a xeon E5-2430 with 32gb of ram. It basically just a file server

I've a strange problem with our new Dell Poweredge T640 Server. The Server was originally equipped by Dell with two SSD Drives and a Perc 730P RAID Controller. Everything was fine until we decided to add two more NLSAS HDDs from Dell (2 x 4 TB 7,2K 1/min NLSAS 12Gbit/s 512n, 3,5" Hot-Plug). The server fans jumped to 50% and are very nosiy (constantly even while the CPU is idle). We have 8 slots for HDDs. The first two (0 & 1) are used by the SSDs while the next are occupied by the new NLSAS (slot 2 & 3). We also tried to move the new HDDs to slot 4 & 5 or 6 & 7, but this doesn't help.

We made a update of the firmware, everything is up to date and iDRAC doesn't report any problems. The only thing we observe is that the hypervisor ESXi 6.7 U1 (Dell Customized Image) ist giving us a warning in the hardware logs (attached). Could this be an issue, affecting the fan speed? If yes, how can we fix that? Is there a way to update the drivers ESXi is using or how can I get more information about this reported problem?
I have a Dell poweredge R900 with a Perc 6/i integrated raid controller. The controller only supports 2tb drives, and I only found this out after buying 4tb replacement drives. The server is a good server and won't to utilize it for storage. I was told I could purchase something like a PERC H200 to upgrade the controller. However, when I opened it up there was no sata ports and no sata power cables.

Everything runs from the front of the server into a board that feeds everything. Most of the connectors look like oversized IDE cables (not sure what they are called). I just want to make this a storage server.
Hi guys, I have bought some mellanox gear pretty cheap off Ebay. I need to set some time aside to properly read through everything and learn what i am doing. But i am just trying to get it online to do some basic testing and even that seems to be a bit of a pita.

My setup is blade M1000e with 2x M4001T switches both showing as online. I then have 40Gb NICs in two R730 servers. Both these connections are showing as disconnected. (if they connect direct without the switch they work perfectly)

I purchased a 56Gb/s card for a blade server and installed that. I then installed OpenSM / mellanox software and i created the mellanox service. I then started the service and the first port came online. I assigned it a static Ip address but none of the other ports came online.

The documentation for this specific switch is eluding me. If anyone has some information on what i need to do for the config it would be appreciated!

I have ordered a serial cable to plug in to the device but from what i read, i was led to believe i wouldnt need one as i can use opensm to configure the switches and bring them online.
Hi all

I am helping a company that is about to "upgrade" their IT infrastructure. This is there current setup:

On Prem DC/AD - windows server 2008r2
On Prem File Server (250GBs) - windows server 2008r2
On Prem Server hosting internal application - windows server 2008r2
QuickBooks - windows 10 desktop
Exchange 365 - cloud

Im thinking to hell with on prem hardware for such simple resources (essentially they have a fileshare), and going with a solution like this:

Use a service like egnyte for a file server (Supports Azure AD SSO ~ $8 a month per user
Use Azure AD Premium for MFA and SSO to apps such as egnyte, they dont use any GPO - ~$7 a month per user
Move the internal application to a hosted solution (already offered by provider) - unknown
QuickBooks operates on a users local so can just switch the file path of the database - no change in cost

In turn i would:
Scrap the on prem domain controller
scrap the on prem file server
scrap the on prem server hosting internal application

All these servers are due for upgrade, and we estimate costs being in the tens of thousands to keep them all prem or even use a hybrid azure solution. I could save them a load of upfront costs as well as maintenance/security, etc.
The fans spin up the slow down, and there is a steady amber blinking light. There are no beeps, and the behavior is exactly the same whether RAM is installed or not. ''Have cleared the CMOS with the jumper, but this did not fix it. 

The board is a dual Xeon, and I have tried moving around the CPUs - using only 1 in the primary socket, etc. If no CPU is installed, the fans won't spin up, so it is detecting something. 

My understanding is that we should at least get 3 beeps with no RAM installed. Not sure what is going on. The system was working a brief while ago, and there has been no "incident" preceding this. 

We have a ESXI host with version 5.1, today with no reason i lost connectivity to this host in management ip address "same as guests network", i can ping host ip and all vms guests is ok and running.

This server is Dell r720, i connect in console and press F2 "to view logs" after i type user and password and press enter the screen return to initial info "ip / press f2 etc".
I try to connect to shell "alt + f1" but shell not accept any command" i type and not happen, if i type alt + f2 screen return do info.

I can telnet 902 port, but i need directions to act in this situation.


Need to do some site surveys regarding IT Security and don't having anything in-place at the moment.  We'd like to get insights on to what to document and do while at the remote sites.
I have Proliant DL360 Gen 9 with Smart Array P440ar.  I installed a 4th 300gb hard drive into an existing Raid 5 array.  I don't know how or why but my array switched to Raid 6 (ADG).  At least i think it did because I believe I originally set it with Raid 5. My question is can i downgrade it back to Raid 5 without losing data in the array??
Amazon Web Services
LVL 13
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.


We have a HP Workstation xw4200 with Windows 2003 server installed on it.

This unit is usually left on all day every day.

This unit has worked fine for years with no problems.

Yesterday, I noticed that the server had turned off.

When I pressed the power button this this unit, the following occurred in sequence:

1. Green power LED appeared for 6 seconds
2. 1 second with power LED not lit
3. Power LED blinked RED 6 times, once per second, then 2 second pause (Beeping sound heard for every time power LED blinked RED)
4. The 3rd step repeated 4 times after each 2 second pause (total 5 times)
5. The 3rd step repeated but with no sound heard

I pressed on the power button on this unit and the power LED was no longer lit.

Any time I try to turn on this unit, the same 5 steps as above occurs.

1. What could be the reason for these beeps?

2. How can we solve our problem and get this server to boot?

I'm going for network engineer/security engineer position with a local company and part of the job is creating secure architecture diagrams, which I don't any experience with and need much information regarding this topic.  

I'd like to know what tools are available, both paid and non-paid, utilities.  Also, where can I get a crash course on this subject and maybe some type of hands-on soonest?  The meat of the position is identifying threats and mitigations, but I would like the position and again, I'm weak on documention skills.
So I have no ability to boot from UEFI on a Proliant ML350 Gen8 which makes my 8 2tb drives useless in a raid 10... The 2tb limit comes into effect. I tried ESXI but could not get that to work either.. Any ideas?
Recently dell r720 has been power off, when I boot the server, the server hang at scanning for device dell message. the is in the server is windows server 2008r2

I am having problems moving a virtual drive from one storage location to another on one of my VM Machines but can't understand why. The VM I am trying to move the drive on is our Production SQL server that serves up data for our ERP system. The data and all drives currently sits on a SAN we purchased but the 10K drives cannot handle the requests so I thought I could move that drive that contains the SQL database to a HOST that has a bank of SSD drives. That datastore is 735GB and the drive I want to move is 400GB so it should fit however when I go to Migrate the drive it says that there is not enough room. What am I doing wrong? Can I move a drive off a SAN to a local Datastore on a host? Do I need to move the whole VM drive structure to a new datastore? I was under the impression I could move just one drive which it looks like can be done but I don't completely understand the process.

When I am in the advanced settings of the migration process do I need to tell the application where all the drives need to stay and where to move? I mean In the Advanced window do I need to tell the system to keep all the drives on the current datastore (SAN) and change the one drive to the new location? I was just telling it to move just the drive but each time I would click next it would tell me that there isn't enough space.
iLO 4 on a Proliant ML 350 G8 server. I upgraded the firmware from 1.4 to 2.61 and now i get an error for the iLO Health stating Controller firmware revision 2.10.00 Embedded media initialization failed due to media write-verify test failure . I read that some suggest formatting the Embedded Flash but I see this message WARNING: Formatting the Embedded Flash erases all data on the iLO partition and cannot be undone. External providers (like BIOS, Intelligent Provisioning, OneView and FLM) will need to be re-configured. Im not sure if this is going to mess the server up.

Server Hardware





Servers are computing devices that are similar to desktop computers in that they have the same basic components, but are significantly different in size, configuration and purpose. Servers are usually accessed over a network, and many run unattended, without a computer monitor, input device, audio hardware or USB interfaces. Many servers do not have a graphical user interface (GUI), and are configured and managed remotely. Servers typically include hardware redundancy such as dual power supplies, RAID disk systems, and ECC memory, along with extensive pre-boot memory testing and verification. Critical components might be hot swappable, and to guard against overheating, servers might have more powerful fans or use water cooling.