Server Software

7K

Solutions

12K

Contributors

A server is a computer program or a machine that waits for requests from other machines or software (clients) and responds to them. This architecture is called the client–server model. The clients may run on the same computer or may connect to the server over a network. The purpose of a server is to share data or hardware and software resources among clients. Typical computing servers are database servers, file servers, mail servers, print servers, web servers, game servers, and application servers.

Share tech news, updates, or what's on your mind.

Sign up to Post

I need to setup a new server for a veterinary hospital wth 10 users on Windows 10 workstations. They currently use a workgroup with a workstation running server 2018 for shared data and printers. I want to setup an AD domain because managing user permissions and workstation setup and configuration is getting too time consuming in the workgroup environment. Their database size and shared file storage needs are very low so we don't need enterprise level power. I just want the minimal server hardware and os necessary for AD management, some remote access, group policy changes and to standardize workstation UI and software configuration, plus physical space for server hardware is very limited. Extra capacity for future growth is not necessary because they are at the maximum physical size that is possible for their location.

Thank you
0
SOFTWARE UPDATES ARE NOT INSTALLED IN WINDOWS 10 1703 TASK SEQUENCE:

Software updates are not getting installed from task sequence during Windows 10 1703 build.

We have the latest version of SCCM Client in place and used respective version of ADK while capturing image.

Followed the instructions are added registry as per this link: https://msitproblog.com/2017/06/08/windows-10-1703-update-installation-fails-mdt-task-sequence/.
But, we get the below error during build from Windows Update log. ATTACHED LOG FILE for reference.


Please provide us ideas to get this issue fixed.

2018/03/23 13:22:38.1500375 276   3448  Metadata        [0]0114.0D78::03/23/2018-13:22:38.150 [metadataintegrity] failed: hr = 0x8024500C
2018/03/23 13:22:38.1500397 276   3448  Metadata        [0]0114.0D78::03/23/2018-13:22:38.150 [metadataintegrity]GetFragmentSigningConfig failed with 0x8024500C. Using default enforcement mode: Audit.
2018/03/23 13:22:38.1500404 276   3448  Metadata        [0]0114.0D78::03/23/2018-13:22:38.150 [metadataintegrity] failed: hr = 0x8024500C

2018/03/23 13:27:29.9309801 4344  4848  ComApi          [0]10F8.12F0::03/23/2018-13:27:29.930 [comapi]ISusInternal:: DisconnectCall failed, hr=8024000C
2018/03/23 13:27:29.9372862 4344  4848  ComApi          [0]10F8.12F0::03/23/2018-13:27:29.937 [comapi]ISusInternal:: DisconnectCall failed, hr=8024000C
2018/03/23 13:27:34.9056674 276   840   Reporter        [0]0114.0348::03/23/2018-13:27:34.905 [reporting]REPORT …
0
Hi
I am not certain if League of Legends is an RTS type network server, or an FPS? The player movements are well spaced out, so I'd think RTS

In Summoner's rift, is it only 5 people/champions playing? Is that the practical limit on players, in most network games?

If I port my working Java RTS server that I finished a little while ago to Python, could I expect any performance shift? It is TCP messaging, with UDP duplicates sent afterwards for speed.

Thanks
0
I have an application server in dmz and database in nside zone.now i want to use xenapp to publish this application to my out side users.what should be the xenapp component design best practice and is ssl certificate is mandatory.please explain the design and
0
Some advice please.

Should a terminal server be installed on a DMZ?
0
Hello I’m looking to putting in my first firewall. I’m looking for a good option for a municipality. If someone could help me out with this it would be great like I said this is my first and I don’t have any experience in it at all! Thanks.
0
Over one month ago I setup a new Server 2012 / Exchange 2016 with the intention of migrating the existing Exchange 2010. No disruption of services was the highest priority so installation progressed at a glacier rate. We finally reached a point where both mail server were operational, the 2016 server could send out email, the 2010 server continued to run the show. Last weekend I changed firewall settings so that the new 2016 server handled both inbound and outbound email and proxied down to the 2010. Worked great for about 5 days; no one was even aware of the change. As of last night...

1) 213 outbound emails stuck in queue

2) OWA gets a "page not found error"

3) Exchange Admin Center shows the login screen but displays a blank page and hangs. Even more interesting is the ECP folder is empty.  There is only a config file.

Temporary fix - changed the firewall settings back to the old server. It would be nice to get the 2016 to deliver the emails stuck in the queue.

Short of completely reinstalling Exchange 2016, is there a way of fixing this? And more importantly, how did it happen?
0
Hi,

I saw in the server room there is "One Empty switch" (100% empty; no cable is attached to it).

Question: Why they prepare "the empty switch" in the server room?

tjie
0
Hi,

I saw NAS (Network-Attached Storage) and SAN (Storage Area Network).

Question:  Why do they have both (NAS & SAN)?

tjie
0
Step by step guide to map emc vmax lun to iscsi target using emc unisphere
0
After using apache and weblogic for more than 10 years(the last working module used is: mod_wl_22), I am ready to set up a replacement system with the newer version of the connector module (mod_wl_24) for our production.

I follow the official documentation from this link:

https://docs.oracle.com/middleware/1221/webtier/develop-plugin/apache.htm#PLGWL395

The server OS is:
root@server90 ~]# uname -a
Linux server90 4.1.12-94.3.9.el7uek.x86_64 #2 SMP Fri Jul 14 20:09:40 PDT 2017 x86_64 x86_64 x86_64 GNU/Linux

Open in new window

Apache version:
[root@server90 ~]# apachectl -version
Server version: Apache/2.4.6 ()
Server built:   Oct 19 2017 14:54:33

Open in new window

APACHE_HOME folder details
[root@server90 httpd]# pwd
/etc/httpd
[root@server90 httpd]# ll
total 8
drwxr-xr-x 2 root root   58 Mar 10 21:58 conf
drwxr-xr-x 2 root root  103 Mar 10 21:56 conf.d
drwxr-xr-x 2 root root 4096 Mar 10 21:42 conf.modules.d
drwxr-xr-x 2 root root 4096 Mar 11 15:31 lib
lrwxrwxrwx 1 root root   19 Feb 22 16:32 logs -> ../../var/log/httpd
lrwxrwxrwx 1 root root   29 Feb 22 16:32 modules -> ../../usr/lib64/httpd/modules
lrwxrwxrwx 1 root root   10 Feb 22 16:32 run -> /run/httpd
[root@server90 httpd]# 

Open in new window

I created a lib folder at the APACHE_HOME folder and copy all the lib files and this connection module(downloaded from Apache foundation website) into this folder
[root@server90 httpd]# cd lib/
[root@server90 lib]# ll
total 138808
-rwxr-xr-x 1 root root  6990875 Mar 10 21:00 libclntshcore.so
-rwxr-xr-x 1 root root  6990875 Mar 10 21:00 libclntshcore.so.12.1
-rwxr-xr-x 1 root root 58793741 Mar 10 21:00 libclntsh.so
-rwxr-xr-x 1 root root 58793741 Mar 10 21:00 libclntsh.so.12.1
-rwxr-xr-x 1 root root   409107 Mar 10 21:00 libdms2.so
-rwxr-xr-x 1 root root  1768370 Mar 10 21:00 libipc1.so
-rwxr-xr-x 1 root root   544150 Mar 10 21:00 libmql1.so
-rwxr-xr-x 1 root root  6747034 Mar 10 21:00 libnnz12.so
-rwxr-xr-x 1 root root   346242 Mar 10 21:00 libons.so
-rwxr-xr-x 1 root root    98521 Mar 10 21:00 libonsssl.so
-rwxr-xr-x 1 root root    72281 Mar 10 21:00 libonssys.so
-rwxr-xr-x 1 root root   567319 Mar 11 15:24 mod_wl_24.so
[root@server90 lib]# 

Open in new window

After that, I added directive for loading the module  into the $APACHE_HOME/conf/httpd.conf file:
[root@server90 httpd]# cd conf
[root@server90 conf]# ll
total 36
-rw-r--r-- 1 root root 11814 Mar 11 00:49 httpd.conf
-rw-r--r-- 1 root root 13077 Oct 19 17:55 magic
-rw-r--r-- 1 root root  4104 Mar 10 21:58 weblogic.conf
[root@server90 conf]# cat httpd.conf 
LoadModule weblogic_module /etc/httpd/lib/mod_wl_24.so

Open in new window

Then verify if this apache web server has included the dynamic sharing module: mod_so.c
[root@server90 conf]# apachectl -l
Compiled in modules:
  core.c
  mod_so.c
  http_core.c
[root@server90 conf]# 

Open in new window

the next step is to try to test the syntax of httpd.conf:
[root@server90 conf]# apachectl -t
httpd: Syntax error on line 355 of /etc/httpd/conf/httpd.conf: Cannot load modules/mod_wl_24.so into server: libonssys.so: cannot open shared object file: No such file or directory
[root@server90 conf]# 

Open in new window

it shows some error message:

Open in new window

0
Hi SFB Experts

as i understand from this link that in order to install SFB enterprise you have to have three front end servers in the pool

and in order to install SFB standard edition you have to use the built in MSSQL express inside SFB media

so what if i want to install only one front end server and use external MSSQL 2014 standard edition so technically this possible and such setup called standard or enterprise

i know front end server license is the same for stranded and enterprise only CALS play roll here but i want to know my setup is doable and under which category standard or enterprise

https://insidemstech.com/2016/12/31/skype4b-standard-vs-enterprise-edition/

https://insidemstech.com/2015/08/17/skype-for-business-licensing/


thnaks
0
What are some good step-by-step articles showing how to upgrade my below to 2016 since I have a small setup, plenty of backups, and can take everything down over the weekend if needed ?

Current Setup
 1. one PHYSICAL Windows 2012 R2 server
 2. five VIRTUAL Windows 2012 R2 HyperV servers
0
what's the name of that software I need to install on my HP ProLiant servers to manage them see my ILO info, install updates, upgrade my ILO, etc?  I have four Gen 8s that I need to install it on and I can't remember what to google.

Thanks
0
When I open Dell OpenManage Server Administrator, it is correctly showing the inventory of the server, except for the physical and virtual disks on the machine. Instead, it is showing me the physical and virtual disks and RAID-5 array on a DIFFERENT machine. I have tried opening OMSA with localhost, the IP of this machine and its name, I have checked that NSlookup is only reporting the IP of this machine. Is there some way to force it to check the inventory again? I have uninstalled and reinstalled twice now.
0
I try to update System Center Configuration Manager to version 1706.
The status is "Applicable", but if you right click only have the option for "Show Status" other options are grayed out.
If you click Show Status, Download is in progress.
I already try:

1.delete the package under EasySetupPayload folder

2.delete SQL record by this command:
DELETE FROM dbo.CM_UpdatePackages WHERE PackageGuid = '0f11caa4-7f7f-454b-96d6-75f427d015ce'

3.Use CMUpdateReset.exe reset the package:
CMUpdateReset.exe -FDELETE -S sccm2012.mydomain.com -D CM_MYD -P 0f11caa4-7f7f-454b-96d6-75f427d015ce

After that the package was deleted on the Console, but when it try to download again, it stuck in the same spot.
Pack-Status.PNG
Right-Click-configuration-Manager-17.PNG
dmpdownloader.log
0
We have newly configured AlwaysOn in SQL Server 2016. But we didn't added any DB to AG group (Just empty).
When i ping AG listerner i am not able to ping.

My understand is if we not add any DB to AG group, the listerner will not work.
Am i correct?  if not please correct.
0
I am now responsible for a very old 2003 environment with 2003 AD, 2003 Exchange and several 2003 servers.  I would like to do long term upgrade to AD2016 and on premises Exchange 2016.  Can the AD upgrade go directly to AD2016 (via additional new servers) and then a new Exchange 2016 server while still support existing 2003/2008/2012 servers with Win 7 end user devices ?  Would like to preserve existing domains (two) and upgrade the AD to 2016 first and then do an inplace/onsite migration from Exchange 2003 to Exchange 2016.

Lastly, there are still some Windows XP machines - I assume they must go ??
0
I am trying to add a host route as a test to my routing table in AWS to make it go over my DX connection. However for some reason I seem to not be able to get
the route to propagate as can be seen in the attached image. Traceroute fails to make it beyond even the first hop. What can cause this?
No-Prop.png
0
I am using Oracle 9i database and PHP(5.6.33) for an application.
Application is showing PHP extension issue "None of the supported PHP extensions (OCI8, PDO_OCI) are available".
But i have tried to download couple of php extension named as OCI8.dll and PDO_OCI.dll to my PHP configuration file, but
still error is not going.Please help me on so I can connect oracle database with PHP.
0
Hi Guys,

I am desperate for a solution!

We've setup an Exchange server 2016, transferred all the mailboxes across from Exch 2010 and everything was working just fine.
Abruptly the server could not access OWA or ECP and gave an error:

Bad Request - Invalid hostname
HTTP Error 400.  The request hostname is invalid.

Workstations were also unable to connect.

Upon troubleshooting I found all certificates on the server to be missing.
Creating a new request for both Godaddy and Selfsigned produced blank entries after import.

I recreated virtual directories, confirming virtual URL's, etc to no avail.
I called it a day, as we were under a lot of pressure and reloaded Exchange 2016 in a VM.


This time round I documented every step and followed the setup conservatively.
Fortunately the mailboxes were still available in the "broken" setup to be transferred.  This made me believe that the initial errors were IIS related.

The second-installation 2016 VM server (ecp, OWA, mapi) all was working fine and all mailboxes were transferred yesterday.

I made an IIS backup today "appcmd add backup xxx" to prevent an unrecoverable scenario as with the first 2016 installation.

About 30 minutes after the backup, ECP was broken yet Again!
BAD REQUEST - Invalid Hostname
HTTP Error 400.  The request hostname is invalid.


Needless to say did a couple of checks in EMC, including Default Website bindings in IIS, and did not find anything wrong ...

0
I keep seeing this error message on two 100% identical (same hardware ProLiant DL380p G8, 8 GB RAM on each, same 2012 R2 o/s, same updates) servers that are currently
doing nothing and have nothing else installed in terms of roles and
features except file server. No Exchange, no DC, etc.
Both are physical servers (NO virtualization running on them) on the same network in the same AD domain as all other servers that do not show this error
They both have Shadow Copies enabled and configured for previous versions of files/folders,

Source: ESENT, Type: Warning, EventID: 906
svchost (1036) A significant portion of the database buffer cache has been written out to the system paging file.  This may result in severe performance degradation.
Resident cache has fallen by 4749 buffers (or 97) in the last 1 seconds.
Current Total Percent Resident: 2 (111 of 4860 buffers)

always followed by ESENT EventID 912
svchost (1036) A portion of the database buffer cache has been restored from the system paging file and is now resident again in memory. Prior to this, a portion of the database buffer cache had been written out to the system paging file resulting in performance degradation.
Resident cache has restored by -1 buffers (or -100) in the last 589 seconds.
Current Total Percent Resident: 0 (0 of 9 buffers)

and on one server preceeded by these almost always

ESENT 102
msiexec (4124) Instance: The database engine (6.02.9200.0000) is starting a new instance (0).
0
I have just had a Malware Bytes Enterprise Anti Malware database update (v2018.01.27.03) (dated 2018/01/27 15:38:31 GMT) and this has updated on my servers and effectively flagged every server service.

I have managed to get in via vSphere into my DCs and turn off "Website Blocking" which now makes internal DNS work. However I have an Exchange server which wont work and appears to be flagging some of the services for quarantine. Further more restarting the servers causes the "Website Blocking" to enable itself again and the issue persists.

I am on the verge of uninstalling the client on the servers to try and get a stable environement. As I cannot access my email I cannot access my MBAM support so I am unable to raise a case. Does anyone have MBAM and having the same issue and can raise a case?

Thanks,
Tom
0
Hi,

I am curious if it is a security risk to keep internal files within the same level of the accessible directory. I am using Plesk to manage my server.

Plesk sets up the directory structure as such
  1. vhost
    1. example.com
      1. error_docs
      2. http
      3. logs

Within the example.com directory, the http directory is accessible to the public via www.example.com

i have added additional directories within the example.com directory to keep everything in the same spot. The additional folders contain sensitive information.

I know that these folders are not directly accessible to standard users but im curious if i should move them up the directory hierarchy so i only have the public http directory.  Or is this something i dont have to even worry about
0
Hi

Hi we are using VMware- Virtual appliance for our network infrastructure .I was working on the server room tidying the cables  and I have received an email triggered from VMware infrastructure as follows:

Target: ESX-001.domain.local
Stateless event alarm
 
Alarm Definition:
([Event alarm expression: Network Redundancy Degraded] OR [Event alarm expression: Network Redundancy Degraded on DVPorts])
 
Event details:
Uplink redundancy degraded on virtual switch "vSwitch1". Physical NIC vmnic3 is down. Affected portgroups:"NFS".

At the moment the servers are up and running without any problems.
Please let me know if there is a problem , if so where I need to look at to rectify the problem.

Thanks  and  help will be great.
0

Server Software

7K

Solutions

12K

Contributors

A server is a computer program or a machine that waits for requests from other machines or software (clients) and responds to them. This architecture is called the client–server model. The clients may run on the same computer or may connect to the server over a network. The purpose of a server is to share data or hardware and software resources among clients. Typical computing servers are database servers, file servers, mail servers, print servers, web servers, game servers, and application servers.