SSH / Telnet Software

Telnet is an application layer protocol used on the Internet or local area networks to provide a bidirectional interactive text-oriented communication facility using a virtual terminal connection. SSH was designed as a replacement for Telnet and for unsecured remote shell protocols. The term telnet is also used to refer to the software that implements the client part of the protocol. SSH provides a secure channel over an unsecured network in a client-server architecture, connecting an SSH client application with an SSH server.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hi expert

I had encountered the followng error "showing too many parameters for command synchronize".

i have the attach the script files  for reference example

option batch abort
option confirm off
open sftp://test1:test@200.1.1.1 -hostkey="ssh-rsa 1024 e4:dd:11:2e:82:34:ab:62:59:1c:c8:62:1d:4b:11:11"
synchronize local E:\SIN\Marketing\Daily Reports  /Reports

please note I have attached the errors message for your reference.
0
Free Tool: SSL Checker
LVL 9
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

I am setting up spiceworks monitoring on my domain and "one" computer it cannot connect. I already opened the ports on the domain and in the firewall (Symantec) but still cannot connect.
I did a telnat but it shows ports listening that is not required in their documentation.
Is there a network tool that I could use to monitor to see what is blocking the server application to communicate with client
0
We have an account that when someone SSHs in to it won't accept a password. If I login via Putty and su to the account I get asked for the password and when I put it in it's accepted. If I ssh to that account I'm asked for a password and it is rejected.

Hasn't been any real changes to the OS/Server but I'm not an Unix  pro. Where should I start?

Yes, I can delete and recreate it but I'd like to find the underlying issue.
0
I am new to ssh and I have no idea what I'm doing. I followed the instructions on public and private key generating, and all that grand stuff, but when I open terminal on my mac, I get this. What am I doing wrong?
Screen-Shot-2017-07-21-at-4.14.32-PM.png
0
Hello,
I have powershell code for winscp that uploads files from a local directory using a filter on files in the directory to a remote server.  I need code to determine if files are in use before they are uploaded. If a particular files is in use, I would like the code to skip the upload of that particular file and continue with the upload of the files not in use.  The code needs to accommodate applications that might be using the file that do not support file handles and any process that might have a lock on the file.

Any help would be greatly appreciated.

Thank you
Diammond
0
Dear All

           I have a CentOS 7 suddenly can not ssh to it, below is the error, any idea what happen ?

ssh
0
Previously Bluecoat proxy allows access to SendThisFile service but sometime in
May, Bluecoat proxy has blocked it as "potential data loss/leakage".

I can see that SendThisFile has options for files transfer via PCs/laptops/emails
though previously when I could access, they have good encryptions etc.  Don't
recall SendThisFile is HIPAA & PCI certified.

What about IPSwitch (refers to link below):
https://www.ipswitch.com/resources/data-sheets/ipswitch-gateway
It's PCI & HIPAA certified but what else sets it apart from SendThisFile that it's
not a potential data loss/leakage source?  Some major insurance companies
want to exchange files with us using IPSwitch.

What I can think off are whether IPSwitch can restrict such that:
a) use only sftp that IPSwitch offers, not ftps (correct me, but I believe ftps is
   less secure than sftp)
b) don't allow transfer via PCs at both sender/recipients ends but this is
    something controlled at recipient/sender's ends right?  Not by IPSwitch
    or unless IPSwitch has an option that restricts connections from servers
    IP addresses of senders & recipients - does it have this option?
c) how is IPSwitch PCI certified?  They mask their customers data or have
    segregation of different customers (ie no co-mingling)?
d) how else can we restrict such that sender/recipient do connect from
     public places & homes of their staff but only from their organizations'
     servers?
e) I suppose we should not allow …
0
Hi,

I am using secureCRT version 8.0.4 on windows 10. Whenever I ssh into any of the devices, there is no terminal length set for example when i ssh into cisco router and give a command of Show Run it displays the whole configuration instead giving breaks i.e.--more-- in the middle like in putty.

How can i achieve the same using secureCRT?
0
I have many winscp ftp website, login, password
Rather than me looking through email, and sms to figure out what the passwords are,

how can I backup the passwords in a file
and use that same file to restore in a new windows 10 computer
0
I found a really nice looking example of how to do telnet over VB.  

It is the last post on this page:

http://stackoverflow.com/questions/9113632/test-telnet-communication-on-remote-computer-using-vb-net

It looks to be exactly what I need, but I don't know how to use it.  

I want to use it to connect to cisco routers and issue commands.  

I've built a form to do it, but, I have a really silly problem.  I don't know how to instantiate the class, set the settings and use it!

I don't do a lot of VB and this bit has stumped me.  

Ideally, if you checkout the code below and assuming it is ok,  tell me how to:
1.  Connect to a telnet device using the hostname from a textbox called txtHostRouter and the port number from a textbox called txtPortNumber
2.  Recieve whatever output (probably a password prompt)  into a text box called txtOutput.  
3.  Send some input from a text box called txtInput for example "show Run"
4.  Recieve the output into a different text box called txtOutput.  

So I can keep doing 3) and 4) until I am finished and then close the connection.  

I am not sure where to start, so even if you just get me started, I bet I can work it out.  

I have pasted the code below

Any help would be appreciated

Thanks in advance

Imports System.Threading
Imports System.IO
Imports System.IO.Pipes

Public Class TelnetClient

Open in new window

0
Enroll in August's Course of the Month
LVL 9
Enroll in August's Course of the Month

August's CompTIA IT Fundamentals course includes 19 hours of basic computer principle modules and prepares you for the certification exam. It's free for Premium Members, Team Accounts, and Qualified Experts!

I am configuring OpenSSH on windows, when I sftp a number of files through winscp the following error is logged and the transfer fails.

Fault bucket 120742644444, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: sshd.exe
P2: 0.0.12.0
P3: 58f3d47d
P4: StackHash_c1e2
P5: 10.0.14393.0
P6: 578997b2
P7: c0000374
P8: PCH_BC_FROM_ntdll+0x00000000000A59A4
P9:
P10:

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_sshd.exe_22ea82deddc0bc295fdb7f2a9ebb7d12a9daedd_01be728d_1f386bfb

Analysis symbol:
Rechecking for solution: 0
Report Id: df3f0593-ed53-412b-8d6f-bc3fd55c42df
Report Status: 0
Hashed bucket: 7e077c76baf60d7e7a72f62d6b43bfe1

I have tried to disable the Microsoft DEP but I am still stuck with this error.
0
Sys admin has provided me username and password and advised that solaris uses nis (and then I've been given hostnames).

I've downloaded putty but it gives me authentication failure. Nothing special I have to do if its NIS authentication?
0
I want to be able to SSH to the outside interface of a remote ASA 5505 so that I can connect to make changes without losing connectivity as the current access is to the inside interface over a VPN connection. I tried  ssh XXX.XXX.XXX.XXX 255.255.255.255 outside but it did not work. This is the public IP of the outside interface. What else do I need?
0
Feel free to try connecting yourself, it's just a test server atm.

I have tried both WinSCP and FileZilla and can not make a connection. I was previously able to login, but I am using a free webhosting so I don't get free tech support.

Host Name: files.000webhost.com
Username: php-lessons
Password: temporarytestftp

ftp.png
0
I am in the process of setting up SFTP communications with a vendor of ours.  After changing the project parameters from using a web service to SFTP, I have learned that IIS 8 does not support SFTP. Can anyone provide me with an application to use?

Requirements
1) Secure - Kind of a given, but I'm saying it anyways
2) Actively supported
3) Easy to use - I'd prefer not to have to do everything via command line\powershell
4) Known product\Trusted - I'm looking more for a time tested application rather than the newest latest greatest

Other
1) Can be a purchased product  - though I'm aware of several that are free
2) If it has any special features, I will be using the SFTP to mainly receive XML files into a T-SQL database

Thank you!
0
Dear Colleagues,
I have HP Aruba2530 switch installed at state hospital.
The problem is that SSH and WEB access is not secured by any password, all the settings are default whatsoever.
Plz help me to add a password authorization to SSH and WEB interface.
0
I am writing a script using plink to send commands remotely to network devices (routers and switches) and then output the console to a text file.  Using the below, I can successfully acheive this but with some strange results:

(plink -ssh user@1.2.3.4 -pw password <.\commands.txt)>output.txt 2>&1

The resulting output.txt file actually shows the command output and then all of the login banner mumbo jumo you get when you log into a device normally (***WARNING*** THIS IS A PRIVATE COMPUTER SYSTEM, etc...)
So my format ends up being:

- results
- login banner

I am having trouble getting the format correct to send a pause trough plink so that my output file shows the results as if I was logged in:

- login banner
- results

Any suggestions?  or is this even possible?
0
Able to take telnet of the server and unable to take ssh.
0
My 14.04 LTS ubuntu box has 2 active network connections:

The default gateway is the hardwired eth0 (192.168.1.x) going to my cable modem, which has a WAN ip address of 68.x.y.z

The wireless connection is wlan0 (192.168.0.x) is to a cellular access point to Sprint LTE gateway, which has a WAN ip address of 174.x.y.z

I want to have the option to ssh into the server with the option of choosing which WAN to use for ssh socks proxy port forwarding.

I added a route with this command:
route add -net 192.168.0.0/24 gw 192.168.0.1

Open in new window


Here's the output of my route command:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0

Open in new window


I want to ssh with the -b option to bind to the wireless connection and with socks proxy port forwarding going through the Sprint network, not through my cable modem:
ssh user@myserver -b 192.168.0.1 -D 1080

Open in new window


But when I use my browser to go to whatismyipaddress.com using the socks proxy on port 1080, I still pull up the WAN ip address of the cable modem 68.x.y.z rather than of the sprint WAN.

How can I get ssh to route through the sprint WAN on wlan0, rather than the default gateway through the cable modem?
0
Free Tool: IP Lookup
LVL 9
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

We are outsourcing our customer screening function (to screen for customers who
are known to be $ laundering or terrorist-funding related) to an external vendor.

We have to do sftp to transfer our customers' info to this vendor daily.

a) Is is more secure that we are the sftp server (ie the vendor connects to us to
    'get' the data or the vendor is the sftp server (ie we 'put' the data to the vendor
    or it doesn't matter?
    Considering whether to get Tectia ssh client or Tectia ssh server

b) Anyone come across direct secure data transfer between apps (say via API)?
    Does such API uses sftp protocol?   If so, any keys need to be established and
    exchanged between our apps & the vendor's apps?  Perhaps this question
    doesn't make sense

c) For a more secure environment, should we enable one-way instead of two-ways
    ssh keys exchange?'

d) I'm inclined to think that should an ex-employee left us, he can copy the ssh
   keys out;  so would a 2nd extra authentication (say password authentication)
   help?  Or what could help with this scenario where a staff at vendor's end
   or our end leave & copies out the ssh keys?
0
Hi, all,

I've had a number of people help me out with a slow computer issue. The other computer on my network slows down to almost nothing sometimes as well.

I decided I'd turn off wireless access to the router for a few days, to see if that would help. My gateway IP is 192.168.1.254. I've never had trouble accessing it before (It's a Telmex Infinitum router).

But the connection times out. So two questions:

1. Could that be an indication that it's being controlled by someone else? Or am I just being paranoid?

2. How else can I get into it? I know in my old job I used telnet to access routers. I guess I could do that?

Thanks. I'm on Windows 7 SP 1.

UPDATE: I tried telnet, maybe I did it incorrectly?

Microsoft Telnet> open 192.168.1.254
Connecting To 192.168.1.254...Could not open connection to the host, on port 23:
 Connect failed
0
000webhost.com
lamp shared server

I cant see
.htaccess

on winscp ftp (latest) using windows 10


I can create new file and add text but can not edit again

If I need to make a small change I need to create file again and copy paste all contents
I also can not see on web browser
https://php-lessons.000webhostapp.com/Paypal/
no index.php so you can see all my files (but not .htaccess)

I am not sure if htaccess even works

one line of .htaccess code
#this is a comment

Open in new window


if I right click 'new'->'file' I see 'edit' and then I type in .htaccess and see that file stays the same
but I can not see icon in winscp

right click new then file
0
I had this question after viewing error log using ftp.

Ray created a custom error log
Does 000webhost.com provide a default error log and if so;  what is location?

Can I see using ftp
0
000webhost.com

shared linux server

control panel very limited
not plesk or cpanel
is there an error log?
can I get to log using ftp?
0
. 2017-01-30 20:15:19.665 --------------------------------------------------------------------------
. 2017-01-30 20:15:19.665 WinSCP Version 5.9.3 (Build 7136) (OS 10.0.10586 - Windows 10 Home)
. 2017-01-30 20:15:19.665 Configuration: HKCU\Software\Martin Prikryl\WinSCP 2\
. 2017-01-30 20:15:19.665 Log level: Normal, Logging passwords
. 2017-01-30 20:15:19.665 Local account: ROOT-HUB\win-computer
. 2017-01-30 20:15:19.665 Working directory: C:\Program Files (x86)\WinSCP
. 2017-01-30 20:15:19.665 Process ID: 7992
. 2017-01-30 20:15:19.665 Command-line: "C:\Program Files (x86)\WinSCP\WinSCP.exe" 
. 2017-01-30 20:15:19.666 Time zone: Current: GMT-5, Standard: GMT-5 (Eastern Standard Time), DST: GMT-4 (Eastern Daylight Time), DST Start: 3/12/2017, DST End: 11/5/2017
. 2017-01-30 20:15:19.666 Login time: Monday, January 30, 2017 8:15:19 PM
. 2017-01-30 20:15:19.666 --------------------------------------------------------------------------
. 2017-01-30 20:15:19.666 Session name: php-lessons@files.000webhost.com (Site)
. 2017-01-30 20:15:19.666 Host name: files.000webhost.com (Port: 21)
. 2017-01-30 20:15:19.666 User name: php-lessons (Password: secret, Key file: No, Passphrase: No)
. 2017-01-30 20:15:19.666 Transfer Protocol: FTP
. 2017-01-30 20:15:19.666 Ping type: Dummy, Ping interval: 30 sec; Timeout: 15 sec
. 2017-01-30 20:15:19.666 Disable Nagle: No
. 2017-01-30 20:15:19.666 Proxy: None
. 2017-01-30 20:15:19.666 Send buffer: 262144
. 2017-01-30 20:15:19.666 UTF: Auto
. 

Open in new window

0

SSH / Telnet Software

Telnet is an application layer protocol used on the Internet or local area networks to provide a bidirectional interactive text-oriented communication facility using a virtual terminal connection. SSH was designed as a replacement for Telnet and for unsecured remote shell protocols. The term telnet is also used to refer to the software that implements the client part of the protocol. SSH provides a secure channel over an unsecured network in a client-server architecture, connecting an SSH client application with an SSH server.

Top Experts In
SSH / Telnet Software