SSH / Telnet Software

Telnet is an application layer protocol used on the Internet or local area networks to provide a bidirectional interactive text-oriented communication facility using a virtual terminal connection. SSH was designed as a replacement for Telnet and for unsecured remote shell protocols. The term telnet is also used to refer to the software that implements the client part of the protocol. SSH provides a secure channel over an unsecured network in a client-server architecture, connecting an SSH client application with an SSH server.

Share tech news, updates, or what's on your mind.

Sign up to Post

How to check if a remote ssl cert has expired using IP address  On mac terminal
Announcing the Winners!
LVL 19
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!


My environment:
AWS EC2 linux 2, apache 2.4, PHP 7.3, WinSCP (for SSH).
With AWS EC2 I have a choice of owners: root, www, ec2-user, apache
And a choice of groups: root, www, ec2-user, apache

Document root: www/html
Non-directory root which I classify as 'private' since I don't want browsers (except mine) to have access: www/private

I am the sole developer. The website is accessed by users on their browsers (vs local).

I need the following:
1. PHP to be able to create, edit and remove directories in both /html and /private.
2. PHP to read and write files in both /html and /private.
3. WinSCP (my SSH) to be able to create, edit and remove directories in /html and /private (from the browser), for development (not for world access).
4. WinSCP (my SSH) to be able to transfer, move, copy and remove files in /html and /private (from the browser), for development (not for world access).

I need help with:
Which owner:group should I give /html (and by default, its sub-directories) and why?
Which owner:group should I give /private and (and by default, its subdirectories) and why?

I have two accounts with the same hosting provider.  They allow SSH access.  I created backup copies of websites on one account that I need to move to the other account.

I can move them individually, explicitly with "wget" but if I try to just pull all files from that one directory it fails.

Here is the command I am using, there are NO other sub-directories, just a bunch of files in one directory that I want to copy over from Account A to Account B.

wget -nc --level=1 --recursive --no-parent --accept jpa <url>/backups/

All I get when I run that command in the SSH portal is an "index.html" file and nothing more.  No error, just that one file (which is then automatically removed because it is not on my accept list).

I see other people (in general) are having a similar issue on StackOverflow (for example).

Server restriction maybe?  Problem with the command?

Thanks. :)
What Ubuntu tools (or tips) make learning Ubuntu easier?

I have used LINUX here and there over the years, but always feel like it's the first time. Most of my software development jobs were Windows and Web, with Windows Server.

So, I just successfully SSH'ed to my AWS Ubuntu instance. AND need to get up and running quickly.

What tools can you suggest?

Is there a GUI I should consider?

Was the X-Windows??

And what other tools are there besides a GUI?

I expect to host a WordPress Podcast. So, any helpful tools or tips would help greatly.

Need to SSH to my AWS Ubuntu server from Mac Terminal

I opened Terminal, executed
sudo su (to become super user)

changed directories so that my current folder shows my KeyPair1.pem file and when I execute

ls - l

I see my .pem file has the following permissions:


please explain this. It's Read access for who exactly?

I ran "chmod 400 KeyPair1.pem" as a way to protect the file from being over-written, Is this the correct thing to do?

I have the IP address of my Ubuntu server:

I execute the same command provided by AWS, but find the terminal locks. I am forced to press Ctrl+C to get the cursor again:

ssh -i "KeyPair1.pem" ubuntu@

Does anyone see what's wrong?

When I type ssh <ENTER> I get:
usage: ssh [-46******************Yy] [-B bind_interface]
           [-b bind_address] [-c cipher_spec] [-D [bind_address:]port]
           [-E log_file] [-e escape_char] [-F configfile] [-I pkcs11]
           [-i identity_file] [-J [user@]host[:port]] [-L address]
           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
           [-Q query_option] [-R address] [-S ctl_path] [-W host:port]
           [-w local_tun[:remote_tun]] destination [command]

Does this mean SSH is installed?

Is there a way to see what variant of SSH is installed?

ssh access with public key..

I recently allowed port forwarding to an internal host. how do i configured access for users with ssh key so that only those users are able to establish a connection even if port forwarding is open. one of the users provided  me with her ssh public key but i'm not clear if that's something to be configured at the fw or server.

i have an ssh-sftp container on my ubuntu.
from ubuntu i add ip for container ( docker inspect "container_id")
then i can ssh and sftp from my ubuntu server to container
how to do it out of ubuntu server (on my domain)?
where to add container's ip for ssh or sftp to container?
I have used Putty (TelNet) to connect my race timing box with my pc in order to stream running race results as they come into my race results software.  It works very well but I was trying to streamline the interface for the benefit the people doing my timing in order to avoid user error by modifying a program I found online.  It works well except that it times out and so I occasionally miss some results.  One other thing I have noticed is that, with the version I am using, I can FTP into the timing box and get all data.  I can not do that with seems that it is locked.  I am wondering if that is an indicator that Putty locks things down more than my version and is the likely shortcoming in the one I am  using.  Long story short...can someone look at my code and see if they see anything amiss?  If this is a bigger issue than is appropriate for this forum, I might be willing to have someone take a look at it for fair compensation.My Telnet Interface
Please note that I have no problem connecting or with any functionality except the time-out issue.  Any help would be much appreciated!

Private Sub Form_Load()
    Dim form_left As Long, form_top As Long, form_height As Long, form_width As Long
    form_left = GetSetting(appname:="simptel", section:="position", Key:="Left", Default:=0)
    form_top = GetSetting(appname:="simptel", section:="position", Key:="Top", Default:=0)
    form_height = GetSetting(appname:="simptel", section:="position", 

Open in new window

I need to access data from a race timing machine via an ethernet connection as runners cross the finish line.  I have a TelNet connection that is working but I am not sure how to keep it from timing out.  In my search for a solution to that I have been directed to SSH.  I have open SSH installed on my Windows 10 machine.  How can I connect my timing box with my PC using a vb6 program.  This piece is all very new to me.

Thanks for your assistance!
I have a TelNet utility in my vb6 app for race timing to get finish times from my timing machine to my computer.  It has been working well but at the last race (one of the first I have used it for) it stopped sending data after about an hour.  Is there typically a time-out feature in TelNet and, if so, how can it be adjusted?  I can post the code if need be.
CompTIA Network+
LVL 19
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

I want to add the following algorithms to my ssh and sftp server.
aes128-ctr hmac-sha1
As per my knowledege aes128-ctr is something related to encryption and
hmac-sha1 is related to authentication.
I have a sftp server running on a machine.
I want it to support these two.
Does it need to be added to sftp server ?
or ssh ?
The machine is having openSSH 7.9

My aim is that ultimately anyone connecting to the sftp server these two algorithms should be available..

There is a sftp server i am connecting to .
How do i know the encryption algorithms available/enabled at server end ?
This must be the encryptions in SSH.
So if i login to the server..Is there any command to show the list of algo supported by server for sftp?

I am getting the following error during SFTP connection -
Screenshot-2019-04-06-at-7.09.28-PM.pngwhat could be the reason for that
I am using the

dependency in my java code
I need a GUI client for sftp on MAC.
I have downloaded cyber duck. And i could connect to a sftp machine with port 22.
But then i tried another machine with port 7122. It seems it doesnt have ability to handle this port.
Although i am able to connect if from terminal.
On cyber duck if i manually change the port to 7122 it doesnt work.
It throws the following error :
Please help in suggesting some way to connect to this through some GUI client.
I am incorporating a TelNet utility into my vb6 program.  I have never done anything with TelNet.  The utility I am using is this:

I am using it to get data from a timing machine into my timing software in near-real time...constant stream as runners finish.  Here is what i need to know:

1)  Is there a limit to how much a TelNet client can log?  We will often have 15,000 reads to process....occasionally more.

2) Is there a limit to how much "density" a TelNet client can log simultaneously.  We could easily have 50-100 folks finish in a minute and each one of them typically generates 2-4 RFID reads.

3)  What do I do if I need to get data that is in the source file before I start the TelNet client?  In other words, it is not unusual to carry the timing box to a different place for the race start than where we set up for the finish.  We typically carry our timing box to the start, get all the start reads as the race starts, and then carry the timing box back to the finish and re-connect our timing mats.  How would TelNet get me that data?

Thank you very much!
Hello Expert

I got a customer that have an AWS environment.
I have never work with AWS before and i am trying to connect to the VM. But i cant because to connect it require a SSH key, but i dont have that and also the previous tech dont have that either.

What is the best way for me to gain access to the VM

Thanks in Advance
When I attempt to log in to my iSeries server via Putty (Port 22) - I am connected to the server, but when I attempt to log in, I get "Access Denied"

I compared my SSHD_CONFIG to other systems and everything appears to be the same.

I verified that other users get the same thing - so this is not related to any specific user...

Any assistance would be much appreciated.
I am trying to find a solution for a client which will allow them to push all SSH traffic over remote access VPN? they are also requesting that it must have split tunneling and all http/https traffic must go out over the local internet. Is this even possible? they currently have a fortigate, which says no its not possible, I've called a few other vendors who say their VPN solutions are not capable of that. I know in cisco you can force specific sites to go over the VPN but you need specific IPs and it is not recommend. OpenVPN might be able to do it but I might be misinterpreting what I'm finding. Has anyone come across something like this before and can point me in the right direction?

Basically this client has a lot of remote workers who download large images which is why split tunneling is a must. They work through AWS and SSH into the boxes. The security for this is getting out of hand as they have a lot of servers and they are putting everyone's public IP in the security settings to allow them to access the servers. They no longer want to do this and only use their public IP for security reasons so we are trying to get a baring on how one would be able to accomplish this as they want 1 point to cut all access to the servers if a user would leave or be terminated.
Is there a way to connect one device with another via TelNet in vb6 code?  I need to connect my laptop with a race timing machine so that I can pull data from the timing machine as it comes and and process it for near-real time race results.  I am working with PuTTY now but hoping to "remove the middle man" and do it within the program.

Thank you in advance!
Introduction to Web Design
LVL 19
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

I need to use PuTTY to TelNet to multiple timing systems, each with their own ip address, but daisy chained to one another as well.  How can I do that?  I need live streaming to happen from each timing box to a local file (different file for each timing system).  I have hardly used PuTTY but it looks like I can only connect to one ip address with PuTTY.  Can I run multiple instances of PuTTY simultaneously?

Thanks in advance!
Hi ..
I need to run some commands on a remote machine using ssh . What is the best way to automate this in Python?
I need to log in with a (known) password to the remote machine, so I can't just use ssh user@remotehost.
I'm wondering if there's a built-in module in python I could use or I need to install one.
If you have a sample script is highly appreciated.

Thank you for your help.
We are unable to login to our Extenua Silvershield SFTP app. The admin password is not accepted. I have access to the server but can't login to the Silvershield console.

I have emailed their support like 5 times but no response.

I was hoping someone here uses this app.

I've been trying for weeks to get a solution working to backup Windows clients to a remote Linux based NAS (QNAP).

I've got things working on one laptop but I'm having difficulty deploying the solution on a second laptop.  I tried to keep good documentation of my process but, it was mostly trial and error and I'm performing admin duties in addition to my main responsibility so, my focus was constantly disrupted.  

Anyway - here's what works on the first laptop:
rsync -azv -e "ssh -p 1722 -i C:\Users\<myuser>\Documents\.ssh\id_rsa" . <myuser><myuser>/backup/

Open in new window

Broken down that's:
1.  rsync through ssh
2.  specifying an alternate port for ssh (-p 1722)
3.  Pointing ssh to an identity file (-i C:\Users\...\id_rsa)
4.  Giving rsync the current directory as the source (.)
5.  Logging into the user at the remote server
6.  Giving rsync /share/homes/user/backup/ as the destination on the remote server (a folder named "backup" in the directory where QNAP is storing user home folders)

So, I can run that on the first windows 10 laptop and it works but when I run it on the second, it balks about:
"Could not create directory /home/<myuser>/.ssh"

But if I just run this:
ssh -p 1722 -i C:\Users\<myuser>\Documents\.ssh\id_rsa" . <myuser>

Open in new window

I'm transported to the users home directory.


Any ideas of places where I should look?  Permissions on all of the folders involved?

THanks in advance!
If I ssh to connect to a CentOS Linux server - and from that server I want to open
say five SSH sessions and tab or control or however jump back and forth between
those five session - how could one do that?  Is that a standard capability?
Dear Experts,

I am thinking to use SSIS to do the following procedure.

(1) copy many files to Linux machines. then
(2) execute a Linux program (command) to analysis those files. The program will output the result to the local Linux drive
(3) when (2) is done, then pull the result back to Windows machine

For (1) I am thinking of FTP task (by FTP or SFTP)

how about the task of (2) and (3) ?  Could you please help ... Thanks

SSH / Telnet Software

Telnet is an application layer protocol used on the Internet or local area networks to provide a bidirectional interactive text-oriented communication facility using a virtual terminal connection. SSH was designed as a replacement for Telnet and for unsecured remote shell protocols. The term telnet is also used to refer to the software that implements the client part of the protocol. SSH provides a secure channel over an unsecured network in a client-server architecture, connecting an SSH client application with an SSH server.

Top Experts In
SSH / Telnet Software