Storage

43K

Solutions

35K

Contributors

Computer data storage, often called storage or memory, is a technology consisting of computer components and recording media used to retain digital data. In addition to local storage devices like CD and DVD readers, hard drives and flash drives, solid state drives can hold enormous amounts of data in a very small device. Cloud services and other new forms of remote storage also add to the capacity of devices and their ability to access more data without building additional data storage into a device.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hi I was wondering if there was a third party software solution to make a RAID array.  I know Windows Server comes with one, but I frequently have it fail with an error something like "the drives must be the same block size" even though they are two drives that came off the self and are identical.  

For an example, I use a program AOMEI Partition Assistant to manage the disks and find it much more comprehensive and faster than Windows disk management.

Thanks all.
0
We have got to do some testing around storage of image and video files on our users stored on our users home drives on a windows file server. I have got a big inventory file of all file names, size, last accessed/modified/written etc, which includes file extensions. But there seems to be endless list of possible extensions now listed with video, audio and image files.

I only have to check a sample and so wondered what would you say are maybe the top 3-5 most common file extensions to be associated with image files & video files on windows based systems.  These files will go back literally 10 years so the more common extensions for such file types in 2009 may be much different to those in 2019 (or it may be similar).
0
Let say I have certain files  on my desktop, and I utilized DropBox for cloud storage. How can I prevent files from being backed up via DropBox on my desktop, without moving them to another location, on the C drive? Can I change the properties of the files to prevent cloud storage? Is there an extension such as Adobe Acrobat that would allow me to right mouse click on a file to prevent offline storage? I believe you can set the attribute of a file or folder to do not backup.
0
We're looking for a new server solution for our NFS/CIFS (only) file server(s). The network infrastructure will be 10Gb. Less than 100 users are connecting to the NFS/CIFS at any given moment. The files are a mixture of large and small (I.e. home directories, as well as large scientific data files in excess of 100GB.) The read/write ratio is probably around 70/30.

We are examining solutions like HP's 3PAR system, and Supermicro's 6048R-E1CR36L. Both are SANs with 12Gb backbones.

We are running ONLY file services on these servers (no virtual machine root virtual disks, no databases, no SaaS, etc.)

The only unanswered question is; what is the legitimate value of high disk IOPS in this environment and use case. SSD disks purport up to 75000 IOPS (as an array) , while the spinning disks up to 6000 (as an array).

My initial instinct is that SSD data drives have little to no value. But this is not supported by any facts.

Can anyone offer guidance?
0

Hey all,

I am thinking of creating a virtual machine for one of my clients using Hyper-V. It will be a terminal server environment where they will be using a cetralised database and accessing emails and docs. Their documents folder is only around 50GB and they have been getting away with 240GB up until now but I will increase a little when I build it. My question: Is there a need to partition the OS from the data drive.. will this provide any increase in performance or reliability?

FYI We will be running SSD drives with 32GB RAM, 8 vCPU cores which I think is ample.

0
Have an HP ML110 Gen9 that recently got it's VMware root password lost during a remote session password change.

Knowing the official password reset process is to reinstall VMware, I went local to the server, pulled out it's existing USB drive with the VMware host and put in a new blank one to install to. I matched the EXSI build version with the custom HPE image and was presented with two individual drives, not the single RAID that was somehow working.

I say somehow, because this machine, the ML110 Gen9 only has the B140i software RAID controller that VMware can't see.

But somehow this system had a VMware host that DID see it.

I've tried the most recent version of EXSI, the original matched build version, and gone back to 6.0 and as per the documentation VMware behaves as advertised and will not see the software RAID controller

I am completely confused as to how this host got setup with the B140i RAID controller, but now I can't get my client back operational.

Any ideas on how I might fool VMware back into seeing that RAID?
0
Buffalo Dual Link-Station LS-WXL

Adding Windows 10 machines to network and realise that despite latest firmware that is is still using SMBv1

Log into NAS using SSH to edit /etc/samba/smb.conf following the step-by-step here:
https://forums.buffalotech.com/index.php?topic=24630.0

Restart

Seems to go OK but still can't access via Win 10 and now can't access files from previously connected Win 7 machine

Log in via browser for Buffalo admin console and everything looks OK so data seems safe but inaccessible.
Try to reverse out changes but get error message

configure samba
/etc/init.d/smb.sh: line 53: /usr/local/sbin/NAS_configgen: No such file or directory
/etc/init.d/smb.sh configure fail

Open in new window


Heart sink moment and realise I'm out of my depth.

Priorty to get back to position at start so at least can see files again via Windows from at least one machine, then to get back to fixing the SMBv2 vulnerability.

Have done an non-destructive reset of the NAS and this has reset the root password so know it made some changes but when I list the file my changes are still there.

Everything I've read says the Linkstation uses Samba 3.6.x so SMBv2 should be possible

Here's the last attempt from Putty

login as: root
root@192.168.0.11's password:
root@Moorhen:~# vi  /etc/init.d/smb.sh
#s_config! /bin/sh
#

SMBDOPTIONS="-D"
NMBDOPTIONS="-D"
WINBINDDOPTIONS="-D"
PAMSMBDOPTIONS=
RETVAL=0
USE_MSDFS=1

SMBD_PID_FILE="/var/run/smbd.pid"

Open in new window

0
I create a Lab to test migration of the fileserver from Windows server 2008 R2 to Windows Server 2019, using Windows Admin Center.
I have 3 servers one Win2008 with the source data, other Win 2019 for destination and another 2019 like Orchestrator, the three servers a fully patched. Also, I run WAC ver 1904 from my Win 10 computer. All devices are in the same domain.
Orchestrator and destination server have Storage Migration Service installed.
The following rules enabled on the firewall File and Printer Sharing (SMB-In), Netlogon Service (NP-In), Windows Management Instrumentation (DCOM-In), Windows Management Instrumentation (WMI-In).
Scan for source device run successfully, Validate source and destination devices Pass.
When starting the transfer all files fail on destination server I got the share with all folders and empty files. But these files have the actual permissions. (please check the picture)
I try using the network admin credentials, local admin for each server and same problem.

This is the list of errors:
Couldn't retrieve endpoint details from the database.
Job: FileserverMigrationTest5
Computer: fileserver2008
Error: 36891
Error Message: Device fileserver2008 operationId ccc7e594-556c-405a-8dcc-6cfdf5fa5ed2 does not exist

Guidance: Check the job name - maybe it's spelled differently? We couldn't find it in the orchestrator database.

Couldn't retrieve the computer inventory configuration from the database.
Job: FileserverMigrationTest5
0
Purchased an android tablet Tab S4 with Android 9.0 (upgraded from Android 8.0 Tab S3)

Using MyPhone Explorer to transfer files

It worked fine with the old tablet but with the new tablet I get this error message

\ External storage\ 18072 701 Lighthouse RAP CASp could not be created' OBEX Errorcode: DO - Internal Seiver Error

Please note: It's impossible to write to the external SD card (External storage) for all third party applications due to a security restriction in Android! The internal phone storage (Internal storage) is not affected by this restriction.
Capture.JPG
0
I have a 16 TB storage fibre and I added 8 TB more and I tried to expand current datastore from ESXi 6.5 I selected custom 4TB and it shows now 20TB.
But now I cannot use the remaining 4TB anyone can help me add that and make it useful.
 
Capture1.JPGCapture.PNG
0
hello,

i have tape library hp MSL2024 Fc i need to connect it to cisco ucs 240 server direct through fibre channel.

the operating system is windows server2016
the backup software is veeam
the HBA card installed on the server is emulex lightpulse HBA - storport miniport and the driver is installed.

the problem is i cannot connect the tape to the server, i fixed the speed to both to 8 Gb/s and the port type to fabric on the server and the tape drive. i swapped the cable RX and TX, still no luck

on the tape it gives me no light detected.

help please
0
Is there a list of supported SFP or SFP+ transceivers for the Dell / Compellent SC4020i
0
Hp mediasmart server health issue
Looking at console, it is showing failing though it has least 100gb free.  It was also indicating files not in sync possible file open, though none are.  Others at random time not able to connect.  One computer think the first one, was running extreamly slow. Rebooted and it started running upadtes, finally started responding quicker.  Could this slow computer be causing this error by not syncing?  But could 1 affect others with this server?
0
I am cleaning up my computer storage and found 2 folders with over 10gb.  These are: 'C:\Program Files\Microsoft SQL Server\130\Setup Bootstrap' and 'C:\Windows\Installer'.  Is this normal for these folders to have that amount of storage?  Are they necessary for Windows to run?  And how can I properly delete them?

Thank you.
0
PowerShell Server 2016

I've created a (Storage Spaces) Virtual Disk Though Powershell in Server 2016.

Now in the GUI is simple enough to NOT assign a drive letter and mount it as a folder path, here's me doing that..

Mount
I cannot of the life of me fathom how to do the same in PowerShell, There seems to be no way to Format-Volume unless you have a drive letter?

Wha tIve done So Far..

$pool=Get-StorageSubSystem
!
New-StoragePool -StorageSubSystemUniqueId $pool.UniqueId -FriendlyName SP-1-Tiered -PhysicalDisks (Get-PhysicalDisk -CanPool $true)
!
Get-StoragePool SP-1-Tiered | Get-PhysicalDisk | Format-Table FriendlyName,MediaType,Size
!
$ssd_tier = New-StorageTier -StoragePoolFriendlyName SP-1-Tiered -FriendlyName SSD-Tier -MediaType SSD
$hdd_tier = New-StorageTier -StoragePoolFriendlyName SP-1-Tiered -FriendlyName HDD-Tier -MediaType HDD
!
New-VirtualDisk -StoragePoolFriendlyName SP-1-Tiered -FriendlyName VD-vDisk01 -StorageTiers @($ssd_tier,$hdd_tier) -StorageTierSizes @(7.5GB,16GB) -ResiliencySettingName Simple -WriteCacheSize 1GB
!
Get-VirtualDisk -FriendlyName VD-vDisk01 | Initialize-Disk -PartitionStyle GPT -PassThru

Open in new window


Anyone?
0
Don't laugh!  I know about VIEW and ZenDesktop and use both, but I've been asked!  :)

I have a company with 100 users, give or take, and they want to move their stuff into a COLO and go to a VDI environment using zero clients at the office while letting the virtual desktops live in the cloud.  I've talked to them about VIEW and Citrix and we have discussed the cost.  Once the owners were released from the hospital, we met and talked some more.

I have an idea and I want peeps on here to talk it up or shoot it down and give me some feedback.

My thought is to put in a couple of RRA servers at the COLO and build one or two virtual desktops to spec, convert them to templates and then spin up my needed VMs from the template, one at a time.  We actually have two or three techs who could help so it wouldn't be horrible.  

In the zero clients, we just specify the remote gateway and the VM assigned to that user and let them RDP straight to the desktop assigned to them.

All of this would be supported in the back by 5 ESX hosts and SSD storage to handle the IOPS so I don't expect the "speed" of the VMs to be a problem.  We have 1gig from the office to the internet already so I don't expect bandwidth to be a problem.  Even the usage in the building is mostly email and internet.  The "serious computing" - that's the Solidworks CAD and the media creation - would still be done on local workstations in the building.  Those hitting the VDI would be low bandwidth users, support …
1
Does anyone know if the 10gbe controllers in a SC4020i are 1gbe backward compatible?
0
Hi,

We current have a VMware 6.5 using a Dell Equalogic PS6000 SAN as the backend storage. Unfrotunatley we have two datastores that have extents that cover two physicaldevices, so I plan on vmotioning the vms off the datastore, delete and the recreate the datastore without the extent on the other storage device. On the SAN the storage is split into several volumes used for storage. When I have tested, I have deleted and recreated the datastore fine no problems, but on the volume on the SAN any used space within the new datastore has simply been added to the in se space on the volume. The SAN has no idea that the datatstore has been recreated (I assumed that the new datatstore would be able to use upto the in use space the volume thought it had before growing the volume). I'm guessing that my only option is to vmotion the vm's onto another datastore. Delete the datatstore and back end volume on the san. Recreate the volume on the san and then the datastore and then move the vms back?

Cheers,
Paul
0
I have two 2012 R2 Servers joined to a domain and running HyperV. Both Servers are connected to a SAN via iSCSI and so there are about 8 mapped drives on each server using iSCSI initiators. The previous admin had replication going from Server A to Server B. The VM's have their storage in multiple mapped drives. We upgraded the Backup SAN with bigger drives. The previous Admin setup Replication between the two and then quit.

We failed the HyperV Replication over to the Backup Server and SAN. Everything came up fine, however when we upgraded the Primary SAN and went to set the Replication back up I can't figure out how he did it. When you set the Replication it has a field that says "Specify the default location to store the Replica Files:" under the Authorization and storage section. All of the iSCSI connections have different drive letters.

If I start a replication of VM1 and use it's storage drive letter of H, it comes over fine. But when I try to replicate VM2 with drive letter G, it goes to H as well and the VM's fill up one drive instead of going to their own drive letters and shares.

How can I set this up so they all replicate to their own storage on the iSCSI of the backup Host?
0
We use Veeam BU and Replication at two sites.  At site A, Veeam is on a physical machine and our backup storage is physically connected to that physical machine so adding storage to hold backups and replicas is simple.

At site B, there are two VMware hosts.  Veeam is running as a VM on one of those hosts.  

Each host has 20+TB of storage and I'm trying to add it to Veeam to hold backups and replicas and it's giving me some grief.  

Veeam is running on host 200, but the only way I have found to add storage for Veeam to use is to add a virtual hard drive to the Veeam server and then map to it.  I just want to make sure I'm dealing with this storage in the correct way.

Can anyone offer any suggestion?

Thanks

Cliff
1
We have a DELL MD3000i array with dual-controllers (A/A). Last week, one of the controllers went bad due to memory parity error (or aka. Memory Consistency Error) and we took a huge performance hit. We ordered a replacement and swapped it out, the error was still there.  We thought we may have received a defective part, so we got another controller, but the error doesn't go away. We took out the battery and memory from the controller, waited 2 mins, then popped it back in, but still no luck. Does any one know how to correct this issue? Does something else needs to be done beside putting the controller in offline mode before swapping?

Summary : RAID Controller Module Memory Consistency Error
Storage array:  MDPLSHELP01
Component          reporting problem:  RAID Controller Module in slot 0
 Status:           Online
 Location:  RAID Controller          Module/Expansion enclosure, RAID Controller Module in slot 0
Component          requiring service:  RAID Controller Module in slot 0
 Service          action (removal) allowed:  No 
 Service action LED on component:  No
 Replacement          part number:  
 Board ID:  1532
 Submodel          ID:  63
 Serial          number:  63V10XX
0
Best Practices to store system logs of ESXi Hosts that are part of a VSAN Cluster??


Number of Nodes
Type of Storage = Local JBOD to each host total 6TB's

Since it is a VSAN config, not sure what would be the best approach.  Is it safe to just store them locally on the vsan datastore?
0
Hi there,

I'm new to nimble and not a storage-guy. One of our Nimbe Storage controller has a failed disk without support from HPE Infosight. When I tried to remove the disk say from Slot #9 I got an error as below:

Nimble OS $ disk --listremove 9 --shelf_location B.P1.1
ERROR: Failed to remove disk at slot 9, shelf B.P1.1 This shelf is either not used or inactive.

Open in new window


As per below list Slot #9 was on failed state.

    9 2...RC5         HDD    1000.20 failed  N/A             
    10 13..RC5         HDD    1000.20 in use  okay        

Open in new window


On the other hand when I tried to remove  the disk from Slot #10 I was able to successfully the disk a shown below BUT not in slot #9 as per above (was it because the disk was not on failed-state?)

Nimble OS $ disk --remove 9 --shelf_location B.P1.1
Nimble OS $ disk --list --shelf_location B.P1.1 | grep FRC5
:
     9 2..FRC5         HDD    1000.20 failed  N/A             
    10 13..RC5         HDD    1000.20 removed N/A       

Open in new window


However, when I added a disk in slot #10 from slot #9, I got below error even with --force option:

Nimble OS $ disk --add 10 --shelf_location B.P1.1 --force  
ERROR: Failed to add disk at slot 10, shelf B.P1.1 No such object.

Open in new window


By default what's the RAID level config of Nimble Storage CS220G? Is it RAID 6+spare? How can I check the current RAID config of controller/shelf from cli to know the RAID level? If I'm going to reconfigure the current RAID level to RAID 5, do anyone can guide me how to do this step-by-step as I can't find any documentation anywhere or even from HPE Community forum.

Thanks in advance for anyone for your help.

Kind regards,

Jun
0
i have web form using local storage to keep track of the form data. Assume I fill in the html form using my laptop, and now I use my phone. Is this still possible to get the local storage data back on the phone? I understood I can use database to store the information but I tried not to do that because I want to avoid round trip data in the database.
0
Is there a specific method to disconnecting a USB 3 RAID 1 drive from an old computer to a new Windows 10 computer? My fear is that once I reconnect the drive to a new computer I'll be forced to re-format the drive or create a new simple volume.

My raid setup is a Lacie 2big Quadra 8TB in RAID 1 on a windows 10 machine. I'm getting a new Win 10 pc to replace this one.
0

Storage

43K

Solutions

35K

Contributors

Computer data storage, often called storage or memory, is a technology consisting of computer components and recording media used to retain digital data. In addition to local storage devices like CD and DVD readers, hard drives and flash drives, solid state drives can hold enormous amounts of data in a very small device. Cloud services and other new forms of remote storage also add to the capacity of devices and their ability to access more data without building additional data storage into a device.