Storage

43K

Solutions

35K

Contributors

Computer data storage, often called storage or memory, is a technology consisting of computer components and recording media used to retain digital data. In addition to local storage devices like CD and DVD readers, hard drives and flash drives, solid state drives can hold enormous amounts of data in a very small device. Cloud services and other new forms of remote storage also add to the capacity of devices and their ability to access more data without building additional data storage into a device.

Share tech news, updates, or what's on your mind.

Sign up to Post

I have two 2012 R2 Servers joined to a domain and running HyperV. Both Servers are connected to a SAN via iSCSI and so there are about 8 mapped drives on each server using iSCSI initiators. The previous admin had replication going from Server A to Server B. The VM's have their storage in multiple mapped drives. We upgraded the Backup SAN with bigger drives. The previous Admin setup Replication between the two and then quit.

We failed the HyperV Replication over to the Backup Server and SAN. Everything came up fine, however when we upgraded the Primary SAN and went to set the Replication back up I can't figure out how he did it. When you set the Replication it has a field that says "Specify the default location to store the Replica Files:" under the Authorization and storage section. All of the iSCSI connections have different drive letters.

If I start a replication of VM1 and use it's storage drive letter of H, it comes over fine. But when I try to replicate VM2 with drive letter G, it goes to H as well and the VM's fill up one drive instead of going to their own drive letters and shares.

How can I set this up so they all replicate to their own storage on the iSCSI of the backup Host?
0
We use Veeam BU and Replication at two sites.  At site A, Veeam is on a physical machine and our backup storage is physically connected to that physical machine so adding storage to hold backups and replicas is simple.

At site B, there are two VMware hosts.  Veeam is running as a VM on one of those hosts.  

Each host has 20+TB of storage and I'm trying to add it to Veeam to hold backups and replicas and it's giving me some grief.  

Veeam is running on host 200, but the only way I have found to add storage for Veeam to use is to add a virtual hard drive to the Veeam server and then map to it.  I just want to make sure I'm dealing with this storage in the correct way.

Can anyone offer any suggestion?

Thanks

Cliff
1
We have a DELL MD3000i array with dual-controllers (A/A). Last week, one of the controllers went bad due to memory parity error (or aka. Memory Consistency Error) and we took a huge performance hit. We ordered a replacement and swapped it out, the error was still there.  We thought we may have received a defective part, so we got another controller, but the error doesn't go away. We took out the battery and memory from the controller, waited 2 mins, then popped it back in, but still no luck. Does any one know how to correct this issue? Does something else needs to be done beside putting the controller in offline mode before swapping?

Summary : RAID Controller Module Memory Consistency Error
Storage array:  MDPLSHELP01
Component          reporting problem:  RAID Controller Module in slot 0
 Status:           Online
 Location:  RAID Controller          Module/Expansion enclosure, RAID Controller Module in slot 0
Component          requiring service:  RAID Controller Module in slot 0
 Service          action (removal) allowed:  No 
 Service action LED on component:  No
 Replacement          part number:  
 Board ID:  1532
 Submodel          ID:  63
 Serial          number:  63V10XX
0
Best Practices to store system logs of ESXi Hosts that are part of a VSAN Cluster??


Number of Nodes
Type of Storage = Local JBOD to each host total 6TB's

Since it is a VSAN config, not sure what would be the best approach.  Is it safe to just store them locally on the vsan datastore?
0
Hi there,

I'm new to nimble and not a storage-guy. One of our Nimbe Storage controller has a failed disk without support from HPE Infosight. When I tried to remove the disk say from Slot #9 I got an error as below:

Nimble OS $ disk --listremove 9 --shelf_location B.P1.1
ERROR: Failed to remove disk at slot 9, shelf B.P1.1 This shelf is either not used or inactive.

Open in new window


As per below list Slot #9 was on failed state.

    9 2...RC5         HDD    1000.20 failed  N/A             
    10 13..RC5         HDD    1000.20 in use  okay        

Open in new window


On the other hand when I tried to remove  the disk from Slot #10 I was able to successfully the disk a shown below BUT not in slot #9 as per above (was it because the disk was not on failed-state?)

Nimble OS $ disk --remove 9 --shelf_location B.P1.1
Nimble OS $ disk --list --shelf_location B.P1.1 | grep FRC5
:
     9 2..FRC5         HDD    1000.20 failed  N/A             
    10 13..RC5         HDD    1000.20 removed N/A       

Open in new window


However, when I added a disk in slot #10 from slot #9, I got below error even with --force option:

Nimble OS $ disk --add 10 --shelf_location B.P1.1 --force  
ERROR: Failed to add disk at slot 10, shelf B.P1.1 No such object.

Open in new window


By default what's the RAID level config of Nimble Storage CS220G? Is it RAID 6+spare? How can I check the current RAID config of controller/shelf from cli to know the RAID level? If I'm going to reconfigure the current RAID level to RAID 5, do anyone can guide me how to do this step-by-step as I can't find any documentation anywhere or even from HPE Community forum.

Thanks in advance for anyone for your help.

Kind regards,

Jun
0
i have web form using local storage to keep track of the form data. Assume I fill in the html form using my laptop, and now I use my phone. Is this still possible to get the local storage data back on the phone? I understood I can use database to store the information but I tried not to do that because I want to avoid round trip data in the database.
0
Is there a specific method to disconnecting a USB 3 RAID 1 drive from an old computer to a new Windows 10 computer? My fear is that once I reconnect the drive to a new computer I'll be forced to re-format the drive or create a new simple volume.

My raid setup is a Lacie 2big Quadra 8TB in RAID 1 on a windows 10 machine. I'm getting a new Win 10 pc to replace this one.
0
Hi,

Our VM datastores use extents. One particular datastore uses two different extents to create the volume. Is it possible for the two extents to live on volumes  on separate SANS? If this is possible what happens if one of the SANS or the volume where the extent lives, is offline?

Cheers
0
Hi

We use Window 2012 file server and we use this server for storing the user documents and shared folders .
On one of the shared folder we have a departmental folder 100GB and I was told by one of the staff that their departmental folder was  missing.
When I open the shared folder, I noticed that the folder had disappeared and did the search on the share and couldn’t find . At the moment the free space on the share was only 15 GB .

Please can you let me knowhow the folder should have disappeared.
Any help will be great.
0
Hi All,

We currently run VMware at two sites. Both sites use Dell SANS for storage. We have a few production vms that are managed from site 1 but the datastore is on site 2. The naming of the datastore to SAN volume do not match for many of the datastores. What is the easiest method to marry a VM datastore to its volume counterpart on the SAN?

Cheers,
Paul
0
Hi,

got 2012R2 server.
doing backup using a script in task scheduler.
below is the script i am using.

WBadmin start backup -BackupTarget:E: -Include:D: -allcritical -VssFull -quiet

it fails everyday. saying the error below

The backup operation attempted at '‎2019‎-‎05‎-‎14T04:00:10.764159700Z' has failed to start, error code '2155348040' (There is not enough free space on the backup storage location to back up the data.). Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

but when i check the server- the drive which i am trying to backup "d" is 2.1 TB and the Ext harddisk "E" is 2.7 TB.

i tried formatting the drive., still it fails saying not enough free space - same error every day.

is it something, anyone can give me any ideas ?
0
Azure disk encryption (ADE) vs Azure Storage service (SSE) encryption, which one?

I'm using managed disks in Azure which by default uses 256 encryption at rest. I've checked and my storage accounts are encrypted, Azure security center however advises me to double down and use bitlocker on the disks.

Here is my question.  Can anyone provide a compelling reason why I would want to bother using bitlocker (ADE) on my Azure VMs when I already have 256 encryption on the storage side?
No general links to azure encryption please, I read them to death and cannot find one justification, other than, the VM with bitlocker will not boot if copied off and does not have access to the vault key.
Thanks all
0
Shared Files on Cloud Storage solution for board members.  Board Members of our Our Homeowners Association need access to residential listing in the form of a spreadsheet.  Currently this spreadsheet is offline and maintained by our bookkeeper.  Not all board members have a Google account therefore they do not have a Gmail account.   Google Drive can support shared access through a shared link however anyone with that link would then have access to confidential information.  Seems we need cloud storage file/folder sharing that supports any authorized individual's private email address authentication.  

Looking for a solution that will provide a single account owner with less than 10 additional shared user accounts and less than 1GB storage.  Authentication will allow use of current private email addresses and passwords.
0
I have a RAID 5 system (Intel(R) C600+/C220+ series chipset SATA RAID Controller).

I received an error that the RAID is degraded and a drive has failed.

I can "Mark as normal" the failed drive.

What does "Mark as normal" mean or do?
0
Environment = Vcenter Version 6.7.0.20000 Build 10244845
ESXi, 6.5.0, 7967591

I shrank a flat-vmdk on a vm and now,  vcenter wont let me power on or storage migrate the VM.  

I followed this guide - https://virtualman.wordpress.com/2016/02/24/shrink-a-vmware-virtual-machine-disk-vmdk/
(I should never done it! Big mistake)  The guide seemed so straight forward and I did not think anything would happen.  

Error I get when I try to Storage Migrate the VM:
error2
Error I get when I try to power on the VM:
error1

Let me explain exactly what happen which may help you figuring out a solution:

1.)I Powered off the VM because memory hot add was not enabled and I needed to increase the RAM from 32gb to 228gb total.
When I went to increase the ram I mistakenly increased the Hard Disk from 80GB to 228GB and clicked ok!!!
With the VM still powered off, I decided to try and shrink the flat-vmdk following that above guide.

I followed the ONLY portion of the guide which shows how to edit the .vmdk descriptor file.

Keep in mind the VM was powered off the entire time.  So I skipped the first portion of that guide about shrinking the disk from Windows OS.  

I followed this guide exactly and successfully changed the flat-vmdk to show 80GB :)  But now I get those errors when trying either power on the VM or storage migrate it!!

Please help!
0
Good Dell shared storage?

I have four hosts that need shared storage between them.  All the hosts are Dell so I prefer Dell storage.   Entry level...say 30TB at the most using some existing 3.5 inch SAS drives.

Thanks
0
We have a super weird thing happening.  We have two Dell R730 servers, both with Perc H810 controllers in them.  The two servers are connected to an IBM V3700 and a Dell MD1220.

Last week, we rebooted the first host and at the boot, we got this error:

"LSI-EFI SAS Driver:
Unhealthy status reported by this UEFI driver without specific error

UEFI0116: One or more boot drivers have reported issues
Check the Driver Health Menu in the Boot Manager for details.

One or more boot drivers require configuration changes.  Press any key to load the driver health manager for configurations."

So, we got that after the reboot and after some googling, we decided to move the Perc H810 out of the second server into the first and it booted right up, no issues.  So, we chalked it up to a bad card, ordered a replacement, put it into the first server and it booted just fine as well.  There you have it, we had a bad Perc card.

Now, fast forward a week.  Server 1 has it's new Perc and it's running great, seeing all of the storage and we are happy.

Server 2 is running great with it's Perc card that we stole from server 1 last week and life is good.

Now, tonight, I need to reboot server 2 and boom, it hangs and is now reporting the exact same error as noted above.

Pressing any key does nothing.  The machine will not boot into anything...iDraq doesn't even kick work when it's in this state.  All we can do is remove the Perc card and it boots normally.

It "could be" that…
0
Hi,
I would like confirmation that I am performing data storage in the most efficient manner.
Each month I receive a csv file which has around 120 columns of data and around 10,000 rows.
Please see attached for explanation. The format looks basic but so is my SQL experience :)
If there are more easier and efficient ways of arriving at those 16 files I'd be interested to learn.
I need to keep the data size down as Excel struggles to compute hence the need for all those files.
Many thanks
Ian
SQLCopysort.xlsx
0
Microsoft Teams (And even SharePoint and OneDrive) seem to have grey area with the storage. I can't get a good Microsoft support representative on the phone. I have a project that needs to start with 15TB of file storage and we want to use Microsoft Teams to work on this collaborative project. Is there a license that allows this right off the bat, or is there a way to pay for additional storage?

ie: OneDrive is "Unlimited Storage" but 1TB included, then you have to call when at 90% to get 5TB, and so on and so on. Teams doesn't seem to offer this scaling but we need 15TB to start with.


If Microsoft doesn't have a solution for this, what would be an equivalent?
Thanks
0
I am trying to use iSCSI  to setup a target disk for storage in a failover cluster. I am getting this error message:
error occured during enumeration of iSCSI targets: the WS-Maanagement service cannot process the request. the WMI service or WMI provider returned an unknown error:HRESULT 0X80070015

anyone ever run into this before? i thought it was the Firewall on the server but it has been turned off and the service has been disabled.
0
I have a Ruckus ICX 7250 24 port switch with 8 Licensed 10 GB SFP+ ports and I will be getting a Dell EMC ME4024 Storage Array with 8 Port Dual Controller for iSCSI SFP+. I would like to know how to configure it on the switch and how to best use it with vmware vsphere 6.5.

Any help would be greatly appreciated as I've never had to configure one from scratch.

Thank you
0
hello-

I have a server running esxi with a RAID card controlling 36 disks.  I had 2 disks fail but had 4 disks set as global hotspares for the arrays.  I replaced the 2 disks and now I have 2 disks labeled UGOOD that I would like to make global hotspares using storcli.  The issue is that everytime I issue the command "./storcli /c0/e1/s9 add hotsparedrive" I get the following error back:

CLI Version = 007.0813.0000.0000 Dec 14, 2018
Operating system = VMkernel 6.0.0
Controller = 0
Status = Failure
Description = Add Hot Spare Failed.

Detailed Status :
===============

----------------------------------------------
Drive     Status  ErrCd ErrMsg
----------------------------------------------
/c0/e1/s9 Failure   255 Device state invalid.
----------------------------------------------

Open in new window


My disk layout is as follows:

[root@server:/opt/lsi/storcli] ./storcli /c0/eall/sall show
CLI Version = 007.0813.0000.0000 Dec 14, 2018
Operating system = VMkernel 6.0.0
Controller = 0
Status = Success
Description = Show Drive Information Succeeded.


Drive Information :
=================

-------------------------------------------------------------------------------
EID:Slt DID State DG     Size Intf Med SED PI SeSz Model               Sp Type
-------------------------------------------------------------------------------
0:0       2 Onln   0 7.276 TB SATA HDD N   N  512B TOSHIBA MG05ACA800E U  -
0:1       4 Onln   0 7.276 TB SATA HDD N   N  512B TOSHIBA MG05ACA800E

Open in new window

0
I have a new Gigabyte B450 AROUS M motherboard.  Everything seems to work fine, even installed the OS on the SSD with nothing else connected.

However, right out of the box the board (with older firmware), I had a HGST Ultrastar He10 10TB drive that wasn't detected.  So I thought maybe it died even though it is brand new. However it works on a USB 3.0 to SATA adapter fine on this computer with this board as well as another computer.  So I updated the firmware from Gigabyte to the latest version.  Now the BIOS seems to hang at boot with the drive connected.  However, when I disconnect it, it is fine.

This is a new drive and a new board and both seem to be fine until they are connected together.  

I have tried multiple different power plugs in the case as well as multiple SATA cables and SATA ports.

Any ideas on what to try now?
0
I have a microsoft Azure Storage Account, with a blob container.

I am storing different types of files in this account.  I have excel files, some zipped up xml files, a .net app, and some sql scripts.

Currently I have AD access to this storage account.

What I need to do is configure the best way for my IT team to access these files if necessary and be able to read the excel files and potentially download the other files if needed.

This will be a rare event but the game plan needs to be in place.

I am seeing things regarding API, and URL's but no idea at this point how to configure.  

Please help.   At this point I am not sure if I need more AD rights from my infrastructure team to configure this.

This will be a long time storage facility to archive some retention items in the company.

But should our Audit team need to see anything , IT will be called upon to retrieve.  

I want to setup something that will not require an Azure expert to view these files.

I also want to keep this inexpensive as some of these retentions are literally lifetime.
0
Would like to backup using StorageCraft software to a Western Digital NAS device. Goal is redundancy by backing the data up to a NAS device at another office location. I believe this is an option has anyone done it and how reliable was it. I know StorageCraft is reliable I'm more concerned with their services backing up to a NAS device not in their cloud and the reliability in this part of it. NAS will likely be a Western Digital of some sort unless EE'rs feel there's a better option.
0

Storage

43K

Solutions

35K

Contributors

Computer data storage, often called storage or memory, is a technology consisting of computer components and recording media used to retain digital data. In addition to local storage devices like CD and DVD readers, hard drives and flash drives, solid state drives can hold enormous amounts of data in a very small device. Cloud services and other new forms of remote storage also add to the capacity of devices and their ability to access more data without building additional data storage into a device.