Storage

43K

Solutions

35K

Contributors

Computer data storage, often called storage or memory, is a technology consisting of computer components and recording media used to retain digital data. In addition to local storage devices like CD and DVD readers, hard drives and flash drives, solid state drives can hold enormous amounts of data in a very small device. Cloud services and other new forms of remote storage also add to the capacity of devices and their ability to access more data without building additional data storage into a device.

Share tech news, updates, or what's on your mind.

Sign up to Post

RAID levels 0 and 1 can be combined to make a stripe of mirrors (RAID 10) or a mirror of stripes (RAID 01) configuration.  Which implementation would you prefer to use and why?
0
Will Centos 6.5 running the 2.6.32-431 64 bit Kernel support an m.2 nvme ssd plugged into an NVMe to PCIe adapter in an HP DL585 G7 server ?
0
Dear Experts

I have a question related to controller M1015. I want to use it in IT mode for Unraid server.

In specification I can read this:
The ServeRAID M1015 SAS/SATA Controller has the following specifications:

Eight internal 6 Gbps SAS/SATA ports
Supports SAS and SATA drives (but not in the same RAID volume)
Two Mini-SAS internal connectors (SFF-8087)
6 Gbps throughput per port
LSI SAS2008 6 Gbps RAID on Chip (ROC) controller
x8 PCI Express 2.0 host interface
Supports RAID levels 0, 1, 10 (RAID levels 5 and 50 with optional ServeRAID M1000 Series Advanced Feature Key)
Connects to up to 16 SAS or SATA drives
Supports up to 16 logical volumes
Supports LUN sizes up to 64 TB
Configurable stripe size up to 64 KB
Compliant with Disk Data Format (DDF) configuration on disk (COD)
S.M.A.R.T. support

What I do not understand is - does this controller allows to connect 16 physical SATA drives? If yes why it reports only 8 internal ports?

many thanks for your advice

Vladimir
0
Hi, I have a cluster ESXi 6.0 with 9 nodes.
I noticed very bad performances on different VMs on my infrastructure.
According to resources utilization on entire cluster, I would exclude RAM / CPU issue.
I suspect there is some issue on storage side (we use PowerEdge MD3200 / 3800) through iSCSI.
I ran esxtop on some hosts, occasionally I noticed very high DAVG / KAVG values.
My question is: what would you do next?
Through esxtop I can find the "affected" lun.. isn't there a more efficient way to identify the VM (or VMs) that are causing performance issues?
Thank you
0
Experts out there, I have a question on VMware datastore, hope someone will shed light on it. VSphere client shows a value for "storage usage" is 40 GB and the vmdk file size is less than 40GB. My understanding is that storage usage is included vmdk with some other files (vms,swap, etc). Is there any equation for that extra space usage? like 5% overhead etc.
0
Good day,
We have a VM host that runs two server machines.  The first is the DC/FS and it works great.  The second machine is a terminal server.  It constantly is freezing on the users and it is getting frustrating.  Here is some info:

Host machine is running Server 2016 Standard.  Its specs are:

HPE Proliant DL380 G9
Xeon E5-2620 v3
32GB RAM
RAID 10 for the virtual disks

Server is stable, no issues.

The host machine allocates a large portion of RAM to the DC and the TS.  The DC currently has 8GB and 8 virtual processors.  The TS has 10GB RAM, and also 8 virtual processors.  Originally I had the TS with less RAM and processors, but in trying to fix the freezing issue, I increased the resources.  I plan on bringing them back down.

The TS has only 3 users signing in.  They use the same domain account to log in to the server.  The TS is configured to allow the same user to log in multiple times.  It is light usage.  The TS exists to run only one program.  While using that program, the users may open Word or Adobe, but not much of anything else.  About 4 or 5 times a day, the server just stops responding to that user.  The other users logged in do not experience the same.  It will just spin and spin.  The remote connection never breaks.  Frustrated, they just click the x on the top blue ribbon, and re-log back in.  Then its totally normal until it freezes again.  

During the freeze, the internet is working normally, the others users aren't affected.  A VPN …
0
How do I list Storage / Network Devices in ESX using CLI
0
Probably a fairly "classic" issue but I have surprisingly not found definitive info about it online.

What is the best practice managing hardware RAID controllers on ESX Hosts ? Ideally, we would like to be able to "reach out" to the controller from a Windows guest VM but if not possible at the very least have some management capability (expand RAID, check array consistency) from ESXCLI.

How should we go about it ? In our specific and immediate case ESX6.5 with Intel RMS25CB080 controller.
0
Can i convert a mdadm from raid 6 to raid 0

I have a machine with 10&10TB of data in raid 6.

I'm looking to convert to Raid 0

I dont really care if I lose the data (I have several copies) I just would prefer daving the time off wiping machine - raid 0 - then transferring it all back again.

Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
md0 : active raid1 sdc1[2] sdi1[8] sdf1[5] sdj1[9] sdh1[7] sde1[4] sdg1[6] sdd1[3] sdb1[1] sda1[0]
      4190208 blocks super 1.2 [10/10] [UUUUUUUUUU]

md1 : active raid1 sdc2[2] sdi2[8] sde2[4] sdj2[9] sdg2[6] sdf2[5] sdh2[7] sdd2[3] sdb2[1] sda2[0]
      523712 blocks super 1.2 [10/10] [UUUUUUUUUU]

md3 : active raid6 sdc4[2] sdj4[9] sdi4[8] sde4[4] sdf4[5] sdg4[6] sdh4[7] sdd4[3] sdb4[1] sda4[0]
      75980845056 blocks super 1.2 level 6, 512k chunk, algorithm 2 [10/10] [UUUUUUUUUU]
      bitmap: 2/71 pages [8KB], 65536KB chunk

md2 : active raid6 sdc3[2] sdg3[6] sde3[4] sdi3[8] sdf3[5] sdj3[9] sdh3[7] sdd3[3] sdb3[1] sda3[0]
      2110783488 blocks super 1.2 level 6, 512k chunk, algorithm 2 [10/10] [UUUUUUUUUU]
      bitmap: 2/2 pages [8KB], 65536KB chunk
0
Correct philosophy/topology for  SQLite syncing back to Azure.
And querying items in Azure/storing in SQLite
I have just learn that in UWP you cannot store a .DB file in the solution and connect to it with code, instead the .db file is created in a place in appdata when the app is started.
This means I cannot load up the .DB file prehand with lots of data to be used by the app. This must mean the .DB file needs to “sync” in someway to the main data storage this is touched on in this Microsoft doc
https://docs.microsoft.com/en-us/azure/app-service-mobile/app-service-mobile-windows-store-dotnet-get-started-offline-data

My question is what is the correct philosophy/topology to obtain data stored in Azure interact with that data in a UWP app and then sync that data back up to Azure?
0
I am trying to set up a file server cluster using 2 VMs hosted on an S2D2019 cluster. Both compute and storage takes place on the S2D cluster.

I have create 2 vms FSC1 and FSC2, i have then created the cluster called FSC and created a file server called FSS.

On both VMsi have attached a shared VHDS also hosted on the S2D cluster.

I have tested speeds on the VMs C:\ drive using diskspd.exe and i can get over 3GB read and 1GB write running at 75/25 r/w with a 64kb file.   no problems it works great. I have then tested copying large files from another location to the C drive and it gets around 700MB/s   again no issues with this.

I then go to the drive hosted on the VHDs on the server that is hosting the storage and try to run diskspd.exe again. I get the message

"WARNING: Could not set valid file size (error code: 87); trying a slower method of filling the file (this does not affect performance, just makes the test preparation longer)"

After a while it comes back saying no reads and no writes. If i try to copy a file to this drive i get 10MB/s trying to copy using the share path and 30MB/s trying to copy using the local path.

Is there anything that could cause such pathetic performance? Maybe something i have missed? I created the VHDS on FSC1 and then attached it to FSC2.

Thanks in advance for any help and just let me know if you need anymore information.
0
Hi I have to replace some SAS drives in a Power Edge, they amy SAS hard drive connection.re all in hot swapable carages.  The SAS connection is like the crummy pix I took, it has a single cable connection.  When I go on Amazon to get a SAS drive, the pix all show they have the SATA connections.  I don't know if they are mis labeling their parts, or just use the same pix as the normal drive.

Also, I thought that SAS drives were either 10k or 15K RPM, these are showing up as 7200 RPM.  

Thanks all.
0
Experts - I manage 10 customers, all are server (SBS/Essentials) and Windows 10 clients.  In the typical use fashion, users work on documents, save them to their shared drive on the server and email them to customers, etc.  With the prevalence of cloud storage, is there any one solution that handles this typical use case of server storage of documents that is NOT hard for customers to learn?  I was leaning towards Microsoft Teams, but this isn't an easy one to learn.  Wanted to get your thoughts on this.

Thanks!
0
Physical Disk 0:0 was replaced. There was an option to make it part of a RAID and once I selected that option the "State" immediately went to "rebuilding".
I look at this 3 days later and this is what I see:
Physical DisksHovering over either triangle shows Status: Non-Critical
The only available tasks for disks 0 and 1 is offline
There are no other tasks listed for disk 2 (just shows Available Tasks) or disk 3 (just shows No Task Available)
I inherited this server. It is set up in a RAID 10... not sure which disks belong to what though
RAID 10I think my first concern is disk 0... then the foreign issue with disk 3.
Thoughts?
0
NAS lost a shared folder completely?
Currently have a QNAP TS-451 which has a Shared folder called Storage, this appears to have gone missing off the NAS somehow, can't see it if i log into the NAS but i can see the NAS is using all of the storage.
Going to Resource Monitor i can see the Storage folder taking up  10.82TB but this is the only folder that i can't find?
Nas currently does have a degraded drive and is running in RAID 5 with 4 disk (I understand this needs to be replaced and i can't have another one fail) Would the degraded drive cause an issues with displaying shared folders?
Any help would be great
0
Hi, I was wondering the difrence between SAS and regular SATA drives.  Is the only difrence the fact that they can be on a hot swappable back plane?  Or is there more to it?

Thanks all.
0
Need to automate few reports in separate excel sheet
  • VMware License utilization report
  • VMware Performance reports
  • VMware Health reports
  • Storage Capacity Report
which can be sent weekly /monthly on email

Please help for script to be used  for above requirements
0
Hi, I have a microsoft Azure Storage Account, with a blob container, the quoestion I want to ask is........

Once the first backup of say 200gb is complete the following day it will only backup the changed files which in this instance will be 20gb worth of changed files. I know Micosoft will charge for the first backup of 200gb but what will they then charge for the following day? just the 20gb that has changed?

Thanks
0
HI there,
i just noticed on a SBS 2011 that the backups were failing with details "Volume shadow copy operation failed with error 0x80042306"

The eventlog shows volsnap Event ID 25
"The shadow copies of volume C: were deleted because the shadow copy storage could not grow in time.  Consider reducing the IO load on the system or choose a shadow copy storage volume that is not being shadow copied."

This started 2 months ago & the last completed backup is 12 June.

The Server is set up for a daily full backup at 20.00, the office closes at 18.00

All help is much appreciated.
0
RHEL7 formatting 1 TB disk defaults.

We have a case where a 1 TB disk was formatted during installation with 4096 byte sectors when we expected 512. Is this the default for large disks and can it be changed to 512 during installation?
0
Hi

I have purchased a Qnap server QNAP TS-1283XU-RP 12 Bay  with 96TB (12 x 8TB Seagate EXOS enterprise class SATA HDD 7200RPM)

We are using VMware  and I would like to use this for onsite backup, for backing up our Virtual servers using Veeam backup and backing up user files using BackupAssist software with  this Qnap server as a backup target.

Please let me know the Raid type that i need to set up.
On this Qnap server , It gives me the Raid option of Raid5, Raid 6, Raid10

For Raid 5 With 1 hotspare, it gives a usable space of 72TB
For Raid 6 With 1 hotspare, it gives a usable space of 65TB

I dont want to go for Raid 10  and it ask for 2 spare and the usable space is only  36TB

I am not very keen on the performance of the qnap and it is only for the Veeam Back up target and File server Backup target.

Please suggest , the suitable Raid ( RAID5 or RAID6) that i can set up and your help much appreciated.

Thanks
0
I have an iPhone that indicates the storage is filled on the phone.  Photos are taking up a large amount
of this storage.  How do I resolve this issue so that the storage capacity returns to a more normal level?
thanks,
capreol
0
I have decided that Surveillance vs. NAS hard drives are more about marketing and not much at all about technical spec's.
Do you agree or are there technical differences worth mentioning?
I've looked but not found.

I'm interested because I'm about to set up some file server drives that have pretty modest demands re: speed.
So, I don't know that rpm matters all that much and it appears that cache sizes are the same.
I'll likely put in 10TB drives in RAID 1.
0
Hi,

I have a Windows 10 Dell Optiplex 790 that originally had Windows 7 on it.  We use a USB floppy drive on it which worked fine before the Windows 10 upgrade.  Now, the floppy drive comes up with a "Location is not available" error.  "The disk media is not recognized.  It may not be formatted."  It says this for all disks--even ones that work on another Windows 10 computer that has the same USB floppy drive.  Both computers are Dell and one--the floppy drive works.   This one--the floppy drive has those errors.  I've tried removing the driver and having it reinstall--then restarting.  It still does not work.  Do you have any recommendations or things I can try to make it work?  Oh, and one more thing.  I looked in Disk Manager and it doesn't even show up in disk manager but I do see an "A:" drive in File Explorer.  Thanks in advance for your help!
0
I am currently running a pretty beefy system so this question is purely for my general know. Just messing around really.

I am running Windows 10 pro.

So my OS drive is a Raid 0 1 TB nvme configuration. Yes, I back everything up to multiple locations.

Now my question is, is there a way to take my storage drive and use a portion of the nvme (or another SSD) as cache?  Just to speed up frequently accessed files.

Just curious. Thanks in advance.
0

Storage

43K

Solutions

35K

Contributors

Computer data storage, often called storage or memory, is a technology consisting of computer components and recording media used to retain digital data. In addition to local storage devices like CD and DVD readers, hard drives and flash drives, solid state drives can hold enormous amounts of data in a very small device. Cloud services and other new forms of remote storage also add to the capacity of devices and their ability to access more data without building additional data storage into a device.