Switches / Hubs

21K

Solutions

17K

Contributors

A switch is a device that filters and forwards packets of data between LAN segments. Switches operate at the data link layer or the network layer of the Open Systems Interconnection (OSI) Reference Model and therefore support any packet protocol. LANs that use switches to join segments are called switched LANs or, in the case of Ethernet networks, switched Ethernet LANs. A hub is a connection point for devices in a network. Hubs are commonly used to connect segments of a LAN. A hub contains multiple ports; when a packet arrives at one port, it is copied to the other ports so that all segments of the LAN can see all packets.

Share tech news, updates, or what's on your mind.

Sign up to Post

OSPF Rout metric

o
in the topology above I configured OSPF on R3 for all interfaces. R1 and R2 are configured both with OSPF and RIP. Interfaces connected to R3 are in the OSPF domain

R2 learned OSPF routes from R3 . I can see the metric is 110/20 for the physical interfaces but the metric for the route on the loopback is 110/11

I am not sure why. Though I adjusted the bandwidth , delay , mtu of the Loopback to be the same as the physical interface.


R2#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/11] via 192.168.23.3, 00:01:19, Ethernet0/0
O     192.168.13.0/24 [110/20] via 192.168.23.3, 00:01:19, Ethernet0/0
O E2  192.168.14.0/24 [110/20] via 192.168.23.3, 00:01:19, Ethernet0/0
R2#


R3#sh interfaces e0/0
Ethernet0/0 is up, line protocol is up
  Hardware is AmdP2, address …
0
Take Control of Web Hosting For Your Clients
LVL 12
Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

Hi Guys,

Firewall->HP Switch Layer 3 -> esxi servers 1,2

I'm a vmware vsphere 6 newbie.
I have 2 physical ESXI servers(ESXI v6) that host 30 virtual servers. vmWare vCenter 6 is set up properly. Desperatly looking for some help/advice on this.

Every physical server has 5 gigabit ethernet connections.

Connected NICs:

Management Network x1 (vmnic0)
LAN x3 ( vmnic 1,vmnic2)  (30x Vms)
ISCSI x2 (vmnic3,vmnic4)




Everything is up and running smoothly on our production Network.

Now I need to connect these physical servers to DMZ since there are some vm's that should run on that part of our network.

How should I do that?
What are you guys doing out there?

How about vLANS? Can it be set up and span multiple subnets so I can keep all servers connected to internal LAN?


Thanks in advance.
0
dis
In the topology above R3 is running OSPF and R4 is running RIP. R1 and R2 are running both OSPF and RIP and redistributing OSPF into RIP and RIP into OSPF

R3 and R4 have their loopback addresses with the same IP address 3.3.3.3/24


R1#show run | sec router
router ospf 1
 redistribute rip subnets
 network 192.168.13.0 0.0.0.255 area 0
router rip
 version 2
 redistribute ospf 1 metric 5
 network 192.168.14.0
 no auto-summary
R1#

R2#sh run | sec router
router ospf 1
 redistribute rip subnets
 network 192.168.23.0 0.0.0.255 area 0
router rip
 version 2
 redistribute ospf 1 metric 5
 network 192.168.24.0
 no auto-summary
R2#

R3#sh run | sec router
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
R3#

R4#sh run | sec router
router rip
 version 2
 network 0.0.0.0
 no auto-summary
R4#




R4#sh ip rout  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last …
0
OSPF/RIP Redistribution

I have this topology :
I have advertised networks 1.1.1.1/24 and 192.168.12.0/24 into OSPF
 then Redistributed   OSPF to RIP with metric 10. Now : 1.1.1.1/24  shows with metric of 10 in R3 RIP Routing table, but 192.168.12.0/24  still shows with metric of 1.





ospf
R1(config-router)#do sh run 
Building configuration...

Current configuration : 1412 bytes
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!         
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!
!         
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 !
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex half
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown 
 duplex auto
 speed auto
 !
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet2/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http 

Open in new window

0
Dear experts,

I came across a situation where I wish to create two subnets as in 192.168.1.1 and 192.169.2.1

The 192.168.1.1 will be my main network which will contains most of the PCs, printers, etc....

The 192.168.2.1 will be my wifi network which all wireless connections such as phones, scanners, etc...

Here is the situation:

1. only have 1 switch with 48 ports (can be configured)
2. one sonicwall firewall  4 ports in back(can be configured)
3. allow the two networks to talk to one another as in if I have a PC in 192.168.1.x and wish to access a wifi device in 192.168.2.x

Here are the things that I wish to get answered and accomplished:
1. I wish to know what will be the "BEST and SIMPLE" configuration to accomplish this task. Thanks!
2. Is it possible to connect all devices into a single switch (the 48 port switch) and have combination of networks like 192.168.1.x and 192.168.2.x together without utilizing the VLAN?
1
EIGRP/RIP Metric in the redistribution

I have the topology below.
I do not understand after I redistributed EIGRP into RIP, one route shows with the metric of 2 as we specified it in redistribution command, but the other route shows with metric of 1.

R2(config-router)#redistribute eigrp 12 metric 2

R3(config-router)#do sh ip route rip
1.0.0.0/24 is subnetted, 1 subnets
R        1.1.1.0 [120/2] via 192.168.23.2, 00:00:10, FastEthernet0/0
R     192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:10, FastEthernet0/0
R3(config-router)#

Thank you

rout
0
Hi Guys

I have a network situation Im hoping someone might be able to help with.

We have a leased line provided to us via fibre but the router we must use (its a managed service line) only has copper interfeaces.

We have a Juniper EX2200 switch that we are looking to use in this office, so iwas wondering if we could do the following, or if anyone else has any other ideas.

1) Leased Line  presented via fibre will connect to one of the SFP ports on the above switch.
2) I create a VLAN (VLAN 100 Internet)  that includes a the relevant fibre port on the switch as well as including a normal RJ45 copper port in this vlan.
3) I create another VLAN (VLAN 101 LAN) that includes the remaining copper ports on the switch.
4) Fibre is plugged into SFP port on VLAN 100, and then patch lead on copper port on VLAN 100 on the switch is plugged into the WAN interface of the router
5) LAN port of router is plugged into an copper port on VLAN 101 on the switch.
6) Subsequent LAN devices are plugged into the remaining copper ports on VLAN 101

Would this work, or is there an alternative method thats better practice.  Any config examples would be greatly appreciated.

Thanks
0
OSPF Network Configuration

ospf

I have configured OSPF on all 4 routers displayed in the topology above.
However from the Computer (Router, configured with No IP Routing), I can ping only the interfaces of R1: g0/0 , g1/0,g2/0. I can not ping from computer to any interface on R2 or R3 or R4.

Computer#sh run 
Building configuration...

Current configuration : 1389 bytes
!
! Last configuration change at 19:17:36 UTC Tue Feb 13 2018
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Computer
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip routing
no ip icmp rate-limit unreachable
no ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
!         
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.15.5 255.255.255.0
 no ip route-cache
 duplex half
 !
!
interface Ethernet1/0
 no ip address
 no ip route-cache
 shutdown
 duplex half
 !
!
interface Ethernet1/1
 no ip address
 no ip route-cache
 shutdown
 duplex half
 !
!
interface Ethernet1/2
 no ip address
 no ip route-cache
 shutdown
 duplex half
 !
!
interface Ethernet1/3
 no ip address
 no ip route-cache
 shutdown
 duplex half
 !
!
!
ip default-gateway 192.168.15.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!

Open in new window

0
I recently set up a Link Aggregate Group between a pair of SG300 switches.  I used 3 ports per LAG.

Once set up and running, a test sequence of continous pings showed that an abnormal number of pings were being dropped.
I didn't expect that and it's a worry.

Autonegotiation is turned OFF on the ports are required.

What might I be looking for?
0
Trying to stack 2 3650 switches and one member stuck in initializing, looks like IOS issue, seems they have different versions, but one seems way off and not sure if its reporting correctly?

*    1 52    WS-C3650-48PS      03.06.06E         cat3k_caa-universalk9 INSTALL

*    2 52    WS-C3650-48PS      16.3.5b           CAT3K_CAA-UNIVERSALK9 INSTALL


the second one is the one that will stay in initialization.  not sure how two switches purchased together could be that far off.
0
Hire Technology Freelancers with Gigs
LVL 12
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Is there a special way to cable or config two 3650's as a stack with a stacking kit?
0
Router-->HP Switch-->ESXI1(trunk1) and ESXI2(trunk2)
 
SW config:
 
Layer 3 SW
Routing enabled
LACP disabled all ports
Every VLAN has SW GW IP
 
VLAN 1 “default”            IP:192.168.0.2 /24
VLAN 2  “2UTM”           IP: 10.0.10.2/24
VLAN 3  “2ESXI1,2”      IP:10.0.20.2/24
VLAN 4  “2ISCSI NAS” IP:10.0.30.2/24
 
I can ping from ESXI 1 IP:10.0.20.3 GW of subnet 10.0.30.2/24.But esxi 1 cant ping NAS 10.0.30.5.
 
Example : ESXI1 and ESXI2 cant connect ISCSI NAS(NAS on other subnet IP NAS :10.0.30.5/24 for LUN configuration. If NAS on the same subnet esxi then I can connect.
 
Where I make a mistake?
0
Routing between Vlans using L3 Switch
vlan


in this Lab I am using Vlan interfaces on L3 Switch instead of Subinterfaces
I have the configuration below:
Host1#sh run
Building configuration...

Current configuration : 1822 bytes
!
! Last configuration change at 21:53:36 CET Sun Feb 11 2018
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Host1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1
no ip routing
!
no ip cef
!
no ipv6 cef
!
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.10.1 255.255.255.0
 no ip route-cache
!
interface Ethernet0/1
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet0/2
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet0/3
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/0
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/1
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/2
 no ip address
 no ip route-cache
 shutdown
!
interface Ethernet1/3
 no ip address
 no ip route-cache
 shutdown
!
interface Serial2/0
 no ip address
 no ip route-cache
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 no ip route-cache
 shutdown

Open in new window

0
on the topology below, Host1 and Host2 are in 2 different subnets, connected to L2 Switch which in turn connected to L3 Switch.
I would like to have Host1 and Host2 be able to communicate to each other.
How can this be accomplished ?

Thank you.
switch
0
SW
In the topology above. I need to ping from Host1 to Host2 but I cannot. Though I can ping from Host1 to subinterface ip address e0/0.10 on R1, I am also able to ping from Host2 to subinterface e0/0.20 on R1, but not between Host1 and Host2


Switch#sh run 
Building configuration...

Current configuration : 1800 bytes
!
! Last configuration change at 02:32:49 CET Fri Feb 9 2018
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone CET 1 0
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip routing
!         
no ip cef
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
! 
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 duplex auto
!
interface Ethernet0/2
 switchport access vlan 10
 duplex auto
!
interface Ethernet0/3
 switchport access vlan 20
 duplex auto
!
interface Ethernet1/0
 duplex auto
!
interface Ethernet1/1
 duplex auto
!
interface Ethernet1/2
 duplex auto
!
interface Ethernet1/3
 duplex auto
!
interface Serial2/0
 no ip address
 no ip route-cache
 shutdown
 no fair-queue
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 no ip route-cache
 shutdown
 serial 

Open in new window

0
I'm in the market to buy a new switch. Please provide me with a list of affordable 1GBps 48 port Cisco switches that have the latest Cisco iOS.
0
SPAN/RSPAN:   While using SPAN to monitor traffic on a port-channel carrying multiple vlans, the keyword "filter" is it used to remove a Vlan from monitoring or does it only  allow said Vlan to be monitoried. As there is some contradiction between this, I was recently reading a cisco book and it was said that the filter command removed a vlna from beig monitored. But on my current kit whenever I have used the filter keyword it has actually only allowed that vlan to be monitored. Which on is true or does it vary on different devices?
0
I have an HP 3400cl-24g switch ,

on the switch created 2 vlans:
VLAN 1 IP: 192.168.0.253/24
VLAN 100 IP:192.168.1.253/24


I connected port 5 on the switch My NAS ISCSI maschine IP: 192.168.1.252/24.

i try to ping on the switch CL to 192.168.1.252.

Target did not respond.
0
I am new to managed switches.  I have never had to set one up.  So I am not asking for the answer directly, but maybe some guidance/online tutorials.  I have printed out the manual and I attempted this setup yesterday.  After 18 hrs and still not internet and me not getting anywhere, I am now going to reach out and see if I can get some guidance.  I have setup a DLINK DES-3528, and it is currently in production, but only default VLAN can get DHCP and I there is no intercommunication between VLANS.  I have drawn up a network map on what I am trying to accomplish.  I am still going to write out what I am trying to accomplish, but the network map will help with a visual.  I will say that I have successfully set up the firewall with VLANS and static routing.  So I do have basic knowledge.  

Port 1 on NMD Setup

Internet -----> Firewall from ISP.  IP is a static assignment.
VLAN 1 -----> Public Access (10.10.10.0/24)
VLAN 100 ------> Phone only (10.20.20.0/24)

I do have access to this firewall, but I do not change any settings on it due to the ISP manages this firewall.  The ISP is a smaller ISP and I have a good name with the company so they gave me access to the firewall.

Port 2 on NMD setup

Firewall:
Internet ---> Fortigate 60E WAN.  IP is a static assignment.
Fortigate Port 1 -----> Cisco switch.  Port 1 has a total of 5 VLANS configured on it.
Switch:
Port 28 assigned to VLAN 1 (Default 10.0.0.0/24) ----> No DHCP
Port 1-8 assigned to VLAN 100 (Domain …
0
2018 Annual Membership Survey
LVL 12
2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

How PCs communicate through L2 Switch
 

I would like to know how computers communicate between each other through L2 Switch.

PC1:10.10.10.1
PC2: 10.10.10.2
PC3: 10.10.10.3

Any Expert to explain step by step, how ARP and ICMP get involded in order for  instance PC1 to ping PC2 successfully. How does the L2 switch handles that to get the ping to work ?

Thank you

l2
0
When to use IP Default Gateway command.

IP default gateway command , if I am not wrong is used in L2 switches to set up a default gateway so that Administrators can remotely connect to the switch.

OK let's say we have  switch SW1 connected to R1 connected to SW2 and Administrator PC is connected to SW2 , what should be configured  on SW2, R1 , SW1 for Administrator PC to connect to SW1

Thank you
0
I have two proposals to diversify the DWDM fiber line now I have a single path with two 23 km fibers crushed together

The first provides two new routes with a stretch of 23 km routes at 35Km and 38KM, are indicative lengths that can be specified as soon as they are joined on the WDM equipment;

the second provides that the possibility of bringing a third path parallel to the two entrances and also in this case completely diversified, the length would reach about 40 KM;

My question is :
Can I have different lengths on two or three fiber ?
Can I have an excessive latency problem?
At the disk I / O level arriving on two different fiber lengths (see above) I can have problems?
0
We upgraded some Cisco Access Points with newer Aruba Access Points (all PoE) and we noticed that after swapping the AP and reconnecting the ethernet cables, there would be no LED status lights at all on the system or the Radio LED indicator (AP Model 315 Aruba).  We had to switch to different modes to get back the system and radio lights.  Not sure why that would be the case. The switch port is still working as I tested with my laptop so why did we have to switch to different switch ports for the new Access Points to work?

We even power cycled the switch (due to different reason and I tried shut/no shut (in case the switch port went to err-disabled).

Does any know know why?

thank you!
0
I was working on upgrading some wireless Access Points and for some reason, two Polycomm Sound Track 7000 woudn't boot up normally and would show red LED status after it shows the Polycomm logo.  I googled and saw that one suggestion was hardset it by pressing 1,3,5,7, which I did but still the same issue.  We're trying to connect those phones to the original power adapter (if we can find it).  They are using PoE right now.

I connected a different Polycomm desktop phone to that jack and confirmed the port and cable are fine.  I even tried connect the IP Soundtrack 7000 directly to the switch port and has the same issue.  

It is weird that both IP Soundtrack 7000 would have the same issue.  Does anyone know what might be the issue other than to RMA it?

Also, what we noticed is that after the upgrade of our Wireless Access Points, the new Access Points wouldn't lid up until we changed the ethernet cable to a different switch ports.  This happened to about 4-5 Access Points and they are all PoE.

What would cause the original ports not to work and not sure if the Polycomm is related.
0
I currently have EIGRP routing between S1 and S2 and I'd like to add another EIGRP routing between S1 and S2. The new path will go through 2 L2 switches (see diagram).

vlan30 is the management vlan for S2 site.

vlan100 is the SVI that will carry EIGRP advertisement.

vlan10 is the users for S2 site.

vlan20 is the users for S1 site.

S1 site has vtp domain S1 & S2 site has VTP domain S2.

I only allow vlan100 between S1 & Switch2. This is just to allow only EIGRP to be advertised, The problem that I have is S1 reports a VTP domain mismatch because it cannot negotiate the trunk between S1 and Switch2. Any thoughts on how to deal with this?

 pic1
0

Switches / Hubs

21K

Solutions

17K

Contributors

A switch is a device that filters and forwards packets of data between LAN segments. Switches operate at the data link layer or the network layer of the Open Systems Interconnection (OSI) Reference Model and therefore support any packet protocol. LANs that use switches to join segments are called switched LANs or, in the case of Ethernet networks, switched Ethernet LANs. A hub is a connection point for devices in a network. Hubs are commonly used to connect segments of a LAN. A hub contains multiple ports; when a packet arrives at one port, it is copied to the other ports so that all segments of the LAN can see all packets.