We help IT Professionals succeed at work.

System Programming





Kernel and system programming is the process of creating the software necessary for a computer or device to function and operate other programs. Some operating systems (such as Microsoft Windows) are proprietary, but others, such as the various Linux distributions, are open source.

Hi Experts,

I'm sort of running out of server space.

Would like to know if there is a way to determine what has caused the latest decrease of free space, as last few days there was over 15 GB used up...

I want to log all rysylog I configure and everything is fine.
I create a new template that is:
template(name="stdSQLformat" type="string" option.sql="on" string="insert into SystemEvents (Message, Message2, Facility, FromHost, Priority, DeviceReportedTime, ReceivedAt, InfoUnitID, SysLogTag) values ('%msg%','%msg:R,ERE,0,DFLT,1:([0-9]+\.){3}[0-9]+[:]?([0-9]+)?"--end%', %syslogfacility%, '%HOSTNAME%', %syslogpriority%, '%timereported:::date-mysql%', '%timegenerated:::date-mysql%', %iut%, '%syslogtag%')")
but when I run rsyslog I get:
error during parsing file /etc/rsyslog.d/mysql.conf, on or before line 8: invalid character '"' in object definit
I know that the problem is with
but I don't understand what I have to do !
OS: Centos 7
Following tutorial @5:00: https://www.youtube.com/watch?v=KgfljMtrKkI
I get a linker error after compiling this code. What steps do I have to take to build this program?
The author indicated that this is for 32-bit code; and later he may do a series on 64-bit. I am guessing that I am having a 32-bit/64-bit issue here.
I saw a comment that may shed some light:
"I had to run apt-get install gcc-multilib to compile 32 bit on ubuntu."
global main
extern printf

section .data
  msg db "Testing %i...", 0x0a, 0x00

;*** prologue - preserving stack, registers, and allocating space ***
  push ebp      ; preserve caller's ebp (base pointer) value
  mov ebp, esp  ; ebp holds the top of the stack
;*** END prologue - preserving stack and allocating space ***

  push 123
  push msg
  call printf
  mov eax, 0

;*** epilogue ***
  mov esp, ebp  ; restore the top of the stack (effectively deallocates the stack)
  pop ebp       ; restore the caller's ebp value
;*** END epilogue ***

Open in new window

$ uname -a
Linux localhost.localdomain 3.10.0-1062.9.1.el7.x86_64 #1 SMP Fri Dec 6 15:49:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

$ nasm -v
NASM version 2.10.07 compiled on Jun  9 2014

$ nasm -felf -y

valid debug formats for 'elf32' output format are ('*' denotes default):
    dwarf     ELF32 (i386) dwarf debug format for Linux/Unix
  * stabs     ELF32 (i386) stabs debug format for Linux/Unix

$ gcc --version
gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-39)

$ whereis crt1.o
crt1: /usr/lib64/crt1.o
$ which crt1.o
/usr/bin/which: no crt1.o in (/usr/lib64:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/home/user/.local/bin:/home/user/bin)

Open in new window

The error:
$ nasm -f elf32 ex10.asm -o ex10.o
$ gcc -m32 ex10.o -o ex10
/usr/bin/ld: cannot find crt1.o: No such file or directory
/usr/bin/ld: cannot find crti.o: No such file or directory
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.8.5/libgcc_s.so when searching for -lgcc_s
/usr/bin/ld: cannot find -lgcc_s
/usr/bin/ld: cannot find -lc
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.8.5/libgcc_s.so when searching for -lgcc_s
/usr/bin/ld: cannot find -lgcc_s
/usr/bin/ld: cannot find crtn.o: No such file or directory
collect2: error: ld returned 1 exit status

Open in new window

Hi Experts,

I have a list of required fields, and trying to construct a SQL statement out of it as follows.

[input#InsertRecordVisit_Date.cbFormTextField, input#InsertRecordClient_Last_Name.cbFormTextField, input#InsertRecordClient_First_Name.cbFormTextField, input#InsertRecordDate_Of_Birth.cbFormTextField, select#InsertRecordShift_From_Hour.cbFormSelect, select#InsertRecordShift_From_Minute.cbFormSelect, select#InsertRecordShift_From_AMPM.cbFormSelect, select#InsertRecordShift_To_Hour.cbFormSelect, select#InsertRecordShift_To_Minute.cbFormSelect, select#InsertRecordShift_To_AMPM.cbFormSelect, textarea#InsertRecordPurpose_Of_Visit_Goal.cbFormTextArea, input#InsertRecordTemp.cbFormTextField, input#InsertRecordPulse.cbFormTextField, input#InsertRecordRR.cbFormTextField, input#InsertRecordBP.cbFormTextField, input#InsertRecordO2_Saturation.cbFormTextField, input#InsertRecordO2_In_Use0, input#InsertRecordO2_In_Use1, input#InsertRecordRespiratory_Lung_Sounds.cbFormTextField, input#InsertRecordRespiratory_Breathing_Pattern.cbFormTextField, input#InsertRecordBipap0, input#InsertRecordBipap1, input#InsertRecordCpap0, input#InsertRecordCpap1, input#InsertRecordTrach0, input#InsertRecordTrach1, input#InsertRecordVent0, input#InsertRecordVent1, input#InsertRecordCardiovascular_Skin_Color.cbFormTextField, input#InsertRecordSkin_Temp.cbFormTextField, select#InsertRecordCardiovascular_Edema.cbFormSelect, input#InsertRecordNeuro_Alert0, 

Open in new window

Trying to accomplish the following, oBdA provided me with the process script, but I'd like to build on it.  If anyone can help, it would be greatly appreciated!

Have a powershell script that can be called from a vbscript and pass the parameter defined in the vbscript to the powershell script. In vbscript, I can call with this code, but not sure how to pass the parameter (computer) for example defined in vbscript...
'Set objShell = CreateObject("Wscript.Shell")
'Objshell.Run("powershell.exe -noexit .\test.ps1")

Open in new window

Powershell Script I'd like to do a few things:
• Check if the computer is online or offline.
• if computer is is offline, exit and send an email
• if the computer is online, run the below script that will check for running processes.
• if the below has anything other than return code 0 (meaning process is still running), have send email
• if the below has a return code of 0 (meaning no processing running), run an executable and invoke some SCCM commands.
 $computerName = 'RemoteMachine' ## Set to $null to run locally
$processList = @'
    "Name",             "Expected",     "Running"
    "cmd",              "1",            "0"
    "powershell",       "1",            "0"
    "OfficeClickToRun", "2",            "0"
'@ | ConvertFrom-Csv | ForEach-Object {$_.Expected = [int]$_.Expected; $_}

$splat = @{}
If ($computerName) {
    $splat['ComputerName'] = $computerName
    Write-Host "Testing processes on $($computerName)" -ForegroundColor Yellow

Open in new window


  I am developing a C++ application with libfuse on rhel 6.10. And, also a simple test application also there.

  When I run my test application with same arguments to fuse_main, works fine. But, with actual application, /dev becomes empty (corrupted).  I don't understand why this corrupts machine. I am running these apps with non-root user. added non-root user to fuse group as well as changed permissions to fusermount too.

   In which cases, /dev becomes empty due to any application.

Hi Experts,

This is in regards to the following question.


In addition, that script only works for IE, I would like to add check for Chrome, Safari and Firefox as well?

Whoever has an answer kindly post it here.

What can you tell me about Expert Systems?

I work for a technology company where there are hundreds of very smart engineers such as Electrical Engineers, Chemical Engineers and Manufacturing engineers.

They are all very smart and skilled. But the downside of every one is they are human.

I look at Supercomputers, like Summit, by IBM (200 Trillion computations per second), as well as Watson, which I know very little about, and I worry that Watson could wipe out small businesses like the one I work for.

How close are Expert Systems like Watson from performing completed designs, automatically? Let's say, for example, an integrated circuit.

I am curious to hear what a company that sees Watson as their true competition can do on a shoestring budget to harness their own engineers knowledge in a form that can be coalesced into a internal use only decision support system.

The sky's the limit on your theories...This is a wide open question, meant to tickle the mind.

Hi Experts,
I am looking for a program that will list all PC names, browser names and versions within the network.
Would prefer it to be done either as a DOS command, batch file or VBA.
Hi Experts,

How can I modify this DOS command to only look at files created after a certain date?

Hi Experts,
What is the easiest way to search for a word within the contents of files in a specific folder, including sub folders?
Would prefer not to install software or change pc settings, as this is needed for a one time only.
I am preparing myself for interview for System Analyst position.
Ma background is in Application development  and most in  BI Development area.
I need some sources or materials with proper questions and answers to update and upgrade my knowledge. It would be good if it is Microsoft standard test or something similar.

Parent and child processes are accessing same content from nfs share. based on some logic parent process deleted files which are already opened by child process. I think, it's internally created files which are .nfsxxxxxxx. These are with c++ application. Is there any settings or configuration to handle such issues to avoid .nfsxxxx files.

I am attempting to add additional media to my BRMS configuration. I am using the following command:


Where TAPDDBKP is our Data Domain that we are backing up to.

When I run this, I get the following error:  Command ended due to error

Upon further investigation, I am getting the error: Cartridge A01001 not found

In the help text for this, it shows you can run a ADDTAPCTG command to add cartridges.  If I attempt to do this (ADDTAPCTG DEV(TAPDDBKP) CTG(A01001)), I get the following error: Cartridge A01001 not found

I am not sure what I need to do. Any help would be much appreciated!
Can anyone recommend a good book regarding the development of SaaS packages? Not from a technical standpoint, but more from an administrative/costs standpoint. And yes, I know I have posted a simple question to a very complex issue, but I am having to start somewhere.

Also, I am interested in anyone who wants to work on the project. It is basically a report generation project with a little math. The reasons for going SaaS are simple: (1) maintaining one piece of software; (2) not having to deal with multiple versions of the software; and (3) piracy.
I use a couple of cronjobs that reside on my website's "back end" at the hosting company that work like this:

At a set time each week, a batch of files, say from "Folder A." is moved to a folder, replacing the files there which have the same name (overwrites them).

If there are no files in folder A, an email is sent to me notifying me of  the lack of files AND then moves a group of same-named files from a standby folder.

I had these jobs created years ago by a freelancer. Now I need some more. I have a background (from more than ten years ago)  in BASIC and I'm wondering if I can learn how to do this fairly quickly and easily or if it would be better to farm it out to a freelancer. I;m not in a huge hurry, but the sooner, the better.

OR is there an online "auto-writer" type of service that takes your input and generates the code, either at no cost or for a proce?

Your thoughts?
Hello Experts
I need script or what ever tools that allowing me to suspend or stop SQL service at the weekend, even if some one restart the server, until a revers or resume script runing.
The management won't allow users to access applications out of work time
When I attempt to log in to my iSeries server via Putty (Port 22) - I am connected to the server, but when I attempt to log in, I get "Access Denied"

I compared my SSHD_CONFIG to other systems and everything appears to be the same.

I verified that other users get the same thing - so this is not related to any specific user...

Any assistance would be much appreciated.
Does anyone know if it is  possible  to submit a remote command on an iSeries server using SSH (sftp) using a different user than what is configured for SSH?

For example, if I wanted to make a change to a user profile, I would run this command:


If I wanted to run that command as another user (called SUPERUSER) - I would run:


Wondering if there is a way to submit the above command (using the SUPERUSER user profile) via SSH (with the cavaet that the SUPERUSER user profile is not the user configured for SFTP. The following code "should" work - but when it does it tells me I don't have access to the CHGUSRPRF command (which the SFTPUSER doesn't - but the SUPERUSER does)


Hopefully that makes sense

I was just hoping to get around having to configure SFTP for the SUPERUSER if I didn't have to...

Any help would be appreciated.
Hi Experts,

This is in reference to the following.
I would like to have the lunch column getting populated with the correct amount.

Thanks in advance.
Does anyone know how to display the current temperature for an IBM i server?
Desktop Machine
Windows 10 Enterprise

I want to place onto the (primary) desktop, shortcuts of certain file folders. (The "primary" desktop means the one that comes up by default when you first install the OS.) When I was working on Windows 7, I was able to Right-Click (and hold) a folder from the File Explorer to the desktop, drop it (release the Right-Click-Hold), and an icon would appear on the desktop. When you click on that icon, it opens the folder in a File Explorer window.

Now, on Windows 10, when I attempt the same procedure (holding the ALT key before dropping), the tool-tip text says, "Create Link In Desktop." However, the icon never appears on the desktop.

WHERE is the shortcut ICON stored when I attempt to create a desktop shortcut for a folder from File Explorer? I want to know exactly where that shortcut it is saved (by Windows) so I can either move it manually to the desktop, or delete it.

I already know a WORKAROUND for this, i.e., placing a shortcut icon on the desktop: Right-Click the desktop, select "NEW > SHORTCUT", and browse to the folder of interest;  that is NOT the question I am asking.
Is it possible to create an Executable (.exe) to run as a task to search through Task Managers Processes or Application Interface to find a value like a PID or name of a file.
Trying to reduce eye strain and realized someone or something has hijacked my laptop. I live literally next to a small private college where the number one program is Cyber Hacking. So I think some kids have gotten hold of information of mine. I recently had a rash of Hulu, Spotify & Netflix accounts opened. I had to close my bank accounts.

Anyway in my quest to find out the whats and the who's I have learned a little about investigation and need a hand a searching daily on Task Manager if it is possible. I did not see a CNTRL + F function to find items in Task Mgr. I did see "Run New Task" as and EXE.

So if I can do that. Is there a way to create a exe to help me search a long page for a PID or a name? If do how?
Hi Experts,

I had the following code working perfectly fine on my pc.

   sDir = "E:\AppDev\FTP\Caspio"

    StrFile = Dir(sDir & "*" & sFileStr & "*")
    Do While Len(StrFile) > 0 And Not IsFileOpen(sDir & StrFile)

Open in new window

However when placing it into the server it always returning an empty string.

Folder above contains many files (on that server).
how to understand big new project code quickly and effectively to write new enhancement to existing code or to fix some defects or to debug to improve some areas of poor performance.

what are the tips and recommendations , best practices around this
Please advise

System Programming





Kernel and system programming is the process of creating the software necessary for a computer or device to function and operate other programs. Some operating systems (such as Microsoft Windows) are proprietary, but others, such as the various Linux distributions, are open source.