System Utilities

12K

Solutions

16K

Contributors

System Utilities are a type of system software used to support the computer infrastructure, distinguishing it from application software which is aimed at directly performing tasks that benefit ordinary users. Commonly used utilities include password managers, disk managers, system monitors, data synchronization tools, security and antivirus software and editors.

Share tech news, updates, or what's on your mind.

Sign up to Post

In my company we have high employee turnover, and hence our helpdesk receives about a dozen requests per week for new Active Directory accounts. Currently, we receive these requests simply via e-mail or voice-mail, and rarely do we have all of the information necessary to create the account. I would like to find a web application that can be used by a manager or supervisor to formalize the requests they make for AD accounts for new employees under their command. Ideally, the application would prompt for all of necessary information, and allow the helpdesk to review the requests and approve or deny each one. If approved, the application would take care of creating the account and send an e-mail to the manager.

I have found several application on the Internet that handle self-service account management (i.e., password resets or update contact info), which is also nice to have, but nothing that streamlines the new account request and creation part. Can anyone make suggestions on such an application? Thanks.
0
Hi expert ,

Can you share experience on emcopy , I am very new to emcopy utilities . I have one file server to migrate to storage Area Network  device. How to use emcopy and is there any step by step guide to use emcopy ?

B.rgds
0
Hi expert ,

I have problem copy file that very long path on window 7 , i searched on google because of 255 characters , Some site suggest to use robocopy , i tried failed to copy
Is there any expert know how to copy long path file with good  utilities ?
may i know example of robocopy usage for long path file ?


B.rgds
0
I am now installing Lenovo Rescue and Recovery application - from ThinkPad toolbox.
First it seemed to have hung.
A black window appeared but has nothing in it.
It is labelled C:\SWTOOLS\apps\rnr_scu_driver_patch\lenstall.exe.
I found the reference on the web http://support.lenovo.com/es_AR/downloads/detail.page?&LegacyDocID=MIGR-62978
That window has now disappeared but the installation has finished.
I don't want to initiate R and R after restarting because it looks as if I might not be able to restart without repairing the MBR, which is a problem I do not want.
What should I do please?
0
I'm getting ready to change my system on my laptop so I have to back things up and copy them back. It really bugs me that when I copy a folder, it changes the folder date/time to the current date/time. I would like to keep the folder dates intact, without having to resort to zipping and unzipping.

I am looking for a free (not trial period) and simple GUI tool (showing file trees) to do this for me. It should be able to handle large drives, and any type of drive, and I should be able to cut and paste selections of folders without changing the dates of the folders.  (probably a "keep folder date/time" as an option) It would be even handier if it can be split into 2 or more panes, so I can drag and drop to cut or copy and paste from one pane to the other without having to scroll and click all over the place.

This tool needs to work in both Win XP and Win 7. I'd prefer something relatively simple.. regular text layout with the normal file details layout, not graphics and "skins", not a memory pig. It should normally, or with an option, display all system and hidden files and folders as well. A nice option to have would be an old fashioned HEX/Decimal file content viewer/editer built in.

Suggestions? Surely I can't be the only one who wants to retain folder dates.. I remember earlier versions of Windows that didn't change the folder dates when you copied them.
0
I purchased 3 servers, set them up on my domain, and then an outside software vendor came in and installed their software and set it all up. They went out of business but the machines kept chugging away. I changed my domain structure and took two servers down ( put them on a workgroup) preparatory to moving to the new domain. But I was unable to join the domain as that "guru" had changed the local admin password. They are long gone and I really need to "reclaim" those servers! Is there any way I can get that local admin password back??? I haven't yet taken the 3rd server off the current domain and assume its local admin password would have been set to whatever the other two are. Is this any kind of help to me? Can anyone tell me how to reset the local admin password so I can get back into those servers? Or recover that password somehow?
0
Hi,


How to measure disk I/O. what are the tools available in Suse Linux and which tools is best for it.

Thanks in advance,

Regards,
Ranjit
0
Hello,

Here goes:

Recently I accidently repartitioned my drive which had VERY valuable data on. I didn't format the hard drive so the data is still on it. I did use OnTrackRecovery software and I have managed to get data back from the hard drive, but it is in a right mess. The extension (.exe or .jpg, etc...) of my files are not quite what they should be.

I am having a right difficulty on determining what type of file it is by trying to open the file as an ".exe" or a word or PDF or music, I'm sure you catch my drift.

There is over 100GB of data which I am trying to retrieve so as you can imagine the pain i'm in right now!

Is there is way possible to use a software which can run tests or something which can identify which application the files can run in?

I would greatly appreciate your help in this matter as you can see by the screenshot how many types of file extensions there are, some of which aren't detected by a simple google search.

Thanks!

Deepan

Screenshot
0
Hello Experts,

I have a USB Camera that is not working on four different machines.  I have installed the device and drives and it was working.  Now it does not.

All systems are Windows XP.

I have taken the Camera and tried it on a different machine and the device is recognized.
When I plug it into one of the four computers it does not even reconize there is a  device.  I have plugged in a mouse to the ports we use and the mouse works.

How do I remove the current driver for this device?   It does not show up on Device Manager.

The device does work on the firth machine  were I did not install the drivers.  The USB ports work because the mouse will work in those ports.
0
I can get the times (create, Access, Modifiy) of one file and change a second file's datetimes accordingly.  However, I'm having a devil of a time displaying that datetime as a string. See below.

 
FHIn  := FileOpen(FNOut,fmShareDenyWrite or fmOpenWrite);    
GetFileTime(FHIn,@FCDo,@FADo,@FMDo);
FileClose(FHIn);
FHOut := FileOpen(FNOut,fmShareDenyWrite or fmOpenWrite);    
SetFileTime(FHOut,@FCDo,@FADo,@FMDo);
FileClose(FHOut);
                               // - all working so far

showmessage(FormatDateTime('yyyy/mm/dd hh:mm:ss',FMDo)+'   '+FNOut)
                               // this displays - 1899/12/30 00:00:00  (and the file name)

What is the most direct way to display a file's date in string format?

TIA - Ed
0
Dear all,

I have the following existing script using litespeed backup

Declare @filenumber int
exec master.dbo.xp_backup_database @database = N'iXCore_Port',
@GUID = N'7565C182-6AC1-4E5F-82B9-6136A3BAA782',
@filename = N'\\REPO\Litespeed\Batch02\iXCore_Port200903191122LiteSpeed_Full.BKP',
@backupname = N'Repository Daily iXCore_Port Full Backup',
@desc = N'Repository Daily iXCore_Port Full Backup',
@jobp = N'FlTb+IlqB9p9+MB4HPgZQg==', @cryptlevel = 6,
@compressionlevel = 11, @comment = '', @with = N'SKIP', @with = N'STATS = 10',
@filenumber = @filenumber output

exec master.dbo.xp_restore_verifyonly
@filename = N'\\REPO\Litespeed\Batch02\iXCore_Port200903191122LiteSpeed_Full.BKP',
@jobp = N'FlTb+IlqB9p9+MB4HPgZQg==', @filenumber = @filenumber

I have tried to add "@threads =16," and change compressionLevel to 11, but the total time doesn't change much.

Any suggestion on how to optimize that?

Also any link show me how to implemetn full backup + differential backup + retentation period using litespeed?

any way to improve the speed and size ,etc will be good !

DBA100.
0
Greetings,
I am trying to troubleshoot an issue related to a corrupt user profile and internet explorer.  The issue basically impacts the user in a multitude of strange behaviors when running thin client applications in internet explorer.  There are various communication errors that are not reproducible when she logs in to another machine with a brand new profile.  Yet on her machine the problem persists in spite of rebuilding internet explorer.  

Are there any utilities that would be useful that would help analyze what exactly is going on with the users profile as we reproduce the issue?  I was thinking something the event viewer could do to shed some light on what is going on.  We would ideally like to have a lens into what internet explorer and the underlying profile might be doing to cause the communication errors.
0
I was again needing to expand a partition on one of my 2003 x64 servers.  I expanded the vmdk as usual, but, when I tried run extpart either via CL or interactively, I get the following error:

Program Cannot Start or Run
The program or feature "\??\C:\Temp\EXTpart\ExtPart.exe" cannot start or run due to incompatibility with 64-bit versions of windows.  Please contact the software vendor to ask if a 64-bit Windows compatible version is available.

The main difference between now and when I last ran it on this system (5 day ago), is I ran Windows Update the day before (ran out of sufficient free space causing the Exchange (2007) Transport service to reject message submissions).

Any assistance with getting extpart to run, or an alternate method to quickly expand partitions (preferably hot) would be greatly appreciated.
0
We are looking to purchase the Dell SecureWorks iSensor with managed IPS services. We currently do not have an IDP or IPS system in place.

Does anyone have any experience with SecureWorks, the iSensor platform, or their managed IPS services? If so would you recommend it and do you find that it has significantly improved your network security? Have you had much trouble or headaches with the service or device?

We are strongly considering purchasing their services. We have a small network team (myself and one other admin) for a medium sized and fairly complex network so we don't have the time or expertise to learn and manage an IPS system on our own or report to every false alarm they generate.

Thank you in advance!
0
When I boot up via Safe Mode, it would pause for almost 6-7 minutes
while reading mup.sys file below.  I renamed this file to disable_mup.sys
but it recreated this file again.

What is this driver file used for or is it a virus?  Any harm to permanently
delete/disable it?

 Directory of C:\WINDOWS\system32\drivers

04/21/2011  09:37 PM           105,472 disable_mup.sys
04/21/2011  09:37 PM           105,472 mup.sys
0
Hi,

I have a client who has a dead ASUS Laptop mainboard. The hard drive is fully functional. Since it is still under warranty i will be sending it in for repairs. ASUS tech. support requested that I backup the drive contents prior to shipment to them. Normally not a big deal but the client has two programs that he does not have the reinstall disks for.

Is there a way to image that entire drive and save the image until the laptop is returned?

I will have to connect the Laptop drive via a USB adapter to a desktop PC.

Thanks,

Frank
0
Hi,

  I would like download data from a webpage in to excel or csv..

  link: http://www.tcmb.gov.tr/yeni/eng/tablolar.php

  I would need to extract ,

               FX Buying      FX Selling
 Dollar      1.8100      1.8187
 Euro      2.2227      2.2334

   from the above page in to Excel and convert it to the below format in .csv..... file

'USD','TRY','28-JUL-12','Spot',1.8100
'EUR','TRY','28-JUL-12','Spot',2.2227

     Only the Buying rates needs to come in to .csv file....

    ANy ideas or advice.... Help greatly appreciated.


Thanks
Aman
0
every time i start my laptop bitlocker drive encryption password entry when i start my laptop; how do i get rid of it?
bitlocker.jpg
0
I have an IBM P520 that came pre-installed with AIX Unix from a software vendor. The machine is no longer being used for it's orignal purpose and I would like to install a linux distro (Debian preferably) in place of the AIX Unix.

The problem is there was no HMC installed on the machine. IBM want's a support contract to just to talk to them about how to download and install an HMC.

I'm looking for advice on how to get (download) an HMC for an IBM p520 and pointers on how to install it as well, and maybe a link to a manual.

Thanks!
0
I have picked up this HP desktop to repair. The operating system is on a partition on the hard drive. I have done all the diagnostics and start-up OS repairs to no avail. The PC will boot up all the way to the users name and waiting for a password. Sometimes it will reboot before I can type 1 character of the password and other tines I can type the whole password in but that is where it stops and then after a few seconds it reboots.
I took the hard drive out and hooked it to this one and I can see everything on the hard drive.
I ran a check disk and malwarebytes while I had it hooked to mine hoping that would fix any corrupt OS file but that did not work. I really don't now what else to do besides backup and format to factory condition.
Can any of you experts please have an easier way than formatting, There are quit a bit of programs that would need to be reinstalled.
I thought HP had a function key that would repair/reinstall without loosing any data or program but I don't see it/
Any feedback would be greatly appreciated.
bbbb2
0
I have been messing around with Process Explorer.  I have a question.  Is it correct to assume that if I total all the Private Bytes that will equal the Current Commit Charge?.  I am attaching a screen shot to illustrate.

If that is the case is it possible for some memory usage to not show up in the list but only in the total?


Process Explorer
0
I've been searching for an application to do system logging. We’re having an error pop up during the log off process and want to capture what application is invoking it. When this error happens nothing is recorded inside Windows event viewer. I’ve been using ProcMon, but couldn’t narrow anything down.  The monitor needs to a system based process, rather than user. The issue happens when the user logs off.

Does anyone have a good experiences with something else out there?
0
I have purchased a second hand server (DL380 G4) and need to install Windows 2000 Server SP4.  

I have the Windows Server 2000 disk and license but can HP SmartStart be used for the setup?
0
Hi Experts... I have been having trouble sending emails to Bellsouth.net addresses from our server. I noticed that this is somewhat common with their domain. On one of your threads I found the answer to the problem by following the following url:

 http://worldnet.att.net/general-info/bls_info/block_admin.html

Unfortunatley this is no longer a valid path... is there an updated place to go to get removed from the list. We have no other issues like this.


Thanks for the help.
0
Hi all,

I know at first this might seem easy but as always the devil's are in the details.

So here's the scenario...

Let's say I have a directory structure like this:

/a/b/c/d/x/y/z/a/b/y/
/a/b/n/d/x/y/z/a/b/z/
/b/c/d/x/b/c/x

I want find to return all the directories under first directory called "b" it finds so in the above case I want it to return:

/a/b/c
/a/b/n
/b/c

and not

/a/b/c/d/x/y/z/a/b/y
/a/b/n/d/x/y/z/a/b/z
/b/c/d/x/b/c

since these although are under a "b" directory it's 2 levels of "b" down.

Because I don't know how far in the first level "b" will be I cannot use the "maxdepth" option which otherwise would be the easy way. I don't want to return anything but these directories directly under the specified directory.
0

System Utilities

12K

Solutions

16K

Contributors

System Utilities are a type of system software used to support the computer infrastructure, distinguishing it from application software which is aimed at directly performing tasks that benefit ordinary users. Commonly used utilities include password managers, disk managers, system monitors, data synchronization tools, security and antivirus software and editors.