System Utilities

12K

Solutions

16K

Contributors

System Utilities are a type of system software used to support the computer infrastructure, distinguishing it from application software which is aimed at directly performing tasks that benefit ordinary users. Commonly used utilities include password managers, disk managers, system monitors, data synchronization tools, security and antivirus software and editors.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hello,
I posted a question dealing w/ PE a long time ago, but I now have started the learning process again; believe me I need a lot of learning.

I’ve working w/ a Windows 7 x86 PE USB boot image. I can burn the boot image to a USB drive w/o a problem and will boot fine, but that’s where my low level experience steps in. I’m working w/ the WinPE 7 on a x64 Win 8 laptop but don’t think that’d make a difference.

I run bsexplorer in the winpeshl.ini the explorer.exe file starts but has serious problems. When I use run from the start menu, hit browse, a window doesn’t even come up for me to pick a particular file out. There’s also no my computer icon on the desktop, and I’d really like to be able to see what devices need drivers, but I think getting that far is a long ways away. Maybe a missing driver causes the problem to begin w/?

There are a lot of premade WinPEs to download, and there are a lot of WInPEs called Gandell’s WinPE. What I’m trying to do, and haven’t had any luck finding this yet, is to look at the start up files from the ISO mentioned above. I look at the startnet.cmd, and all I see is winpeinit.

I’d like to see what Gandell’s WinPE uses to get its desktop going. A desktop that has my computer on it & functions to get to device manager. Is there a portable app that gives you the desktop w/ the my computer, gets you to device manager, etc? I search through the ISO file along w/ the boot.wim file but don’t see any unattend files. Would what I’m …
0
I have several computers (HP brand) that I am trying to upgrade to Windows 10, however at the end of the process I get a reserved partition error. I researched a tool named MiniTool Partition Wizard. Followed the instructions, however, the computer keeps restarting and not letting me in the login screen, any suggestions on fixing the reserved partition? Specifically, also after using the tool? Thanks!
0
Hi All - I have a folder full of about 10000 files, with a couple of levels of sub-folders.
(If it matters, they happen to be a web folders, copy on my local hard drive of a MAC OS X, websites are live on a Linux/Apache server).

Someone made changes to some of those files, and now I have a copy of that folder with those changes (as well as a copy of the Original folder)

What is the easiest way to do a comparison to see what files have changed between the two folders? (Presumably based on File_Size and Last_Modified_Date)

Note that I do not care what the content of each file is. I just want to know which file(s) were modified.
0
on one user profile so many icons changed to .lnk (as example .rar changed .lnk) . on administrator profile all ok
(windows7)
0
I have an outlook 2007 .pst file that Outlook 2007 can't open.
It was good a few days ago and the computer it was running in crashed.  The HD appears to still be good.
I have some backups that I'll be looking into.

In the meantime, what tools would you recommend to recover the messages and contacts?
I've already tried Kernel for Outlook PST Recovery from Avangate / Lepide.  The contacts (or some of them) came through but without any email addresses.  Quite a few messages seem to be missing as well.
The file size is 1.6GB.

What tools / process would you use?  I've looked for scanpst.exe but haven't found it anywhere.
The platform running Outlook 2007 is Windows 10 64.
0
Hi, I'm still somewhat new to the USB ISO thing.  I use winsetup USB to manage my ISOs.   I want the Lenovo bootable diagnostics to work using one of the ISO to USB converters.  However, my first attempt failed to load the diagnostics.  It gets all the way through the boot of Linux processes and login.  However, the GUI never loads.  The screen is black, with a couple green pixelated boxes taking of 1/4" x 1/4" of the screen.  I'm about to burn a CD but would like to know what is going wrong here
0
Hi all,

I'd like to find a simple (graphical and free, hopefully) program that can monitor the bandwidth usage for our small network and figure out who's hogging up all the bandwidth.

WikiHow is suggesting that i use Wireshark. Is that a good choice?

Thanks in advance.
0
Please provide me with a list of utilities that can be used to boot from a USB thumb drive to reset a user's local Windows 7 password.

I will only be using these sorts of utilities for ethical purposes within my lab testing environment.
0
1) there is not a switch on the usb that is write protecting it
2) i have tried diskpart and removing the read only attribute this doesn't work
3) tried to format and this doesn't work

is there a tool out there that is free that will format this usb stick no questions asked?
if so can someone help me or show me how to smoke this usb that wants to stay write protected.
0
I'm testing a custom sysprepped windows 10 image deployment via Dell KACE software and I'm running into a problem where my deployment does not finish due to the following error message:

"Windows could not complete the installation. To install windows on this computer restart the installation"

I found a workaround that WORKS of this issue by doing the following steps when the error message displays:

1. At error screen, press shift + f10 to display command window
2. At command window, type in secpol.msc which displays the local security policy window
3. In the local security policy window under security settings, choose account policies > password policy.
4. The minimum password length by default is 8 characters (according to my research this is a problem for image deployments because the audit mode in sysprep uses a null password and doesn't meet the 8 character length)
5. Change the 8 character limit to 0
6. Disable the "password must meet complexity requirements" setting
7. Exit command window and reboot

The custom sysprepped windows 10 image I'm testing will eventually be a new network image for my users, therefore I will be using the same Dell KACE deployment software to eventually deploy this image to multiple workstations.

Is there a way to easily script (automate) step 6 above? I've come across some confusing ways (i.e. editing %windir%\inf\defltbase.inf or secedit.exe /configure /db %windir%\securitynew.sdb /cfg C:\secconfig.cfg /areas …
0
We have systems scatter all over the network with a particular ODBC System DSN driver installed. We would like to discover the systems which have this DSN driver installed. Some systems have the driver installed under the ODBC User DSN, so we need a script or if anyone knows of an application that can discover this for us.

If the application or script can be customized to discover the particular driver, so we don't get an output of all drivers installed, then it would be great!

Attached is a script that I am using, but it needs a text file with all the computers, I want to ruun a scan across the network to discover ALL Windows systems - our environment is Windows 7 and Windows Servers 2013.

Can this be done with NMAP, Nessus, or any other application?

Thank you,
ODBC_Final.txt
0
We currently use Appassure to do our backups both incremental and base.  Lately, we've encountered the same issue when trying to do two recoveries of files.   We identify that all of the folders are in the specified directory that we are trying to recover from; however, when we try to restore one specific file, we receive the following error when trying to access it:

\\(the path of the folder)\ is not accessible.  You might not have permission to use this network resource.  Contact the administrator of this server to find out if you have access permissions.

The file or directory is corrupted and unreadable.  

The folder we are trying to look at is 6 Gb's in size and is the largest in the folder.  We can access other folders that are much smaller, under 100Mb's, so I'm thinking the size has something to do with it, but I'm not sure.  

Has anyone encountered this issue before?

-Anthony
1
Our company has installed Windows 2012 R2 on a PC grade desktop. Recently the response of the Server is very slow as reported by our user. When we reboot Windows, the system prompt "Repairing disk errors. This might take over an hour to complete". We have been waiting for over 8 hours and seems the "Repairing" is still ongoing. My boss assign me to see if this can be solved. Our question is:

1) It seems that the hard disk is failing or lots of bad sector. Shall we abort this "Repairing" process and restart just let it finish first before go for any other solution ?

2) We have installed many applications on the computer and reinstalling them will take a very long time. If we buy a new hard disk (Both the existing disk and new disk is SATA) and use a cloning software to clone the disk and wonder it it could address the issue ?

3) As the hard disk my be faulty or contains many bad sector and we would like to know if we clone the disk will it carry the bad sector forward to the new disk or not ?

4) Can any expert suggest a cloning solution/software or shall we buy a disk cloning docker to do the job ?

Your advice is greatly appreciated in advance.

Thanks & Regards
Patrick
0
Hello experts,

I have a user that has adobe acrobat professional but he is not able to print pdf files on his computer. He showed me the adobe print device under printers and device and it has yellow mark.

I asked the user to delete the print device. I would like to know how to update it.

Thanks,
0
Just taken out a pc of FlashAir which I've bought about 9 months back but haven't use it:
when I plug it into my X61 SD slot, can see its SSID FlashAir_xxx (where xxx is a long hex number)
for a while & it then disappears though my Win XP's Explorer can still see the drive & files in it.

Ejected it properly ("Safely Remove Hardware") & reinsert : this time completely did not see
the SSID tho waited for 2 mins : tried a few times & it's always intermittent (& when I tried to
connect to it from Win XP, it vanishes) while my Dell on
Win 7 Ent could not even see the SSID at all times despite refreshing.

This X61's Win XP is unhardened while the Dell Win 7 is corporate hardened (but it could
connect to my Android phone's 4G tethered hotspot & corporate Wifi).

What could be wrong with the Toshiba Flashair?  Any way to make its Wifi signal stronger
& more consistent
0
I ran process monitor from Microsoft Sysinternals tool for only a few minutes I got 54,000 Name not found. 18,000 Reparse. 5,000 File blocked with only readers.

With so many errors where would be the starting point for troubleshooting?
0
I have a Dell PowerEdge T310 with a PERC H700 array controller.
I have fresh version on windows 2012 R2 installed on it but I do not have any utilities to monitor the hard drives.
What is the hard drive/ array controller monitor utility called as I want to download it and set it up.
I don't need any other monitoring software if that make things easier.
Thanks.
0
Hello, I have an Hp ML150 G6 server which was never fully provisioned. Meaning, the it was a blank Win 2008 R2 OS until the other day I got my hands on it.

The RAID controller isn't even enabled. I just recently installed most of the Hp Manangement tools and agents(including iLO)

when I click on the Light-Out 100 link a page opens to a 192.168.2.100 address. I assume the ilo port was previously configured with this IP since dhcp is their default config.

iLO link
The issue is that the server is in a remote office in Europe. Changing the iLO config via BIOS is not an option.

I tried to install the hponcfg util since i found some commands that enable to reset to default, but apparently it is not compatible with my server.

Any suggestions as to how I can reset the iLO port remotely without a restart

thx

t
0
I start to create an image for my Lenovo thinkpad X100e and i am using Clonezilla. everything goes well until I am creating the image. This part is when I am on Partclose windows and then the netbook shuts down and it doesn’t finish the image. Can you tell me why this happen and how can i finish my Image?
0
So Dell has a "ProDeploy" service that's supposed to help you get your server all set up after they rack it up for you... I've already got ESXI set up for the most part.... So I told them when I could really use help with was getting it set up so that the thing would talk to my Dell UPS's and shut down in a power outage.  Not only does the guy am working with not know how to do this is apparently asked around and can't seem to find anybody who knows anything about having a UPS automatically shut down the esxi.

I figure I can install the operating system clients to have all my guest operating systems shut down automatically when the UPS loses power.  But I'm not at all sure how to get ESXI to shutdown as well....

I'm curious if anyone here has any experience with this
0
Hi All

Thanks for any guidance you can provide.

I'd like to automate a robocopy job in Windows 7, and have discovered that a the /RH xxxx-xxxx flag can be used to pause the job until an appointed time.  I've tested a script using this and it works like a charm.

But It is unclear to me whether this job is persistent, between restarts, whether it is persistent daily until a restart, or if it is just a one-time script.

I would like to ensure that this job is executed as such every day.  If need be, I'll put it on the scheduler if necessary, but need to know how the /RH works in this respect.

What would you recommend?

Thanks.
0
I've copied data from a hard drive to a CD-ROM and I want a tool to verify all the data was successfully transferred.  I'd also like the results to be output to a file that confirms the transfer.  I'm thinking of using comp.exe to do this.  If this is can be used, can it include subdirectories as well?  If so, please provide an example of the syntax to include subdirectories.
0
I need to install an HP LaserJet CP4020 printer on clean install of Windows 7.  This driver is not available on HP's website and I've looked and looked on the internet with no luck.   Lately Windows updates are taking hours upon hours to find and install.  Is there somewhere I can download the driver without having to wait for Windows to update the list of printers?
0
We have a file which after setting the permission correctly, after a while
(I don't know after how long), the permission of the file will get changed.

We track Solaris sysadmin's logins (with a video recording tool which all
sysadms have to login through to access) as well as command history
but don't see it.

What can we do to track which app/process/person changes the perm?
ACL piped to syslog?  In Windows, I've seen File monitoring tools.

Any freeware / opensource tools can be recommended as well.
0
i'm getting this error below when trying to install any OS on my lenovo X1 Carbon either via DVD or PXE.

Things i tried already

changing the boot order
disable secure boot in BIOS
enable Legacy Boot in BIOS

i also went into CMD and
select disk 0
clean
convert mbr
create partition primary size=51200
format fs=ntfs quick
active
assign letter=C



nothing worked.

any help is appreciated. thanks

9OLuAuD.jpg
0

System Utilities

12K

Solutions

16K

Contributors

System Utilities are a type of system software used to support the computer infrastructure, distinguishing it from application software which is aimed at directly performing tasks that benefit ordinary users. Commonly used utilities include password managers, disk managers, system monitors, data synchronization tools, security and antivirus software and editors.