We help IT Professionals succeed at work.

TCP/IP

11K

Solutions

17K

Contributors

Transmission Control Protocol/Internet Protocol (TCP/IP) is the set of networking protocols that define end-to-end connectivity specifying how data should be packeted, addressed, transmitted, routed and received at the destination. This functionality is organized into four abstraction layers which are used to sort all related protocols according to the scope of networking involved.

BGP Configuration with and without another IGP

in the topology below, I would like to know if :

-- BGP needs to be configured on R1  R2,R3,R4  without any other IGP (OSPF)configured on the same routers.
-- Or BGP can be configured only on R1 and R4, but IGP (OSPF) should be configured on all 4 routers R1,R2,R3,R4

Thanks


b
0
OSPF Address-Family

I have seen  in some examples EIGRP configured with   address-family ipv4 vrf <VRF Name>  autonomous-system <AS Number>
However I have not seen examples where OSPF  is configured with  address-family ipv4 vrf <VRF Name>

for instance, in the topology below Customer Edge CB_1 uses OSPF  and  it is connect to PE_1

Thanks

m
0
Configuring BGP at the Customer Edge Router

knowing that Customer Edge routers cannot contain in their tables all BGP routes available in the Internet, so how are those Customer edge routers configured to reach Internet without having to have full internet routing table

Thank you
0
Hello,

Currently we are trying to utilize PXE boot across subsets in our environment. Please read below for more information

Current network environment:
ubnt--enviornemnt.png
●      The USG Router and Switches are assigned static IP addresses listed above
●      The USG router has networks/vlans created on them via the UBNT controller UI (v5.10.23.0)
ip-scheme.png
●      The USG Router is responsible for DHCP for each network
●      Our WDS/MDT server is 10.10.1.26/24 sitting on vlan 100
●      We are able to PXEboot clients on the same subnet (10.10.1.x/24)
●      Issue: We are trying to have clients on the Techbench network vlan 3340 be able to communicate pxe boot to our wds server (10.10.1.26/24)

Current settings in DHCP TechBench4 network
DHCP-options.png
Advanced DHCP Options:
advanced-DHCP.png
Error on Client machine:
client-error.png
I will soon place wireshark traffic logs when i finish testing:
0
Need to SSH to my AWS Ubuntu server from Mac Terminal

I opened Terminal, executed
sudo su (to become super user)

changed directories so that my current folder shows my KeyPair1.pem file and when I execute

ls - l

I see my .pem file has the following permissions:

-r--------@

please explain this. It's Read access for who exactly?

I ran "chmod 400 KeyPair1.pem" as a way to protect the file from being over-written, Is this the correct thing to do?


I have the IP address of my Ubuntu server:

I execute the same command provided by AWS, but find the terminal locks. I am forced to press Ctrl+C to get the cursor again:

ssh -i "KeyPair1.pem" ubuntu@1.2.3.4

Does anyone see what's wrong?

When I type ssh <ENTER> I get:
usage: ssh [-46******************Yy] [-B bind_interface]
           [-b bind_address] [-c cipher_spec] [-D [bind_address:]port]
           [-E log_file] [-e escape_char] [-F configfile] [-I pkcs11]
           [-i identity_file] [-J [user@]host[:port]] [-L address]
           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
           [-Q query_option] [-R address] [-S ctl_path] [-W host:port]
           [-w local_tun[:remote_tun]] destination [command]

Does this mean SSH is installed?

Is there a way to see what variant of SSH is installed?

Thanks
0
IP Subnetting

I have this  Prefix 224.0.0.0/4 , If I am not wrong  this will cover 224.0.0.0 to 239.255.255.255.
OK, if I will have to demonstrate that using binary, how can I do that  ?

224.0.0.0
224 = 1110 0000 then the rest is  0000 0000 . 0000 0000 . 0000 0000

so where does the /4 belong there ?

Thank you
0
My questions are about re-linking the kernel and rebuilding the kernel environment.
What does "rebuilding the kernel environment do"?
Is it required when re-linking the kernel?
How can I boot the old kernel if the new kernel fails, or has some wrong behavior?

I am afraid what will happen if the new kernel won't boot, or if there is erratic behavior with the new kernel.
How can I boot the previous kernel that was working fine?
Will the old kernel have trouble if I said "yes" to rebuild the kernel environment when creating the new kernel?

NOTE:  I see this when unix boots if I wait 60 seconds, or hit the enter key

OpenServer Release 5
boot
:
hd(40)unix swap=hd(41) dump=hd(41) root=hd(42) auto

Sizing memory
....................  many rows of dots

I suspect that during the 60 second wait, I can type something to invoke the old kernel.
What do I type?
I have not found any documentation on this in man boot(HW)

Why am I doing this?
I have SCO OpenServer 5.0.7 Host Edition with Maintenance Pack 5
Host Edition does not include Networking.
Enterprise Edition is needed for networking.

I don't know why, but I have some network components on the server.
Perhaps they were installed by Maintenance Pack 5
inetd and ftpd are running every time the system starts.

I tried to add the Intel PRO 1000 LAN adapter with TCP/IP.
I was prompted to re-link the kernel.
I hedged.
I can't afford to end up with a system I can't boot.
I need to know if I can get …
0
Ethernet/IP EIP
TCP/IP IEEE
TCP/IP Modbus

My private network
0
I am trying to exclude a specific ip address from being assign to any Ec2 when rebooting or provisioning a new instance.
Reason.  We have disaster recovery in AWS and auto generate an instance with a specific private ip address  that we need to have available when the instance spins up.
0
I want to forward my TCP/IP port 1433 properly to the local workstations, so far I'm now at Enable port forwarding and connect

Steps taken so far

Enable port forwarding and connect

Create a new port forwarding I have noticed that each router is different. But the goal is the same: Enable the Port Forwarding on your router.

To do that, I have done this see below :

– Login to the router
– Search WAN Services
– And create Port forwarding with this informations:
   • Name : Name for this rule (example SQLExpose)
   • Protocole: TCP/UDP
   • WAN port: 1433
   • LAN port: 1433
   • Destination IP:

(1)      On the Destination IP what do I put there??? Is it the host server IP Public address  or Local workstation IP Public Address??????
(2)       At this point since the server is already configured to enable port 1433 can the machines on LAN work??
(3)      What about those on a secure network (VPN) as per above setting can the machines work?

See picture also

internet-ip-address.png

This is one of the toughest area I’m encountering so far, they are just too many rules, anyway further advice or notes will be appreciated it’s a learning curve.

Regards

Chris
0
Should the SQL Server connection string change also when connecting over the internet what I mean is people will have to input data through workstations that may be dotted in some different countries,( This is after configuring the firewall & enabling TCP/IP)

Let us assume the workstation is in the USA and its static IP Public address is 196.231.241.231 and the host SQL Server is in the UK with static IP Public address 193.231.231.225 now we want to ensure that a person using a workstation in the USA is able to update data in the UK SQL Server (193.231.231.225) without problem. Assuming  the following is done correctly

(1) TCP/IP properly enable and port 1433 forwarded  to host IP address  193.231.231.225  and also the workstation in the USA is linked to 1433 to 196.231.241.231

   Example : Port Range Forwarding (UK Modem)

                      Application                     Start                 End                       Protocol                          IP Address            Enabled
                      Sql                                    1433                1433                      Both                                193.231.231.225       Ticked



Example : Port Range Forwarding (USA Modem)

                      Application                     Start                 End                       Protocol                          IP Address            Enabled
                      Sql                                    1433                1433      …
0
How can I forward the port I opened 1433 to the router, this is after all the below steps were followed:

(1)      In order to allow access to SQL Server instance, I had to enable TCP/IP protocol which is not enabled by default
(2)      From the SQL Server Network Configuration node, I selected the Protocols item for the appropriate SQL Server. In the details pane, I right clicked the TCP/IP item and select the Enable option:
(3)      In order for the changes take effect, from console pane, I selected the SQL Server Services and from the details pane, I right clicked the SQL Server (SQLEXPRESS) database engine instance and click the Restart option:
(4)      Now after the above steps I had to configure the windows firewall as follows:
(5)      From the Control Panel I choose Windows Firewall and clicked the Advanced settings
(6)      In the Windows Firewall with Advanced Security, I clicked the Inbound Rules from the left pane, I right clicked Inbound Rules and select the New Rule, Under the Rule Type I choose Port and click the Next button:
(7)      I now selected the UDP protocol and in the Specific local ports entered port number 1434. To proceed with the settings SQL Browser services, I clicked the Next button:
(8)      Then a dialog box popped up then I choose in the Action dialog choose Allow the connection and clicked the Next button:
(9)      Then there was another dialog box in the Profile dialog I choose all three profiles (Domain, private & public) and click the Next button:
(10)       Then I clicked …
0
This gist:
I need to redirect a wide range of ports (or all, if possible) to a remote server to support clients that are slow to re-resolve DNS. Any recommendations that are compatible with Ubuntu? I'm also open to Windows based solutions (if there's something easier available on Windows).

Details:
I am planning to move a server that communicates with field devices (remote clients initiate the connections) from one provider to another.

Once the server is ready I will change the DNS record to point to the new server, however, experience with our field devices tells me that I can't rely on them all to resolve the new address.

I'd like to see what software TCP redirect options there are. I've actually tested with RINETD in the past and a couple of other solutions that I can't remember off the top of my head, but only a couple of ports/devices at a time.

The traffic is constant but lightweight. Mostly ASCII commands and event data, from ~150 endpoints.

Thanks for any suggestions.
0
Configure OSPF at the Interface  or Global Config level

I have configured OSPF at the Global Config level , then when I checked if OSPF configuration trickled down to  the interface level, but it has not.

R3#sh ip ospf int s0/0
%OSPF: OSPF not enabled on Serial0/0

So I am just wondering in which case you configure OSPF at the Global Config level and  in which case you configure it at the interface level

Thank you
0
Hi Experts, im unable to start the  tomcat in debug mode i also opened port 9090 in windows firewall.please suggest how to start tomcat in debug mode
debug.PNG
0
My LAN is on a subnet 172.18.2.x. I am running out of IP address. What I would like to do is tale all the switches, wireless bridges, etc. and move them to a different subnet but I really want them to have internet access for firmware updates and such. So.... can't I take a cheap little router, plug the WAN port in to the 172.18.2.x subnet (which will give that router internet) then plug one of the LAN ports on it also in to the 172.18.2.X? That is assuming the the cheap has a subnet like 192.168.0.0

   It mean essentially that the cheapo router will have both a WAN and a LAN port connected to the 172.18.2.x subnet but couldn't I, at that point, change all my "non-critical" devices to the 192.168.0.0 subnet which will still let me get to them and give those devices internet?
0
Query Scoping in EIGRP

I have the topology below:

the network is using the address 192.168.0.0/24 from end to end except the loopback 0 behind R7

Router 7 has a loopback 0 with ip address 7.7.7.7/32

if I shut down the loopback 0 on R7 the query will go all the way to R9

if I change the IP address on R7 Loopback 0 for instance to 192.168.7.1 /24 then create summary address on R6 e0/0   192.168.0.0/20 then shut down R7 Loopback interface the Query will not go all the way to R9, it will reach R1 and R1 will reply back and that 's it.

However If R7 Loopback 0 is configured with 7.7.7.7/32 , I cannot see a way to do summarization on R6 e0/0

any idea to get around this  ?

Thank you

query
0
OSPF in Shared Nework

If I understand OSPF in shared  network uses the concept of DR and BDR

Let's say we have 7 Routers connected to L2 Switch

case1 :
the first time 7 routers  boot up at the same time, what are the steps they go through before they elect DR and BDR

Case 2:
2 More new routers have been brought to the network what is the process of exchanging  information with the existing routers should they go through, assuming DR and BDR have been already elected in case 1

Thank you
0
I never really thought about until today... you can ping devices on different subnets but you can't access them without binding a ip on that subnet to your nic? Is that true?

   A case would be I am running on a 172.18.2.x subnet. When I get a new D-Link device in the door (whos default IP is 192.168.0.50) I should be able to ping it without having a 192.168.0.x IP on my nic but I would be able to access it until I add a 192.168.0.x IP on my NIC. Is that right?
0
Hi
If I make my game server in Java, with TCP/IP HELO, START and in-game messages, game runs in browser, javascript to my server,
what can I expect as the worst from the unavoidable hackers and miscreants? Floods..
DSS attacks. Are they detectable? Stoppable? Google suggested they are stoppable. I will be using a Godaddy professional private server.
Floods will be a certainty if my game escalates. It would  suck, because there will be prizes in contention.
Do Blizzard and Microsoft weed these out? Is this how the old disconnect-hacks worked?

Thanks
0
Maximum size of IP and TCP  Packet.

There is a little bit of confusion when it comes to the Maximum size of IP and TCP  Packet
I did some reading nline, I have seen numbers of 65Kbytes and 1500 Kbytes but not clear which number goes with IP packet and which goes with TCP Packet.

Any Clarification?

Thanks
0
Hi
My other networking question is abandoned. I think it has become a snail's nest, so I'll simplify it...pithy...

How is agar.io's networking perfectly natural, with no lag? You can turn your circle with a mouse click or finger tap, and the response never ever stalls.
Some dude has a javascript agar.io networking tutorial out there, below , which is v good, if you want to make a LAN game or ONLY localhost game, pure TCP/IP, but it isn't optimized for the big bad world, ..distance.


There is no UDP w a TCP safety net. How exactly did they make agario perfectly? Browsers eliminate UDP. I have a good Websockets link below that I like..
I am completely comfortable making Java game servers, btw
BTW, That javascript tutorial is here


I like this page I found for WebSocket aspects here
Thanks
0
802.11i:

Improvements to security at the link layer.

Does this mean the link layer of the TCP/IP model?
0
My understanding is for sockets, connect sets the destination IP address, and bind sets the return IP address.

What would happen if I created two sockets, socka and sockb, and did:
socka.connect(10.1.1.2);
socka.bind(99.0.0.1);
sockb.connect(99.0.0.1);

Open in new window

If I now send some data to sockb, will the data go to socka and then will socka forward that data to IP address 10.1.1.2?
0
I subscribe to a site similar to this one that answers a wide scope of questions. The site is www.justanswer.com  My internet speed averages 950 Mbps up and down via fiber. I have a late model router and my problem occurs no matter which computer I am using. Frequently it will give me the errors as pictured in the included photos. It is the ONLY site that I have this difficulty with. The "Customer Service Representatives" indicate that they are having no problem. This has been ongoing for over two years. Can any expert shed some light on this difficulty? I use Windows 10 and McAfee Total Protection. If it is something you think I am causing I am sure you will tell me how to remedy the problem. If you think it is the site in question please give me a short and to the point description for them so that their techs can address the issue with the details that you think are important. Thanks Experts!!Result one of two when attempting site accessResult two of two when attempting site access
0

TCP/IP

11K

Solutions

17K

Contributors

Transmission Control Protocol/Internet Protocol (TCP/IP) is the set of networking protocols that define end-to-end connectivity specifying how data should be packeted, addressed, transmitted, routed and received at the destination. This functionality is organized into four abstraction layers which are used to sort all related protocols according to the scope of networking involved.

Top Experts In
TCP/IP
<
Monthly
>