We help IT Professionals succeed at work.

TCP/IP

11K

Solutions

17K

Contributors

Transmission Control Protocol/Internet Protocol (TCP/IP) is the set of networking protocols that define end-to-end connectivity specifying how data should be packeted, addressed, transmitted, routed and received at the destination. This functionality is organized into four abstraction layers which are used to sort all related protocols according to the scope of networking involved.

Hi all - Will try to explain carefully ... thanks for reading ...  

My problem:
I am experiencing intermittent issues when watching a movie, which is a 7GB file on a local network drive of mine. Downstairs all works fine. Upstairs, when the issue occurs, the movie will play for 10 seconds, then I get a wait-icon (hourglass or what have you) for about 10 second, back & forth over & over.
Sometimes it behaves this way, and other times is perfect.

My Network:
Fast Ethernet service (Time Warner) from the street into my Modem. All over Downstairs it clocks at 110 Mb download and 13 Mb upload, using speedtest.net.
UPSTAIRS I have an Apple Airport Express, setup as a Bridge "Extend an existing network", which worked fine downstairs until I moved it upstairs.  Then connected to that is an Apple TV connected wirelessly, using the same netwk name (SSID).  It clocks at 30 Mb down & 8Mb up, way slower than Downstairs, but I thought would still be fast enough to watch a movie without speed issues.

Note that the data/movie is coming over my LAN ... that I have saved on a local network drive in my house. It is *not* being streamed from any services!  The 7GB Movie is on an ext hard drive plugged directly into the Airport Extreme Base Station.

Can anyone suggest how to troubleshoot this? It's been a long time since I broke a perfectly working network and had to do this!  I am thinking:
- Get a meter or Util to measure exact bandwidth/signal strength?
- Change to use …
0
When a client initiates an SFTP upload to a server - is the size of the file to be coming included in the early part of the conversation? It would be helpful to know in some instances. Thank you.
0
Hello,

Recently we have begun observing some SMB errors logging on our 2k12 R2 servers indicating a failure connecting to a share.  We have a NAS appliance servicing the share(s) in question via SMB3.  Thus far we have bee unable to identify an issue at either the client nor the server level, so it has been very frustrating.  

One thing I can say is that the issue only occurs sporadically and not on all machines, so my inclination is that it is something on the Windows side, but I'm just not certain.

Below is an example of the error.

The network connection failed.

Error: The transport connection is now disconnected.

Server name: \xxxxxxxxxxxxxx
Server address: xx.xx.xx.xx
Connection type: Wsk

Guidance:
This indicates a problem with the underlying network or transport, such as with TCP/IP, and not with SMB. A firewall that blocks port 445 or 5445 can also cause this issue.


Thanks in advance!
0
So im given a subnet range of x.x.54.128 /27

Does this mean any address from 54.128 - 54.254? With a subnet mask of 255.255.255.224

That sound about right? I need to static assign a few servers within that range.
0
Hello,

       I am running through the securing TCP/IP of the N10-06 certification and having difficulty understanding the use of Hash. I get the process of using the algorithm to change the data, but what I don't understand is how that is applied and how it is decrypted on the receiving side to get the data. I have read that it is a One-Way system and cannot be decrypted, but if that is the case how does the recipient decrypt it? Is there a public key sent with the hash and what portion of my computer actually does the decryption. I've been Googling on this a while and reading Mike Myers book as well as Professor Messers video on it, but I am only getting vague descriptions on the intent and concept but not how its staged and executed. Does anyone have any sage advice on this?

Thanks!
0
I've got a client that is running the DHCP role on their domain controller. They are running a 192.168.1.0/24 network and they are running out of addresses. What they would like to do is move to a /23 network so they have a larger pool of addresses. What needs to be done to convert the /24 to a /23 network on the server? Once the /23 network is setup, do I just need to reconfigure the subnet mask on everything static? A reboot to dynamically assigned hosts fix their network connections, right?
0
We have seen that SNMP uses UDP as its transport protocol.  Why was UDP chosen over TCP?
0
One of the first steps in configuring a device to be managed is to give it an IP address. Why?
0
hi experts,

 I changed my printers ip address and I'm on the server and trying to change the ip address and while I try to add a standard tcp/ip port I get access denied, I'm logged on as administrator. see picture
printer.png
0
I am trying to install  Dell Laserjet 5210n on our school network server so it can be shared across all clients. I have assigned a static IP address to the printer and I can ping it. When I try to install the drivers I downloaded from the Dell website I get the attached error.
I have tried installing as a network printer using the TCP/IP port and also as a local printer also using the TCP/IP port. Either way I get the same result.
The Server on the network is running Windows Server 2008R2 and all of our clients are Windows 7 Pro.  I did try to install it using a PCL driver found in Windows and I was able to print one test page but after that the printer went offline and will not come back on line even though I can ping still ping it.

Please Advise.

Thank you!

Robert
Dell-Printer.jpg
0
if I disable ipv6 will it cause a problem on my network?
0
hi experts,

 please see screen shot, sometimes my computers get one ipv4 address and I can go online but sometimes I get TWO of them and unable to go online??
ipv4.png
0
Visited a client site and ran various ‘my ip address’ site to determine what is the External IP address the provider assigned.  Noticed that each device resulted a different value.  For example their phone and their tablet gave different values where that last segment changed (xxx.xxx.xxx.19 and xxx.xxx.xxx.20), yet when we ran myipaddress in our device gave a whole different value in all segments.

We understand that the internet provider assign the cable modem or location a single dynamic external ip.  The location router managed a total different internal ip sequence values and assigns it to each device connecting to the wifi or router within the location.  Thus the cable modem has 1 IP address and the devices within the location has different ip address.

Why would the “my IP address” website display different IP address in all devices connected to the same wifi?
0
When adding the DNS server address of a server (and the server itself is a DNS server), is it preferable to add the IP address as "127.0.0.1" or should the server's actual IP address of 192.168.10.20 be used?

I have seen both types of IP addresses used and am wondering if there is an advantage of using one over the other or if there are any problems with using one IP address format over the other one.

This is in a Server 2016 environment.
1
I have regular outages when listening to an audio feed via my bowser. It just cuts out.

Is there a way for me to find out why?

Also, I got an email from my cloud back-up provider that a backup has not taken place in three days, even though my PC has been connected to the Internet the whole time.

Suggestions?
0
Does anyone know of a regularly updated MAC Address Lookup resource that a person can find what MAC assignments belong to which manufacturers?
0
I need to add the following IP addresses to the A record of autodiscover.companyname.com within my Server 2016 AD domain:

        2603:1036:906:14::8
          2603:1036:3:66::8
          2603:1036:804:20::8
          2603:1036:101:4c::8
          2603:1036:906:84::8
          2603:1036:b00:15::8
          2603:1036:405:2::8
          2603:1036:101:2::8
          40.97.134.216
          40.97.121.8
          40.97.185.24
          40.100.162.200
          40.97.136.200
          40.97.124.40
          40.97.132.40
          40.97.115.56

What is the process to add all of these IP addresses to the DNS A record of autodiscover.companyname.com within my Server 2016 AD domain? All of these IP addresses need to be added, not just one.
0
I've got a normal MS (IIS8) web serve (IIS8 on Windows 2012), to which client browsers connect to request html pages.

One client (or rather its proxy) behaves like this:
1) Outbound connections use a quite small port range
2) Connections in time-wait ,or where the other side is supposed to be in time-wait, are reused for new outbound connections after 60 seconds (the web server uses 120 seconds for this setting, hence the incompatibility)
3) New connections initiated from the client do NOT use a TCP sequence number that is always larger than the last packet sequence number on that particular src/dst pair. Instead a completely random value is used as initial sequence number.

Issue 1) means that the client quite often makes the web server run into a "port re-use" situation, such that a new inbound connection is using a src/dst port combination that has already been used before (the server port is always 80, of course)
Nothing bad with this, though.

Issue 2) means that the the port re-use according to 1) sometimes occurs while the web server is still in time-wait state for that particular src/dst port pair.
This is a problem, as the web server will then not accept the request for some more time (until the server time-wait timeout period finishes), and the client will end up retransmitting its SYN connection attempt during that time, delaying connection.
However, that would not be so bad if it wasn't for issue 3)

Issue 3) means that when 2) happens, the web …
0
What are the least expensive internet domain registration services?

I have a couple domain names I am interested in registering internet domain names and am looking for the least expensive way of doing this.
0
I need help or some guidance for the following issue.

We use a VPN connection when we connect remotely. For software installations, we use an internal web server which we have no problems connecting to when we are at work. However, I am unable to connect from home.

One of the first things I did was to traceroute the host using the LAN connection at work:
  1     1 ms     1 ms     1 ms  chlz-fw01.net.**.** [10.39.41.1]
  2     1 ms    <1 ms    <1 ms  10.39.44.1
  3    20 ms    26 ms    20 ms  10.0.0.1
  4    21 ms    20 ms    20 ms  195.143.73.33
  5    21 ms    31 ms    20 ms  xe-10-3-1-5779.******.interoute.net [194.150.37.65]
  6    21 ms    21 ms    21 ms  10.96.31.111
  7    21 ms    25 ms    21 ms  10.96.20.17

Open in new window


When I connect from home with a VPN, I receive the following reply:

Tracing route to itappstore.**.** [10.96.20.17]
over a maximum of 30 hops:

  1     *        *        *     Request timed out.
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out. 

Open in new window


.. and it stops after 20 hops / with the same response

Next, I used the following command:

> nslookup itappstore.**.**
Server:  itappstore.**.**
Address:  10.96.20.17

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to itappstore.**.**timed-out

Open in new window


So it looks like the problem might be the DNS server.

Because the IP and DNS addresses are assigned automatically,
the adapter setting won't show the addresses.

I also tried an arp command and I get the following reply
> netsh
Server:  GBLDC1-GC01.**.**
Address:  10.96.16.6

*** GBLDC1-GC01.**.** can't find netsh: Non-existent domain

Open in new window


Is this a DNS issue?
0
I am facing internet sharing problem in my broadband connection.I gave connection to 4 users . and each user in connect with own router . I am facing with one user cable . When i connect his cable to my broadband modem port then all users including me getting IP of this user router and no one is able to use internet . When i do unplug cable from port then Internet is working fine .

What type of problem is this ?
0
One of my client computers is giving us difficulty when trying to RDP into it.  I can ping the machine & get a response, where I'm confused is the IP that's returned doesn't match the host name.  I ran ping -a to check this, which returned a host name that was joined to a domain that has been decommissioned for well over 4 years.  Ran nslookup of IP it returned the same odd host name joined to the current domain.  Then I ran nslookup using the odd host name it then returned the odd host name, joined to old domain.
0
We have a Class C network and are running out of IP addresses.  We have multiple switches throughout our company and don't want to incur the expense of upgrading all of them to be VLAN capable.  In order to expand our addresses, is it possible to only upgrade one of our switches to a VLAN capable switch and configure it as follows:
1.) The DHCP server is plugged into one of its ports which is configured to be on the default VLAN.  
2.) Any other switch plugged into it will be plugged into a port configured to be on the default VLAN.  
3.) Any other device (printer, computer, etc.) plugged directly into it will be plugged into a port that is configured to be on a secondary VLAN.
4.)  The DHCP server is configured to hand out a different scope of addresses for devices on the secondary VLAN.
5.) The switch is configured so the VLAN's can communicate with each other.

Again, if all we need to do is expand out addresses, is it necessary that any of the other switches are VLAN capable?  Does anyone have a alternate, perhaps simpler way of expanding the addresses?  We could convert to a Class A or B network.  Please advise, and thanks in advance.
0
in order to configure tcp/ip you must install and enable a network adapter card server 2012 (Dell Server R430)
0
I am looking into using Verizon's Cellular network to gather telemetry data from remote locations. Their data is of course not free.  

I did some simple testing using a Ethernet radio link I already have and saw that to send or receive 4 bytes of actual Data i care about, takes over 170 bytes of traffic to complete the transfer. I will usually only need to gather 200 bytes of data per poll (several times per minute) and I imagine the overhead (166 bytes) will be roughly the same size whatever payload I am sending. But as I currently envision it, that's going to wind up being a third of my data fee. And that doesn't account for whatever overhead Verizon has to add just to send it through their network.

What, if any, tricks can i use to minimize the traffic?
0

TCP/IP

11K

Solutions

17K

Contributors

Transmission Control Protocol/Internet Protocol (TCP/IP) is the set of networking protocols that define end-to-end connectivity specifying how data should be packeted, addressed, transmitted, routed and received at the destination. This functionality is organized into four abstraction layers which are used to sort all related protocols according to the scope of networking involved.