We help IT Professionals succeed at work.






Transmission Control Protocol/Internet Protocol (TCP/IP) is the set of networking protocols that define end-to-end connectivity specifying how data should be packeted, addressed, transmitted, routed and received at the destination. This functionality is organized into four abstraction layers which are used to sort all related protocols according to the scope of networking involved.

Hi everyone

The company I am working for installs its images/OS via a network in UEFI.

How does the computer know on which server the image is stored?
Does the computer send out special packages via TCP/IP to retrieve the location of the images?
What protocol does it use?

I would also be grateful for a link to a site which explains the procedure.



 It is a small office with a windows 2012 R2 standard that is configured as a Domain Controller, DHCP, DNS and file and print server.

The DHCP scope is to
All workstations and other devices including DVR and VPN clients get their IP from DHCP dynamically or there is a reservation for them such as DVR, therefore I can see all devices under Address Leases in DHCP Console.

An annoying device seems to have dynamic IP and it is in a range of the DHCP scope ( , however the DHCP does not show it under Address Leases.
The Arp command indicates that the IP is dynamic. The Advance IP Scanner under find it but cell under NetBIOS group, User and Date are blank The only cell is the Manufacturer and MAC address. I looked around and I don’t see any device that be manufactured by NetGear and the more confusing is that when at the server I run Arp command it indicates that the IP type is Dynamic. so I must assume there is another DHCP server in the network such as router/firewall but I use SonicWall and the DHCP services is disabled.

Can anyone help please ?
what are the things to check before IP change on windows server?
How to find what all application has IP hard coded? any tools to find what all application are dependent on old IP?
Change of reverse lookup ip on pointer record and host A record and static IP on server and anything else need to be change after changing static IP on server
Hi.  We are recovering from Irma and I have noted a strange issue on a few networks where their internet went down.  The specific account I am concerned with is configured as following:
Netgear Router bridged to Comcast Modem - Router
2011 SBS Server - DNS, DHCP & AD - file sharing   IP

I have configured the workstations to use the following configurations:
LAN IP (each PC has it's own)


After setting this up on each PC, I still cannot connect to, nor ping the server or the other devices on the network.
They should be on a domain network, and they are definitely NOT home or Public at the least.

As this has happened on different networks, and the common link is they are Comcast and this has happened since we lost internet (it is popping in and out intermittently).  I just need to get the workstations to talk to the server.

Any ideas or insights?
Google Photo's "Backup & Sync" tool is making my internet connection unusable when I'm uploading photos from my desktop.  I have another desktop & laptop, all on the same WiFi.

I do see I can limit upload and download speed.


If the desktop is the only device requesting bandwidth, I presume that would get all of the bandwidth.

However, when I start using my laptop, shouldn't it share the connection and play nice?

My Comcast is normally 30 Mbps down and 5 Mbps up when I'm not uploading.

When uploading without specifying a limit, it can drop to under 1 download and 1 upload.

I just specified a limit of 400 KB/sec and download limit to 1800 KB/sec to see if that helps.

Please explain the usage of the Multicast ip addresses below

I have seen different Multicast IP addresses used , the most common are shown below. Correct me if I am wrong : I believe this is used by the IGMP querier to  find out if there is any receiver interested in Multicast. : Probably this address is used by the IGMP querier for Auto-RP discovery (it is a little bit vague) : probably this address is used by the IGMP querier when it is configured to use PIM protocol (I am not sure if it is specific to PIM version 2 or any version) : is used by IGMP host (the Receiver) when it leaves the multicast group this is used by IGMP Version 3 receiver, But I am not sure if it is used when the receiver leaves the Multicast Group or it uses it in different circumstances . (please clarify)

Thank you

We use an RDP session through a VPN tunnel to connect to our hosted software out of state.

We constantly experience latency through all of our VPN tunnels.  I can run a constant ping from our hosted provider back to our environment to get a small picture how bad the response times of the pings are.

The ping times will be consistent for a little while hovering at 55ms - 67ms and then we will see "request timed out" multiple times and then ping times will rise.  It seems like the ping times fluctuate a lot  (I assume they would as the signal is traveling through multiple possible connections).

When ping times are at 55ms or less everything seems fine.  However, when it goes up from their end users report latency.

We are not hard lined to our ISP as everything is wireless.  Our internet pipe should be sufficient at all locations as we have spoken with our ISP and we do not hit the high water mark on our bandwidth - only rare spikes the main site.  

We are not hitting the high water mark on bandwidth usage at any of our other sites.  Is there a good piece of Enterprise level software that one could use to help get a clearer picture of where the issue occurs?

What kind of architectural questions should we be presenting to our ISP?   To our hosted provider?

1.  Is your VPN Server over-utilized?
I need to register a couple internet domain names.

What are the lowest priced internet domain name registrars?
Please help me understand about ARP.
I know the local ARP table is cached and records also can be manually added. But how come when I ping a remote IP it doesn't automatically create a corresponding ARP table record?
Hello ,

I have 2 questions about timestamp ;

1. I have try to convert time stamp value to normal time but it was returned anormal dates :) what is the format of this TS val ?
2. As far as i read on the http://www.networksorcery.com/enp/protocol/tcp/option008.htm 

This field is only valid if the ACK bit is set in the TCP header.

but nearly all SYN packets in normal traffic not a DDOS has TSval  while ack was not sScreen-Shot-2017-08-27-at-18.05.41.pnget
Hello ,

Any body know a wiki that show all legal and illegal combination of tcp-flags for ipv4 ?

Thank you for the help
Understanding IPv6  address range

I have done some reading online about IPv6. I want to know if IPv6 global unicast address is the equivalent of IPv4 Public address.

- what is the range dedicated just for Global unicast addresses ?
in the examples I have seen about IPv6 Global address usually starts with 2000,2001.2002. are there more than that ?

-Is there any Global Multicast Address ? if so , then What is the Range
-Is there any Local Multicast address ? if so , then what is the range?

Thank you
I will be migrating a Google Gmail email domain to Office 365.

I have gone through and completed all the required steps as documented on the Migration Wiz website to do this.

I have created the required TXT record within this company's external DNS provider (asmallorange.com) and have been told by the Office 365 domain wizard that I need to add the records shown in the screenshot to our external DNS provider (asmallorange.com).

Is it possible for me to add these records to our external DNS provider (asmallorange.com) while leaving the existing records for Gmail in place?

I want emails to continue to go to user's email accounts within Gmail. The only thing I want to do now is to finish the domain verification of the domain name that is currently being used by Google/Gmail so I can then use the migrationwiz.com website to migrate the email from the Gmail servers to the Office 365 servers.

Then once this migration has completed I will replace the external DNS Gmail email records with the Office 365 DNS records shown in the screenshot and will create new Outlook profiles for all users so Outlook will connect to the Office 365 servers for email.

What I need to do now is to finish the email domain verification within Office 365 so I can then perform the migration wiz migrations (while we coninue to use Gmail as our email service provider--but I don't want to interrupt any future emails from arriving at the Gmail servers until I officially cut the online DNS …
Hello ,

We are facing with a strange issue  , first of all i need to be sure  , if packet marked with SACK_PERM then does it really need to have TS , WS ?

there is nothing between SACK and MSS values  02 04 05 b4 04 02
0000   a0 36 9f 55 7c aa dc 38 e1 ac 9b 89 08 00 45 00  .6.U|..8......E.
0010   00 3c 7d 23 40 00 2e 06 47 3c 67 f6 c9 98 b9 09  .<}#@...G<g.....
0020   9d c4 81 5b 00 50 39 00 25 a3 00 00 00 00 a0 02  ...[.P9.%.......
0030   72 10 bb 2c 00 00 02 04 05 b4 04 02 08 0a 59 97  r..,..........Y.
0040   58 80 00 00 00 00 01 03 03 07                    X.........

Open in new window

Before Sack_Perm there is additional :      02 04 05 b4   01 01 04 02
0000   a0 36 9f 55 7c aa dc 38 e1 ac 9b 89 08 00 45 00  .6.U|..8......E.
0010   00 30 a6 03 40 00 7e 06 c9 84 bc 47 5a 47 b9 b6  .0..@.~....GZG..
0020   bc fa c4 22 00 35 64 18 ae 7c 16 a5 e2 49 70 02  ...".5d..|...Ip.
0030   20 00 06 04 00 00 02 04 05 b4 01 01 04 02         .............

Open in new window

what is this between MSS & SACK options in the packet ?

Is this a mistake or  am i  checking sth wrong , how should be a packet with missing checksum ?

0000   a0 36 9f 55 7c aa dc 38 e1 ac 9b 89 08 00 45 00  .6.U|..8......E.
0010   00 25 8b cb 00 00 fd 11 d7 aa 89 3c 5a 64 b9 b6  .%.........<Zd..
0020   bc fa fc 5d 69 87 00 11 00 00 ff ff ff ff 55 38  ...]i.........U8
0030   55 76 03 00 00 00 00 00 00 00 00 00              Uv..........

Open in new window

What are the exact steps to lookup which company hosts a company's external DNS records?

I will be migrating a company from a corporate Gmail account to Office 365. Currently no one knows which company is being used to host this company's external DNS records. I will need to change these external DNS records to point to the Office 365 servers to successfully complete the migration from Gmail to Office 365.

I'm already familiar with using websites like MXtoolbox.com but where within MXtoolbox.com or other websites can I determine exactly which external DNS provider hosts a company's external DNS records including the MX records?
My issue is two fold, why can I PING an IP of a device that isn't on the network and I can't print.

I have a Datamax label printer that I just created a device description for and assigned it a new IP address, this printer is plugged into a switch, the switch is plugged into a firewall that goes through to another firewall before it gets to the IBM i.  We have two partitions, PROD and TEST.  I copied the device description and out queue from TEST to PROD to ensure they were identical on both sides.  

This printer works perfectly in TEST.  When plugged into the network I am able to print to it, I can PING its IP, TELNET to it and the trace route returns the three expected entries.  When I vary off the device and unplug it from the network I cannot PING it from the IBM i nor the network, I cannot TELNET to it and the trace route only returns the two expected entries.  All as it should be.  

However, in PROD I am unable to print to the device.  When I release a spool file it goes right to RDY status and the writer gets error CPD337F Error CPD337F.  I have verified that the port and IP are correct, I have verified that the remote device is not busy, I have verified that the printer is on line.  I can PING its IP from both the IBM i and the network but I cannot TELNET to it and the trace route returns only two of the three expected entries.  When I vary off the device and unplug it from the network I can still PING it from the IBM i but not from the network, I …
Hello -

I presently have a CIsco ASA 5505 (running ASA version 8.2(1) ) sitting behind my Comcast Business gateway. I have a static public IP through Comcast. The Comcast gateway is in pass-through mode (i.e. its LAN DHCP, WiFi, and MoCa are turned off).

I have configured my Cisco with the necessary VLANs and interfaces such that I have an inside network of 10.0.10.xxx and a DMZ of 192.168.10.xxx.

I am fairly certain that I have the correct NAT and ACL settings done.

From the ASA, I can successfully ping my Comcast static IP and the Comcast gateway address - but nothing else. And, of course, any client devices connected to either the ASA's inside interfaces or DMZ cannot access the Internet.

FWIW, I have also checked with Comcast to make sure there are no compatibility issues with their device and Cisco ASAs (because I'm only getting an orange LED on the Comcast gateway's Ethernet port - no green link light). The ASA is set to auto duplex and speed.

If I configure a laptop with the static IP and plug it directly into the Comcast gateway, it works fine.

I have attached a text file with my ASA configuration.

Can anyone suggest a possible fix?

Thanks much.
I have a classroom of PC's that I need to connect an IP printer to and I'd like to do it quickly.
I'm conducting a training session so I have no admin rights.  But I can CONTROL PANEL=>Add a printer=>Create a new port=>STandard TCPIP port, etc. etc.
How can I make this process quicker so that I don't have to spend so much time at each pc?
I'm thinking some sort of batch file?
What is the process to determine which company hosts an organization's external DNS MX records?
I have disabled the Windows Firewall of my Windows 2012 R2 server, When I telnet to localhost 445, it is ok, but when I tenet to the actual IP 445, it fails.

Anyone have idea of why?

I need the tcp/445 for remote log pulling from a SIEM connector.

Here is a simple example of CIDR IP blocks

I would like to change them into

So from 4 IP blocks to change them into 1 IP block.

I know how to manually aggregate CIDR blocks, but I have over 5.000 IP blocks.

I’m looking for a tool that will automatically combine adjacent IP blocks into larger IP block.
I have a multi host cluster using a Distributed Switch on esx. I have 50 ports and 29 available. Currently there are at least 6 vm's running server 2012 with static LAN addresses and have WAN connectivity.  I just created 6 more vm's and assigned static addreses but cannot get WAN. I have verified subnet/gateway etc. I am able to ping the domain controllers and gateway when there is a static assignment. When set with a DHCP address, the servers have WAN. I have tried to remove the virtual NIC, reset tcp/ip stack. I cannot figure why i get no connection on a static address but do on DHCP. I have even tried to enter the DHCP settings manually, exactly the same. Any ideas?
I am connected Biometric Attendance Machine to my system using the Ethernet cable. I assigned IP of the biometric machine and computer system.
When I am doing ping biometric machine I am getting error " Destination Host Unreachable "

I set upIP  of the machine is:
Subnet Mask:

Where as sytem IP
Subnet Mask :
Default Gateway :

I tried by USB connection too but getting failed to connect in ZKTECO BIOMETRIC Software.

Recently had a perculiar issue with clients on one of our customers networks that stopped being able to lookup names on the internal network, losing network drives, gpo etc as a result.

DHCP is served by windows server 2008 DC with DNS service also hosted on this with the relevant pointers to this set up in DHCP.

We ended up having to statically set the DC name in the HOSTS file until I looked at this onsite this morning, I noticed a nslookup was resolving the router as the dns service instead of the DC. Powering off the router and running the same nslookup and it resolved to the DC. DNS and DHCP were both disabled on the router.

I made a change to the Interface in DNS as it was set to 'Listen On All IP addresses' I changed this to 'Listen on specific IP' which was the IP of the DC(Itself). Flushed the cache on the clients, restarted them they got the gpo, drive mappings, and I could resolve the server by name.

However, a nslookup still resulted in the router name rather than the DC name, despite obviously being able to resolve hosts on the network.

I then disabled ipv6 on one of the clients nics and hey presto a nslookup resolved to the IP of the DC, if I re-enable ipv6 on the nic it reverts back to resolving the router.

My thoughts are that the client isn't able to resolve the DC by ipv6 so it is reverting to the server for some reason, perhaps because of forwarders/root hints set up in DNS.

They are up and running again but I have noticed …






Transmission Control Protocol/Internet Protocol (TCP/IP) is the set of networking protocols that define end-to-end connectivity specifying how data should be packeted, addressed, transmitted, routed and received at the destination. This functionality is organized into four abstraction layers which are used to sort all related protocols according to the scope of networking involved.