We help IT Professionals succeed at work.






Transmission Control Protocol/Internet Protocol (TCP/IP) is the set of networking protocols that define end-to-end connectivity specifying how data should be packeted, addressed, transmitted, routed and received at the destination. This functionality is organized into four abstraction layers which are used to sort all related protocols according to the scope of networking involved.

I have a device that has an ip address like 192.168.1.xxx that is suddenly conflicting with the same ip address in my environment.  The prevents me from connecting to this device.  When I take the device off site I am able to connect just fine.  When I do an ipconfig on my pc it says that there is a wireless lan adapter that has this ip address.  How can I identify the specific adapter and change it's ip address?

Any help would be much appreciated!
We are going to be moving a server to a new Location and the IP address on the server needs to change.

What would be the steps to take on the server when you have to change it to another IP address.

I found these steps online. Can you let me know it this is accurate?

[b]To perform this procedure, you must be a member of the Domain Admins group in the domain of the domain controller whose IP address you are changing.

To change the static IP address of a domain controller
Log on locally (also known as interactively) to the system console of the domain controller whose IP address you want to change. If you are not able to log on to the domain controller by using the domain, you may have to start the domain controller in Directory Services Restore Mode (DSRM). For more information, see Restart the domain controller in Directory Services Restore Mode locally (https://lazyadminblog.wordpress.com/2015/04/11/restart-the-domain-controller-in-directory-services-restore-mode-locally/).
On the desktop, right-click My Network Places, and then click Properties.

In theNetwork Connections dialog box, right-click Local Area Connection, and then click Properties.
In theLocal Area Connection Properties dialog box, double-click Internet Protocol (TCP/IP).
In theInternet Protocol (TCP/IP) Properties dialog box, in the IP address box, type the new address.
In theSubnet mask box, type the subnet mask.
In theDefault gateway box, type the default gateway.
In thePreferred
When you are running iSCSI, is TCP sliding window an important consideration? The situation is is Cisco UCS fabric interconnect to a Nexus 5k switch. The switch frequently drops packets inbound from the UCS and this appears to be an issue iSCSI frames from UCS being 1514 bytes which the interface on the Nexus is 1500 and jumbo framing is not enabled. I don't know why the vast majority of frames make it on through yet a significant number (in the millions) are dropped.
The port channel spikes up to about 10Gbps and most of that will be iSCSI. So the connection initiator to target works for the most part. I've planned to enable the jumbo frames as recommended by Cisco so that the 1514 iSCSI will be better processed and not dropped.

But my question is this: With iSCSI, are TCP conversations lengthy or very brief? To what degree would some dropped frames (.003%) in-path cause an issue for iSCSI TCP conversation? Or would this percentage just be noise that TCP connection orientedness should just deal with?
Is pipe.exe something to remove and if so, how do I remove it?  Was watching TCP connections in Resource Monitor and saw that. It has an IP of  Anyone know what that is?
What is stateful and stateless connection? I got to know TCP is stateful connection while HTTP is stateless. Though HTTP is L7 and TCP is L4 protocol and HTTP in turn uses TCP protocol. So how it is going to work? a stateless protocol over stateful protocol.

so if we need to configure a failover mechanism then which protocol is better? stateful or stateless? I really would like to read more about it on how it works. Thanks!
I added a network printer on my pc as tcp/ip printer .. the next day the port name changed to the name of the printer and in the IP address field also I found the printer name . I tried to ping the printer by its name and I failed then I deleted the port and added a new tcp/ip port and it worked again . my question is why the port configuration got changed I mean the IP address in the port configuration got changed to the printer name . is it from WSD (the discovery port) on the printer properties?

note: the printer is also installed on a domain server and listed in the directory and shared from it. but in my pc  I added it as network not as shared printer.


I started with this:

but when i completed this i had no internet connection.

ive done the basics, eg disable/enable and reboot. help!
On internal intranet the C/C++ client sends out REST-like queries via TCP/IP and receives an XML response from the Java server. If the REST query loops fetching 3 records at a time, the total time to accumulate 90000 records is about 10x longer than if we fetch 100 records at a time. We will be performing a number of timing tests to isolate the cause. In anticipation that the problem may be the slow TCP/IP start due to initial small windowing, what settings are there to tell TCP/IP to start off with the largest (or larger) window size possible?

We are on 64-bit RHEL servers, and I assume that since the client/server are run on an intranet self-contained within the company, that we do not have to be concerned about congestion.

Hi! i am currently using classA network and run out of ip. how can i extend to get more ip.
Hi, if i have subnet mask  is that mean i have ip address from to Say if i use class b is that mean i can use ip from to
I'm using C++,  WxWdigets and Ubuntu and sometimes my application needs to send TCP packets to a TCP server.
The packets are in this format:
std::array<uint8_t, 8> command1;

Open in new window

I'm using a non-blocking TCP client method from boost asio and it works pretty well.
The problem is that I need to change the content of command1 since I need to send 32 different values depending on users actions.

At the moment, I connect to the server by using start_connection() function which connects to the server and execute the function start_write(int scelta) which sends the command1 over the net.

I would like to call the start_connection() function by passing the value of command1 in order to send it with start_write() function.
Is there any solution to do this?
Or, is there a smarter and faster solution to acquire what I need?

#include <boost/asio/buffer.hpp>
#include <boost/asio/io_context.hpp>
#include <boost/asio/ip/tcp.hpp>
#include <boost/asio/read_until.hpp>
#include <boost/asio/steady_timer.hpp>
#include <boost/asio/write.hpp>
#include <boost/bind.hpp>
#include <iostream>
#include <string>

using boost::asio::steady_timer;
using boost::asio::ip::tcp;

std::array<uint8_t, 8> command1;

class client
  client(boost::asio::io_context& io_context)
    : stopped_(false),

  void start(tcp::resolver::results_type

Open in new window

I'm using Ubuntu and I have a C++ application which uses WxWidgets and sends a string over TCP several times. It works pretty fine only if the router and the connection are OK, otherwise it gets stuck and I need to manually quit the application.
I would like to send the data without blocking the application flow in case of errors.

I call the function in this way:

 SendCommand ptr;
    if ( ptr.sendcommand(16,16,1) ){
    printf("Porta Aperta\n");
    } else {
    printf("Errore di comunicazione - porta non aperta\n");

Open in new window

and this is the function:

int SendCommand::sendcommand(int relay_on, int relay_off, int stop){
    printf("eseguo la funzione nella classe\n");

    std::array<uint8_t, 8> command1;
    std::array<uint8_t, 8> command2;


    case 16: command1 = {0x58, 0x01, 0x12, 0x00, 0x00, 0x00, 0x10, 0x7B}; // switch on the relay 16



    case 16: command2 = {0x58, 0x01, 0x11, 0x00, 0x00, 0x00, 0x10, 0x7A}; // switch off the relay 16


    int sockfd, n;
    struct sockaddr_in servaddr;

    std::string serveraddr = "";

    sockfd = socket(AF_INET, SOCK_STREAM, 0);

    if ( sockfd < 0 )
        cerr << "Error creating socket! " << strerror(errno) << endl;
        return -1;


    bzero(&servaddr, sizeof(servaddr));
    servaddr.sin_family = AF_INET;
    servaddr.sin_addr.s_addr = inet_addr(serveraddr.c_str());

Open in new window

FileZilla-Server-Connection-Issues-.docxFileZilla Server SFTP connection issue from outside network. I need help resolving issues with sftp connection to filezilla server from outside network. Please see attachment for details for my current Router, FileZilla Server, and FileZilla Client configurations.

I just enabled DNS-Over-HTTPS in my google chrome and wanted to know how to set it in the iPhone/iPad.   Haven't been able to do ti; how can I enable DoH in my iPhone/iPad?
I have (2) Watchguard M270's configured in a firecluster.

Interface 0 is the External interface configured with a /28 block.
Interface 1 is the LAN

We have consumed all of our IP's so I ordered another /28 block from our datacenter today. As soon as I configure Interface 2 for our new IP block, outbound traffic for the most part ceases to work on our network, however some things do work.. so we'll call it intermittent. As an example, I can ping out to but can't ping As soon as I disable Interface 2 that is configured for the new IP block, I am able to ping again.

I'm assuming this is because we now have 2 WAN interfaces configured and outbound traffic doesn't know which interface it should be sending traffic out on but I couldn't be sure. I've made 4 calls to Watchguard support and nobody can identify the problem. I even had our datacenter issue us a different IP block just to rule out any kind of odd conflict but the problem persists with a new IP block.

Am I going about this all wrong trying to have 2 IP block's configured on our Watchguard? Is the better solution to just order a bigger block of IP's and re-IP everything? I was trying to avoid that hassle by just adding an additional block of IP addresses but it seems that what I'm trying to do here isn't working..

I would appreciate any advice or input that someone could give on this. Thank you!!

My site has not stopped planting for a while.
I was advised to check my logs and I see that there is this IP 150.918 times in my logs from 00:00:07am to 12:36:01am

what do you advise me to do?

I added this Deny from to my .htaccess but ip continues to show...

Thank you for your advice,
I have an electronics board which has 16 relays and it works over TCP/IP.
The IP address of the board is and the port is 3000.
I would like to control it with C/C++ under Ubuntu.

There is a list of HEX commands that it is possible to use in order to remotely switch ON and OFF each relay on the board.
This is the list:
"580112000000016C",  // switch on the relay 1

"580111000000016B",  // switch off the relay 1
"580112000000026D", // switch on the relay 2
"580111000000026C", // switch off the relay 2
"580112000000036E", // so on..

I'm correctly able to switch on and off each relay by sending command line commands under Ubuntu:

echo '580112000000016C' | xxd -r -p | nc 3000

Open in new window

The above code correctly turns on the relay.

I would like to do the same with C/C++ code since I want to control the …
I have 2 PCs that are both connected to the same WiFi network.  Both PCs are on the same work network, both have the same workgroup name and I have toggled network sharing off and on - on both of the devices.

Neither can ping the other.  However, where it gets strange here... If I run simultaneous cmd pings of each other, #1 PC starts successfully pinging the other, but stops if I stop the ping attempts from the other PC to it.  #2 PC pings never resolve.

Both devices are Dell Optiplex 3030AIO and on Windows 7 Pro, Service Pack 1

All the Servers are in Data Center (Colo).
I want to go remotely to all the Controllers (including IDRAG) which are in Colo.

Question: What command would I use to get the above IP addresses?

I'm having issues finding IP address design plans to implement in a newly deployed network.  Running BGP at the Edge and OSPF as an IGP.  Any assistance is greatly appreciated.
I have two NICs, one is cabled directly into a server, and the other goes through a Sonicwall and out to the internet where it sends and receives files from a central portal.

The NIC to the server is working fine.

The NIC to the internet is saying "Limited" and I cannot get full connectivity for that NIC, can anyone please advise on how to troubleshoot a NIC that is giving this error
My network is not allowing me to see all the network devices using windows 10, I see some of the devices.  My MAC however see all the Network devices.  I have a server WIN 2012 server and it see some of the devices in the network.  We are using a Workgroup environment connect to Office 365.  Some machines are connected to the Work and School and some are not.
My main problem is a NAS server that is on the same subnet but I cannot get it to be discovered when I use the IP address of the NAS server?  I have 2 NAS servers and both are very difficult to connect to?   I took over this network and the previous Admin used a lot of VLAN configurations, can he controlled the network using th vlan on the switches?

I looking at the router, I looking at the switches....I not sure where exactly to start and try to identify the lag in the network and why I cannot see the other devices?
Can someone help me determine how to find out where the IP address of lives on my network. It appears to be a webpage. I'd like to turn it off with the abillity to turn it back on, then see if anyone complains that they are missing something

Message meets Alert condition
Virus/Worm detected: HTML/Framer.INF!tr Protocol: "HTTP" Email Address From:  Email Address To:
VIRUS REFERENCE URL: http://www.fortinet.com/ve?vn=HTML%2FFramer.INF%21tr
date=2019-08-02 time=09:04:13 devname=FG-Corporate devid=FG100D3G14808552 logid="0211008192" type="utm" subtype="virus" eventtype="infected" level="warning" vd="root" eventtime=1564751053 msg="File is infected." action="blocked" service="HTTP" sessionid=106413455 srcip= dstip= srcport=49975 dstport=80 srcintf="lan" srcintfrole="undefined" dstintf="wan1" dstintfrole="undefined" policyid=92 proto=6 direction="incoming" quarskip="File-was-not-quarantined." virus="HTML/Framer.INF!tr" dtype="Virus" ref="http://www.fortinet.com/ve?vn=HTML%2FFramer.INF%21tr" virusid=8054799 url="http://ww1.useyourinterface.com/" profile="default" agent="Mozilla/5.0" analyticscksum="0a449968f2e6c0c358cecf9365b94041399735926a25573e1e37fbdb4e741f05" analyticssubmit="false" crscore=50 crlevel="critical"
We have multiple sites all on different subnets, we have one central DHCP server which I want to change (so I can do maintenance).

I want to add a second DHCP server (for redundancy) but I can only broadcast one helper address from the site routers.  I have read up on virtual IP's but am unsure if this is the correct way to go.

We have multiple DC's in different geographical locations
Routers are part of our MPLS so I cannot make changes (I can have the helper add changed)
All servers are in the hosted data center (VM's)

All help/advice gratefully received.
Usage of Update-Source Loopback X

I have seen in BGP configuration where they configure : Neighbor x.x.x.x remote-as x  Update-Source Loopback X
Even if there is only one path to reach the neighbor
for instance in the topology below, let's take R5 with R1 as example:

R5: Neighbor remote-as 1 update source loopback 0

instead of Neighbor 51.0.01 remote-as 1

assuming R5 s1/0= and R1 s1/2 =

Thank you







Transmission Control Protocol/Internet Protocol (TCP/IP) is the set of networking protocols that define end-to-end connectivity specifying how data should be packeted, addressed, transmitted, routed and received at the destination. This functionality is organized into four abstraction layers which are used to sort all related protocols according to the scope of networking involved.

Top Experts In