Troubleshooting is a problem-solving process of evaluating faults that occur in a mechanical or electronic system. Steps often include recreating the problem and then trying alternative and creative solutions in order to fix the situation. Troubleshooting is deployed when software or hardware are rendering abnormal responses or remain unresponsive.

Share tech news, updates, or what's on your mind.

Sign up to Post

I am running VMware ESXi 6.5u1 hosted by OVH.

This morning i receioved an email indicating my server had stopped responding and a hard reboot was completed. Non of my websites had come online so I logged into the ESXi console. I noted that the hosts had not restarted.

I restarted the hosts and also enabled Autostart. Both of the guests restarted and were responding. However a couple of minutes later the ESXi server and guests again stopped responding.

I have again restarted the server and now it does not  boot to ESXi console at all. It does not respond to pings and apparently is not working.

I presume that it is the guests starting that is causing the server to stop responding.

I can boot the server into the OVH recovery image and access the server using telnet. However the recovery web console is not available.

Can someone assist in troubleshooting this. The first thing that I think should be done is to disable the autostart on the guests. Can this be done through editing a file from recovery?



So I am trying to troubleshoot replication issues in this domain with two domain controllers DC1(PDC), DC2(BDC). About a year ago the PDC stopped working and they were having issues with users logging, changing passwords and stuff so they promoted DC2(BDC). Upon inspecting today I found that the replication issues were caused due to netlogon service not running and every time a manual replication was tired "The target principal name is incorrect" as an error was thrown.

So after some troubleshooting the netlogon service is running now without any issues but now I am get the following error when I try manual replication.

The following error occurred during the attempt to syncronize naming context CN=Configuration,DC=Domain,DC=Local from Domain Controller AD to Domain Controller AD2; The directory service cannot replicate with this server because the time since the last replication with this server has exceeded the tombstone lifetime. This operation will not continue.

Open in new window

Also when I run the "netdom query fsmo" command both server claim to be owner of all roles except for DC2 not claiming Domain Naming Master Role.

netdom query fsmo on DC2
Schema master     
Domain naming master
RID pool manager  
Infrastructure master
The command completed successfully.

Open in new window

netdom query fsmo on DC1
Schema master     
Domain naming master
RID pool manager  
Infrastructure master
The command completed successfully.

Open in new window

Can you please tell me what's the best solution here for me?

Thanks so much!
Outlook not updating address book. If I try download the offline address book in Outlook, it gets stuck on connecting to Microsoft Exchange.

2 x Domain Controllers - Replicating to each other
1 x Exchange Server 2013 Standard CU21

Troubleshooting steps performed so far.

1.) Checked OAB Virtual Directories, both internal and external directories are pointing to the correct URL's but the OAB database hasn't updated for a few months now
2.) Run Get-OfflineAddressBook, shows the OAB as "DGE-Default <Ex2012>" and that it is a Version 4
3.) When I run the checks on the Arbitration mailbox, the Arbitration / System Mailbox cant be found.
4.) If I check in Active Directory all the System Mailboxes are missing.

I then moved on to troubleshooting the Arbitration mailbox and see if i could re-add them using the Exchange  setup.exe /PrepareAD as per a Microsoft Technet article.
This passes the prerequisites but fails when looking for the Default Email Address Policy

The operation couldn't be performed because object 'Default Policy' couldn't be found on 'serverXXXX.local'

Attached a copy of the Exchange Setup logs.

When running Get-EmailAddressPolicy I can see the 3 policies that are set up on the server but not the Default Policy.
If I run Get-EmailAddressPolicy -IncludeMailboxSettingOnlyPolicy then I can see the Default Policy as it has no email address properties attached to it.

I can't seem to find a way to add email address …
I have a Windows Server 2012 that freezes and eventually just goes to black screen.  What tools are there for me to fix this server?
Where can I start to troubleshooting this server?
Since installing multiple windows updates on an SBS 20008 server  the default company web is unavailable as users are presented with the page HTTP 404 page not found, i have gone through various troubleshooting steps including IIS reset but still unable to resolve.

Any ideas?
Hi EE,

I am trying to install a windows update on my Server KB919355 x64, I am getting error message update is not applicable to this computer. I have checked via PowerShell the KB hasn't been applied how do I fix this?

Download link

I also tried to install this via windows update but the server is in a locked down area of the network and network admin sick until Monday at least.

Any help is appreciated.

Thank you.
Exchange 2010 SP3(single server)
Couple days ago Exchange stoped sending mails.
If I restart server everything is fine.
Troubleshooting the issue I found that my colleague updated server and installed NET framework 4.7.2.
I presume net framework is problem
What is the best way to uninstall net framework 4.7.2?
Exchange 2010 stops sending and receiving messages after 8-9 hours. Suddenly, like 5 days ago, problem occured first time. I do not know where to start troubleshooting. After restart everything is OK for another 8-9 hours. Antivirus (ESET) uninstalled, but problem remains. Exchange 2010 with latest updates (updates were installed after problem appeared). OS W2008 with latest updates (automatic).

No error in event log seems to be clear and indicating any problem. Please advice where and how to start?

many thanks

I have one user (out of 60) whose Sprint phone randomly but often keeps getting the message pop-up: "The SIM card has locked. Please power cycle the device and if the problem persists contact customer service." This was a new Samsung S9. After useless troubleshooting with Sprint tech, we returned the phone for a replacement. After a few days the issue appeared on the new phone as well.
Any suggestions would be appreciated. This is not happening to nay of our other users.


I have a server running Windows Server 2008 SP2 32bit

I was attempting to perform Windows Updates today which were immediately failing.. In an troubleshooting effort, I attempted to restart the trustedinstaller.exe service, which immediately rebooted the server and it has been stuck in an "Failure configuring Windows Updates, Reverting Changes, Do not turn off your computer" state which just reboots the server and continues in a loop..

I have done some research on this and performed the common fix for this, from what I've seen: Boot from startup disk, enter the command line and rename the C:\Windows\SoftwareDistribution folder to SoftwareDistributionOLD and rename C:\Windows\winsxs\pending.xml to pending-xml.OLD

However, this solution that appears to work for most people doesn't work for me.. I'm at a loss as to what to do. There are no system resource points, startup repair doesn't work.. Please help.
Peplink Balance One router/ap unit reporting latency issues with wired/hard wired network devices.  need to perform direct to the cable modem first but I like to have access and documentation later for if and when I have to troubleshoot this unit.   The site seems to be lacking a manual nor is as easy as reaching the gateway IP to access the GUI.

Anyone familiar with access to this unit?  Does anyone spot the manual?  I sent a troubleshooting ticket a month ago to Peplink and they have yet to respond.  They don't even have one phone number on their site anywhere.

Any can advice how to troubleshooting the .vmdk vdisk missing and corrupted? see attached error screenshot.

Use VMware Converter, to create a V2V, or right click and use CLONE to CLONE the VM are failed. Restored from backup also failed


PDC [Windows Server 2012]
RDS [Windows Server 2008 R2]
Forest Function Level [2003]

Terminal Server Continually Losing Trust Relationship.
I am currently troubleshooting an environment where, on a daily basis, a terminal server is losing its trust with the domain.

The users are able to logon if the machine is removed and re-added to the domain, or if the PC account is reset.
However, this is not a solution in the long run, as we cannot manually reset the RDS server within AD daily.
All DNS settings appear to be correct.
Forwarders are properly added.
Both machines are looking to the PDC for DNS.
All networks are configured as domain.

RSOP confirms that there are no GPOs currently resetting any DNS settings.
There is a GPO that is set to specify the site name.

Included are the DCDIAG and REPADMIN /replsum outputs for analysis.
Any assistance would be great appreciated!



Directory Server Diagnosis

Performing initial setup:
   Trying to find home server...
   Home Server = [PDC]
   * Identified AD Forest.
   Done gathering initial info.

Doing initial required tests

   Testing server: Default-First-Site-Name\[PDC]
      Starting test: Connectivity
         ......................... [PDC] passed test Connectivity

Doing primary tests

   Testing server: Default-First-Site-Name\[PDC]
      Starting test: Advertising
I'm experiencing some issues in out Office 365 Hybrid environment...

Strangely, out of the few thousand users, there is a very small handful of users that people who have mailboxes in O365 get the following NDR when emailing them.

Sender:       (mailbox in O365)
Recipient:   (Mailbox On Premises - rejected your message to the following e-mail addresses: gave this error:
Hop count exceeded - possible mail loop ATTR1 []
A problem occurred during the delivery of this message. Please try to resend the message later.

Diagnostic information for administrators:
Generating server: #554 5.4.14 Hop count exceeded - possible mail loop ATTR1 [] ##rfc822;

Recipient does have an email alias on-prem of but doesnt have a Target Address stamped. So I would think it wouldn't be sending the message back to ExOL etc.

I don't know where to start troubleshooting, this is only happening when cloud users try emailing …
I have been having an issue with Azure AD Connect and have run out of troubleshooting ideas and hoping someone can help. I have a support ticket open with our Office 365 re-seller but so far they have been unwilling to open a ticket with Microsoft.

The issue is that our password hash synchronization stops working after a few days. The event viewer logs an event 611, Password hash synchronization failed for domain: (our domain name). Details:
Microsoft.Online.PasswordSynchronization.SynchronizationManagerException: Unable to open connection to domain: (our domain name). Error: Unable to retrieve source domain information. ---> Microsoft.Online.PasswordSynchronization.DirectoryReplicationServices.DrsException: Unable to retrieve source domain information. ---> System.DirectoryServices.DirectoryServicesCOMException: There is no such object on the server.

I originally uninstalled and reinstalled Azure AD Connect and that fixed the problem for a few days. Then the same error re-occurred. I originally thought that it might have been a networking issue with our Hyper-V cluster because disabling IP-Sec offloading on the VM and rebooting the VM caused the password synchronization to start working. However, I think that was just a coincidence because the password hash failed again a day later and doing the same thing had no effect the second time around. Either way, the support agent I have been working with wanted me to install the Azure AD Connect on a physical computer, …
Vmware ESXI host, 5.5.0, 1623387( is not responding suddenly.

Login to ILO and found purple error message and perform a cold restart to one of the ESXI host that issue. See attached screenshot.
Servers (Guest OS) all move to another ESXI host when auto failover.

How to retrieve ESXI log and read the log for easy troubleshooting?


Power outage created a mess with Exchange and auto discovery issues since. After power outage cycled on a 2012 Sever Standard with two VM's, 1. PDC 2. Exchange. After server came up Exchange doesn't allow auto-discover and Outlook clients don't connect. First problem was noticed when all Outlook clients reported "Trying to connect" to the Exchange server. For troubleshooting purposes I deleted an Outlook profile and get the following trying to create a new profile.
errorerror2Some certs were replaced and we believe the problem may be here, we're looking at certs and will follow up. Another interesting issue is the IP address on the exchange server was hardcoded before the server restart. However after the power outage when the server restarts in DNS and the "Network" tab on the VM show a different IP address, it's dynamic rather than the static. Tried to get things working with the static IP however Exchange will not work at all this way. Changed the static IP address on the Exchange server to DHCP and it works with OWA only. Outlook clients still won't connect. With auto-discovery not working all phones have disconnected, this likely will change after auto-discover is working again.
Not able to run "regsrv32" from a Administrative Command prompt.   The error I'm receiving is "regsrv32 is not recogniozed as an internal or external command, operable program or batch file".

Please note: Troubleshooting Steps taken so far is
OS: Windows 2012 R2
Permission Level: Enterprise Admin

Visit the Environmental Variable
Select the System Variable>Path>"Made sure that the %Systemroot%\System32;%Systemroot%  is inserted correctly without any syntax errors by exporting to a notepad.

Made sure the Regsrv32 file was listed inside of the System32 directory.

Tried to use other command from the command prompt like net commands which worked fine.
Hi I am using exchange 2010 with outlook 2007/2010/2016

I ran Microsoft exchange troubleshooting Assistant on exchange 2010 and i got Mail submission failed: Error message: The SMTP host was not specified..

All my emails are flowing well in and out. There is just one thing one email was sent by one account to a group email and none of the users in that group have received it.

Any suggestions
CAn someone give me the troubleshooting steps to get a SAN DISC USB Flash drive to work. Here are the steps.

I have MacBook Pro 15-inch, 2016
I have a SanDisc USB Flash memory.
Plug it into a USB - USB-C adapter.

Anyway, when I open Finder it's not recognizing the chip.

So. I tried to close all applications and restarted the computer. Still nothing.

Very frustrating. Anything you recommend I do?
Hello Experts,
I need help troubleshooting an error I am getting in my WPF.Net application with C#.Net code-behind.

The error I get has to do with the OLEDB connection I am using to try to access and read an Excel (.xlsx) spreadsheet from my application (see error below):

The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.

Here is the code I use to try to access and read the Excel spreadsheet from within my application:
        OleDbConnection conProds;
        conProds = new OleDbConnection("Provider=Microsoft.ACE.OLEDB.12.0;Data Source=" + "C:\\Users\\gizmo\\Documents\\RR\\ISDQuoter\\Products.xlsx" + ";"); 

Open in new window

Please let me know how to fix this issue.

Thank you,
new to certificate troubleshooting but getting this error on my AD server

also does this mean this AD server is also a certificate server?

its a Win 2008 R2 Std
In trying to troubleshoot why we are having performance issues on our webserver, we pulled the web log files and I found several instances of cs-method = OPTIONS and our server
returned a sc-status of 405.  

Can someone explain what OPTIONS means and the 405 response?
Hello, how can we tell what is is causing high load average? TOP has some processing using anywhere from 15-30 % CPU but none stays at 100% CPU.
I was updating the Comware for my HP A5120-48G-PoE+ EI switch. Its model number is JG237A. I deleted the old comware version with the command delete /unreserved flash:/....

I accidentally powered down the HP switch and turned it back on. It brought me to the boot menu. I displayed the files in flash and there was no comware boot software file in flash. I tried all the options necessary to get the new flash on the switch.

What else should I do?


Troubleshooting is a problem-solving process of evaluating faults that occur in a mechanical or electronic system. Steps often include recreating the problem and then trying alternative and creative solutions in order to fix the situation. Troubleshooting is deployed when software or hardware are rendering abnormal responses or remain unresponsive.