Troubleshooting

117

Solutions

297

Contributors

Troubleshooting is a problem-solving process of evaluating faults that occur in a mechanical or electronic system. Steps often include recreating the problem and then trying alternative and creative solutions in order to fix the situation. Troubleshooting is deployed when software or hardware are rendering abnormal responses or remain unresponsive.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hi Experts, I would like to get some help with troubleshooting a Site-to-Site VPN connectivity between two ASAs. I need to NAT the internal subnet on both sites to a pubic IP address in order to avoid overlapping subnets. I can establish a VPN tunnel as long as I ping the NAT address (the tunnel does not come up if I ping any host on the internal subnet). The issue I am having is that I am not able to ping any hosts on the subnet from either end after the tunnel is established.


Site A outside IP is 50.50.50.2 (Internet G0/0 is 50.50.50.1)

Site B outside IP is 60.60.60.2 (Internet G0/1 is 60.60.60.1)

Site A and Site B can ping each other outside IP.

Site A inside subnet is 10.16.0.0/24 and is NAT to 50.50.50.3

Site B inside subnet is 10.10.0.0/24 and is NAT to 60.60.60.3

 Simple nework diagram
vpn-pat-overlapping-subnets.jpeg.jpg

 

ASA Site A:

ASA Version 9.7(1)4
!
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address 50.50.50.2 255.255.255.0
!
interface GigabitEthernet0/1
nameif inside
security-level 100
ip address 10.16.0.1 255.255.0.0
!
object network obj-siteA-real
subnet 10.16.0.0 255.255.0.0
object network obj-siteA-map
host 50.50.50.3
object network obj-siteB-real
subnet 10.10.0.0 255.255.0.0
object network obj-siteB-map
host 60.60.60.3
object-group service ogs-srv-icmp
service-object icmp echo
service-object icmp echo-reply
service-object icmp traceroute

access-list acl-outside-in …
0
Ensure you’re charging the right price for your IT
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

As part of an MS Word automation, I am using ADODB to read from a .csv file into an array, then immediately after than a different procedure uses ADODB to read from an Excel file.   See code snippets below.

Everything works great for me, but one of my users is encountering an "Automation Error, the object invoked has disconnected from its clients" error.  The error happens in cases where they do this import twice in a row.  I can't reproduce that error on my machine, so having a hard time troubleshooting.

My tool uses a string variable saved to the Registry to remember the root of a "contentlibraryfolder" from which is accesses different types of files for many functions.  Notice in the code snippets below that the CSV import does not access the contentlibraryfolder (the CSV is on the local machine), however the second snipped where it  reads in an Excel file DOES use the contentlibrary.  I suspect this may be where the error is happening.  Here's why: When the user sets the content library location to point to a  remote server (\\XXXXXX\ContentLibrary), things work fine with no error.  But when the user points to a content library on their local machine (which has an identical copy of the library files and folders), the error occurs the second time.  

Anybody have an idea what might be going on?  Thanks for any pointers!

Sub ImportCMSCSV(ByVal CSVfolder As String, ByVal CSVfile As String)
Dim datafile As String
Dim objConnection As 

Open in new window

0
I have a client that with an intermittent issue, she has 2 screens, which I am thinking is part of the problem... but she has been fine for YEARS & no issue... she actually got a NEW computer too & the issue came back??  

She has a 1"-2" WHITE Space on apps when she opens the MAXIMIZE, doesn't happen all the time, but usually she has to reboot & this fixes it, until it comes back??  When this WHITE space is on you can NOT SEE the top of the app to close or minimize or bring out of maximize... just unavailable...

I have brought down the display options to 135% norm is 100%, alot of my clients like the 125% just so everything is bigger... she wanted it a bit bigger in one of her programs & so we have been playing with that area, 150% too big, 140% is good, but the 2" white came back.

I keep thinking it is the 2nd screen maybe causing it... I really don't know, we have been back and forth alot, but the only thing that helps temporarily is reboot or changing the %... but it always comes back...

Any ideas would be appreciated??  

Thanks guys!
0
We have web servers in our production environment.  Sometimes as part of troubleshooting, a web server may need to have the IIS app pool recycled or a particular Windows service restarted. Currently only ops staff can do this because they have full admin rights and can remote into the server.

Is there a tool that we could use to allow other staff to perform these limited functions, without giving them remote desktop access and full admin rights to the web servers?
0
I have a VMware environment with View Personas that works for most users where it will create two folders, one with their username and the other is the V2 folder. This works for most users, but I have a couple that for some reason it does not create a profile folder. I cannot seem to figure out what is different from their account to make it so it doesn't create a profile folder. Can someone guide me in troubleshooting these accounts?
0
Hi, I've noticed all our access switch interfce LEDs blinking rapidly which suggests there's a broadcast storm going on, the switches are all Cisco and mainly 2960X, there are two stacks formed with 4 switches each and three other standalone access switches together with six storage and server switches.

Any ideas on the best way to analyse and identify the cause (without disconnecting cables as this is a live environment).

Thanks.
0
Slow-Application-Speed.PNGHi
I am currently troubleshooting an issue with a new server  hosting an application service which is using Oracle Weblogic accessible through a "https" url by other devices on the network.

The problem is when devices running the client application which connects to the https url, the speed is so slow it causes time-outs when syncing data. This is more evident when downloading the runtime client application files directly from the server using that link, the download speed is running at 20/kbps per second (and this is a local network device).

I resolved the problem once by dis-connecting the internet for a few seconds and re-connecting it, which fixed the problem for a few days. But the speed seems to getting progressively slower, and restarting the router is no longer having any affect.

I'm not sure how to even begin to diagnose this issue as I'm used to running ping tests to measure latency issues, but in this scenario Pings to the server are within perfect range. Copying files from the SMB shares are at Gigibit speeds, and server resource consumption is marginal. It's just anything to do with the local https link.

Any thoughts?
0
We have several MacOS devices running Mojave that are having trouble staying connected to our AD Domain. These machines are bound and join AD successfully at first. We are able to login with domain credentials, however, after a while, these machines will stop authenticating domain credentials. We have 3 locations that are all macos devices and the other 2 locations do not have this issue, only this one location.

All 3 locations share the same ad domain but each site does have its own domain controller.

Any advice on troubleshooting steps to see why this one location keeps "losing" its authentication to AD?
0
I have a client with a Surface Pro LTE (model 1807), Win 10 Pro, 8 GB RAM, 256 GB SSD.

After he wakes the Surface from sleep, the Type Cover is completely unresponsive. He needs to log in using the onscreen keyboard. The keyboard only becomes active after he logs in.

I've tried the following:

1. Uninstalled and reinstalled Surface Type Cover in Device Manager (checked the box to Delete Software) before rebooting

2. Updated to the latest Windows (1809 when the issue was reported)

3. Applied all available cumulative and firmware updates in Windows Update

4. Tried a different, brand new keyboard

5. Downloaded all available Surface updates directly from Microsoft

After none of the above steps worked, I swapped him over to a new, identical Surface LTE. I imaged his original device via Clonezilla before transferring it to the new one.

He reported that the issue is persisting even on the new one, which suggests to me that the issue lies in something with his system configuration.

Just wondering if anyone could advise of any additional troubleshooting steps to be performed?

Any assistance would be greatly appreciated.
0
Troubleshooting step, advice for Server Freeze or Hang issue, is that compulsory to enabled full dump on new setup operating system as practice?
0
Exploring SQL Server 2016: Fundamentals
LVL 13
Exploring SQL Server 2016: Fundamentals

Learn the fundamentals of Microsoft SQL Server, a relational database management system that stores and retrieves data when requested by other software applications.

We have an issue after standing up a hybrid solution. Only on-prem users can see online users and send messages. Does not matter if they are local to network or coming through Edge server on guest network. Online users can only see other online users, cannot send or reply to on-prem users. Both sides are open federation. Federation partner test passes. All users are synced with AADC with Skype attributes enabled. All local, tenant configuration settings, DNS entries doubled checked by multiple people. Edge server running in DMZ with dual NICs with F5 acting as reverse proxy. Wondering if someone could point us to where we need to go next for testing, troubleshooting to get this resolved.
Thanks!!
0
We've been having problems with an SBS 2011 server recently.  People weren't getting the logon script to get the mapped drives, and if they tried to get to shares, they were prompted to login again (it's a domain).  Then they get the shares

After some troubleshooting, it was because NetLogon wasn't started.  We can manually start netlogon (which is set to automatic) and everything is fine... till a reboot and netlogon doesn't start.

Looking around for info on that issue, it talks of making sure it's set as a dependancy to Lanman server and lanman workstation.  and to make sure those are set to automatic.

Uh, I don't see those listed in services at all!

And running dcdiag for the netlogon issue, also pointed ot windows time service not started / the server not advertising as a valid time server.

Any thoughts on, most pressing - getting netlogon to start (and should lanman server and lanman workstation be in the list of services in computer management?

and maybe something to get me started with windows time?

I saw a batch script to help resolve that:

net stop w32time
 w32tm /unregister
 w32tm /register
 net start w32time

but now, after a reboot, I manually start netlogon successfully.  Then look and windows time is not in the server list.  

if I run w32tm /register, I get  windows time in the services list.  I change login from local account to local system account.  Then start it manually, I get error 1709 account specified for the service is …
0
I am troubleshooting an issue with email flow in Exchange 2013.  I have enabled PipelineTracing and all parameters
Set-TransportService Mailbox01 -PipelineTracingSenderAddress chris@contoso.com
Set-TransportService Mailbox01 -PipelineTracingPath "F:\Anti-Spam_Agents_Log"
Set-TransportService Mailbox01 -PipelineTracingEnabled $true 
Get-TransportService Mailbox01 | Format-List PipelineTracing*

Open in new window

With the last command it reports all is configured correctly but... when I send an email from the mailbox nothing is written to the output folder.  I can't see any details of required folder permissions (set it to everyone FC as a test but no change) for Exchange to write to the chosen output folder,

Any suggestions

Late edit - I also stopped and restarted ther Transport and MBX Transport Delivery services just in case
0
We have a Cisco 2921 ISR connected to a 500Mbps ISP line for Internet.  Also, it is running a DMVPN to the main office.  Both Outside and Inside interfaces are connected Full Duplex, 1Gbps.


People are complaining, at times, of slowness.  When I check the router it doesn't appear to be overloaded.  There are, however, a lot of input errors.

A person at that site mentioned that the router we are using only has a 50Mbps throughput.

I am not sure where he got that information, but when I do a speed test it I get a around 350Mbps download and 100Mbps Upload.

Any ideas on troubleshooting?
0
Issue in Brief: Unable to add node back to the cluster.

Details of the issue: We noticed that one of the nodes in the two node cluster(node & disk majority) is 'down' in FCM.  However, we're able to ping it from another node and also RDP into it.

Troubleshooting Performed:
-Tried to evict and re-add the problematic node to the cluster, but unsuccessful in doing so - both via. PowerShell and via. GUI.
-Also rebooted the node, and performed the above operation.  Still no luck.
  Error: Unable to successfully cleanup.
-Applied "Clear-ClusterNode" and it was successful.
-Then, tried to re-add the node but received the same error, but through GUI & PowerShell.
-Rebooted the problematic node; still getting the same error.
-Upon further investigation, we noticed that  the "CLUSDB" was missing in the registry of the problematic node.
-Copied the database to the problematic node (from the other node), and tried to load it in the registry, without success.
-Then copied the "CLUSDB.blf" file to the location, renamed it to "CLUSDB" and tried to add the node again.  Still getting the same error.

-Looked into AD, and found the appropriate CNO for the cluster, and VCOs of its corresponding nodes.

-Noticed below error in the cluster logs as part of our investigation.

"New join with n2: stage: 'Authenticate Initial Connection' status HrError(0x80090301) reason: '[SV] Authentication failed'"

-Did a "portquery" on the other node, from the problematic node and it …
0
I have a customer on a Synology 916+ with Cloud station Sync.  Laptop isn't getting ALL of the files.  So, customer gets frustrated when he goes on the road to find that the files he posts on the server aren't showing up on the laptop.  The agent doesn't continue syncing and believes that it's finished syncronizing.  I've seen complaints on the Synology forum with no specific answers.

Anyone have experience with this problem?
0
Error Publishing Template Set in HotDocs Server V11.0.1 from HotDocs Developer V11.2.4
Error message HotdocsError.jpgPublishing Errors.txt
(1) Error in '180830 Business Incentives and Tax Savings Review Services.docx': failed to copy a file to the publishing folder.

Any expertise in troubleshooting issues like this with HotDocs is appreciated.
0
I  need help with Dell MD3200 controller troubleshooting. Unit has two controllers and COntroller 0 went down. I checked the status of the controller via serial port but I cannot figure out what errors mean so I need someone with thorough MD3200 experience and VMware...

Attached is text capture from serial port when starting up Controller 0...
MD3200-Serial-Port-Dump.txt
0
We have been trying to deal with this password prompt for quite a while now and for a period of time we were pointing the blame to a few add-ins. However, during today's troubleshooting I ran a little connection status test to see what it was trying to connect to during the time of the prompt. Well I found a little connection that stood out where it was trying to connect in cache mode. I decided to turn cached exchange mode off and ever since then I have not gotten a password prompt. After restarting outlook about 50 or so times I decided it was enough and tried to re-enable the cached exchange mode, and as I expected, the password prompts started coming back.

So what could be causing cached exchange mode in outlook H&B 2016 to to prompt for these windows credentials? I saw one spiceworks article where a guy was basically saying that cached mode might be connecting the public FQDN instead of the private network name and it prompts because it sees the server as being outside of the logged in domain? Just looking for a possible resolution so that we can still keep exchange mode enabled for the benefits it provides.
0
Announcing the Winners!
LVL 13
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

I have firewall that blocks some IP's from accessing the Internet that works fine. When an user comes in from the VPN they are able to access any devices except the devices that are being blocked from Internet access. I would like help troubleshooting or creating a policy that will keep the network devices from access the internet but when an user logs into the vpn they are able to access the devices.
0
My organization has been having an issue for a few months now where a user will try to unlock their Windows 10 computer but no field populates to enter their password.  Sometimes the username will appear, other times nothing will appear.  On the lock screen you can see the date and time, but once you hit enter, it goes blank (you can still see the lock screen wallpaper).  A simple restart will fix this, however at the rate this is happening that is only a work around, and if the user has an unsaved document that presents a problem.  The troubleshooting steps I’ve tried based on my own research have been to disable Fast Start under Power settings and to make a registry edit which disables the lock screen.  Disabling Fast Start had no effect and disabling the lock screen seems to at best lessened the frequency of the issue occurring to once every two or three weeks.
0
Hello,

I am troubleshooting some Exchange Server 2013 problems related to ActiveSync, and I need to be able to use the test-ActiveSyncConnectivity cmdlet.  I've followed the steps as outlined in the Microsoft Doc here.  However, I receive an error message during the initial New-TestCasConnectivityUser.ps1 script execution (looks like setting attributes to the test mailbox), and I'm unable to execute the test-ActiveSyncConnectivity cmdlet after the script completes.

[PS] C:\Windows\system32>cd \temp
[PS] C:\temp>& $env:ExchangeInstallPath\Scripts\New-TestCasConnectivityUser.ps1
Please enter a temporary secure password for creating test users. For security purposes, the password will be changed r
egularly and automatically by the system.
Enter password: ***********
Update test user permissions on: EXCHANGE13.[REDACTED].local
Click CTRL+Break to quit or click Enter to continue.:
UserPrincipalName: extest_ba8013b96ceb4@[REDACTED].local
A parameter cannot be found that matches parameter name 'MaxSendSize'.
    + CategoryInfo          : InvalidArgument: (:) [Set-Mailbox], ParameterBindingException
    + FullyQualifiedErrorId : NamedParameterNotFound,Set-Mailbox
    + PSComputerName        : exchange13.[REDACTED].local

A parameter cannot be found that matches parameter name 'RemotePowerShellEnabled'.
    + CategoryInfo          : InvalidArgument: 

Open in new window

0
Windows update not working on server 2012 r2 standard.

Tried the general Microsoft Site for the Update Readiness Tool

http://support.microsoft.com/kb/947821 

Tried the following Microsoft Site for general update failure.

http://support.microsoft.com/kb/2509997 

Finally looked through the Windows Update Troubleshooting site. The manual approach requires registry settings so take great care.

http://support.microsoft.com/kb/971058 


windwsupdate.log
2018-11-27      11:15:01:377      1976      224      AU      #########
2018-11-27      11:15:01:377      1976      224      IdleTmr      WU operation (CSearchCall::Init ID 6) started; operation # 4478; does not use network; is at background priority
2018-11-27      11:15:01:377      1976      224      Agent      *** START ***  Queueing Finding updates [CallerId = AutomaticUpdates  Id = 6]
2018-11-27      11:15:01:377      1976      224      AU      <<## SUBMITTED ## AU: Search for updates  [CallId = {BC718562-0D95-4F90-91B2-D3BD75D2FEE2} ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}]
2018-11-27      11:15:01:377      1976      224      Agent      SkipSelfUpdateCheck search flag set for serverId: 117CAB2D-82B1-4B5A-A08C-4D62DBEE7782
2018-11-27      11:15:01:377      1976      224      IdleTmr      WU operation (CSearchCall::Init ID 7) started; operation # 4480; does not use network; is at background priority
2018-11-27      11:15:01:377      1976      224      Agent      *** START ***  Queueing Finding updates [CallerId = AutomaticUpdates  Id = 7]
2018-11-27      11:15:01:377      1976      224      AU      <<## SUBMITTED ## AU: Search for updates  [CallId = …
0
I created a test exchange server 2016 (internal only) but Autodiscover is not working.
I tried troubleshooting but was unsuccessful.
please advice.
0
I have an NEC DT700 series phone. I think specifically it is a DT730.

Right now the message light is blinking, but the voice mailbox is empty.  It also has "MSG >>>" on the screen.

There is "Frontdesk" as the identifier, but I cannot clear that off.
0

Troubleshooting

117

Solutions

297

Contributors

Troubleshooting is a problem-solving process of evaluating faults that occur in a mechanical or electronic system. Steps often include recreating the problem and then trying alternative and creative solutions in order to fix the situation. Troubleshooting is deployed when software or hardware are rendering abnormal responses or remain unresponsive.