We help IT Professionals succeed at work.

Unix OS

33K

Solutions

18K

Contributors

Unix is a multitasking, multi-user computer operating system originally developed in 1969 at Bell Labs. Today, it is a modern OS with many commercial flavors and licensees, including FreeBSD, Hewlett-Packard’s UX, IBM AIX and Apple Mac OS-X. Apart from its command-line interface, most UNIX variations support the standardized X Window System for GUIs, with the exception of the Mac OS, which uses a proprietary system.

Which AWS FREE Tier is most advisable (for WordPress)?

I will not choose either of the Windows Server options due to exposure to viruses.

There are 4 LINUX options:

Amazon Linux
Red Hat
SUSE Linux
Ubuntu

(Is Ubuntu an instance of LINUX?)

But I m a .NET developer and may be interested in the following option:
NET Core 2.1 with Amazon Linux 2 - Version 1.0 - ami-0bed74d89326c46bc
.NET Core 2.1 and the PowerShell 6.0 pre-installed to run your .NET Core applications on Amazon Linux 2 with Long Term Support (LTS).

Which platform is safest against hacking and viruses?

Thanks
0
Dear Gurus,
I have been given root access to a Red Hat linux server 7.5
Now I need to do the below

Onboard a user : george with a home directory /home/george
I used:
adduser -m george

Open in new window

. It works

Onboard an application Account (System User): java_user
I used:
 adduser -r java_user

Open in new window

It works

Define  a Home directory to the java_user:  /home/java_datahub
I used:
usermod -d /home/java_datahub java_user

Open in new window


The above command doesn't do anything. The directories are already existing.

Give sudo access to george  so that he can login to the application account once on the server using the below command
sudo su - java_user

Open in new window

I am not sure how to do this.

Kindly suggest

Thanks
0
i have a sftp server on docker. In compose file i open a port 2121:2121 and 2222:22 as you can see here
 sftp_server                                      "/usr/local/bin/entr…"   40 hours ago         Up 2 hours              0.0.0.0:2121->2121/tcp, 0.0.0.0:2222->22/tcp
it's working fine when i ask    sftp -P 2121 "user_name@"host_name"
in my domain.
i create an haproxy in other server (is internet connection)  i add following in my /etc/haproxy.cfg
listen  sftp-server
            bind   *:2121
            mod     tcp
            option  tcplog
             default_backend          sftp-server01
backend       sftp-server01
 server ftp01         "docker_container_with_sftp_name"."domain":2222 check port 2222
and i restart haproxy

in my domain i can ssh to sftp with port 2121 (ssh "user_name"@"host_name" -p 2222)
without any problem.
but nor working with haproxy even in my domain. what is wrong ?
0
Hi ,
I have below script which i want to improve to include one more exec run if first one finish good.

spool ICMTR.lst
SET SERVEROUTPUT ON SIZE 1000000;
SET FEEDBACK OFF;
SET LINESIZE 200;
WHENEVER SQLERROR EXIT 1;
var out number;
EXECUTE  test.run_batch_all(1,:out);
spool off

Now i want to add one more only if EXECUTE  test.run_batch_all(1,:out);
finish good then
execute test.pp.all(1,0)
0
Problem with lpsched & printing from Solaris 10.

LP printing has been working but stopped working today.  Running lpstat -t gives the following errors:

lpstat -t
scheduler is running
no system default destination
system for CUPS-Print-Anywhere-Staff: adfe-183-db130.mohawkcollege.ca (as lpd://adfe-183-db130.mohawkcollege.ca/printers/CUPS-Print-Anywhere-Staff)
system for Print-Anywhere-Staff: adfe-183-db130.mohawkcollege.ca (as lpd://adfe-183-db130.mohawkcollege.ca/printers/Print-Anywhere-Staff)
CUPS-Print-Anywhere-Staff accepting requests since May 21, 2019 10:59:02 PM EDT
Print-Anywhere-Staff accepting requests since May 21, 2019 10:59:02 PM EDT
Failed to get printer info for CUPS-Print-Anywhere-Staff: not-found
Failed to get printer info for Print-Anywhere-Staff: not-found
Failed to get job list: bad-argument
Failed to get job list: bad-argument

Printing had been working including from CUPS and from the native O/S lp/lpsched.  There should be a list of approx. 80 network printers listed along with the printers configured in CUPS.  LPSCHED is running and CUPS is currently not running (for troubleshooting purposes) as shown in the output below.

svcs -a |grep print
disabled       Oct_27   svc:/application/print/ppd-cache-update:default
disabled       Oct_27   svc:/application/print/ipp-listener:default
disabled       13:31:38 svc:/application/print/rfc1179:default
online         15:37:12 svc:/application/cde-printinfo:default
online         16:22:57 …
0
Hi Experts,

What would be the regular expression to denote

XXXXAYYDDD999999

Where XXXX is the bank code. For eg. SBI's bank code is SBIN. All alphabets
A is the system identifier. The possible values are A-Z
YY is two digit year. 10 for 2010. (Possible Dates 01.04.1991 to 31.12.2025)
DDD is julian date. 032 for Feb 1.
999999 is 6 digit sequence number.

Similary

XXXXA9YYYYMMDD00999999

Where XXXX is the bank code. For eg. SBI's bank code is SBIN. All alphabets
A9 is the system identifier. One is digit and one alphabet. Range from A-Z and 0-9
YYYY is four digit year
MM is month. 04 for April
DD is date. 04 for 4th.
(Possible Dates 01.04.1991 to 31.12.2025)
99999999 is 8 digit sequence number.

I need to use the same to found the UTR number from Sentence given in a Excel Cell.

E.g., Sentence is UTM:XSCXQ52019050400148805//UUQP PQDQ XQP/MTGS TO:SXXXX19124112345:SQDHNQ GHOST

I will be using the same in the following function to extract UTR.

Function FindUTR(strin) As Boolean
    FindUTR = UCase(strin) Like "[A-Z][A-Z][A-Z][A-Z][A-Z] [0-9] (0[1-9]|1[012])[- /.](0[1-9]|[12][0-9]|3[01])[- /.](19|20)[0-9]{2} ########"
End Function

Whether Strin is appropriate here ?

Regards
Kanwaljit
0
we have run a few security scripts over a red hat linux server and one of the issues it has raised is the fact that passwords are available in plain text in an /etc/fstab file. By review of the permissions I can see all users on the server can read this file, so this is not good. I think the /etc/fstab file is being used as there is a link between this server and another for storing documents. I presume amending the ACL on the /etc/fstab file itself from the current presumably default ACL, is not a good idea as it could break things. So what other options are there to prevent users seeing this plain text password in the /etc/fstab file, or what are the best practices in such cases.
0
Can you assist with interpreting the output of getafcl for /etc/passwd and /etc/shadow files on a live server. The output shows as below:

# file: etc/shadow
# owner: root
# group: root
user::---
group::---
other::---

/etc/passwd permissions

# file: etc/passwd
# owner: root
# group: root
user::rw-
group::r--
other::r--

fromwhat I understand security best practice suggests /etc/shadow should only be readable by root (as it contains security sensitive info), and /etc/passwd should only be writable by root as you can upgrade permissions to root if you can edit the file. However, the permissions on /etc/passwd indicate 'user' has rw which indicates read & write permissions. Is this a security flaw or is this the default setting? What does 'user' actually represent, and is it all users on the server, if so this seems like a problem from the offset.
0
Hi all,

 I have to install libfuse for development on rhel 6.

 how to install? I tried with "yum install fuse-devel".  But, I couldn't find /etc/fuse.conf to configure fuse on my local machine.

Thanks,
Bvm
0
When logging in via "dzdo us - [user_name]", the server times out after like 2 minutes! I do heavy work on it sporadically, and it's like 50 times a day I'm logging on, then dzdo, etc.

could I run a small job that would simulate "pwd", so the thing does not time out? And this would run every 30s.

And I'd want to turn it off, if I am going to be doing some "vi" editing, then back on.
0
I need to run a command in Unix to set up aliases. This is for a "su - " account and when logged in, there's no .profile file that I can set up.

I created "aliases.sh" and tried to run it as ./aliases.sh and it "runs" but the aliases are not created.

How can I quickly set up my aliases upon login to the "su - " account?
0
Does access control list testing/reporting in red hat linux follow the same principles as windows, e.g. you can only produce a report (access control list) of who can access a file/directory if the account you are running the tests from has access to it yourself. E.g. if you are not a root level account, can you only check who can access files/directories that you have access to. If you try and get an access control report for a file/folder you don't have access to, will you get some sort of access denied error?

I have been looking at the ls command for my own development. I think this may produce similar to windows CACLS command (but also gives a bit more info such as size etc, what would the correct syntax be to check permissions of a file, is it simply ls path, or is there a bit more to it?

I assume most critical information (e.g. system configuration files) are by default locked down to root access only, so it would take an admin to start amending settings to make a default copy of linux less secure in terms of critical server wide configuration files. Or can other things amend settings above and beyond naive administrator amendments.
0
Is there any way at all to enable Solaris 10 BSM without rebooting Solaris.
Will issuing "pkill -HUP  BSM_process" enable certain config files to be read
without rebooting?
0
Do any of the config files in the \etc\ directory give any clues on the last time certain RHEL accounts were used/logged into. I can query /etc/shadow but I think the numerical value in there is actual days since password last set, not days since last login/last login date. It would also be helpfull, if at all possible, to identify the date an account was created.

Also is there a command that will show the exact version number/build of RHEL.

And using putty.exe and running a command with a >>output.txt result, how can you tell where the putty software defaults to when saving the output of a file, e.g. on commandprompt in windows I can see where its going to write the files too unless I specify a new path, but in putty connected to RHEL I cant actually tell where it is going to write the output to.
0
is there any quick command that can be run via putty once connected to a RHEL server, to determine the privileges granted to that account you are logged in with, e.g. is it a root account, does it have su/sudo privileges etc. I have been given an account to a test server for some security checks, but I am pretty sure a lot of it is not completing as the account has limited privileges. But as it is a fairly new area to me, I could do with a quick command you can run via putty once connected with this account to list what security privileges it actually does have.
0
I am looking into some basic security controls regarding red hat linux (v6.8). I am trying to identify some of the critical files that I can ask the sysadmin to extract for analysis offline, e.g. on a windows machine. The key files I want are:
1-a list of all accounts on the server (status/permissions/password last set)
2-history of security updates applied to the server/last time OS patches were applied.
3-password policy settings the accounts are subject too
4-list of running services/open ports
5-ideally an inventory of all files on the server, path, file size and corresponding file access permissions
6-what audit policies are configured on the server, if any, e.g. logins, file access etc
7-inventory of installed software/versions

can anyone give the basic commands an admin would run to extract these files into a format that could be analysed on a windows machine. Plus any other key areas you would focus on from a basic security controls perspective that I have not covered in my main 7 areas above.
0
Can anyone provide a step by step instruction on how to compile & 'make'
a fully useable ClamAV on Solaris 10 (x86)?

A minor update engine was released for Linux with source code but package
is only available for Linux, no Solaris
0
how to extend root-vg.
I have 100 extra gig on my root-vg how ro add to volumne
0
I want to install gcc-3-runtime on solaris 11. But, always fails.

$pkg install gcc-3-runtime
No updates necessary for this image.
0
I'm exploring if Rapid 7 can be used to track patch status (what patches are applied on which dates
& which ones have been released but yet to be applied) of our Solaris, RHEL 6/7 & Windows servers
as well as configuring it to do weekly scan of CIS hardenings (including for Cisco switches/routers).

Any document/materials on how to configure to check for patch status & CIS hardenings are
much appreciated.
0
in RHEL, I can find out the dependent packages in advance by
   rpm -q --whatrequires package_name  or
   yum dep_list package_name
before actual day of doing "rpm -ivh ./package_name", then
only found out what's the missed dep pkgs & having to start
downloading them on the day of installation.

For Solaris 10 x86  packages, what's the equiv commands/steps
to find out the dependent packages in advance?
0
Have a couple of Solaris x86 running in VMWare/vCenter that after the sysadmin
left, the root password was not handed over.

How do we recover the root password?  I can't recall in Sparc what's the keystroke
to send to the Sparc to get into recovery mode
0
I need to exclude the target location from Veeam backup of AIX. I escalated to Veeam support they gave me this. I am not an AIX admin I need guidance to exclude the Veeam backup target from backing up. Below is the email from Veeam Support.

************** Message from Veeam Support**********************
I'm pretty sure /mnt directory should be excluded from processing. To do this backup script should look like this:

Mode=Overwrite
LogFile=/var/log/veeam/backup.log
 
SNumber=0
SLabel="Configuration"
SComments="Veeam Agent for IBM AIX"
/VEEAMCFG/* /SubDirs
:
SNumber=1
SLabel="Full backup"
SComments="Veeam Agent for IBM AIX"
/* /SubDirs
/cdrom/* /Xclude
/tmp/* /Xclude
/mnt/* /Xclude
/VEEAMCFG/* /Xclude
/var/log/veeam/backup.log /Xclude
/var/log/veeam/backup.err /Xclude
Redirections =
SRC=/
DST=/a/
END
:
SNumber=2
SLabel="Log files"
SComments="Veeam Agent for IBM AIX"
/var/log/veeam/backup.err
/var/log/veeam/backup.log
:
I added the following line to first step:
/mnt/* /Xclude
This will exclude your backup location from processing completely. Let me know if you have any questions regarding this.

************** End of Veeam Support email****************


Anyone can assist me ?

Thanks
MAS
1
My colleague got the attached error last month back when trying
to download Sparc Solaris 10 patchset : what's the reason?

Didn't try to download the patch for Solaris x86.  Does the support
contract we have with Oracle makes any difference if it's Sparc or x86?
Or the patch is simply old & has been superseded with a new one?
cantdwnldSolarisPatch.png
0
Suppose we hv missed Solaris 10, Java, Weblogic 10/11 and eBusiness Suite  patches for the last 1.5 years, will applying the latest current patch cover what's missed so far?

Or we have to apply all the patches tt hv been missed plus the curent Jan 19's?

Kindly note for all the four products
0

Unix OS

33K

Solutions

18K

Contributors

Unix is a multitasking, multi-user computer operating system originally developed in 1969 at Bell Labs. Today, it is a modern OS with many commercial flavors and licensees, including FreeBSD, Hewlett-Packard’s UX, IBM AIX and Apple Mac OS-X. Apart from its command-line interface, most UNIX variations support the standardized X Window System for GUIs, with the exception of the Mac OS, which uses a proprietary system.