Unix OS

32K

Solutions

18K

Contributors

Unix is a multitasking, multi-user computer operating system originally developed in 1969 at Bell Labs. Today, it is a modern OS with many commercial flavors and licensees, including FreeBSD, Hewlett-Packard’s UX, IBM AIX and Apple Mac OS-X. Apart from its command-line interface, most UNIX variations support the standardized X Window System for GUIs, with the exception of the Mac OS, which uses a proprietary system.

Share tech news, updates, or what's on your mind.

Sign up to Post

Interestingly enough I have no problem using let's encrypt on Windows platform and figured it was going to be a breeze on *nix... Running into a slew of issues.  For one I am trying to use certbot to facilitate this.  When I issue the correct commands and webroot I see it builds the .well-known folder but it does not build the acme-challenge folder.  If I try to manually create the acme-challenge folder it deletes it after the sudo certbot certonly --webroot -w /var/www/example -d example.com -d www.example.com command (with my domain info substituted of course) with the following error:

Detail: Invalid response from
   http://<mysite>/.well-known/acme-challenge/bM6ijKNrbr6Dcf3nzJdyhssFHrySeeLk-2VWQgAlWnQ:
   "<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
   <html><head>
   <title>403 Forbidden</title>
   </head><body>
   <h1>Forbidden</h1>
   <p"
Super frustrated as everything in *nix is always easier, right?  Well not this time LOL.   Any suggestions would be appreciated!

-J
0
What does it mean to be "Always On"?
LVL 4
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

My SCO Unix RAID 5 server have 3 HDD. Today 1st and 2nd HDD failed only 3rd HDD showing ONLINE. Is there any chance of data recovery if i install new HDD in 1 and rebuild and then the 2nd HDD and rebuild.
Is there any chance of data recovery.
0
Hi,

I am fed up with putty with basic options.

Any better tools or IDEs to check logs or to grep unix/linux boxes.

Where  i can download secure ftp and how much is fees?
any advanced putty IDE there
any good free IDE accepted by industry.

please advise
0
We have some alarms lights  in the front of the server panel.  How could i get a diagnostic list of all the current failures in the server.  Please provide detail steps.
0
what the heck is delta rpm and why use it , cant I just update or upgrade with yum update or something like that ?

thanks
0
Hi expert

How to upload SSL to openLdap server?
0
I have xlc compiler version 8 and perl 5.10 running on AIX 7.1. I have been able to install DBI.pm module successfully, but now am in need to install DBD::ORACLE module. The oracle version is 12 (64bit)

perl Makefile.PL runs fine for the DBD::ORACLE module, however the "make" command is throwing below error:
I attempted to fix the issue by changing the object mode value, but that end up giving a different type of error.
Can you advise on the solution ?

#make
        rm -f blib/arch/auto/DBD/Oracle/Oracle.so
        LD_RUN_PATH="/u01/app/oracle/product/12.1.0/client_1/lib:/u01/app/oracle/product/12.1.0/client_1/rdbms/lib" ld  -bhalt:4 -G -bI:/usr/opt/perl5/lib/5.10.1
            /aix-thread-multi/CORE/perl.exp -bE:Oracle.exp -bnoentry -lpthreads -lc -lm -L/usr/local/lib Oracle.o  dbdimp.o  oci8.o /lib/crt0_64.o -bI:/usr/lib/iocp.
            exp  -o blib/arch/auto/DBD/Oracle/Oracle.so     -L/u01/app/oracle/product/12.1.0/client_1/lib/ -lclntsh -lclntshcore -lld -lm -ldl -lc -lm -lpthreads -
            lodm
            -lbsd_r -lld -lperfstat -lm -lpthreads
ld: 0711-736 ERROR: Input file /lib/crt0_64.o:
        XCOFF64 object files are not allowed in 32-bit mode.
make: The error code from the last command is 8.

#bootinfo -K
64

#ORACCENV='cc=xlc_r'; export ORACCENV

#export OBJECT_MODE=64
#make
        rm -f blib/arch/auto/DBD/Oracle/Oracle.so
        LD_RUN_PATH="/u01/app/oracle/product/12.1.0/client_1/lib:/u01/app/oracle/product/12.1.0/client_1/rdbms/lib" ld  -bhalt:4 -G …
0
I recently upgraded AIX from 6.1 to 7.1, which resulted in perl getting upgraded from 5.8 to 5.10 as well and in process i no longer have a dbi.pm module under perl 5.10.

I have been unable to find binary version for dbi.pm for perl 5.10 so i am trying to compile it but running into an issue with it.
I am using steps of running perl Makefile.PL, make, make test, make install to compile.
I am able to successfully run perl Makefile.PL from the dbi.pm directory that i saved in /tmp from cpan.org, but when i run the "make" command, i get following error.

Skip blib/lib/DBI/ProfileData.pm (unchanged)
        xlc_r -q32 -c    -D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -qmaxmem=-1 -qnoansialias -DUSE_NATIVE_DLOPEN -DNEED_PTHREAD_INIT -qlanglvl=extended -I/usr/local/include -q32 -D_LARGE_FILES -qlonglong -O    -DVERSION=\"1.636\"  -DXS_VERSION=\"1.636\"  "-I/usr/opt/perl5/lib/5.10.1/aix-thread-multi/CORE"   Perl.c
/bin/sh: xlc_r:  not found
make: The error code from the last command is 127.

I do have xlc compiler installed.
  vac.C                      8.0.0.0  COMMITTED  IBM XL C Compiler
  vac.C                      8.0.0.0  COMMITTED  IBM XL C Compiler
  vacpp.cmp.core             8.0.0.0  COMMITTED  IBM XL C/C++ Compiler
  vacpp.cmp.core             8.0.0.0  COMMITTED  IBM XL C/C++ Compiler
  xlC.aix61.rte             12.1.0.3  COMMITTED  IBM XL C++ Runtime for AIX 6.1

/usr/vacpp/bin/xlC -qversion
IBM XL C/C++ Enterprise Edition V8.0 for AIX
Version: …
0
Hello,

I have installed a module on the puppet master server,  how do I make client to pickup those modules and execute?
0
I have a file with a character that translates into 272 when I do:
od -xc

The character looks like an A with a caret on top with a degree sign to the right. I am attaching an image of the character as well. I have tried sed, perl and tr and none of them are working.

For example:
sed -e 's/'$(echo "272")'/ /g' input_file > output_file

This does not work.

Any suggestions?
Image.jpg
0
On Demand Webinar - Networking for the Cloud Era
LVL 9
On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

I am creating a shell script to check if cron jobs are enabled/disabled and send a mail notification for the same (with job name).

#!/bin/sh

crontab -l > /app/file.txt
App_Home=/app
ctab='$APP_Home/file.txt'

while IFS= read -r value; do
entry=`$value | awk '{print $1}'`
echo $entry
if [[ $entry == "#" ]]
then
  echo " Entry $value is disabled "
elif [[ $entry == '#*' ]]
then
   echo " Entry $value is disabled "
else
   echo " Entry $value is enabled "
fi
done < $ctab

Open in new window


However, the above code is failing with the error message (#*: command not found).
0
in Unix

what is the meaning of below command



zgrep 'RPT|O|GetProducts' xyz.gz meaning
why we need RPT|o|
in the beginning what is the meaining of pipe here?
please advise
0
Imagine the following scenario:

A NAS box, providing a samba share, with several versions of a fíle collection in dated directories (name i.e. "2017.05.24").

On the NAS should be some links into subdirectories of the latest version, so the copy script should create symbolic links on the share to the latest version of that file collection.

When I try
ln -s <samba_share/link_name> <samba_share/dated_dir_subdir/>

Open in new window

I get an error that this is not possible. Any hint ?
0
when it displays "Global Group memberships", it it is long, then it is only partially seen. is there a way you break it down to many single line step output?
0
Hi Experts,

I am using below command to send file as body instead of attachment, I am able to do that but I want to send subject in french also.

cat french_characters.txt | mailx -s "RELEVÉ" -S ttycharset=iso-8859-1 -S sendcharsets=iso-8859-1 -S encoding=8bit email@email.com

This only send file as body in french charaters but not subject.

How do I do that?

Thanks in Advance.
0
Dear All,

I wanted to create a User in AIX system but having only access rights only to specific folder.
As a first step i have created a group FTP and a User i wanted to use in ftp.
Also i have created an ftp access file in /etc in order to give access to user.
When i log in from web browser with the specific user i cannot see the folder user was configured for.
When i change folder to  /  it gives me access to all folders.

Because i tried to find some manuals and tips but in web all information is not concentrated in a manual.
Can someone help me with all steps needed in order to make user work....???

Best Regards.
0
Problem with external aerial and galleonm time server just turned back on. I'm guessing this is telling me its not worked for 9 days?

Should I now force a poll or wait?



Code:
$ntpq -p
     remote           refid      st t when poll reach   delay   offset    disp
==============================================================================
 time-p1      .MSF.            1 -   9d   64    0     0.43    0.027 16000.0
 time-s1      0.0.0.0         16 -    - 1024    0     0.00    0.000 16000.0
*LOCAL(0)        LOCAL(0)         9 l   25   64  377     0.00    0.000   10.01
0
Having a bit of a discussion with a software vendor about this. Can anyone confirm my understanding?

/etc/sudoers file example:-

user1 server1 = NOPASSWD:/usr/bin/ls -l
user1 server1 = NOPASSWD:/usr/bin/file

Open in new window


But then the following command fails (logged in on server 1 as user1) because its not in sudoers file.

sudo java abc.jar

Open in new window


Surely this is correct? You can't sudo a command unless you have appropriate permissions in /etc/sudoers? Am I right?
0
hi,
i have a xml file like below.

<title> <line1>Abc</line1><line2>bce</line2></title>.

i need to pull only line2 value. how can i do in solaris.
i tried sed and awk but no luck..

can help to get simple command or script to pull out such values.

thanks
0
Independent Software Vendors: We Want Your Opinion
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

I'm trying to chroot jail SFTP service on AIX 7.2 system. What I mean is to allow users from 'sftpgrp' group to ONLY SFTP access. Authentication is through SSH KEys (no passwd). Also, no SSH login is allowed for users inside 'sftpgrp' group.

Until now SFTP chrooted is working properly, I mean, users in sftpgrp group access their chrooted HOME DIRECTORY without problem.

But, the problem is  the problem is when theses users try to SSH (using Pub KEy) the same server, I this error:

/dev/pts/5: No such file or directory
open /dev/tty failed - could not set controlling tty: No such device

See part of debuged log from SSHD:

.
.
debug3: aix_restoreauthdb: restoring old registry ''
debug1: audit session open euid 0 user iga3 tty name /dev/pts/5
debug3: mm_request_send entering: type 26
debug3: mm_answer_pty: tty /dev/pts/5 ptyfd 6
debug1: session_pty_req: session 0 alloc /dev/pts/5
debug1: Ignoring unsupported tty mode opcode 42 (0x2a)
debug1: server_input_channel_req: channel 0 request shell reply 1
debug1: session_by_channel: session 0 channel 0
debug1: session_input_channel_req: session 0 req shell
debug1: Forced command (config) 'internal-sftp -l INFO'
debug1: Values: options.num_allow_users: 0
debug1: RLOGIN VALUE  :0

debug3: mm_audit_run_command entering command internal-sftp -l INFO
debug3: mm_request_send entering: type 57
/dev/pts/5: No such file or directory
open /dev/tty failed - could not set controlling tty: No such device
debug3: 

Open in new window

0
Hi,

what are the best practices and features, options while using grep.

i am using these days to search in log files, files, directories, content etc

When should i give single quote '  '
like
zgrep 'xyz' aaa.gz


When should i give double quote " "
like
zgrep "xyz" aaa.gz


how to use tail and head etc along with grep to effectively monitor last or first 100 lines etc
please advise
0
Hi,

I keep getting below error when i wrote hello.sh shell script file and try to open it to.



Swap file ".hello.sh.swp" already exists!
[O]pen Read-Only, (E)dit anyway, (R)ecover, (Q)uit, (A)bort:



why it created .swp file autoatically?
why it asks above question. How to tell unix not to ask that question.
please advise
0
Hi,

https://bash.cyberciti.biz/guide/Hello,_World!_Tutorial

I created hello.sh script using vi hello.sh
then typed below

echo "Hello, World!"
echo "Knowledge is power."

do i need to tyope below line as well at top?

#!/bin/bash
what above line means?

when i try to execute gets errror as

$ ./hello.sh
-bash: ./hello.sh: Permission denied



please advise
0
Hi,

I am trying below program

http://www.programmingunit.com/2013/04/19/shell-script-to-check-leap-year/

how to save and execute above shell script and see output and send output to different files say test123.txt. please advise

i tried using vi editor as sample.sh and pasted content.

did esc to escape from isnert mode then shift zz to comeback to regular screen from vi mode

]$ vi sample.sh

[1]+  Stopped                 vim sample.sh

Not sure what it mean by stopped as above i saw message

when i ran getting error
]$ ./sample.sh
-bash: ./sample.sh: No such file or directory

when i do ls -ltr i do not see sample.sh though
0
Hi,
what are differences between
user defined, environmental. local, global variables

when to use which one. what are advanatages, disadvantages of using each with practical examples.
please advise
0

Unix OS

32K

Solutions

18K

Contributors

Unix is a multitasking, multi-user computer operating system originally developed in 1969 at Bell Labs. Today, it is a modern OS with many commercial flavors and licensees, including FreeBSD, Hewlett-Packard’s UX, IBM AIX and Apple Mac OS-X. Apart from its command-line interface, most UNIX variations support the standardized X Window System for GUIs, with the exception of the Mac OS, which uses a proprietary system.