Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.

Share tech news, updates, or what's on your mind.

Sign up to Post

Dear Experts,

What is the best practice of exporting a virtual machine(Hyper-V) of production environment. After shutdown the machine or During running? I have read blogs people prefer if after shut down.

If we export it to another server on another hyper-V do we need some extra configuration?
0
we have different deliver groups like finance group, marketing group , legal group  and IT group

these groups have machine catalogs , users in each group have  shortcuts applications on their desktop when they log in which are specific to their department.

we have active directory, studio, provisioning server, deliver controller, need to know how application short cuts are created in citrix environment, is it on base image vdisk?
0
Oracle Virtual Machine installed from this website virtual - installed the oracle virtual machine successfully accepted all defaults

downloaded winzip 7

https://www.linuxtrainingacademy.com/vdi/ download linux vertical disk image  Centos version 7

Extracted Centos version 7 successfully, it is 64 bit

unable to open due to the fact that my virtual machine settings do not go beyond 32 bit I have no idea why?
I have rebooted no change please see screen shots
unable-to-see-64-bit-application-fo.docx
1
Hi

I have a Hyper-V VM (Host an VM are Windows 2012 R2) that work fine this morning and after 1 hour after employed begin to work, it began to have many problem, most are network specific. It is a DC. This week-end we had a power outage, so I think first that it come from there. I tried to find the problem but it that something is stuck somewhere. many service seem to initialising but stay there or many doesnt seem to start. But there nothing in event log. I have a remote access program on the vm and it is not start, Sql server don't respond, RDP don't respond and many other service don't respond but all share work fine. Internet access is working.

When I check windows activation it said product id unavailable. I tried to reinsert the key but it seem to work without stopping. The key come from an open licence account and it is use on the host and it work fine on it. When I check the maintenance manager it said maintenance running. I tried DISM.exe /Online /Cleanup-image /Scanhealth but it did nothing after 2 hours.

I have in server manager I have problem with managability, it said, online - data retrieval failures occured. I have an other problem reported by server manager for the automatic refresh: Configuration refresh failed with the following error: Call was cancelled by the message filter.

When I shut down the server it stuck on Stopping service  :

I tried restore a 1 month old vm backup and start from there but it does the same thing. That's very weird. …
0
Customer has one physical box with Server 2016 running Active Directory and all services needed for that, and File/Print/ redirected folders, etc. They now have need for an RDS server. Is it possible to add the Hyper-V role to that server, create 2 new Virtual Windows Server 2016 Machines - one for RDS and the other to migrate everything that the current server is doing at the moment? It would be like an in place migration project. Their network has less than 20 users and the physical server is quite nice. In the end they would have a Hyper-V host, with 2 VMs, one Server running AD, File Print , DNS DHCP and another running RDS. Does that sound doable?
1
I have a win 2008 R2 certificate server that I need to replace. I want to replace it with a win 2016 server virtual server. How to I go about doing that? What to do about the certificates already issued? The Certificate server is also a DC
0
I asked a question some time ago that was about a Server testbed I set up.
It's still up and running and useful.
But I perhaps went about setting the static IP addresses on the Server VMs in an overly complicated and dysfunctional way.
So, I'd like to try once more to make it more "conventional".
The network diagram is attached.

The VM setup was the original concern.  But I also notice something in the Hyper-V machine interface.  So, I'll start with that:
There is a physical interface getting 192.168.13.103 via DHCP AND a virtual interface with static IP 192.168.13.4.  Is that normal or is that odd?  I wouldn't think that having two IP addresses used up would be normal.  BOTH interfaces have the same MAC address.

Now, on to the VMs:
There's a dual-NIC PCI card.
The physical NICs have no configuration.
The virtual NICs are configured with static addresses and have been manually assigned the MAC addresses from the physical NICs they relate to (presumably that's the overkill?)
If this is wrong, then how might I change it so things will continue to work?  I don't think that removing the MAC addresses from the VMs did the trick the first time I tried it.
Testbed-Configuration-2019_06_28.pdf
1
I set up a Windows Server testbed and asked a question here:
https://www.experts-exchange.com/questions/29143184/Hyper-V-VMs-physically-on-separate-subnets-howto.html
In the midst of the discussion, I tried to set a static IP address for each of the two VMs that I had implemented.
I used a method where I used Advanced Features of the VMs network adapter and assigned a MAC address.
Cliff Galiher took exception to what I did and I took that advice seriously.

Later, I tried to set things back to what I thought had been suggested but doing this broke the testbed.
So, the testbed remains with what I did....

I should point out that in the original testbed, each Server VM was on a different subnet and had a separate physical NIC.

Now I'm setting up another testbed with the real Servers and similar Hyper-V VMs.
I need to make sure that the VM Servers have static IP addresses - as before.
I don't want to overthink this or to overdo it.  
So, what is the recommended approach?
In this case, the 2 VMs in the Hyper-V platform will be in the same subnet and I envision one physical NIC for the pair.
So, in that sense, it's just a little simpler than the original testbed.
1
I just wanted to see if I could get some best practices for virtualizing a file server in respect to semi-large data volumes. Note that this is a small setup, there is no SAN or Shared Storage in play here, just a large direct attached storage RAID 10 array on ESXi 6.7

Aside from the actual virtual machine and the boot/OS volume, I was planning on simply adding an additional 2TB disk to the VM that would house all the shares. Is there anything else I should be thinking about concerning this (other than probably thick provisioning it for the best volume performance)?

Simple question I know, but just wanted to get some opinions.
0
we have desktop servers- hosted shared

like we have finance group shared desktop, marketing group, IT group

i see different citrix policies under each group in active directory

like xendesktop server profile management policy
citrix mapped drives and application short cut policy

but where should i check what application short cuts are being applied and where when try to edit the policy

is it i have to check store front?

is there any documentation which shows how to apply applications like work excel or any othera pplications to users in that particular group for ex. finance group

I need to give access of adobe acrobat only ?
0
I am looking at nested virtualization in our vSphere 6.0 lab.  I want to look at ESXi 6.7.  

When I create a new VM and select other, I only see VMware ESXi 6.5.  

Is there any issues with selecting this option and then loading ESXi 6.7?
0
We recently virtualized our environment. We P2V most of our servers except the DCs. One of those DCs is running NPS using Radius for our wireless environment which EE helped me to set up and has worked great for the last couple of years. I want to spin up another VM running Windows 2016 and configure it the same way. I set up the physical server as a certificate server and it uses LDAP for wireless authentication with a GPO for the corporate side wireless access and a pre-shared key for Guest. I want to use an SSL Cert instead of using certificate services. Looking for how to set this up on a win 2016 server and how I can transition off the current win 2008 NPS/Radius server
0
Need to make a VM out of a CentOS 6 asterisk box with 3 500GB SATA drives in RAID 5.  This gives me a 1TB drive that has 42GB used.
After some googling, it looked easy to use "dd conv=sparse" but that produced a 1TB disk image.  I loaded the dive on /dev/loop0 and tired to use gparted to shrink it, but gparted said it need gpart to see inside and gparted was nowhere to be found.  (The disk image in on a Centos7 machines.)

I have used TestDisk on the image with a few different parameters but it always comes up with results that don't match fdisk -l on the original machine.  (I have attached the output.)

I was going to try Clonezilla next, but I thought I would ask some expert advise before wasting more time.

So, what is the best way to get a 1TB RAID 5 image with multiple partitions into a VirtualBox VM with only the 42G of data? (I would make a 60GB virtual drive anyway.) fisk-output.txt
0
I replaced a Server 2012 HyperV box with a new Server 2016 HyperV box - got all the VMs over and working using replication - had to use certificates which was very involved to generate due to issues with names of 2 servers in the certificates.
Now wish to have the new ServerV2016 box replicating all its VMs to a similar new Server2016 box so if Im correct if a VM stops working on the main it will switch to the second.

They are in a workgroup and not on the VMs domains.

Im trying to use kerberos in port 80 rather than doing certificates all over again - is this possible in a workgroup as when I try - it sees the replica box but upon finish I get error no credentials are available in the security package.
0
Have a HyperV 2016 Host running 5 Server 2012 VMs - recently installed. I thought Id take some checkpoints - all worked apart from one which states  Cannot take checkpoints because one or more pass through disks are attached.
Which I see means that VM is attached to a physical disk . I can see articles on how to convert physical disk to VHDX but how can I find where this physical disk is ? All the VMs are located on seperate physical drives as VHDX ? I cant see how this one is any different ?
0
I created a VM guest by virtualizing my company laptop.  I then copied this to my personal laptop and I'm running it in VMWare Workstation 15.1.  I used the virtualizer free from VMWare and pointed to by their product.  I deployed it on the company laptop, ran it, copied the results to my personal laptop via thumb drive and then opened it with VMWare.

Both my host and guest are Windows 10.

I can't copy and paste files between the guest and host and I'm guessing it's because VMWare Tools isn't installed (at least I think that's the issue).  When I to install them the option is grayed out and I can't.

Is there something special/different about an image that comes from a clone?  Neither had a DVD so neither can be fixed with the trick I've seen posted about playing with the CD/DVD options.
0
Vcenter esxi version 6.7.0.20000 Build 10244845

VMware ESXi 6.5.0 build-7388607

Is it safe to enable deduplication & compression on an already live in production 2 node VSAN?
0
Hello,
We have one VMware VM that is getting the following error message:
{Delayed Write Failed} Windows was unable to save all the data for the file . The data has been lost. This error may be caused by a failure of your computer hardware or network connection

Is there something we need to look at or can this error be ignored because it is possibly a generic error?
From what we can tell, there doesn't seem to be any real issues with accessing data from the server.
The server is running 2012 R2
Thanks
1
Hi,
I have VMWare vCenter Server Virtual Appliance 6.0 U3. I want to upgrade it on VMWare vCenter Server Virtual Appliance 6.5 U2.
Different versions of ESXi hosts (starting from version 5.0 and ending 6.0) are connected to the current vCenter server 6.0 U3. Will the current versions of ESXi hosts be compatible with the new version of the vCenter server (6.5 U2)?
0
A little background information:

I am in the process of upgrading our BackUp Exec server and backups. We were on version 2012. We are upgrading to BackUp Exec 16. I built a new Windows Server, OS 2012r2 and installed the Backup Exec 16 software without an issues. I have a few physical servers that aren't VM host. I configure them. All are backing up without issue.

As for the VM Host and virtual machines, I'm wanting to use the new features so I can use file/folder-level Granular Recovery Technology (GRT). I'm just not sure how ro back up the VM's so I can do this and use Simple Disaster Recovery too. In other wordsCaptureVM.JPG, I want to be able to recover the whole VM and/or a file from that VM. What is the correct way to do this?

As so, when I configure the backup, when do I need to capture the Host Components? I have included a screenshot of what I'm trying to do. Just not sure if I need to have 2 backups, one for SDR and one for GRT.

Any advice or instruction on this matter would be greatly appreciated.

Regards,

ABBEadmin
0
Hello,
I have XenApp 6.5 under windows server 2008.
XenApp 6.5 - initializing Citrix data store failed if TLS1.0 is disabled,
In fact, When I disabled the TLS1.0 on the server and after we are running Citrix AppCenter We obtained an error message (attached error.png) :
Errors occurred when using ServerDB1 in the discovery process.

Please can you advise me what is the solution ?

Best regards,
0
We have vcenter 6.5 in our main office and would like to add a remote office's ESXi host to the main office's vCenter.
I can add the ESXi host, but it shows as disconnected. I am unable to manage any vm on that remote site.
The remote ESXi host is version 6.0 and i created a separate datacenter folder.
I would appreciate your input on this.
0
Hi Guys,

I increased the storage on a VMWare ESXi 5.x server by adding another disk to the server.

I managed to expand the storage of the Datastore.

I am now trying to increase the disk provisioning space for the virtual machine, but I seem to be having some challenges.
I powered off the virtual machine, but the Disk Provisioning section stays grayed out.
0
We've got a VM running on Hyper-V, for some reason Installed memory (RAM):  15.6 GB  (2.97 GB Usable).  Usually when i see this it make's me think it's x86 or shared with GPU. On a VM I'm unsure of why the system limits the usable amount of RAM.
0
Hi

We are planning to replace the core switch and keen in getting a HP core switch.

Firstly ,I would need 4 Copper 10Gig ports on the new core switch to connect between 2xHP ESX servers and Storage and i don't want to use a storage switch.
Secondly,I would like 4 Fibre SFP ports that can be connected between Core and Edge switch.

At the moment the Edge are 1 Gig SPF ports   and want to use the 1G connection between new core switch and edge switch. Later I will be upgrading the edge to 10Gig and during that time I must be able to switch over to 10Gig connection on the new HP Core switch.

Please let know HP switch which can do this job or suggest me the plan for this.

Thanks in advance.
0

Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.