Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.

Share tech news, updates, or what's on your mind.

Sign up to Post

I have a 16 TB storage fibre and I added 8 TB more and I tried to expand current datastore from ESXi 6.5 I selected custom 4TB and it shows now 20TB.
But now I cannot use the remaining 4TB anyone can help me add that and make it useful.
 
Capture1.JPGCapture.PNG
0
hello,

i have tape library hp MSL2024 Fc i need to connect it to cisco ucs 240 server direct through fibre channel.

the operating system is windows server2016
the backup software is veeam
the HBA card installed on the server is emulex lightpulse HBA - storport miniport and the driver is installed.

the problem is i cannot connect the tape to the server, i fixed the speed to both to 8 Gb/s and the port type to fabric on the server and the tape drive. i swapped the cable RX and TX, still no luck

on the tape it gives me no light detected.

help please
0
Long story short - My client's one of the sub-companies is being sold. They were separated for a while on paper - but still were using the same IT infrastructure.
My job is to split existing company's IT infrastructure. Most of their data is mixed and stored in the same shared folders etc etc.
Since they use several Virtual Servers on HYPERV backbone - I plan to "clone" the existing servers, and when done - split the physical network.

I am thinking of using the VM replication as means of accomplishing this.
Do not have any experience with VM replication so far, but isn't this a standard for IT projects :) ?

My hope is that I will be able to bring the replicas to be "primary" after I separate the physical network, and i hope users for each company will see everything as it was before the separation.
Afterwards I plan to cleanup some files and resources that do not need to be shared, remove computer/user accounts etc.

Does it sound like a probable solution?
0
Are there any known issues with VMware build ESXi650-201905001?

I'm experiencing slow performance
0
Dear Experts,

Is there any tutorial or guide in drawing a Hyper-V vSwitch Port Assignment diagram?
0
I have MSA 2050 with 2 Volumes (vol1 and vol2)which is connected to ESXi6.5 as datastore.
I have added 6 more HDDs on a different expansion enclosure and created one more volume (vol3)
I can see the newly created volume in expansion page. Below are the screenshots, Just want to verify I am doing right
Capture0.JPGCapture1.JPGCapture2.JPGCapture3.JPGWill I loose my data if I click yes from the above step?
.
Below is the enclosure screenshot.
Capture4.JPG
0
Citrix Error: You have not been granted access to this published application
XenApp 6.5
StoreFront Server: sf 3.7
netscaler vpx 11.1
when users are trying to launch applications few users are getting this error.
https://support.citrix.com/article/CTX135807
No Luck, After disabling my published Desktop and re-enabling
Raju-Error.jpeg
0
Don't laugh!  I know about VIEW and ZenDesktop and use both, but I've been asked!  :)

I have a company with 100 users, give or take, and they want to move their stuff into a COLO and go to a VDI environment using zero clients at the office while letting the virtual desktops live in the cloud.  I've talked to them about VIEW and Citrix and we have discussed the cost.  Once the owners were released from the hospital, we met and talked some more.

I have an idea and I want peeps on here to talk it up or shoot it down and give me some feedback.

My thought is to put in a couple of RRA servers at the COLO and build one or two virtual desktops to spec, convert them to templates and then spin up my needed VMs from the template, one at a time.  We actually have two or three techs who could help so it wouldn't be horrible.  

In the zero clients, we just specify the remote gateway and the VM assigned to that user and let them RDP straight to the desktop assigned to them.

All of this would be supported in the back by 5 ESX hosts and SSD storage to handle the IOPS so I don't expect the "speed" of the VMs to be a problem.  We have 1gig from the office to the internet already so I don't expect bandwidth to be a problem.  Even the usage in the building is mostly email and internet.  The "serious computing" - that's the Solidworks CAD and the media creation - would still be done on local workstations in the building.  Those hitting the VDI would be low bandwidth users, support …
1
Hi,

We current have a VMware 6.5 using a Dell Equalogic PS6000 SAN as the backend storage. Unfrotunatley we have two datastores that have extents that cover two physicaldevices, so I plan on vmotioning the vms off the datastore, delete and the recreate the datastore without the extent on the other storage device. On the SAN the storage is split into several volumes used for storage. When I have tested, I have deleted and recreated the datastore fine no problems, but on the volume on the SAN any used space within the new datastore has simply been added to the in se space on the volume. The SAN has no idea that the datatstore has been recreated (I assumed that the new datatstore would be able to use upto the in use space the volume thought it had before growing the volume). I'm guessing that my only option is to vmotion the vm's onto another datastore. Delete the datatstore and back end volume on the san. Recreate the volume on the san and then the datastore and then move the vms back?

Cheers,
Paul
0
Hi,

Weird problem here. I've got a Windows 10 VM that used to work. But now it always fails with an 0xc000021a error. I tried to google a solution but I have failed so far :(

I've tried running sfc /scannow as well as Dism /Online /Cleanup-Image /RestoreHealth (after having successfully booted in Windows 10 by using 'disable driver signature enforcement' in the 'startup settings' of the troubleshoot menu.

Any other ideas? Thanks!
0
Hello experts,

I am getting the current error with my VM on Windows 2008 R2

Cannot open the disk '/vmfs/volumes/55fb6cc5-06834bbb-558f-009c02a8359a/AJSWAN001/AJSWAN001_5.vmdk

Open in new window


I have to run to a meeting, but I can provide additional details, just let me know.
0
Hi, I was wondering if there was a way to use Veam Backup and restore to backup from an ESXi server and restore to a Hyper-V system.

Thanks all.
0
I have two 2012 R2 Servers joined to a domain and running HyperV. Both Servers are connected to a SAN via iSCSI and so there are about 8 mapped drives on each server using iSCSI initiators. The previous admin had replication going from Server A to Server B. The VM's have their storage in multiple mapped drives. We upgraded the Backup SAN with bigger drives. The previous Admin setup Replication between the two and then quit.

We failed the HyperV Replication over to the Backup Server and SAN. Everything came up fine, however when we upgraded the Primary SAN and went to set the Replication back up I can't figure out how he did it. When you set the Replication it has a field that says "Specify the default location to store the Replica Files:" under the Authorization and storage section. All of the iSCSI connections have different drive letters.

If I start a replication of VM1 and use it's storage drive letter of H, it comes over fine. But when I try to replicate VM2 with drive letter G, it goes to H as well and the VM's fill up one drive instead of going to their own drive letters and shares.

How can I set this up so they all replicate to their own storage on the iSCSI of the backup Host?
0
We use Veeam BU and Replication at two sites.  At site A, Veeam is on a physical machine and our backup storage is physically connected to that physical machine so adding storage to hold backups and replicas is simple.

At site B, there are two VMware hosts.  Veeam is running as a VM on one of those hosts.  

Each host has 20+TB of storage and I'm trying to add it to Veeam to hold backups and replicas and it's giving me some grief.  

Veeam is running on host 200, but the only way I have found to add storage for Veeam to use is to add a virtual hard drive to the Veeam server and then map to it.  I just want to make sure I'm dealing with this storage in the correct way.

Can anyone offer any suggestion?

Thanks

Cliff
1
Hyper-V DDA makes me crazy.

I have installed a 2019 Hyper-V server with a 2019 server as guest - all up2date, all current drivers installe, all bios options for hyper-v are set.
I am trying to make a graphics card available to a machine via DDA.The script from https://docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/deploy/deploying-graphics-devices-using-dda works! However, as soon as I try to power on the VM, the hypervisor shows errors:
'NameOfMyMachine' failed to start.

Virtual Pci Express Port (Instance ID 540C1694-484B-4451-B6E7-91D6B2772D18): Failed to Power on with Error 'Element not found.'.

[Expanded Information]
'NameOfMyMachine' failed to start. (Virtual machine ID 96D073C6-E9B8-4095-96FD-E887B93C0EC5)

'NameOfMyMachine' Virtual Pci Express Port (Instance ID 540C1694-484B-4451-B6E7-91D6B2772D18): Failed to Power on with Error 'Element not found.' (0x80070490). (Virtual machine ID 96D073C6-E9B8-4095-96FD-E887B93C0EC5)

Could not allocate the PCI Express device with the Plug and Play Device Instance path 'PCIP\VEN_10DE&DEV_1C30&SUBSYS_11B310DE&REV_A1\4&25438C51&0&0008' because it is already in use by another VM.

Open in new window

Rest assured: that card is NOT in user by another VM since there is only one VM and there never was a 2nd. Using powershell, I can even determine that it is assigned to that very VM.

What should that funny error tell me?
0
I am going to be building a CA on a VM and the Microsoft documentation I have found seems out-dated.

What is the recommended platform for this, I have found having an offline one that is the root and then subordinates to issue the certificates as the idea. This seems really intensive.

I really just need one to issue certificates to devices/users for VPN items and HTTPS certificates for SCCM later. Nothing to intensive.

Does anyone have a good method to get one up and running quickly?
0
Dear Experts,

I tried to export the ovf template to my PC via VPN but it only managed to download the .ovf and .nvram file successfully.

The vmdk file which is 20GB only have 8GB downloaded.

I suspect the internet bandwidth is slow for the site where the equipment are installed.

I have tried from my home and office PCs. I have also tried to download it to a VM server also stuck at 10%, 33% and 66%

The ESX is Dell's v6.7U1
0
Hi, I was trying to use Microsoft Virtual Machine Converter to P2V and when it ask for credentials it fails out.

Im dooing this from the computer I want to convert.  

Question can you convert from the physical computer, or do I have to do it from a third computer?  With VMWare converter I can do it from the local computer

Thanks all
0
Hi,

Our VM datastores use extents. One particular datastore uses two different extents to create the volume. Is it possible for the two extents to live on volumes  on separate SANS? If this is possible what happens if one of the SANS or the volume where the extent lives, is offline?

Cheers
0
I am running Hyper-V  on Svr 2012 R2.
I rebooted the host after installing visual c++ 2015 Redistributable.

when it came back up i saw my VMs stuck in a "Saved" state.
when i try to start the VMs i get the error
"An error occurred while attempting to change the state of virtual machine"
"'Hostname' failed to initialize.

I tried deleting the saved state, but got the same error as noted above.

i check the event viewer and see event IDs 14070 and 15120.


I am also getting error with event ID 1000 as shown below.
Log Name:      Application
Source:        Application Error
Date:          5/13/2019 2:39:48 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      HYPERV-HOST.MYDOMAIN
Description:
Faulting application name: vmwp.exe, version: 6.3.9600.19227, time stamp: 0x5c0b5147
Faulting module name: KERNELBASE.dll, version: 6.3.9600.19269, time stamp: 0x5c5e079f
Exception code: 0xe06d7363
Fault offset: 0x0000000000008e6c
Faulting process id: 0x10e4
Faulting application start time: 0x01d509c39fdc6f46
Faulting application path: C:\Windows\System32\vmwp.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: ddda0b19-75b6-11e9-80bb-4cd98f608fa5
Faulting package full name:
Faulting package-relative application ID:
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID …
0
I have VMware Workstation 14 Pro on Windows 10.  We exported a VM from an ESXi server (three files: dg.mf = 1 KB, dg.ovf = 10 KB, dg-disk1-vmdk = 53 GB) and I am trying to import it.  

"Failed to write content to disk C:\Virtual Machines\dg-disk1.vmdk. Reason: There is not enough space on the file system for the selected operation."

The three files together take 53 GB, while there are 145 GB free on the hard drive.  What could be the problem and how can I fix it?
0
Is there a way with Veeam backup version 9.5 to do a restore from like a time frame range?
ex: Sept - Dec for a certain file
I don't see anyway to do that just wondering if it is possible or not and if so, how can I set that up?
0
Exchange server 2013 VM (Hyper-V 2012R2) has low disk space.  Am I able to increase the partition size with an exchange store located there?
0
Environment = Vcenter Version 6.7.0.20000 Build 10244845
ESXi, 6.5.0, 7967591

I shrank a flat-vmdk on a vm and now,  vcenter wont let me power on or storage migrate the VM.  

I followed this guide - https://virtualman.wordpress.com/2016/02/24/shrink-a-vmware-virtual-machine-disk-vmdk/
(I should never done it! Big mistake)  The guide seemed so straight forward and I did not think anything would happen.  

Error I get when I try to Storage Migrate the VM:
error2
Error I get when I try to power on the VM:
error1

Let me explain exactly what happen which may help you figuring out a solution:

1.)I Powered off the VM because memory hot add was not enabled and I needed to increase the RAM from 32gb to 228gb total.
When I went to increase the ram I mistakenly increased the Hard Disk from 80GB to 228GB and clicked ok!!!
With the VM still powered off, I decided to try and shrink the flat-vmdk following that above guide.

I followed the ONLY portion of the guide which shows how to edit the .vmdk descriptor file.

Keep in mind the VM was powered off the entire time.  So I skipped the first portion of that guide about shrinking the disk from Windows OS.  

I followed this guide exactly and successfully changed the flat-vmdk to show 80GB :)  But now I get those errors when trying either power on the VM or storage migrate it!!

Please help!
0
Good day. We have a nasty Proxmox kernel error on a RAID1 system: (out of /var/log/messages)

May 10 14:58:37 proxmoxXXX kernel: [57269.175789] scsi target0:1:0: volume handle(0x00be), volume wwid(0x05ac9c5b28c5dbfb)
May 10 14:59:06 proxmoxXXX kernel: [57298.871751] sd 0:1:0:0: attempting task abort! scmd(00000000c23993b1)
May 10 14:59:06 proxmoxXXX kernel: [57298.871758] sd 0:1:0:0: [sda] tag#4 CDB: Write(10) 2a 00 27 5d 21 68 00 00 10 00
May 10 14:59:06 proxmoxXXX kernel: [57298.871762] scsi target0:1:0: volume handle(0x00be), volume wwid(0x05ac9c5b28c5dbfb)
May 10 14:59:06 proxmoxXXX kernel: [57298.871767] sd 0:1:0:0: task abort: FAILED scmd(00000000c23993b1)

Our RAID-controller is: SAS2004 PCI-Express Fusion-MPT SAS-2 [Spitfire] (pretty old LSI low budget controller)
Our Proxmox system is: Virtual Environment 5.4-4 running on Debian 9

The problem seem to occur when the load average climbs over 5-7 (and higher).
Someone mentioned to me maybe upgrading the firmware of the RAID-card but I have not found any drivers yet.
Any ideas where to catch them or any other ideas on this issue ?
Thanks a bunch
Uwe
0

Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.