Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.

Share tech news, updates, or what's on your mind.

Sign up to Post

We noticed that we can't open a remote console for a deployed VM from VRA web interface, we get the below error:

"Cannot connect to remote console. Verify that the machine is powered on and connected to the network."

The VMs are powered On, on Vcenter side the VMs look healthy.

This is what i have tried so far:

Ping from Host to vcenter where the VRA VM resides:
	[root@host:~] ping vcenter
	PING vcenter (10.93.104.30): 56 data bytes
	64 bytes from 10.93.104.30: icmp_seq=0 ttl=64 time=0.186 ms
	64 bytes from 10.93.104.30: icmp_seq=1 ttl=64 time=0.282 ms
64 bytes from 10.93.104.30: icmp_seq=2 ttl=64 time=0.343 ms

	--- vcenter ping statistics ---
	3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.186/0.270/0.343 ms

Open in new window



-Curl to port 902 from vRA to host works fine:
            
[replica] vra1:~ # curl -vvv telnet://host.domain.local:902
		* Rebuilt URL to: telnet://host.domain.local:902/
		*   Trying 10.93.104.27...
		* TCP_NODELAY set
		* [b]Connected to[/b] hosts.domain.local (10.93.104.27) port 902 (#0)
		220 VMware Authentication Daemon Version 1.10: SSL Required, ServerDaemonProtocol:SOAP, MKSDisplayProtocol:VNC , VMXARGS supported, NFCSSL supported/t

Open in new window



-Connection to port 902 from vRA to host:
	[root@host:~] esxcli network ip connection list | grep 902
	tcp         0       0  10.93.104.27:902                10.245.253.3:40456  [b]ESTABLISHED[/b]     67166  newreno  busybox
	tcp         0       0  :::902                          :::0                LISTEN          67166  newreno  busybox
	tcp         0       0  0.0.0.0:902                     0.0.0.0:0           LISTEN          67166  newreno  busybox

Open in new window


In Security properties on VRA this is already set:
 vra1:/etc/vcac # grep -i timeout security.properties
consoleproxy.timeout.connectionInitMs=20000

Open in new window


Infrastructure -> DEM status -> all are online
Infrastructure -> log:
Error:
The underlying connection was closed: An unexpected error occurred on a receive.
Inner Exception: Certificate is not trusted (RemoteCertificateChainErrors). Subject: C=US, CN=vm-vcenter.domain.local Thumbprint: DBDF5C8DDAF5C4AE34A55AB995DFF56C14B13181

Open in new window


Stack trace:

Open in new window

0
Dear Expersts,

I need to understand licensing of VMware vCenter, I have two host VMware Esxi, First host have 7 VMs and second have 2 for fail over scenario. I want to understand how we licensed VMware ESXi and VMs that would running on it is also required to licensed??
0
Here is the situation:
I recently purchased a Dell server that had Server 2019 Standard pre-installed. Now it is my understanding that I can install Hyper-V and have 1 "free" install of Server 2019 Standard as a VM.
Is that accurate?

If so, where do I obtain the actual product key from?  

Thank you!!!
0
Dear Experts
We have recently implemented veeam backup and replication solution, would like to set the best practice backup and retention policy for VM’s and files. Please suggest me to daily backups best way to rotate  and similarly weekly and monthly how many days retention to be set and rotate. please help me with best practice way to configure like first full backup and then daily incremental and weekly and monthy how to set please suggest the best backup policy and set the retention
0
hi,

we just setup CentOS VM using hyper V in windows 10 enterprise, and we try to avoid the situation which we mix up the existing VM, should we just create a snapshot of the existing CentOS VM ? this can make sure the current CentOS VM can restore back by this snapshot ?

then how can I create the snapshot?
0
This machine kicks the user out after about 45 minutes (logging in remotely)
0
Hi, I have a cluster ESXi 6.0 with 9 nodes.
I noticed very bad performances on different VMs on my infrastructure.
According to resources utilization on entire cluster, I would exclude RAM / CPU issue.
I suspect there is some issue on storage side (we use PowerEdge MD3200 / 3800) through iSCSI.
I ran esxtop on some hosts, occasionally I noticed very high DAVG / KAVG values.
My question is: what would you do next?
Through esxtop I can find the "affected" lun.. isn't there a more efficient way to identify the VM (or VMs) that are causing performance issues?
Thank you
0
New server for a site of approx. 30-35 users.  Will be running 4-VM's in Hyper-V on W2K19 Server OS (VM's- DC/Print Server, Remote Desktop Server (minimal use), 2-Application servers). Possible future File VM (would need more MS licensing).  Purchasing a new HPE DL380 Gen 10 Server as the Hyper-V Host.  2-processor (24-core), 128GB RAM, P816i-a SR Gen10 Controller with 16-open SFF slots.  Thinking OBR RAID 10, (8) 600GB SAS 10K 12Gb/s drives plus (2) hot spare.  Extra bays for future growth.  Will have 1-Array with 2-logical drives- one for Host OS and one for the VM's. I am researching SSD options from HPE as well but looking to justify cost to owners.  

Question- Should I be installing SSD in this configuration?  Read, Write or Mixed use?  Site typically runs servers 6-7+ years.  SATA or SAS SSD (leaning towards SAS SSD if we go SSD route). Trying to justify the extra cost of the SSD setup.  The SSD SAS 12GB/s option from HPE is pricey.

Thanks in advance for the input.
0
I have a Server 2016 - it's actually a terminal server with a lot of apps on it.  I can not get an updates on it. I think the last time it updated was sometime early July, maybe even June.  I've tried deleting the software distribution folder and re-registering it with my wsus server but still not luck.  I've tried Sconfig and that doesn't work either.  I even tried downloading the updates manually and installing them and that isn't working either.  There is no information in the event logs and the update history isn't any help either.  I've tried dism too and that hasn't given me any information either.  This is a VM and it's heavily used.  I'm out of ideas.. Any suggestions?
0
hi,

any easy to follow procedure to setup CentOS VM on windows 10 and install MySQL standalone on top of CentOS VM ?
0
Good day,
We have a VM host that runs two server machines.  The first is the DC/FS and it works great.  The second machine is a terminal server.  It constantly is freezing on the users and it is getting frustrating.  Here is some info:

Host machine is running Server 2016 Standard.  Its specs are:

HPE Proliant DL380 G9
Xeon E5-2620 v3
32GB RAM
RAID 10 for the virtual disks

Server is stable, no issues.

The host machine allocates a large portion of RAM to the DC and the TS.  The DC currently has 8GB and 8 virtual processors.  The TS has 10GB RAM, and also 8 virtual processors.  Originally I had the TS with less RAM and processors, but in trying to fix the freezing issue, I increased the resources.  I plan on bringing them back down.

The TS has only 3 users signing in.  They use the same domain account to log in to the server.  The TS is configured to allow the same user to log in multiple times.  It is light usage.  The TS exists to run only one program.  While using that program, the users may open Word or Adobe, but not much of anything else.  About 4 or 5 times a day, the server just stops responding to that user.  The other users logged in do not experience the same.  It will just spin and spin.  The remote connection never breaks.  Frustrated, they just click the x on the top blue ribbon, and re-log back in.  Then its totally normal until it freezes again.  

During the freeze, the internet is working normally, the others users aren't affected.  A VPN …
0
I have 2 VM's running on separate physical machines.  Both are running Windows server 2016.  We will have them running our ArcGIS mapping program but want one to be the main server everyone works off of and the other to only replicate the main server once a day and setup fail over in case something happens on the main.  Any help or advise on accomplishing this would be greatly appreciated.
0
Probably a fairly "classic" issue but I have surprisingly not found definitive info about it online.

What is the best practice managing hardware RAID controllers on ESX Hosts ? Ideally, we would like to be able to "reach out" to the controller from a Windows guest VM but if not possible at the very least have some management capability (expand RAID, check array consistency) from ESXCLI.

How should we go about it ? In our specific and immediate case ESX6.5 with Intel RMS25CB080 controller.
0
HI all (Andrew), I was looking for a way to migrate a server from one ESXi server to another incrementally, I think.  

So I have a server that is like 2 T on a VMware server, I want to image it over, then be able to migrate it to another VMWare server, then be able to just migrate the changes over.  

Like if it's going to take a long time I can do it, then when we have a small window get people off the server, then zap over the changed files, shut off the old server boot up the new one and done.

I was trying to figure it out in Veeam, but got stuck.

Thanks all.
0
Hi,

I d like to setup a Hyper-V with KVM (wont attach display or keyboard/mouse, the hardware will not be reachable physically once condigured, so need to have control as from boot) on a Intel NUC.
Preferrably 32 GB or more, will run lab environment (Windows domain, some test servers, some w10 machines) periodically but most of time do nothing so power usage is key.
Also has t to be latest top knodge performance, budget is important too (just a lab which I might shutdown/boot when needed/not needed). Have a Synology ds918+ that could run the vms or I run them locally and backup via Synology.

Please advise what hardware you would recommand. Would like to spend like 200 Euro max, if really worth it, budget is stretchable).

J
0
Need to extract slot information from vCenter Cluster

Can we extract  the same using script /automation for information like ..

Cluster ,Total Slots ,Used Slots ,Available Slots ,Slot CPU and Memory

Thanks
0
I am new to VMWARE..
In ESXi 6.5, I have a SSD Datastore (500 GB) that is giving a Data usage warning (free space low) .
The Server installed on it only uses 80GB, whereas the Virtual disks are 400 GB.
why all this difference and how to restore unused space.
0
I need to build embedded Linux image using Yocto Project.
https://www.yoctoproject.org/docs/2.7.1/brief-yoctoprojectqs/brief-yoctoprojectqs.html

Yocto requires Python 3.4.0 or greater
I have Python 2.7.15+

How to upgrade python in Linux VM that I can connect to with windows PC secure shell like puTTy.  Also, I can connect to Linux VM by Remote Desktop connection from my windows PC.
0
Hi

Im testing veeam backup for o365 and have jobs set to run tonight to save locally to repository c:\ on the veeam VM in azure.  Its backing up share point and exchange.

Ive followed lots of: https://www.veeam.com/veeam_backup_microsoft_office_365_3_0_user_guide_pg.pdf?ad=azure-o365 but need guidance to  whats the best practice for backup repositories?  i.e. storage account in azure or VM or virtual NAS/SAN..?

Suggestions?

Thanks
0
We upgraded a physical sql server from SQL Server 2014 to a 2016 VM.  There were a lot of changes made outside of just the SQL Server upgrade:     OS, Application, SQL Server edition, changed to VM, to name a few.

It is v2016 sp2 CU8.  It was Standard Edition before, and still is now.  The server is maxed at 128GB ram for max server memory (mb).  

From the point of go-live on the new server, ALL performance has been dreadfully slow.  20-30 times slower response than we saw on the old server, for the calls that complete. A lot of them are also timing out.  Basically, it is unusable for production requirements.

I have checked everything -- the disk, the cpu, the memory usage -- I did a blitz and blitzfirst check, trying to find what is dragging the server --- absolutely none of my checks are coming back with anything questionable.  I don't see any memory or cpu pressure, I don't see anything but expected read and write latencies on the disk and tempdb.  I cannot find anything at the sql server to explain this remarkable performance degradation.

I believe it could be the VM, but I do not know how to confirm the VM configuration is good or lacking.
I also fear it could be something new in SQL Server 2016 that I am unaware of -- but, I've performed the 2014 to 2016 upgrade before, and never seen anything like this.

Any Expert help?  A script I can run to point to something as the cause of this problem?  Ok, I know that is too easy, but I need some insight.  Any …
0
I am trying to set up a file server cluster using 2 VMs hosted on an S2D2019 cluster. Both compute and storage takes place on the S2D cluster.

I have create 2 vms FSC1 and FSC2, i have then created the cluster called FSC and created a file server called FSS.

On both VMsi have attached a shared VHDS also hosted on the S2D cluster.

I have tested speeds on the VMs C:\ drive using diskspd.exe and i can get over 3GB read and 1GB write running at 75/25 r/w with a 64kb file.   no problems it works great. I have then tested copying large files from another location to the C drive and it gets around 700MB/s   again no issues with this.

I then go to the drive hosted on the VHDs on the server that is hosting the storage and try to run diskspd.exe again. I get the message

"WARNING: Could not set valid file size (error code: 87); trying a slower method of filling the file (this does not affect performance, just makes the test preparation longer)"

After a while it comes back saying no reads and no writes. If i try to copy a file to this drive i get 10MB/s trying to copy using the share path and 30MB/s trying to copy using the local path.

Is there anything that could cause such pathetic performance? Maybe something i have missed? I created the VHDS on FSC1 and then attached it to FSC2.

Thanks in advance for any help and just let me know if you need anymore information.
0
Hello EE, I've got a weird issue when I turned on Hyper-V in Add/Remove Programs,Turn Windows Features On/Off it killed the WiFi on my machine.  It for what ever reason placed the WiFi Device in a disabled state, unable to enable.  I checked to verify there were no power settings that could be causing this.  After doing a little troubleshooting I decided to remove Hyper-V, after Hyper-V was removed WiFi works fine again.
0
Hi,

I have a Windows 2016 VM of which screen resolution is really bad (RDP from Windows 10).
VMWare tools are installed, no clue what else could be going on.

Please advise.
J.
0
Ok....

Our school has 2 DC's

DC1 is a physical box running Windows 2008r2

DC2 is a VM running Windows 2008r2

DC1 has all FSMO roles

I've successfully completed migration to DFSR

The AD schema is 47

I want to replace BOTH DC's with 2019 servers

NEW_DC1 - physical
NEW_DC2 - VM

I'm looking for advice on the order of tasks to get this done.

Thanks for your time !!!
0
Hello Experts,

We do have enough  free space  to start the JAVA process but getting error like below:

Error: Could not create the Java Virtual Machine
Error : A fatal exception has occurred, Program will exit.

 The same program was running since 3 years with java version :
JAVA Version :
C:\Users\.......>java -Xms512m -Xmx1536m -version
java version "1.7.0_21"
Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)

Open in new window


HeapSize:

C:\Users\*********>java -XX:+PrintFlagsFinal -version | findstr /i "HeapSize
PermSize ThreadStackSize"
    uintx AdaptivePermSizeWeight                    = 20              {product}

     intx CompilerThreadStackSize                   = 0               {pd produc
t}
    uintx ErgoHeapSizeLimit                         = 0               {product}

    uintx HeapSizePerGCThread                       = 87241520        {product}

    uintx InitialHeapSize                          := 2147483648      {product}

    uintx LargePageHeapSizeThreshold                = 134217728       {product}

    uintx MaxHeapSize                              := 2061500416      {product}

    uintx MaxPermSize                               = 85983232        {pd produc
t}
    uintx PermSize                                  = 21757952        {pd produc
t}
     intx ThreadStackSize                           = 0               {pd produc
t}
     intx VMThreadStackSize                         = 0               {pd produc
t}
java version "1.7.0_21"
Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)

Open in new window


Can anyone help to what is wrong here ? If we remove the condition on the max and min size then the program runs fine and also on java version 1.8
0

Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.