Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.

Share tech news, updates, or what's on your mind.

Sign up to Post

Need a good P2V plan for a DC.

Here are the requirements:

Physical DC = server 2008 R2

Converted VM = needs to be server 2012R2

Needs to have the same name and IP as the physical dc.

What would be the best way to accomplish this task?

Here is my plan so far:

1.)      Transfer all FSMO rolls to another already running DC
2.)      Demote, and Decommission Physical DC, and shut down
3.)      Reset computer object in AD
4.)      In Vcenter, Stand up new vm
5.)      Make it a member server with same name as the physical
6.)      Give it same IP as old physical dc
8.)      Promote to DC

Will this work?  is there a better way?

your thoughts
0
how can i get info on backup jobs for all of 2019 thus far?  i see job data going back a week and the history showing the first 500 which goes back about 5 weeks.  auditors are looking for backup job history since january.  running backup and replication 9.5 update 4
0
I want to use the Veeam VUM to upgrade all of the vms Hardware to the latest version since we just upgrade our VM host from 5.5 to 6.5
If I select the vm hardware from the baseline, will it shut down the vms one at a time to upgrade the hardware and then will it power them back on once complete?
0
Server 2012 R2, Hyper V Cluster, guest loss disks. The vm boots, has the C drive obviously, but my D, E and F drives are gone. Within the guest, I can go into Disk Management and I see the 3 drives, all are offline. Try to bring on line and get message that they are managed by Failover Cluster Manager. I have tried removing the guest from Failover Cluster Manager and adding it back in, I have tried removing and also deleting the VM from Hyper V Manager, then create a new VM using the same disks. I have tried copying the VHDX files to another folder within the ClusterStorage. I end up the same problem no matter what. I have looked at the security on the VHDX files and this is where I think the problem lies. For all my other guests that are working correctly, they have an object with Full control that looks like a SID followed by (NT VIRTUAL MACHINE/SID). In addition,(my luster consists of 3 hosts) if I try to create a new machine from my Failover Cluster Manager > Virtual Machine > New Virtual Machine, and try to browse to the location for storing the VM here is what happens:

Host 1 = works good, lets me browse to the ClusterStorgae folder, C:\ClusterStorage
Host 2 = bad, instead of the ClusterStorage folder, I get the path ::{0907616E-F5E6-48D8-9D61-A91C3D28106D}\HV-LRN-MNC-02.domain.com
Host 3 = bad, same as Host 2, ::{0907616E-F5E6-48D8-9D61-A91C3D28106D}\HV-LRN-MNC-03.domain.com
0
Hi all, I've been a member here since 2016 but have only been in-and-out to peek at some solutions which have been very helpful to me over the years.  So first off, I'd like to thank all the awesome people out there who provide answers to our questions - Thank You!    I have done a quick search in the exchange about my current question: "VMware ESXi 6.5 Console session, cannot type, keyboard does not work in console".   My setup, I have a Dell R210 II server, installed ESXi 6.5 Hypervisor on it, and stood up a VM with two dual core processors, 6GB of RAM, and 3 NIC interfaces .  A very basic setup.  The intent of this VM is for a Sophos XG Home firewall.  Standing up ESXi went quickly without issues, as well as configuring the VM in the Hypervisor.  I uploaded the ISO to the datashare, and the VM did successfully boot to the Sophos 17.5 XG Firewall install.  My issue is, when I login to the ESXi web interface and browse the VM's to launch the console session, no matter what I do, I'm not able to type in console.  I've tried to connect to the console in I.E., Firefox and Chrome - same result.  I've closed the console session and reopened the session a few times, no change in results.  I've even rebuild a second VM with the same parameters, no cigar. Has anyone ever experienced this?  I'm beginning to think there's an issue with the laptop I'm using to interface with the ESXi Hypervisor, but that doesn't make sense to me.  I don't think there's an issue with the ESXi server... …
0
I have a VM host running VMWare ESXi 6.0, which I usually access for maintenance with VSphere Client 6.0.0. The account I use has admin permissions.

I'd like to set up the server to send email notifcations in case of i.e. hardware problems, but I can't find out where to set that up, and VMWare documentation is not very helpful with that.

Any hint ?
0
VM fails to boot when 2nd disk is present. Rather than booting from hard disk, it tries NIC to boot up and soon "Operating system not found" error appears.
Everything is fine once I remove the 2nd disk. In boot options, hard disk is obviously the 1st option. Disconnecting NIC makes no difference. Strange!
Please advise.
0
Hi,

Our HV HDD was crush. We manage to restore AD Domain controller (Windows server 2012R) but when i boot the VM. I received this blue screen. I tried all the available solutions.
This is only one domain controller and we have to restore it.

Boot VM via 2012r2 ISO and perform below commands but still receive the same blue screen error.
SFC/scannow
bootrec / fixmbr
bootrec / fixboot
bootrec / rebuildbcd

Please suggest me to resolve this issue.
2019-04-23_19-48-52.jpg
0
hello all


i registered a vmx file manually on VMware ESXi 5.1.0 Update 1 ( build-1065491 )

the registervm command output vm id 3, reported no issue, created the usual files including .vmxf and edited the .vmx as usual

listing the vms produces the message "Skipping invalid VM '3' " but lists other vms

powering on the vm produces "Power on failed" without a single hint

"vim-cmd vmsvc/destroy 3" does not output anything and exits with a 0 error code but does not destroy anything

the vm is listed as "Unknown" in the UI and no action is available


the same script used on esx6 with the same vm works without problem. i am unsure i ever tested that same script against 5.1. i was expecting this host to be on-par with the rest of the cluster.


questions

- how can i actually unregister/destroy that vm

- how can i debug what vmware does not like ?


thanks for your help

sk
0
Hi,

We are facing very difficult situation at the moment. let me explain in detail.

Problem 1:
We are running Exchange 2016 server and  Domain controller AD on two separate VM's.
Last night, we faced disaster and our Hyper V HDD was crash. We trying everything but its totally crash.
We have Exchange 2016 VM backup but we don't have AD VM backup.
Please let me know how what will I do at this situation. If I created new AD with same domain name so I believe I need to rejoin exchange server with new AD.
What will happen with current mailboxes. They will work like same way that they were working previously.

Problem 2:
As i explain above our Hyper V HDD was crash so our three RDSH servers and their AD (Its not same AD as i explain above, different domain name) also down.
Again we have RDSH servers backup but we don't have AD backup so i guess I have to republish all the apps again.

Please let me know how to resolve these problems. Both are related to AD's. One for Exchange 2016 and other for RDSH server.

OS: Windows server 2016
Exchange: Exchange server is 2016

Shoaib Nawaz
0
I am looking to create a file server to store all my home network PC's and laptop files. Basically a home share - I don't need file and folder permissions but that would be nice so i could make sure the kids don't delete stuff they shouldn't. It would also be nice to have previous versions or shadow copies enabled so it is easy for my home users to restore files on their own.

I would also like to setup a pfsense firewall for my home network.

I was thinking i could build a server that would handle all of this in vmware! But the more i read i think it seems that I would need to purchase vmware essentials licencing and potentially  a windows 2008 r2 server license from Microsoft.

Is there any way to accomplish the above without purchasing licensing or maybe im just confused on the licensing stuff. Can someone please explain the licensing required for the above for a home setup?

OR is there a completely free or low cost alternative that would allow me to setup a virtual environment to accomplish the above? My budget is about 300$
0
I have a hp z800 and want to setup esxi 5.5 on it as a home lab but i am not sure what kind of disks to purchase and how to configure the built in intel raid (is this considered as software raid? If so i dont think ESXI supports software raid and I may need to purchase a physical LSI - pcie raid hardware card)  so that vmware will be able to see my hard drives as a datastore. I will also be running esxi off of a usb thumb drive.

I also believe 2TB drive is the largest siz drives i would get (i know some of it gets lost but how many 2 TB drives would i be able to use and what would be the expected available size after setting them up in raid and what it the best raid configuration to put it into Raid 5, 10?

Thank You in advance for your time!
0
Hello, we lost power to our esx + san environment, and my backups have been failing on VEEAM. I went into vmware, and saw this message, however the disk is attached in the VM. How do i fix this?

Vmware 6.0 drive properties
0
It is a VM under Server 2019. It was activated. I then had to move it to a temporary server and now it is back to the original server but it is no longer activated. I still have the product key but when I go to "Change Product Key" I get the attached screenshot. It started out being a fresh, clean install of Windows 10 so I don't know why it thinks it wasnot activated prior to upgrading. It has to be a false error. Any ideas on how I can reactivate?

Error Message
0
Hello all,
I was just wondering if someone can set me straight with the correct and I guess recommended way to add CPUs to a VMware VM.
So for instance if we needed to bump a vm from 4 CPUs to 6 CPUs, from the web client would I change the setting under CPU from 4 to 6 or would I change the setting under Cores per socket to 6?
I just want to be clear and make sure we are setting the CPU settings on our vms the best or proper way.
0
DPM encountered error from VMware while trying to get Change Tracking info

Issue occurs with our vCenter vm, file fault ID 33621 Internal Error code 0x80990EF3

Any ideas some of the links I have seen for it point to changing the cbt just looking for advice on this if possible
0
have an old 5.5 esxi host (same vcenter) Out of need due to resources on another host I had to build an exchange server on it.  It didnt' have much in the way of diskspace and because of the swap file taking up 50gb I only have 400mb left on the local storage, my mailbox databases reside on an iscsi volume. OS on local.  I can't even backup because of the low space on local. I want to move that OS drive to the Iscsi Volume. Is it as simple as turning VM off, migrate and powering on?
0
I need some help to know where to start digging.

I've got two hosts (ESX) and they both have 10gig NICs.  They plug into a 10gig switch (ubiquiti).  

I'm using Veeam to migrate one VM from host one to host two and the speed is 48 MB/s.  Of course, I am expecting faster.

Now, my Veeam Server is a standalone server with it's own 10gig NIC, going into the same 10gig switch, so I thought maybe the traffic is passing thru the Veeam server and that's slowing it down.  Maybe it's the storage (since Veeam tells me the source is the bottleneck).  Of course, it dawned on me AFTER I started the move that I could have just moved it from one host to the other using vCenter, since the VM isn't changing storage, just moving hosts.  Stupid me...I don't wanna cancel it so I'm letting it run.  

This is also a good exercise for me.  I need to know where I'm weak.

Anyway, Where do I start?  

No jumbo frames turned on by the way.

Thanks
0
Hi,

I am trying to test out VRF lite which I have to implement. I have a single router with some loopback addresses in different VRFs. What I am trying to do is to import and export routes between them which I should be able to do with the route import / export command but I am not having any luck.

I know this makes no logical sense to why I am doing it but I need to test this before I implement it in a production network (with many VRFs).

version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Test-DC
!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

!


clock timezone EET 2 0

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

!

!

ip vrf Customer_A

rd 10:10

route-target export 10:10

route-target import 10:10

route-target import 10:20

!

ip vrf Customer_B

rd 10:20

route-target export 10:20

route-target import 10:10

route-target import 10:20

!

!

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

cts logging verbose

!

!

redundancy

!

!

interface Loopback0

ip vrf forwarding Customer_A

ip address 172.18.7.254 255.255.255.0

!

interface Loopback1

ip vrf forwarding Customer_A

ip address 172.18.253.254 255.255.255.0

!

interface Loopback3

ip vrf forwarding Customer_B

ip address 192.168.17.254 255.255.255.0

!

interface Ethernet0/0

no ip address

!

interface Ethernet0/0.10

encapsulation dot1Q 10

ip

Open in new window

0
We recently stepped into the light and virtualized our environment. I was told that doing a p2v on a domain controller was not recommended. I was wondering if that is the case? I have a physical 2008 R2 server that is a DC, NPS and a Certificate server which is used for my wireless environment using Radius which EE helped me to set up and configure and works great.. I would like to virtualize this if possible. We had an outside company do the virtualization. For the DC they created a couple of VMs and made them Domain Controllers and transferred over the FSMO roles from the physical to the virtual. It has been a few months now and everything is running fine. We still have three physical servers because of their AD roles. What can I do about those?
0
Windows 2016 Data Center
VMware ESXI 6.5

I recently changed my Windows 206 Data Center VM Network Adapter from E1000E to VMXNE 3 Adapter.

I have been getting this event over and over and over ever since I made this change.


Log Name:      Application
Source:        MSExchange Common
Date:          4/14/2019 8:59:40 AM
Event ID:      205
Task Category: General
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SERVER021.mynetwork.com
Description:
No DNS servers could be retrieved from network adapter 9d4aef73-3aa3-463b-8df8-8286a1f7dce3. Check if the computer is connected to a network and Get-NetworkConnectionInfo returns any results.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchange Common" />
    <EventID Qualifiers="49156">205</EventID>
    <Level>2</Level>
    <Task>1</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2019-04-14T12:59:40.504082100Z" />
    <EventRecordID>4354806</EventRecordID>
    <Channel>Application</Channel>
    <Computer>TGCS021-N1.our.network.tgcsnet.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>9d4aef73-3aa3-463b-8df8-8286a1f7dce3</Data>
  </EventData>
</Event>

Open in new window




When I run

[PS] C:\Windows\system32>Get-NetworkConnectionInfo


RunspaceId  : 5718e5ea-e17d-4d74-b5d7-bcf5dc666608
Name        : vmxnet3 Ethernet Adapter #2
DnsServers  : {10.2.8.30, 10.2.8.24}
IPAddresses : {10.2.8.17, fe80::ccca:4267:b925:6774}
AdapterGuid : beeaac63-29d7-4439-8767-5f07db4d33ce
MacAddress  : 00:50:56:89:04:91
Identity    : beeaac63-29d7-4439-8767-5f07db4d33ce
IsValid     : True
ObjectState : Unchanged

RunspaceId  : 5718e5ea-e17d-4d74-b5d7-bcf5dc666608
Name        : vmxnet3 Ethernet Adapter
DnsServers  : {10.2.8.30, 10.2.8.24}
IPAddresses : {10.10.10.17, fe80::993c:566f:7bfc:b44a}
AdapterGuid : 05367732-b9a2-486d-80fd-dcf33380802b
MacAddress  : 00:50:56:89:7E:9B
Identity    : 05367732-b9a2-486d-80fd-dcf33380802b
IsValid     : True
ObjectState : Unchanged

RunspaceId  : 5718e5ea-e17d-4d74-b5d7-bcf5dc666608
Name        : Microsoft Failover Cluster Virtual Adapter
DnsServers  : {}
IPAddresses : {169.254.2.174, fe80::889b:965a:3900:fc98}
AdapterGuid : e5873df1-c2a9-4d40-9b70-10024f0f089e
MacAddress  : 02:1A:83:54:CB:41
Identity    : e5873df1-c2a9-4d40-9b70-10024f0f089e
IsValid     : True
ObjectState : Unchanged

Open in new window



Any deas?
0
Hi,

we use veeam for our backup solution in the datacenter. We backup our Hyper-v hosts to a veeam backup and replication server. This server is located in the same datacenter. After this backup we use cloud connect to send the data to another location.

Last week someone told me that the cloud connect solution is not so good as if the original backup i take is corrupt then the cloud connect copy is also corrupt.

He told me that we need to setup a second backup and replication server and then take a second backup with that server.

when i told veeam about this they told me to use the sure backup option. we have the enterprise license and this is included they told.

what are your ideas over this? What to do to make sure we take correct backups.
0
I'm trying to add a VM to a user in Exchange and I keep on getting this error.  We use 3CX as our VoIP system, in a VM, and Exchange is where the VM is stored.

Starting yesterday, when I try to add a VM to a user, I keep on getting this error. NO changes to my 3cx server or Exchange, so this is odd.

I checked my event logs app/system, and didn't find anything that would point to an issue.  
Also did a wireshark capture for 10 seconds on my exchange during the time I received the error, and still, I didn't see any issues in the wireshark that could be a problem.  
I looked on my 3cx system, in the logs, and nothing shows up there as an issue.

I don't think this would have anything to do with it, but my manager disabled TLS 1.0 on our exchange server to make it more secure, so I doubt that would have anything to do with it?

Not sure what else to do, any thoughts?
exchange VM
0
Hi,
I am using ESXi 6.0
I see a warning "vSphere HA failover operation in progress in cluster XXX in datacenter DC YYY: 1 VMs being restarted, 0 VMs waiting for a
retry, 0 VMs waiting for resources, 0 inaccessible Virtual SAN VMs". Apparantly, all VMs are up&runnig (according to our monitoring), so I assume this is cosmetic.
Anyway, how can I identify which VM is restarting?
Thank you
0
Hi There,
I am running a server 2012 r2, of which I broke up the nic team to test performance difference. Now I am stuck with a virtual ethernet adapter that I need to remove in order to redo the teaming. The cmdlt for "vmnetworkadapter" is not working.
0

Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.