Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.

Share tech news, updates, or what's on your mind.

Sign up to Post

We have a HP DL360 Gen 9 running HyperV on Windows 2012 R2. Approx. 1-2 times per month the server will be unreachable via remote software (RDP or Dameware).
Prtg monitoring will show all sensors as Red. The server still responds to ping.
During this occurrence, all VM Guests remain fully accessible and function normally.

Using the Servers ILO remote console, we can see the Welcome screen where you would press Ctrl, Alt, Delete, but we are unable to send any remote hot keys or send Ctrl, Alt, Delete from the ILO menu's.

The only option we have is to remote onto the VM Guests and power them down, and then reboot the Physical server via the ILO

We have another 2 identical servers at other sites that are on the same latest SPP and configured the same way that are unaffecting, so drivers/firmware doesn't seem to be the issue.

Looking at when PRTG monitoring first flags an issue is usually around 03.00am, the only thing doing any work at that time is Veritas Backup Exec
The windows event log for that time frame, lists Event ID 3, Filter manager failed to attach to volume \Device\Harddisk2\DR183. The final status was 0xC3A001C

After a reboot and the server comes back up, everything works but we still get the filtering error.

The mentioned Event ID3 may be a red herring as we also get the event on the other two working servers

regards, Rick
0
I'm having an issue opening a Word 2016 document in Protected View I was hoping for some expertise with.

When I try to open on local drive, I"m getting this error:
OS Not Configured
I then look at the properties and have the option to "Unblock" in the security settings as shown here:
Unblock
Issue:

    This does open in "Protected View" on another workstation I have but NOT in my VDI environment.

    • All policies are the same, and "Protected View is Enabled in both environments - therefore the issue is I cannot open in Protected view in my VDI environment - on LOCAL storage.

    • Note 1:  If I copy the file to One Drive, or Sharepoint online and open with either Word or Word online - I do not get the error and it opens without being in protected view.

    • The only real difference I have noticed is with "Trusted Publishers".

    1. On a workstation where it opens without issue in Protected view, here is what the Trusted Publishers looks like:
    2. trustedpublishersworking.JPG

    1. On my VDI, where this does NOT open in protected mode and errors out, this is what my Trusted Publishers looks like:
    2. trustedpublishersNOTWORKING.JPG

    Other than turning off protected mode in each app for 2016, is there a reason for this or other work-around or explanation?

    Thanks in advance experts!
    0
    Hi all and happy Sysadmin Day!

    I have a hyper-v 2012 R2 host. I'm backing up one of the VMs and noticed that Veeam is only backing up the C: VHD disk, it's not backing up the other VHD disk which is H:
    what could I look at to determine why it's not backing up the 2nd VHD disk on this VM?
    test.png
    0
    We have a production site and a DR site.

    We have Veeam installed on the production site. Among others, Veeam replicates the backups and the virtual machines to the DR site.

    As part of the replication jobs, I would like to know if we can replicate the Veeam backup server to the DR site and if there is any best practices that must be followed for such scenario.
    0
    In VMware, is there a way to emulate disk drives that reside in a canister that connects to the back of an ESXi Server?

    We have some VMs on a 6.0 vSphere system that accesses a real canister of disk attached to an ESXi Server.  I think RDM is used. We do not have the canister and cannot obtain one or attach it to our ESXi Server

    Is there a way to emulate the disk drive connection in VMware?

    Possibly by using datastores, shared drives, or even a USB device (RDM) ?

    thanks
    0
    Hi,

     I have a Hyper-V virtual machine "TS3" running Windows Server 2008 with 278GB space allocated, but only using 100GB of space.

    So I wanted to shrink the VHDX size. When I ran "Shrink" option in Disk Mgmt.msc, I got an error "Access denied".

    I tried different suggestions on Google, but to no avail. So I ran Disk2VHD in TS3 and it created 72GB VHDX file.
    Then I created a new VM "TS3 - VHDX" using existing 72GB VHDX file. But when I fired up the new VM, it still shows that hard drive size is 278GB in "My Computer".

    Furthermore, when I tried to shrink it using DiskMgmt.msc, I still get "Access denied"error.
    I don't mind seeing 278GB in "My Computer" of the VM as long as real size of VHDX is till 72GB.

    My objective is to reduce the VHDX file and free up overall hard drive space on HyperV server.
    But I am curious why the VM would not display current HD size based on VHDX file size?
    0
    i have an ubuntu 18.04 (upgrade from ubuntu 16.04) it was menber of domain as ubuntu 16.04 (in samba active directory).
    After upgrade i can't see this server in my dns. but it's there because i can't add it as a new host. dns error: "the record alredy exists.)
    it's take min. 5 minutes to login via ssh to server.
     what should i do? what is wrong?
    in var/log/auth.log is error entry every 2 min. pam_unix(cron:session): session opened for user root by (uid=0) then after 2 min. pam_unix(cron:session): session closed for user root
    0
    Trying to install Volume Activation Management Tool on a 2012 R2 Virtual server.  I installed the VAMT from the Windows 10 ADK.   This VM did not have SQL installed.  When I opened VAMT and it prompts to install Microsoft SQL server express and I chose to do that.  It installed SQL Express 2017.  When VAMT tries to connect to the VAMT database, it opens the database connection settitng dialog.  I have tried to enter the current VM name as the server and VAMT as the database name and if fails with this error:
    "A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible.  Verify that the instance name is correct and that SQL Server is configures to allow remote connections.  (Provider: Named Pipes Provider, error: 40. Could not open a connection to SQL Server).
    I have no idea on what to do with SQL, I have never installed on a Virtual server so maybe that is the problem.  In the past on other servers, after choosing to install SQL, I have been able to create and connect to just by using the servername and 'VAMT' in the database connection.
    If you can point me in the right direction, it would be greatly appreciated.
    0
    I am using VMPlayer 15 to run a Windows 7 guest operating system on a Windows 10 PC.  I have been having problems with the guest OS lately that I can't explain.  The guest OS runs very slowly, there have been network connection issues, there have been problems using multiple monitors and most annoyingly, the mouse seems to randomly switch back to the host.  My "gut" is telling me that the guest is to big for the host.  When I say too big, I mean that the guest is configured so that it is more powerful than the host can handle.  I am not even sure if that is possible using VMPlayer.
    0
    What is the minimum requirement for a server CPU  in terms of cores and Hertz.
    I speak about a windows 2016 server which it will work only as file server without any virtualization

    I think a 10 cores cpu at 2GHz it will be ok. Isn't it?
    If not what are the minimum requirement?

    In another case for a server with 2 VM what are the minimum requirement for the CPU?
    0
    Citrix XenDesktop 7.15 CU4, MCS, Windows 10 Persistent VDI, Local User Profiles, VMWARE ESXi 6.5,

    What are the options we have to update regular Windows Security patches and Install Applications on VDI's with some automation?

    Regarding Process and technical details.
    With SCCM and Without SCCM.
    0
    In Vsphere 6.7 where on earth are the Advanced CPU HT Sharing:  Options!!!!  I have looked in both the HTML and Web client and cant find these options!

    Here is a screenshot from Vsphere 5.0 console showing clearly where these options are located:
    Edit VM
    Can anyone help point me in the right direction?

    I need these same options because I do not want to share any CPU with any other vm so I need to find this same option in Vsphere 6.7 and choose "None"

    Thanks
    0
    This is a SuSE 11 with SP3 virtual machine. In /var/log/message, i found a line as follows,

         "2019-07-19T17:03:17.852797+08:00 zlnx01 org.a11y.atspi.Registry[24075]: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server "localhost:10.0"")

    What is this error about? Does this refer to the "X windows" of sshd. btw, only sshd is running (remote desktop). This error only happens once. Does this sort of soft error?

    Thanks in advance.
    0
    I am trying to retrieve user input from a form in my PHP web app so that i can assign these values to variables with the $_POST[' '] command. Then, i want to make changes to a database with the values retrieved. But my problem is that the $_POST[' '] command is returning empty values for every field i put information in..
    To put into context, i am using Oracle VM VirtualBox with a Linux VM, and within this i use the Eclipse Workspace to code my program. Here is the php file with the code that is not working:

    <?php 
    require "init.php";
    
    if(empty($_SERVER['CONTENT_TYPE'])) {
        $SERVER['CONTENT_TYPE'] = "application/x-www-form-urlencoded";
    }
    
    if (!isset($_SESSION['NOM_UTILISATEUR'])) {
        echo "<script>alert('Vous n'êtes pas actuellement connecté ! Redirection vers la page de connexion ...');
        window.location='index.php'</script>";
        session_destroy();
    }
    
    $_POST['SELECT_ENCAN'] = "";
    $_POST['DESCRIPTION'] = "";
    $_POST['TITRE'] = "";
    $_POST['DONATEUR_MAJ'] = "";
    $_POST['VALEUR'] = "";
    $_POST['PRIX_INITIAL'] = "";
    $_POST['INCR_MIN'] = "";
    $_POST['ACH_IMM'] = "";
    $_POST['PHOTO'] = "";
    
    $select_encan = "";
    $titre = "";
    $description = "";
    $donateur_maj = "";
    $valeur = "";
    $prix_ini = "";
    $incr_min = "";
    $ach_imm = "";
    $chemin_photo = "";
    
    $page_ajout = $_SESSION['Ajouter'];
    $page_maj = $_SESSION['MAJ'];
    
    if ($page_ajout == true) {
        if (isset($_POST['OK_MAJ'])) {
          
            $titre = $_POST['TITRE'];
            $description = $_POST['DESCRIPTION'];
            
    

    Open in new window

    0
    Core 2016 Hyper-V with VM DC, network adaptor showing no IP address. The hyper V management console will no longer connect from my workstation. It is the only DC in our network which is just a few computers. I can see the machine is running on the host but the IP address is showing as {}

    Is there a way I can set the IP address of the adaptor on the host? All searches on Google say it should be done from the Management console.
    0
    I have a full Windows Image Backup of a server running 2008 Standard. I need to create a virtual machine (hyper-v) from this backup. I have done this before, but I can't remember what I did. I know boot up with an ISO and go into system restore, but once I get there I cannot access the USB media that contains the backup. Any suggestions!?

    The server im trying to restore was a standalone server.
    0
    I have recently recreate a 2016 VM template.  The two server being deploy both have a problem - WINDOWS UPDATES DOWNLOAD STUCK  AT 0%.

    Please advise if anyone has an idea of how to fix.  

    Thank.
    0
    We want to deploy a simple VDI infrastructure based on Windows Server 2019 RDS.

    We have a two node S2D cluster and we would like to know if we can use this cluster as the RDS virtualization host.
    0
    I want to setup a Hyper-V virtual server on a Server 2012 or 2016.  My understanding is that they both allow for 2 VM licenses.  Do these licenses include the server license to install on the VM.  Do you use the same product key as the server.  Having a difficult time finding the information on the Hyper-V licensing.  Seems like there are many different opinions on what is included and how it all works.
    Any help would be appreciated.
    ArtW
    0
    This is about the new virtualization using VMware with simplivity hyperconverge. My parent company is heading toward this direction, probably with HPE hardware solution. We are looking for 6-8 hosts implementation. Where can find more and further information about the technology?

    Thanks in advance.
    0
    Windows server data volume sizes - thoughts?
    Hey there - we have an older windows server with about a 900GB partition for data that is about 90% full.  Actually setting up a new VM, and creating the volumes.
    Anything I should take into consideration about watching the sizes of the vmdk not concerned here really about size limitations of the vmdk, but from a Windows Server data volume size perspective.  Is there a point if I were to go to 1 or 2 GB that it could take excessively long to defrag, or any concerns about integrity?  I would think not. but just wondering.

    Thanks guys!
    1
    Hi

    I built a new Windows 2019 VM by cloning the Server template and when I went to configure the IP address, I was not able to see the network adapter .
    I went to device manager and on the Ethernet controller, it has an exclamation mark.
    Please see the snapshot, do I need to install any drivers, and do I need to choose a different adapter.

    Please help any tutorial will be great.

    Thanks
    Lan-properties-snapshot.jpg
    0
    i am using below powercli command to grab all vm uptime

    Get-Stat -Entity VMNAME -Stat sys.uptime.latest -Realtime -MaxSamples 1

    Then i getting the VM uptime in the output

    How to display the VM name itself along with the uptime output
    0
    Hi

    I created a windows 2019 virtual Machine through VSphere client 6.0 .
    I copied the ISO to the one of the DATA store and from the Vsphere client - file  and created a virtual machine .

    I noticed the VM was installed and when completed it booted and now it stays in the attached scree.

    Please let me know how to resolve this , so that the VM boots into window.

    Thanks
    Server-2019-startup-screen.jpg
    0
    I am moving some roles from a physical server to a virtual server and was wondering what the order of operations should be. I have a physical server that is a domain controller (no fsmo roles), network policy server and a certificate server. I will have the same roles on the virtual server. Both servers are running Windows 2016.
    0

    Virtualization

    18K

    Solutions

    11K

    Contributors

    Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.