Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.

I had this question after viewing Trying to boot Virtual Machine getting "Deleted invalid filename (5) in directory -588626008".

Hi all, a few months went by and I rebooted the server after migration and got the same error.

tons of the following.
Deleted invalid filename (5) in directory -588626008

It had rebooted a few times OK, now this.

Andrew had mentioned that I should have ran an sfc on the old server first, but I got around it via finalizing the conversion, so I never did that.
0
How can you dedicate one NIC in Windows 10 to VMWare Workstation?  In a nutshell I want the data to flow through the card (it has a dedicated IP via MAC DHCP address reservation in Tomato router) to the VM.
1
The page says: With Converter Standalone, you can convert remote powered on machines, powered off VMware virtual machines and Hyper-V Server virtual machines.
https://docs.vmware.com/en/vCenter-Converter-Standalone/6.2/com.vmware.convsa.guide/GUID-377C42CF-B7EE-4D32-9BC5-D0648050B9AE.html

It also says:  For information about the interoperability between vCenter Converter Standalone and powered off hosted VMware Workstation and VMware Fusion virtual machines, see VMware Product Interoperability Matrices.

I tried the "VMware Product Interoperability Matrices" at https://www.vmware.com/resources/compatibility/sim/interop_matrix.php#interop&216=&28=&455= but it seems to only support Workstation 14 and up.

Does this mean I can convert via the 'remote powered on machine' method?
0
Hi
Im trying to install server 2016 on a VM on hyper V, without any success
I keep getting boot failure, reboot and select proper boot media...
Ive tried Gen 1 & 2 vms no success
Ive tried the Virtual DVD drive point to ISO on Hyperv Host and from bootable USB but still no success
where am i going wrong
Thanks in advance
0
VMWare Storage: VM using 4.7Tb when disks add up to 2.8Tb and there are no Snapshots. How can I find out what is using the extra disk space?
VMware Version 6.0

The VM has 5 disks total of 2.8Tb No snapshots
Provisioned storage: 5.08Tb
Used Storage 4.77Tb

Why is this so high is there some orphaned disks?
0
Hyper-V running on a Win10 Pro PC. Host and VM share the same NIC.  Recently RDP stopped working to the VM.  After someone tries to RDP in I have to force "Turn Off" the VM in the Hyper-V Management Console and then it allows me to connect via Hyper-V Manager until someone tries to RDP in to the VM again.  VM locks up and have to "Turn Off" again.  Tried removing and recreating the virtual switch and when I didn't that the VM allowed me to connect via HV Manager without having to hard power off.  I've poked around the network settings on the VM and host and haven't been able to figure out what might be causing this lock up.  Nothing jumps out at me from Eventvwr.  

Anyone heard of something like this?
0
I have a hyper-V server running 2012 R2.  20 cores and 256 gigs RAM.  On the host is a VM (server 2016) with 8 cores and 64 gigs RAM statically assigned.  That server runs an SQL 2016 application for route automation.  The VM is five days old, just built, prepped and put into production.

There seems to be a memory problem.

Every day since install, the RAM works it's way up to 97% and the server becomes non-responsive.

Task Manager, Resource Monitor and RAM Map DO NOT show any process using this RAM.

I repeat, the process using the RAM does not show in task manager, resource monitor or RAM Map.

I'm having the dickens finding out what is eating up the RAM and need someone to make some suggestions that might help me zero in on this.

I've thought about the 2012 R2 host and the 2016 VM and maybe its a hyper-visor issue, so, anyone know any issues with 2016 running in a VM on 2012 R2?

Anyone have any software they know of that might show me where the RAM is allocated that is not showing in the programs mentioned above that I'm using?  Something other than RAM Map maybe?

Anyway, that's the ghost I'm chasing.

Thank you for any feedback you might have.
0
Azure Site Recovery / Zerto or Veeam?

Hello

Im investigating and testing replication of a test VM we have in azure and failing miserably.  Current production config:
  • Site to Site VPN from our on premise site(s) connected into UK South Azure region.  
  • 10.0.0.0/16 address space.
  • All production resources (Domain controllers only so far) located here.
  • A test SQL server VM stored here 10.0.0.11 and being replicated by ASR to UK West region.
  • dedicated ASR vnet used at the UKWest site.
  • A dedicated failover vnet also used for the failover replica.

I clearly must be missing something.  I have yet to failover, but understand that the replica VM can have the same IP address as before but its recommended that it doesn't (depending on the address space and subnet?

Also am i right in saying we must either add vnet peering between UK South and UK West?  A VPN connected to UK West should UK South go offline or just allow external WAN IP access?

There doesn't seem to be much simple standard information for ASR.  I was hoping this would be easy and simple.  Which leads me onto Zerto and Veeam (currently using), is anyone using this in an azure to azure setup?  If so any pointers over ASR?

Thanks
0
Hi,

I'd need to upgrade some software on a vm, the software uses backend SQL.
I can take a snapshot of the vm, but how do I backup (restore?) the SQL (2008)  in a quick & simple way?

J.
0
I have a vm in hyper-v host that I tried to restart a service stuck in stopping mode. After waiting minutes I used task manager to kill the service. In Services.msc was still showing stopping. I then tried to restart the vm using shutdown cmd from hyper v manager. Shutting down got stuck too . After few more minutes I used Turn Off cmd in hyper-v manager. When I tried to start the machine I got the attached error. I would really appreciate any help on this, having this production vm down for a while now. Thank you,

screenshot of error

Gabe
0
Is there a way to clone the image of a VHDX file to a physical drive to restore an image of W10 pro?
0
Afternoon all

I need to update a VMHost which has the correct base install but I need to update it to a newer build. I want to do this manually and as far as I know you can drop the zip file or the folders within the zip file over to the host and run  "esxcli software vib"

Anyone got a really quick, this is how to do it thing?

Thanks all.

Alex
0
I have a DXZ4 Amulet Hotkey PCOIP Device but im not sure if you can use that to connect to a VM Host directly (PCOIP Technology)? If not what is a great thin client out there that uses RDP to connect to ESXi hosts?
0
hey guess, we had a muck up.
The backup server accidentally turned on a VM thats a domain controller (hostname ADFS which is win2008r2), so we had 2 of the same VM running at the sametime, so it caused a duplicate existence -  Active Directory and replication didn't like that (also the GC got messed)
note: main DC is called NEWDC (win2016)
here's what DCDIAG and dcdiag-failure.txt

here is repadmin - repadmin-fail.txt

1) I ran repadmin /showrepl and it showed replication failure, so i thought resetting the burflags for replication would help. I did this article for non-authoritative restore.
https://support.microsoft.com/en-ca/help/290762/using-the-burflags-registry-key-to-reinitialize-file-replication-servi
   a) after this atleast the repadmin /showrepl command showed all Replication - Succesfull but later when i reset the server it all failed again. Replication will go back and forth between failed and success. Currently at 930pm it shows 'successful' but it will fail again. repadmin-success.png dcdiag-flipssuccessfulshortly.txt
2) when running DCdiag it gave a list of errors including SYSVOL not being online, LocatorCheck, all failing.
3) when i try to open Active Directory and Users on any DC it gives AD-not-opening.png

Whats the best way we can get replication to start from the other NEWDC and fix ADFS??
0
I have HyperV installed and I have a working windows vm.  I need to install SQL 2014 Developers edition but it is not an iso, it is a exe.  How to I install SQL inside the VM?

Thanks,
John
0
Hi,

Finally, My Dell Power Edge R 510 is running Windows Server 2019 (actually, it is a straight forward installation).

Now, I want to install VM machines in this server.

As Dell Server, my experience in VM machine is also limited.
Can somebody direct me what would I do to create the Hyper V server 2019?

Thanks,
tjie
0
Sharepoint 2013 SP1, Virtualbox, Windows 2012 R2

I am trying to install SharePoint on Virtualbox for a testing area.  I have done this before successfully but I am having what appears to be a common problem (a google search provides hundreds of solutions).  The problem is getting the AppFabric installed as a prerequisite.  The prerequireinstaller fails with an error or states that the AppFabric step was skipped.

I have always good luck with EE for solving problems, so let me know what you have found to overcome this problem.  Let me know if you need more details

Thanks
0
Dear All,
I am monitoring ESX logs on a test environment,however I am receiving lot of logs
I need to focus on security logs only
What kind of logs should I look for?Any help?
IN case i want to know if a virtual machine was created,where to look for?
Any tips on monitoring a vmware ESX?
Regards
0
I had this question after viewing how to truncate Exchange 2016 DAG DB transaction log..?.

We are considering implenting a DAG environment.

How does application aware backups using products such as veeam etc impact DAG members that utilise replay lag times and passive dag members?

eg - is there a chance of replay not being healthy if for example the backup job truncates logs but the copy was in a bad state?
Should i be backing up the passive node instead?
If i backup the passive node, what happens to the logs on the active, passive and replay lagged database copies?

All very confusing.
0
How to perform a specific VM Disk Consolidation using power cli

Get-VM "MyVM" | which command need to be use after the pipeline to perform disk consolidation
0
I need to take a windows 2016  VMWare  VM (in my laptop)  to Azure cloud . Microsoft support comes up with some steps , But it looks like I need to have an ESXI server for it .
0
How can I create a VHD file from a VWWare Virtual machine  with Windows 2016  ( The VHD file later need to be taken to Azure Cloud)
0
Hi, I am using VMware cluster (ESXi 6.0).
I just created a VM and I noticed that Network adapter option is greyed out.
I created ANOTHER VM, and I got same results.
"Connect on power on" icon seems normal,  but "connected" is not.
Any suggestion?
I am using DVS (distributed virtual switch)
0
Running into a major issue with one my of virtual machines that is running exchange 2007 server. Out of nowhere, I've gotten this message twice now in the last few weeks. The error that I'm getting is this "msg.hbacommon.outofspace there is no more space for the redo log you may be able to continue this session by freeing space". The only thing that gets rid of this message is powering off the server completely and powering it back on. After that the exchange server will start working again without any error messages for a few weeks this issue has happened twice and both times this is the only thing that has fixed the issue. I went through the snapshot mananger and found a snapshot for a virtual machine we never use anymore so I started the process of deleting the snapshot for that machine. I'm sure this issue will come up again and I'm trying to figure out how to fix this problem.

My current system is a Dell PowerEdge 2950
Running VMWare ESX Server 3.5.0 64607
I have 6 Virtual machines attached to this server

I have 2 Virtual Machines that haven't been used in over a year that could be deleted but I'm not sure what is the correct process of deleting a virtual machine and gaining back the space and not harming anything else in the process.

If somebody could give me some suggestions on what could be taking up the space in my virtual server and how I can clear up some of that space?
Also my data storage says it has a data store of 1.35TB and I only have 14.2 GB of…
0
I currently have a site where we had originally purchased a 3-2-1 (3 servers – 2 ISCIS – 1 SAN) solution back in 2012. The SAN was upgraded about 4 years ago, but we are really at a point where we need to do a full refresh. Overall the setup has been good and haven’t had any major complaints from end users.

Due to the single point of failure and latency sometimes incurred during backups, large upgrades to our application server which uses SQL, and RDS use, I was hoping to move away from SAN and use local storage while keeping the HA / vMotion features.

Obviously, VMware’s vSAN came straight to mind even though I knew I’d basically have to purchase all new licensing (Currently Essentials Plus) and vSAN.

We will be replacing all our Windows 2008R2 VMs with Windows 2019 but here is a quick overview of performance:

RSR-Overview.png

RSR-Disk.png
After the upgrade it be similar to another site and VM count.
GPT-Overview.png
GPT-Disk.png
Overall we should not have over 12-15 VMs. There will be 1 RDS server which will probably have around 32-64GB of RAM but I usually dedicate a host for that VM.

I called my Dell rep and tell them about the refresh and budget I’m trying to stay in for hardware and any VMware licensing and of course they come back with the vxRail solution, Enterprise Plus Licensing, etc, with a price point 3x my budget. I feel like I’m talking to a car salesman looking to see how much they can get out of me and…
0

Virtualization

18K

Solutions

11K

Contributors

Virtualization is the act of creating a virtual (rather than actual) version of something, including (but not limited to) a virtual computer hardware platform, operating system (OS), storage device, or computer network resources. Virtualization is usually the creation of a system that executes separate from the underlying hardware resources, or the creation of an entire desktop for systems located elsewhere, similar to thin clients.