[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More







VMware is virtual machine software that provides a virtualized set of hardware (a video adapter, a network adapter, and hard disk adapters) to the guest operating system. VMware virtual machines become highly portable between computers, because every host looks nearly identical to the guest. In practice, a system administrator can pause operations on a virtual machine guest, move or copy that guest to another physical computer, and there resume execution exactly at the point of suspension. VMware's enterprise software hypervisors for servers, VMware ESX and VMware ESXi are bare-metal embedded Hypervisors that run directly on server hardware without requiring an additional underlying operating system.

Share tech news, updates, or what's on your mind.

Sign up to Post


normally Broadcom/qlogic has a relatively strict driver-firmware compatibility.

For VMware ESXi 6.7, this is also shown in the compatibility matrix for the “tg3” driver

But for the now default ntg3 driver, the recommended firmware is listed as “N/A”

Any experience with this combination?

Or is the tg3 recommended over the newer ntg3?

(NIC is Broadcom BCM5719)
Acronis Data Cloud 7.8 Enhances Cyber Protection
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

Just installed new Esxi host running 6.7. Everything looks green.  All datastores are present.  All networks have portgroups.  But when i try to vmotion i get :

Failed waiting for data. Error 195887167. Connection closed by remote host,

I confirmed vmotion enabled on iscsi and management portgroup just for sake of troubleshooting.   Any help would be great

We have NetApp SAN and 3xFujitsu PRIMERGY ESX host servers and Brocade switches and Cisco switches.
and using VMware - vCcenter appliance.

SAN has two power supplies and
node A power supply is connected to UPS-A
node B power supply is connected to UPS-B

Each of Fujitsu PRIMERGY(ESX)servers have 2xPower supplies  
Each of the PRIMERGY ESX server power supply is connected to UPS-A and UPS-B

Core Cisco switches have 2 power supplier and each of the power supply is connected to UPS-A and UPS-B.

Brocade switches (storage switches) have only one power supply each.
Brocade switch –A is connected to UPS –A
Brocade switch –B is connected to UPS –B

The power maintenance is scheduled by local company and we will not have power for 30 minutes. We have APC UPS  and  APC virtual appliance is setup to power down the servers in a power failure situation when the ups running out of the battery, but this has not been tested on a real-time.
I am hoping the servers should run for 30 minutes on the UPS. But if it exceeds this time I want to power off the server’s safety.

On all the 3 ESX servers , can i power off all the guest machines  and then power off the 3 ESX server one by one - to save power .
So that SAN and brocade switches and core keeps running?
Please let me know the sequence of powering off the server.

Any suggestion will be great
How can we set our VMware hosts to be not fully managed by vCenter while still remaining connected to it?  Here's the background:

We have a number of VMware ESXi hosts running v6.0 and v6.5.  After we recently removed our last v5.1 host, we installed a new vCenter server appliance v6.7 to replace the existing v6.0 vCSA.

The problem comes with Altaro VM backup, which always backs up through vCenter if the host is connected to one.  Despite saying that the versions we're using are supported (http://support.altaro.com/customer/en/portal/articles/808716-what-are-the-system-requirements-for-altaro-vm-backup-) in fact the combination of vCenter >= v6.5 and hosts v6.0 is not supported (http://support.altaro.com/customer/portal/articles/2949256).

Now Altaro support suggested that it's possible to work around this by setting the hosts to not be fully managed by vCenter.  How do we do this?

The alternative is to downgrade the v6.5 hosts to v6.0 and use a v6.0 vCenter Server Appliance, which we'd rather not have to do as it means we can't use any hosts of v6.5 or later.
Hi Experts

I have Dell T410 located in data center, running ESX 6.0.0 5224934. 64GB of RAM and 3 disks (each is physically consisting in 2 disks mirrored).
suddently after running without any problem over 2 years, ESX restarted itself yesterday 12NOV2018 at about 21.15

I have downloaded all the logs available and they are with me.

Can you advice what had happened? How to find cause of problem?

Many thanks

V3700 Remote Mirroring

vmWare Essential Plus V5 - 2 hosts
Storage Lenovo V3700 v2 - iSCSI

I Need a solution of Disaster Recovery, so I will acquire other storage V3700 and active the feature called Remote Mirroring.  With this solution, all datas will be replicated in two storages.

Imagine the primary Storage fail. What will happen to VMs?
How do I configure vmware essential plus to VMs will be running in other storage ( mirrored)


I am trying to reset the local admin password for Windows Server 2K16. The only account that has access to the desktop is a basic user account so I am unable to make any changes in the GUI (lusrmgr.msc). I tried to boot to the windows recovery prompt but I can not seem to find the drive with the local os installed. Below are the following drives that I can see in recovery cmd:


How can I get C, or the hdd with the actual os to show? I do have a \windows\system32 folder in X but there is no utilman.exe file. This is a VMWare box if that helps

Thanks in advance!
I have a two node plus witness cluster set up in VMware 6.7. The system is currently failed over to one host due to a bad vSAN network card in the other.

While waiting for the HW vendor to ship me a new card, I had to add another VM. It worked, but when I try to power the VM on, I get:

"No host is compatible with the virtual machine."

I assume it has something to do with the failover state? Is there any way to override whatever is causing the error and get the machine started? I don't think it's a real resource issue since there is plenty of memory and CPU available, but I switch the new VM down to 1 CPU and 512MB RAM just in case and it didn't help.

This environment is not in production, but I don't want to risk the other VMs not coming back if they shut down because other still need to test them.
Hardware: Dell Poweredge R630 - running latest BIOS and firmware.  SD card boot;   Accessories: CD drive;  USB port;  [NO Hard Drive]

Operating System: VMWare 6.5.0    5310538

Problem with sticky boot up when restarting a Dell Poweredge R630 VMWare ESXi host which has no hard drive. [i.e. boots up from onboard SD card] It can take 3 attempts to restart the server which appears to successfully boot through all the hardware configurations but stalls when loading the VMWare environment.  I have spoken with Dell who say that this is a VMWare problem. I am not an expert on this but since the server is running at the moment I was hoping that I might be able to copy the current configuration onto another medium and boot up from it in order to eliminate the SD cards.   Does anybody know how to do this?

If the problem is with VMWare how do I diagnose the likely cause? Does anybody know the best course of action?

Thanks to anybody for taking the time to look at this.
I have a vm 2008 server with a single disk, partitioned into two drives.  The C drive is full.  Does anyone have a step by step guide using VMware Disk Manager to split these into two vmdks?
Big Business Goals? Which KPIs Will Help You
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.


We have Fujitsu Primergy RX200S7 server and the company who did the server consoladitation went into administration.

So sure what is the default password, i tried user name and password as admin.

It is not taking the password:

Please post me tutorials to reset the password. Is this risky procedure?

Any help will be mush appreciated.

Many Thanks
We are in the process of testing VMware Horizon 7.6 and have the following questions.

1) When using instant clones and I need to make a change to the parent VM i.e: display setting in guest etc.. and take a new snapshot, is there any way for me to edit the pool to use the new snapshot or do I need to recreate the pool?

2) I noticed the Windows 10 VM's hang slightly on " Preparing Desktop" which makes sense, do some organization use Mandatory profiles to get around this? We are not using Roaming Profiles.

3) The screen seems a bit fuzzy on some VDI VM's.  Should I adjust the resolution in the parent VM ? Also I do have 3D rendering enabled?
$vcenter1 = 'testw'
$vcenter2 = 'testdr2w'
$names = Get-Content '\\management server name\C$\Admin\Scripts\input\aplist.txt'
#$names2 = Get-Content '\\management server name\C$\Admin\Scripts\input\aplist2.txt'
$snapoutput = '\\management server name\C$\Admin\Scripts\snap-results.txt'
$snapreport  = '\\management server name\C$\Admin\Scripts\output\SnapReport.csv'


send-mailmessage -From $mailfrom -To $mailto -Subject "Snapshot Cleanup - START" -SmtpServer $smtpServer

if (Test-Path $snapoutput -ErrorAction SilentlyContinue)
Remove-Item $snapoutput

Import-Module vmware.vimautomation.core

Set-PowerCLIConfiguration -DefaultVIServerMode Multiple -Scope session -Confirm:$false

Connect-VIServer $vcenter1, $vcenter2 -InformationAction SilentlyContinue

foreach ($name in $names)
Get-Snapshot "$name" | Remove-Snapshot -Confirm:$false
#Write-Host "A snapshot was deleted from $name"
Write-Output "A snapshot was deleted from $name"
) | Out-File -FilePath $snapoutput

get-vm | get-snapshot | select VM,Name,Created,@{Name="SizeGB";Expression={[math]::Round($_.SizeGB,2)}} | Export-Csv -NoTypeInformation -UseCulture -Path $snapreport

i have 2 questions on above snap creation

1) $names = Get-Content '\\management server name\C$\Admin\Scripts\input\aplist.txt'
hi experts

I have a virtual disk which has 120GB disk in the disk it has a 72GB folder
the disk is displaying 2.22GB Left  this is incorrect size it is showing

server 2008r2 En
VMware 6.5

thanks in advance

I have a Veeam VM I used to back up my production host VMs with, as well as replication to a DR box.  I increased the size of the drive for the backups, then realized I need to increase the size of another drive.  vSphere threw an error: 'Cannot complete operation due to concurrent modification by another operation'.

There are no other concurrent operations active on this host, much less VM.   I also looked at the disk management in the VM and it sees the additional space allocated to the first drive.  Oddly though, the 'expand the partition' option is grayed out.

I'm on vSphere 6.7 using vCenter web client.



I can not connect to my VMware Host 3.0 from VSphere Client. I have not changed anything. i can ping the Host Server IPvmware-error-2.png address and connect to it through web browser Https:// but through Vsphere Client it give error as attached in the file. Vmware-error-1.png
Greetings - I do hope this isn't a re-post, I haven't been able to find it anywhere.

I am in need of exporting the file//folder tree for a virtual volume mounted inside VMWare, really any way would be helpful, but CSV is best.
Quick backstory - old boss really screwed the pooch when setting this up, new boss wants it gone, however prior to doing so wants info on what is in here and last mod'd date. In lieu of manually doing this, I've been trying to find a way to export it, to no avail.

Here is the tree in need of export.
Any info would be greatly appreciated.
As I know FT and clone exist in VMware and also ESXI in the cluster for VM's availability. But, VM will reboot at next esxi  when the hardware fails.
Then, What is tVM cluster?
Is it something we have to do at application layer?
I updated our 6.7 VCSA to U1 using VMware-vCenter-Server-Appliance-

The ESXi Host is at build 10302608.

I rebooted ESXi Server and VCSA after the install.

When I login to the ESXi Host and click on VCSA (vCenter), i see the below warning:

The configured guest OS (Other 3.x Linux (64-bit)) for this virtual machine does not match the guest that is currently running (VMware Photon OS (64-bit)). You should specify the correct guest OS to allow for guest-specific optimizations.

If i login to vCenter and click on VCSA (vCenter), I do not see the warning?

What is the casue of this erroor when logging into the ESXi Host and what is required to corect it?

Build an E-Commerce Site with Angular 5
LVL 12
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

Hi ,

I wanna deploy Vmware intregated openstack and found on blog which link is given below. How can i use Ravello, is this free? if not how it will cost money for vio deployment?

any guide for using this ?


Migrating a VM that has RDMs. I want to perform a storage migration of 2 VMs that are paired in a Windows failover cluster. All I am d0in is moving the VM Files to another Datastore.. I am not touching the actual RDMs. Will this pose a problem or will the mappings for the second VM (using Existing Disk for RDM) update automatically?

I am working on attaching OVA file on Web Console of vSphere Client 6.5.
The problem is that attaching the file is stuck in the middle of the process.
(I am using Internet Explore.)

Here are what I am doing:
1. Right click on the machine  and choose [Deploy OVF Template]
2. Move to "Selecting an OVF template" and choose the OVA file from my local PC
3. Move to "Selecting a name and folder" and name the machine /choose a location for the virtual server
4. Move to "Select a computer resource"and click Next

Then,  the screen is stuck with "Validating" screen even if Compatibility check is succeeded.

I  am not sure what I am doing wrong.
I appreciate if you can tell me how can I create virtual machine using the OVA file.

I have a restore of a production server, lets call it ProdAppServer01. The customer wants to have it renamed to another name lets call it DevAppServer01, but remain in it's current state and be joined to the domain for application upgrade testing.
This is a Windows 2008 R2 server.
From everything I have read I am not able to run NEWSID on this server.
From everything I have read, I do not want to run Sysprep.

The customer needs it to be identical to the production server for the purpose of testing the installed software upgrade with the vendor.

If I power on this machine off the network, put it in a workgroup, and rename the server, can I then put this server on the network and domain with its new name and not knock the production server off of the domain?

I tried something similar before. But I put it on the network and changed the name and it stole the OU object for the original server and renamed it causing a production outage. I cannot have this happen again.  I also do not have a development network to test this on.

-Need to migrate off of 5.5 Standard to 6.5 Standard
-Consolidating from 3 hosts (5.5) to 2 hosts (6.5)
-30 VM's total
-Brand new environment...new hosts, new vCenter has already been stood up by consultant, new storage.  
-Networks can see each other...all routable subnets between each other.

Old environment: vCenter 5.5
New environment: vCenter 6.5

I am trying to figure out the best way to migrate these VM's.  There are currently no NFS datastores set up on either end...it's all VMFS5.  The old environment is a 3Par and the new one is a Dell VRTX environment.  Downtime is not an issue, but I am trying to think of a more efficient way to get these VM's moved over besides using OVFTOOL or Standalone converter.  Am I overthinking this?  Should I just present a new NFS datastore from the old environment?
In Horizon 7.6 I am setting up a Instant Clone pool, when I get the screen which allows you to select the AD info the drop down menu is blank and my domain is not listed? Thoughts?






VMware is virtual machine software that provides a virtualized set of hardware (a video adapter, a network adapter, and hard disk adapters) to the guest operating system. VMware virtual machines become highly portable between computers, because every host looks nearly identical to the guest. In practice, a system administrator can pause operations on a virtual machine guest, move or copy that guest to another physical computer, and there resume execution exactly at the point of suspension. VMware's enterprise software hypervisors for servers, VMware ESX and VMware ESXi are bare-metal embedded Hypervisors that run directly on server hardware without requiring an additional underlying operating system.