Voice Over IP

Voice over IP (VoIP) is a methodology and group of technologies for the delivery of voice communications and multimedia sessions over Internet Protocol (IP) networks, such as the Internet. Other terms commonly associated with VoIP are IP telephony, Internet telephony, broadband telephony, and broadband phone service. The term specifically refers to the provisioning of communications services (voice, fax, SMS, voice-messaging) over the public Internet, rather than via the public switched telephone network (PSTN).  Examples of the VoIP protocols are H.323, Media Gateway Control Protocol (MGCP), Session Initiation Protocol (SIP), H.248 (also known as Media Gateway Control (Megaco)), Real-time Transport Protocol (RTP), Real-time Transport Control Protocol (RTCP), Secure Real-time Transport Protocol (SRTP), Session Description Protocol (SDP), and Inter-Asterisk eXchange (IAX).

Share tech news, updates, or what's on your mind.

Sign up to Post

Hello all-

I am primarily used to the FreePBX interface, where you can configure daily PBX backups to an FTP server. However with Elastix, it looks like the built in backup/restore funtcions are a little different. You can set daily backups, but they are local backups to the PBX. You manually have to go in and drag and drop your local backups to your designated FTP server.

Is there anyway to automate this process so we don't need to worry about backups filling up the disk on the PBX and configure daily backups of an Elastix PBX to a remote FTP location?

Thanks!
0
I am planning to upgrade my 5510 ASA pair as described  in the subject.  I am hoping to use the procedure at this petenetlive URL..

http://www.petenetlive.com/KB/Article/0000733.htm

A few concerns.  

Will upgrading from 8.21 to 8.47 and then 8.47 to 9.14 be a good sequence?

Is there any risk to the functionality of my CIsco Proxy phones?  I have about 20 deployed around the country and I am concerned that the upgrade could leave some sales reps without phone service if there's an incompatibility.  Any issues to consider there??

Is there any risk to a VPN tunnel to another ASA 5510 pair which is still using 8.21?  That would likewise be very bad
if after the upgrade I could no longer get to the remote site.  Anything need to be reconfigured on either side after the upgrades?
0
I have set up an IP Phone LAB inGNS3 and VMworkstation. I installed IP communicator software on a couple of VMs, and configured IP Phones on the Router using Command Line and everything worked fine.

Now I want to do the configuration from Scratch on the GUI , instead of Command line.

So I did part of the configuration with CLI, just enough to bring the CME GUI on internet explorer. However if I make any changes , such as setting maximum IP phones and click Set it prompts me to save changes, I do so, but nothing happens on the router configuration file when I run show run.
If I try to add phone from GUI,  I receive a message "No free phone sequence number"

ip
The CLI configuration is as displayed below:
R7#sh run
Building configuration...

Current configuration : 1088 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.137.1 192.168.137.5
!
ip dhcp pool MyPool
   network 192.168.137.0 255.255.255.0
   option 150 ip 192.168.137.2
   default-router 192.168.137.2
!
!
no ip domain lookup
 !
ip tcp synwait-time 5
 !
interface FastEthernet0/0
 ip address 192.168.137.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 

Open in new window

0
Hi EE,

I have 6 people P1, P2, P3,P4,P5,P6 with extensions 11,12,13,14,15,16 respectively.

They are in a hunt group defined as follows:

P1->P2->P3->P4

P2->P4->P5

P5->P6

If a phone call is made to P2 it should go to P4 then P5 and if P5 doesnt answer it should go to the voice mail of P2. How would you configure that on UC520? Thanks in advance.
0
I opened a ticket with our phone vendor about two months ago and we have been struggling with one issue with our Mitel Phone system. We have a user who states that when she picks up phone calls, there about 10 to 15 second delay on when the call connects. This issue will occur for both internal (extension to extension) and external calls.Please note that this will not occur for every call this user receives.

We two offices and we use a feature called hotdesking. This allows a user to log onto a Mitel phone with their office extension they are traveling from. The issue does not occur in our remote location when she logs in.

We have tracked down the issue to only occur in our main office. Ontop of that, it will only occur if they are on the headset.  We do have one other user that see's this issue and reported it.

We have done the following to troubleshoot this issue:

1. Replaced the Mitel Phone

2. Replaced all headset equipment

3. Replaced all Ethernet Cabling

4. Moved the onto a different switch in the office.

5. Recreated the extension and removed all features off the extension.

Note - We can also confirm that the other user that reported it is also on the same type of headset. When they do not use the headset, the issue does not occur.

We have many employee's in the office on this type of equipment and the users who reported it are only these two users.

I have so far found that the issue is in our main office and it is headset related. I am …
0
After upgrading the firmware for a Polycom IP 450 phone we managed to lock ourselves out of the phone and are unable to reset the admin password.

We followed documented steps to press certain key sequences and enter the mac address in lower case which is supposed to reset the admin password to the default of 456  but have been unable to succeed.

Please do you have any idea, do we need a Polycom provisioning server or TFTP etc. setup to work around this issue?
0
Or does it...
At my office there is a Cisco switch (not sure of model) that has QoS configured so that the VoIP phones have high priority. When my PC starts doing cloud backups (Carbonite) it takes up all bandwidth. When we answer a call, the phones "crap out" because there's no bandwidth. Why aren't the phones given priority and my PC knocked down?
0
We have a small company that is going to be moving into a new building. They will have 8 users that all need a phone. They will also have one fax machine. They want to have a main line that all callers dial into of course. They then want 3 or so users to have a direct dial. I have contacted time warner and they suggested that we go with their land line service and they will give us 5 lines (one for fax). I'm trying to find a small, affordable phone system for them. I was looking at the XBLUE X16 6-Line Small Office Telephone System, 8pk but I need an affordable, simple system that is fairly easy to setup since I have never set one of these up before. Any suggestions on what would be a good fit?
0
I am using 2 Windows VM machines with IP Communicator installed on each (IP phone emulator.)
On GNS3 I have cisco router with IOS 12.4, I configured telephony service on it by running the Setup command line.
The set up assigned MAC addresses and line buttons automatically. In real World with real IP Phone hardware that comes with their own Mac addresses , you may have to configure that manually...
I would like to know how to do that ?

I am not sure if I was not supposed to run the command Setup, and type whatever it has prompted to type.

Any help will be very much appreciated.


 Thanks


R2#sh run
Building configuration...

Current configuration : 1519 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.137.1 192.168.137.5
!
ip dhcp pool MyPool
   network 192.168.137.0 255.255.255.0
   option 150 ip 192.168.137.2
   default-router 192.168.137.2
   domain-name wr
!
!
!
!
!
!
!
!
!!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.137.2 255.255.255.0
 duplex half
!
!
no ip http server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-ephones 4
 max-dn 4
 ip 

Open in new window

0
In Cisco Terminology there are Call Manager Express and Unified Call Manager
I would like to know the difference.
which of them I can copy to flash then will enable me to configure IP Phones?
I believe CME is the one I saw Cisco Admins copy to the router Flash and configure IP phones at the router command line, I am not sure about UCM, if it is the same.

I also would like to know which GUI software is used in CISCO to manage IP Phones.

Any Help will be very much appreciated.

Thank you
0
I have CUCM 7.1 and Cisco 7945G phones.  A sales Director wants to be able to listen into calls for training
purposes.  Is there some kind of splitter which would allow two headsets to be jacked into the phone at once?  Or perhaps there's a way that his phone can listen in to the phone of the sales rep in training?  Thoughts appreciated.
0
Hi,

Is it possible to upload prerecorded wav file to Exchange 2010 server as voicemail greeting? Is it possible to do it organizational wide or it must be done user by user?
Exchange 2010 server is used in combination with Lync 2013 server.

Thank you for your help!
0
Dear Experts:

We have installed asterisk and Freepbx for calls , recently forgot the freepbx admin password,  please help step by step on how to reset the password.

I am having ssh access to server and also OS level root login and password is available, please suggest
0
I am going to replace a customer’s old PBX with a Cisco CME/CUE solution.  They just added another requirement, which is huge, and I’m trying to figure it out.  This is a retirement facility.  The VOIP solution was going to be just for the office staff,etc, but we just found out that residents that live in the facility also get phone service via their current PBX.  So they actually provide them phone service and bill them for it. They have direct numbers to the rooms so they can be called directly from the outside.  They want reporting capabilities for the residents, so am researching a call accounting software now.  Can I integrate a 3rd party call accounting software with CME or do I need CUCM?  The business itself if getting all Cisco IP Phones, but that is not cost effective for the resident rooms.  They currently have normal two wire analog phones, and we want to keep them with what they are comfortable using.   Is using an ATA in each resident room the only way that they could continue to use their analog phones on the  VOIP system?  Can I still use the accounting software to look at placed  calls coming from their analog phones that are plugged into the ATA?  The business will have one main number and use CUE as an autoattendent , but residents will have direct numbers.  Any assistance would be helpful.
0
I have a three clients on hosted VOIP solutions, one is ring central, another two are phone.com.  The Ring Central person and 1 of the phone.com person has a delay in the ring or sometimes a disconnect when they answer.  The delay is say 2-3 seconds, meaning  about 5 rings, but the desk phone has only run once and sometime not at all.  The disconnect, to me seems more like the phone is still ringing, but this time, the delay was so long even though the phone is ringing, when they pick up handle, the call is to voice mail already.  To make it worse, this only happens to every 10-15 calls.  The other times, it works exactly the way it is supposed to.  Caller hears one ring, so does the desktop phone.

The second Phone.com client's phone always works as expected, who also has the same cheap SOHO router as the Ring central person, so I don't think it is quality of router.  

The problem Phone.com client has a SonicWall TZ 210.  This client also has multiple phones, and there are times the "hunt" meaning it rings one phone, no answer it goes to the other phone, shows this behavior also.  Example, ext1 rings 3 times, falls to ext2, which doesn't ring until 1-2 seconds after Ext1 stopped. They also observed ext2 to start ringing, but the call came through main line, skipping ext1 entirely.   Or maybe rings once, sometimes not at all then VM light comes on showing they missed a call.  Or when they pick up, the person mentions it rang a few times, even though the desk phone only …
0
We have a problem where some of our Polycom phones which connect through our TZ105 Sonicwall to a hosted PBX will go unreachable.

under VOIP Settings of the TZ105 we have:

Enable consistent NAT
Enable SIP Transformations

However when we look in the log of the FW it says "UDP Packet Dropped" destined for the very device which goes unreachable.  It only does this for one or two of our 17 phones and it seems to change which phone it is periodically.

We set an allow rule for the IP of the hosted PBX and this did not change the dropped packets.  For some reason it is dropping the keep alive packets for just a few phones.    I have not seen a pattern as to which phone it is.

The hosted PBX Is running FreePBX.  I have tried changing the NAT settings on the PBX between Yes, no, never and route without much noticeable difference in behavior.

For some reason one or two phones will not stay registered and therefore not receive calls.  They are able to make calls.

This is my first Sonicwall
0
We have a remote Mitel 5330e phone that has access to our Call Server via our layer 2 VPN tunnel.  The remote site only has 1 VLAN and it's the default VLAN.  We used the DHCP config helper to build option 125 and it still can't get an IP address.  The headquarters where the Call Server is uses VLAN 20, however, I'm able to access the Call Server from the default VLAN 1 on the remote network just fine..  So..  This is why we used the default VLAN ID of 1 on the DHCP config builder.  But..  The remote phone still can't get an IP address.  The desktop computer that is plugged into the phone can..  Any ideas?
0
We have written a softphone in VB.NET that connects to a Asterisk PBX.  In looking at the asterisk database, I see that there is a UNIQUEID for each call.  But SIP seems to use a CALLID field as the key value for calls.

Does anyone know of a way to convert a UNIQUEUID to a CALLID or visa versa?  Or is there a what to have the UNIQUEID passed in the SIP message?  Or CALLID stored in the Asterisk Database?

Thanks in advance
0
We are upgrading from 8 analog phone lines that currently plug into two VIC2-4FXO cards on my Cisco 2821 Voice Gateway router to a voice PRI.  I already purchased a VWIC2-1MFT-T1/E1 for the PRI connection.  Now all I need is an FXS card to plug my fax machines into.  They are going to port my fax number over to the PRI.  We have three fax machines in the office, so I don't believe a VIC-2FXS will work since it only has 2 ports, unless I can somehow use a splitter.  Will a VIC-4FXS/DID work?  The description from Cisco on this card says "Four port FXS/DID Dual Function VIC. FXS mode is default operating mode"  I just wanted to make sure since the part number has DID on it.  Thanks.
0
I am ordering a voice PRI for my office.  I  am using a Cisco 2821 H323 voice gateway router and a CUCM 7.1.5 server.  The provider asked me two questions that I am unsure of:

1.  How many digits do you want to send.  They said I can do 3, 4, or 10.  Can someone please explain this?
2.  What protocol  do I want to use.  I wasn't sure so they picked NI2.  Will this work my an  H323 gateway?
0
We have several users set up through a Cisco Unified Call Manager. All phones go to voice mail after 3 rings. There is one user in particular that needs his phone to ring 5 or 6 times before going to voice mail. I looking through the call manager and the cisco unity that we use for voice mail and do not see a part I can change. Could someone point me in the right direction as to where I could make this change?
2
Hi experts,
my company policy will not allow me to install skype in my laptop (O.S. Windows 7 Enterprise).

Is it possible to use skype without installing the Skype desktop software??

if so, how? and where can I download this version?

Thank in advance!
0
Good day,
We are looking to implement a simple Computer Telephony Integration system. We have a traditional phone line support number where employees pick up the phone. The drawback is that we only have 2 numbers and therefore are limited to two active calls.
We want to switch to CTI so that there would be on ly 1 number to call and several people using headsets could answer, hold or transfer the call.
My questions is how can we make this happen without much of a hassle and on the cheap side.
Thank you in advance !
0
I am running a lab of cucm 8.6 and unity 8.6.   I have them both in seperate vm's on vsphere.  I can see the unity gui web page fine but the cucm wont come up.  It just times out.  Both command lines come up for each but no gui on cucm.  It came up once yesterday and i restarted the vm and now it times out.   TY in advance for any help.

One other thing, i can ping the cucm just fine its only the web part that is not reachable for me.
0
I have a 2 site setup of the Cisco Unified communications system. We are using two UC call managers located at our HQ office. We have a Cisco 2911 router at our 2nd Location that acts as a voice gateway for my India site. I have a few licensing questions. We are expanding the office. We currently have around 60 employees there. We are running around 47 physical handsets and users utilize the Cisco IP communicator. I'm not 100% at the moment how everything is setup as I am remote and have never visited the site. questions below

1. I understand the C2911 router can only support 50 phones. Does that include analog phones as well as Cisco IP phones?

2. When users use the IP Communicator, are they communicating/terminating to the UC call managers or are they communicating/terminating to the C2911 router?


some more detail on the questions. I am concerned about growing over the 50 phone limit. I am wondering if we have our IP communicator setup correctly over in India as it seems we are using the TFTP connection back to the Cisco UC call managers in our HQ office.
0

Voice Over IP

Voice over IP (VoIP) is a methodology and group of technologies for the delivery of voice communications and multimedia sessions over Internet Protocol (IP) networks, such as the Internet. Other terms commonly associated with VoIP are IP telephony, Internet telephony, broadband telephony, and broadband phone service. The term specifically refers to the provisioning of communications services (voice, fax, SMS, voice-messaging) over the public Internet, rather than via the public switched telephone network (PSTN).  Examples of the VoIP protocols are H.323, Media Gateway Control Protocol (MGCP), Session Initiation Protocol (SIP), H.248 (also known as Media Gateway Control (Megaco)), Real-time Transport Protocol (RTP), Real-time Transport Control Protocol (RTCP), Secure Real-time Transport Protocol (SRTP), Session Description Protocol (SDP), and Inter-Asterisk eXchange (IAX).