[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x

Voice Over IP

Voice over IP (VoIP) is a methodology and group of technologies for the delivery of voice communications and multimedia sessions over Internet Protocol (IP) networks, such as the Internet. Other terms commonly associated with VoIP are IP telephony, Internet telephony, broadband telephony, and broadband phone service. The term specifically refers to the provisioning of communications services (voice, fax, SMS, voice-messaging) over the public Internet, rather than via the public switched telephone network (PSTN).  Examples of the VoIP protocols are H.323, Media Gateway Control Protocol (MGCP), Session Initiation Protocol (SIP), H.248 (also known as Media Gateway Control (Megaco)), Real-time Transport Protocol (RTP), Real-time Transport Control Protocol (RTCP), Secure Real-time Transport Protocol (SRTP), Session Description Protocol (SDP), and Inter-Asterisk eXchange (IAX).

Share tech news, updates, or what's on your mind.

Sign up to Post

We are currently in a contact, but our service quality has been bad, therefore I emailed the vendor multiple times asking what the early term fees are, they say 100% of the remaining contract, which is what our contact says, but we want them to reduce it to 50% of the remaining contract since service is bad.

Any recommendations like http://savings.whitefence.com/articles/how-get-out-service-contract-if-you-are-unsatisfied-customer talks about ?
0
We have a Cisco 2921 router using an SRE-710 and running Cisco Unified Communications Manager Express 9.5 and when incoming calls or internal calls are placed on hold a tone sounds, but when the call is parked you head the music on hold as it should be.  Cox is providing a T1 PRI Voice Circuit and below is the associated telephony config.  Any thoughts on why we are not hearing the music on hold?

control-plane
!
!
voice-port 0/0/0:23
 local-alerting
 timeouts interdigit 3
 !
 !
 !
!
!
mgcp fax t38 ecm
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/1.20
sccp ccm 172.20.10.1 identifier 1 port 2444 version 7.0
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register confdsp
 associate profile 2 register xcodedsp
!
dspfarm profile 2 transcode
 codec g711ulaw
 codec ilbc
 codec g711alaw
 codec g729ar8
 maximum sessions 64
 associate application SCCP
!
dspfarm profile 1 conference
 codec g729br8
 codec g729r8
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 maximum conference-participants 16
 maximum sessions 4
 conference-join custom-cptone jointone
 conference-leave custom-cptone leavetone
 associate application SCCP
!
dial-peer voice 1 pots
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
!
dial-peer voice 1001 pots…
0
I might switch to a Microsoft Lync phone system.

What "BASIC" phones do you recommend ?
  ** nothing special, just BASIC
0
I currently have a cisco 2821 router that I have configured for my Voice Gateway Router.  It has two VIC2-4FXO cards in it, with a total of 8 analog phone lines plugged into it.  We are growing out of the 8 phone lines, and are looking at going with a voice T1 so we have more lines and DID capabilities.  Below is what the telco is offering me:

*16 paths for voice/pri/analog lines – thus can handle pri and fax machines
*unlimited local calling
*5,000 long distance minutes; current volume 3582 – thus no overage
*1 toll free #
*100 DID #’s with caller id name and #
*the package has internet on it – only a small amount 1.54mbps
*managed router
*web portal to make moves adds and changes

What kind of card will I need to get for my 2821 router to interface with this?  I'm guessing with 16 paths, I will be able to handle 16 simultaneous calls at the same time right?  I am having a meeting with the telco tomorrow, but wanted to get a heads up on what interface cards I will need and what the configuration will look like.  Any Assistance would be greatly appreciated.  Thanks.
0
I have a cisco unity server 4.2 with a full hard drive. This is the hard drive where we store all voicemail. It is currently full. How do i clean up the voicemail database?
0
We are going to replace our 3COM NBX 100 VOIP phone system this year.  I have talked with some tech consultants and they have suggested that I go with Microsoft Lync for a VOIP system.  They tell me it has alot of other benefits because it integrates with Microsoft software well.  What are your Expert comments on Lync?
0
Can someone please help me with my my issue in which only the toll free 800/600 numbers is unable to call, it is giving a fast busy tone when it has finish dialing. Local and International calls are working with no issue.. please please let me know if you need other details from my side to sort out my issue. Thank you in advance.

Network setup,

Cisco 2811 Router
Cisco Call Manager 4.2
0
HI I resubmitting my question with a bit more meat.   This has driven me insane since a client asked me to look at taking over a Freepbx / Asterisk environment for them so I wanted to build it in a lab first.  I have built both the distribution from Freepbx (Twice) and Asterisk Now iso (4 times) and there is no way that port 5060 is being listened to by the server.  

My Soft phones wont connect and it seems pretty fundamental that the SIP Port is 5060 should be listening when you run netastat and surely the rules of technology state you should be able to telnet localhost 5060.  But no where in any documentation can I see how to get the server listening on this port.

I wondered if it maybe a safety thing you have to enable but cannot see anything anywhere.

Can anyone tell me if they have built from the ISO recently and that Soft phones connect straight away and port 5060 is happy and listening away.  

Terry
0
I have a CISCO SPA 500S attached to a CISCO SPA 504G. The status lights flash amber. All three SIP trunks are registered and the speed dials work. Any ideas as the status lights should be green.
0
Hi Experts,

I am in search of a compatible Microsoft Lync phone that will work with minimum configuration or none at all.

In other words,  We have Polycom CX600 IP phones that works perfect with our system.  The phones configured themselves automatically when users login to their computer with  their credentials, this also opens Lync 2010 messaging software.

What I need is a Basic phone that works with our system without us configuring the phone manually and if that's not possible, then a phone that we only have to configure minimum setups.  We need to install this phones in the hallways/corridors in case of an emergency.   We don't want to use the CX600 IP phones because of its price and because it not connected to any PC.

Any help is appreciated!!

Thanks,
0
Hi -

I'm looking to see what you think should be in a typical SLA for a VOIP phone system.

I have the items below.

Anything missing?

Non-Emergency call time 24 hours
On-site support emergency response time 2 hours.
Remote Support emergency response time 1 hour
Response times indicate maximum amount of time before a technician will be on-site.
In the event of total system failure, X will have temporary service at key locations (e.g. Attendant Station) within eight (8) business hours of determining severity of failure.
SLA doesn't include add, moves, changes.

Term is 60 months, however cancellable with 30-days notice

Pricing of $X after year-one for years 2 through 5.
First year maintenance and support included in purchase price.
0
I’ve been asked by a non-profit to set up VOIP phones for them.  This is in a building that is being setup for Internet by a contractor.  He says that they have dedicated 10MB download speed and 10MB upload speed coming in the building and fiber coming to the non-profit’s office.  The non-profit will have 2MB down and 2MB upload in the office.  I was shocked because to me 2MB download is nothing.  But he said that coming over fiber and having that 2MB dedicated was the equivalent of the 20MB download he gets at home from Time Warner cable.  Can I assume this is correct?

There will be eight ethernet outlets in the room coming from a network switch.  What are my options in terms of VOIP phone service with this configuration? They’ll want to keep their current phone number if possible and they don’t have much money, so it must be relatively inexpensive.

The primary desktop computer/server is a Dell Optiplex 3010 with 8GB of RAM, running Win7 64 bit, if there’s any way to run the phones off of that.

Any suggestions?

Thanks,
Alan
0
Are there any general recommendations for Jitter Buffer settings in Asterisk?

I've searched around, but haven't found much aside from the brief comments in the config files. They just give the defaults but .. no explanations beyond that or description of what impact changes might have - good or bad.


; jbmaxsize = 200             ; Max length of the jitterbuffer in milliseconds.

; jbresyncthreshold = 1000    ; Jump in the frame timestamps over which the jitterbuffer is
                              ; resynchronized. Useful to improve the quality of the voice, with
                              ; big jumps in/broken timestamps, usually sent from exotic devices
                              ; and programs. Defaults to 1000.

Open in new window


Any tips would be GREATLY appreciated.
0
I had installed a cups vm previously (cisco unified presence) but removed it because it wasn't the latest version and we were shuffling our call mgr subscriber and pub around.  Now when i try to install the cups vm i get the message "this node is not the first node in the cluster.  You must first configure this node on the server before you can proceeed."

This is the first publisher in the node.   i'm not sure how it would even go out and check to see if there was a publisher or not because i haven't entered any IP settings from our cucm environment.  any help would be much appreciated.  thx
0
Hey guys,

We have an older cisco 2950 switch that we use for our pc's and servers. Now we are going to add a VOIP phone system.
So i need a POE switch, and also the pc's are going to plug into the phones (non-cisco) to go online.

I'd like to separate the phones and voice into separate vlans. What switch would work for this?
0
Hello I'm working for a company that has about 8 PSTN lines coming in plus another few fax lines, we want to switch to an IP based phone system.
 I was looking at a free PBX system but I'm completely lost as to the big picture , what I need, do I need a gateway for the phone lines can I go full VOIP can I keep the same numbers ?  I just need a good overview I guess. I think I can manage the phone setup it's the PSTN to PBX translation I'm having trouble with.

If anyone can explain or provide some links that would be great.

Thanks
Derick
0
i have Cisco Call Manager Express with Cisco Router 2821 and cisco 7911 phones working with it. Now i want to add new non cisco telephones i.e. Panasonic KX-NT511, how i can register a non cisco telephone with cisco call manager?

thanks
0
We have Citrix XenApp 6.5 installed on Win Server 2008 R2 standard with Secure Gateway 3.3.1

When calling from Skype in Citrix and connecting video calls the receiver cannot see the caller.
But the caller can see themselves on their screen and can see the receiver.

If anyone has any information, guides or documents that provides a resolution to this issue I'd be very grateful.

I have tested this from different computers with different hardware/webcams... same issue.

Thanks
0
I have recently built a SIP softphone in VB.NET using the a 3rd party SIP SDK product.  The backend PBX is an Asterisk.  We currently have our call queues strategies set to “leastrecent” or “random”.   I am finding both of these methods to be fairly problematic as the callers seem to be sitting on hold for 10-30 seconds and not getting passed to the softphones quickly enough.   I am seeing calls are in the queue when users are available to receive them.   I have experimented with the “ring all” queue strategy, but that strategy has the down side of making the softphone users fight over the same call.

Ideally I would like the agents to see that a call is holding and have them click a button on the softphone to try to request the call.  The first person to click the “get call” button would be the one to get the call.  I am not even sure if this possible in SIP or Asterisk.

Has anyone done anything like this before?  If so, how did you handle it.  

Thanks in advance…
0
Based on this documentation section Catalyst 2970/3560/3750—Auto QoS VoIP Model
In scenario we have 3750X and 3560X switches only in medium size LAN and I want to configure QoS for interface with Phone+PC

interface GigabitEthernet1/0/2
 description **** Access Port Phone + PC ****
 auto qos voip trust 

Open in new window


The switch will generate default QoS configuration from the script but question now

If I want to configure another port for Voice and Data do I need to set this?

interface GigabitEthernet1/0/12 
 description **** Mitel IP Phone + PC **** 
 switchport access vlan 10 
 switchport mode access 
 switchport voice vlan 20 
 mls qos trust cos 
 mls qos cos 3                                    ! It will set  CoS "3" for PC 
 switchport priority extend cos 0     ! this will reset CoS "0" in case PC sends hight CoS 
 mls qos trust device cisco-phone   ! will use CDP or LLDP-MED to trust only Phone CoS ?

Open in new window


And on trunk ports between switches should I set

interface GigabitEthernet1/0/3
description **** Trunk Port ****
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 5
switchport trunk allowed vlan 5,10,20,30,40,50
[b]mls qos trust cos[/b]
end

Open in new window


Or I should use MQC?

Could you guide me with steps for basic QoS configuration?
0
Skype Screen Sharing does not allow you to request control or relinquish control by default.  I was wondering if there was a way to do this with an add-on or something?  

It would be faster and less trouble than TeamViewer because when you are on a Skype call and you bring up TeamViewer before letting the person go on the Skype call, it causes all sorts of issues.

A Skype plugin that will perform this function is very necessary.  Assistance is greatly appreciated.
0
I am building a lab environment for my ccnp voice using a 1760 cisco router and an 1841 router
On my 1760 router I am getting the following error message when setting up the t1 controller:
voicertr1(config-controller)#ds0-group 0 timeslots 1-24
%Insufficient DSP resources to create the ds0-group

I checked my inventory and I do have DSP's
NAME: "DSP Module Slot 0", DESCR: "Packet Voice DSP Module Slot 0"
PID: Packet Voice DSP Module Slot 0, VID:    , SN:

NAME: "DSP Module 0", DESCR: "Packet Voice DSP Module with 1 C549 DSPs"
PID: Packet Voice DSP Module with 1 C549 DSPs, VID: 3.2, SN: ICP0642005Z

NAME: "DSP Port 0/0", DESCR: "C549"
PID: C549              , VID:    , SN:

NAME: "DSP Module Slot 1", DESCR: "Packet Voice DSP Module Slot 1"
PID: Packet Voice DSP Module Slot 1, VID:    , SN:

NAME: "FastEthernet0/0", DESCR: "PQUICC_FEC"
PID: PQUICC_FEC        , VID:    , SN:

What should I do?  I also tried decreasing the range of time slots to 1-5 and still no luck
0
Hi Experts,

How can i check what settings are there in Polycom video conferencing HDX 8000.

thanks.
0
I am trying to separate my 255.255.254.0 subnet into smaller subnets for segregation.

I have a layer 2 dell power connect 3448p switch that I have created 2 vlans on 9 for phones and 5 for clients. I have tagged the port my phone is in to into both 9 and 5. Through the config on my phone I have set it to vlan 9 and it has a separate network card for the pc which I have set to vlan 5.

I then have another port which is plugged into my dell sonicwall nsa 2600. In here I have created 2 new zones, Clients and VOIP which are under port X2:V5 and X2:V9. All the routes between my trusted interfaces were created properly and my PC can still talk to the servers on the original subnet and my phone boots up fine both on the correct VLAN.

The only problem is my phone when receiving or making calls only has 1 way audio. They can hear me but I cannot hear them, I have checked all the routes etc and everything seems fine. Does anyone know what could cause this issue?
0
Hello Experts,
I am using Asterisk as a SIP server to make outgoing call. When I dial to any number, the number seems to be appear as some random number which is never configured in any of the sip.conf or asterisk.conf or extension.conf. How to make caller ID appear as what I need to mention. Below are the contents of the sip.conf file

[1013]
type = friend
callerid =  IT Operation
secret = 0000000
host = dynamic
canreinvite = no
context = IT Operation
dtmfmode = rfc2833
mailbox = 1013
disallow = all
allow = ulaw
transport = udp

Below are the contents of asterisk.conf file
[1013]
type = friend
callerid = IT Operation
secret = 0000000
host = dynamic
canreinvite = no
context = mobileusers
dtmfmode = rfc2833
mailbox = 1013
disallow = all
allow = ulaw
transport = udp


Below are the contents of extension.conf file
[IT Operation]
exten => _1NXXNXXXXXX,2,Dial(SIP/${EXTEN}@localphone)
exten => _1NXXNXXXXXX,n,Hangup()
exten => _NXXNXXXXXX,1,Dial(SIP/1${EXTEN}@localphone)
exten => _NXXNXXXXXX,n,Hangup()
exten => _011.,1,Dial(SIP/${EXTEN}@localphone)
exten => _011.,n,Hangup()
exten => _00.,1,Dial(SIP/${EXTEN}@localphone)
exten => _00.,n,Hangup()

Thanks and regards.
0

Voice Over IP

Voice over IP (VoIP) is a methodology and group of technologies for the delivery of voice communications and multimedia sessions over Internet Protocol (IP) networks, such as the Internet. Other terms commonly associated with VoIP are IP telephony, Internet telephony, broadband telephony, and broadband phone service. The term specifically refers to the provisioning of communications services (voice, fax, SMS, voice-messaging) over the public Internet, rather than via the public switched telephone network (PSTN).  Examples of the VoIP protocols are H.323, Media Gateway Control Protocol (MGCP), Session Initiation Protocol (SIP), H.248 (also known as Media Gateway Control (Megaco)), Real-time Transport Protocol (RTP), Real-time Transport Control Protocol (RTCP), Secure Real-time Transport Protocol (SRTP), Session Description Protocol (SDP), and Inter-Asterisk eXchange (IAX).