Web Components

Web Components are a set of standards currently being produced by Google engineers as a W3C specification that allow for the creation of reusable widgets or components in web documents and web applications. The intention behind them is to bring component-based software engineering to the World Wide Web. The components model allows for encapsulation and interoperability of individual HTML elements. Support for Web Components is present in Chrome and Opera and is in Firefox (with a manual configuration change). Microsoft's Internet Explorer has not implemented any Web Components specifications yet. Web Components consist of 4 main elements: Custom Elements, Shadow DOM, HTML Imports and HTML Templates.

Share tech news, updates, or what's on your mind.

Sign up to Post

I am running a 32 bit application on an IIS 7 server in classic mode. I need to have *.svc mapped to ISAPI.dll.

I have been working off of Microsoft's site to get as far as I have gotten.

I have been following my errors up to now but now I get a 500.19 error I do not understand.  In the error page under config source I get this

-1:
 0:

Here is the portion of the web.config file I have been working on:

<system.web>
<httpHandlers>
      <add verb="*" path="*.svc"
        type="SVCAspHandler, SVCAspHandlerAssembly" />
      <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" />
    </httpHandlers>
        <authorization>
            <allow users="etariffdev\TMSService" />
        </authorization>
  </system.web>
  <!--
        The system.webServer section is required for running ASP.NET AJAX under Internet
        Information Services 7.0.  It is not necessary for previous version of IIS.
    -->
  <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
        <caching enabled="false" />
        <directoryBrowse enabled="true" />
      <add name="SVCAspHandler" path="*.svc" verb="*"
        Modules="IsapiModule"
        scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\inetsrv\isapi.dll" />
  </system.webServer>

Can anyone help me get this working?
0
Hello,

I have an ascx user control and two instances of user control on the same aspx page.

I would like to add javascript to manage the postback of a button inside the user control in order to show a waiting icon and disable the button  while execution.

The following javascript is working well ONLY if there is just one instance of the user control on the page but if there are two or more instances,  the javascritpt is executed but in the first instance of the user control created on the page. (I mean, i I click the button of the second user control on page, the button disabled is the one of the first user control and also the <div> is shown in the first user control.

The javascript is the following:

// Get the instance of PageRequestManager.
var prm = Sys.WebForms.PageRequestManager.getInstance();
// Add initializeRequest and endRequest
prm.add_initializeRequest(prm_InitializeRequest);
prm.add_endRequest(prm_EndRequest);

// Called when async postback begins
function prm_InitializeRequest(sender, args) {
// get the divImage and set it to visible
var panelProg = $get('divImage');
panelProg.style.display = '';

// Disable button that caused a postback
$get(args._postBackElement.id).disabled = true;
}

// Called when async postback ends
function prm_EndRequest(sender, args) {
// get the divImage and hide it again
var panelProg = $get('divImage');
panelProg.style.display = 'none';

// Enable button that caused a postback

Open in new window

0
We have web forms that are processed by php on several sites. It now appears that any email address entered by a user that contains an underscore is delivered in the reply to the form owner without the underscore. So "somebody_somewhere@yahoo.com becomes somebodysomewhere@yahoo.com when the reply is received from the site.
0
I am not sure "Hard Coded" is the right word.

I have a client using a C5 custom theme built in 2010 (I think) by an unknown person.

I need to change/add the content on the page. I had a hard time finding the page because it was hidden with the system pages in the sitemap.

I also had to give the administrator permission to edit the page.

Once I found and could edit the page the Add To main is on the top of the area I want to edit and the Add to Footer is below (see attached image, HarkinsLoginPage.jpg).

So it is hard coded into some page stored some where, but I cannot find the page anywhere.

The URL is: http://www.harkinsassociates.com/index.php/newsletters/...

When I am logged in to edit the page, the URL is: http://www.harkinsassociates.com/index.php?cID=5&ctask=check-ou...

The site registration page is also built the same way and I cannot find that either. The URL is: http://www.harkinsassociates.com/index.php/register/...

I found a newsletter folder, but it is empty. I have not found a register folder yet.

I looked at every file I could find regarding login, register etc, but no page with this text and form written into the page.

I've looked at the page source and had Chrome inspect the elements.

Normally I can find the file that has the mysterious code in it, but this one has me stumped.

Does anyone out there have a clue where I might look for this? Suggest a tool that will lead me to the page. Maybe I missed something in the view …
0
How would i add a script that would add .z-index to the tab-panel that is active?

This is what i have:

<ul class="nav nav-pills pills-round" role="tablist" id="myTab">
<li class="active col-sm-4">Amount<a href="#tab1" role="tab" data-toggle="pill"><span>1</span></a></li>
<li class="col-sm-4"><hr>Name<a href="#tab2" role="tab" data-toggle="pill"><span>2</span></a></li>
<li class="col-sm-4"><hr>Payment<a href="#tab3" role="tab" data-toggle="pill"><span>3</span></a></li>
</ul>

When you select a tab, it opens a panel:

<div class="tab-content" id="myTabContent">
   <div class="tab-pane" id="tab1"></div>
    <div class="tab-pane" id="tab2"></div>
    <div class="tab-pane" id="tab2"></div>
</div>

I tried this script but it doesn't work. Any ideas?

$('.pills-round>li>a').click(function(){
$('.z-index').removeclass('z-index');
$('.active').addclass('z-index');
});
0
I see a lot of website using this format.

Big picture on the top and 3 icons in the middle.

is this something from wordpress format?
(or what is this made of if not wordpress)
Why is this so popular and please tell me the benefit of using this format as well.

http://www.freee.co.jp/?referral=taxac&utm_campaign=taxac&utm_source=taxac

https://shopcurbside.com/index.html
0
Running on Windows, is there a way to find memory leaks in google chrome or in the web pages served by the browser ?
0
Do we have any method by which we can export any information from a web based J2EE application  ?

E.g. I have an application which has user information and i want to retrieve employee IDs for multiple users from the web app.

Please suggest.
0
We have an Internet application which requires to print to a specific local printer.  Currently we have to press a button on the app which brings up the Browser popup printing window and you select the printer, click print and away it goes and prints correctly.

What we want to achieve is: -

Press the print button in the app and the printout goes straight to a specific printer with no popup selection window appearing.  The printer that we want to print to is not necessarily the default printer.

Can anyone assist?
0
Hi all, I'm trying add a 3rd logo to our website footer in wordpress using  the following code.  So 'someimage1' and 'someimage2' are displayed fine.  But for 'someimage3' nothing is shown except a small image box with the actual logo missing - the link is working. I can view the logo in wordpress without any problem and media file uploaded OK.

the code is in appearance\editor\footer

Thanks

<footer class="footer navbar-fixed-bottom">
                  <?php wp_footer(); ?>
                        <div class="block left block1">
                              <div class="img-block left">
                                    <a target="_blank" href="http://some website 1">
                                          <img class="left" src="<?php bloginfo( 'template_url' ); ?>/images/someimage1.png" />
                                    </a>
                                    <a target="_blank" href="http://some website 2">
                                          <img class="left" src="<?php bloginfo( 'template_url' ); ?>/images/someimage2.png" />
                                    </a>
                                    <a target="_blank" href="http://some website 3">
                                          <img class="left" src="<?php bloginfo( 'template_url' ); ?>/images/someimage3.png" />
                                    </a>
                                    <div class="clearfix"></div>
                              </div>
                        </div>
                        <div class="clearfix"></div>
                        <div class="block right block2">
0
Hi Folks

I'm desperately trying to figure out how to set up my IIS 7 Server so that the default is for each web site I create is automatically placed into its own Application Pool. I've read document after document but for some reason it's not sinking in.

Can someone explain it to me in words of one syllable so I can understand how to set it up? :)

Cheers
Chris
0
I created a Google Form that posts to a Google Sheet.   Additional feature I need is to allow user to browse to and upload PDF's or images.    I would like to have the file uploaded and the filename added to a field in the Google Sheet along with other field data associated with the form.
0
Hello,

Our website domain is using a .com web address. The performance (when loading the site) is effected if accessing the site in Asia for example. I'm thinking of just creating a duplicate of the website but with a .cn as the sub-domain web address.

So what I'd like to happen is when visiting contoso.com (detecting if your IP is from Asia region) the browser will redirect to contoso.cn and decrease load times. Can this be done? What is this process called? Our domain is hosted off-site, how can i request this specifically from our hosting provider?

Thanks.
0
We have a public (hosted) website.

We are making an internal webserver and need some advice how to setup a public URL for it.

1) Something like www.MyCompany.com/schedules/

2) Or should we register a new name or just use one of our public IP addresses? (we have 3 unused)

3) or something else?

Anyone have any tips or advice to set this up exactly?

(Bonus points for code so that Google and other search engines will not index our new site).

Thank you,
HappyTech
0
Hello and thank you for reading my post.

I have a project coming up that needs to take a working web site and implement the ability to support mobile device such as iPhone, Android, Windows Phone and tablets.

I need to know where to start. If there are tools such as Xamarin which would handle cross platform design that would do most of them if not all using such a single tool and that is easy to deal with.

All comments are welcomed and thanks again.
0
On an intranet site when someone types and hits enter in textbox, would like doclick to trigger on search button. The following works great in IE, but not Chrome:

On Load:
  Me.CurrentVin.Attributes.Add("onKeyPress", "doClick('" + Button23.ClientID + "',event)")
Html:

<script type= "text/javascript">
    function doClick(Button23, e) {
        //the purpose of this function is to allow the enter key to
        //point to the correct button to click.
        var key;

        if (window.event)
            key = window.event.keyCode;     //IE
        else
            key = e.which;     //firefox

        if (key == 13) {
            //Get the button the user wants to have clicked
            var btn = document.getElementById(Button23);
            if (btn != null) { //If we find the button click it
                btn.click();
                event.keyCode = 0
            }
        }
    }
</script>
0
Hi Everyone

I have a domain - sennajean.com.au - that redirects to sennajeandesigns.bigcartel.com
The redirection works fine but I would like sennajean.com.au to remain in the address bar so clients don't know its a Bigcartel website.

Can someone please tell me what I need to add to the htaccess file to get this masking working

Thanks

Regards
Michael Tiemann
0
Hi Experts,

I am looking some idea how to make a website of freeLancer projects like ODesk or elance, where people can post projects and programmers can bid. and employer can pay through paypal to programmers.

I am java/J2ee programmer and know little about php. I am thinking to make something in spring/hibernate and mysql.

Also considering wordpress to customize project as post etc. Any idea or guide line about initial structure about the project?

Thanks.
0
I would like to prevent Google from  crawling wp-content/plugins and wp-admin  for wordpress website .In other ,word  we need to do  ideal robot text  for our website


Thank you
0
We have modified our Wordpress install to allow for pretty permalinks, but now, every web page url includes index.php as part of the address - how do we modify config to eliminate this, so our SEO tags and links all blend nicely?

Wordpress 3.9  Windows 2008 R2  IIS 7.5  

Permalink Settings in Admin
Using Custom Structure
http://name.domain.com
/index.php/%year%/%month%/%day%/%postname

(That had to be inserted to make permalinks run correctly.)
0
I'm currently trying to implement a simple datatable with editor.

datatables.net

I need the table to be within inside the container however it seems to break out across the page.

please see link below.

www.shl.me/editor/1/

Many thanks in advance.
0
Greetings,

I will be building an ASP.NET application to process orders in a multi-user environment, and I am thinking about thread safety considerations with the class model and usage in my design.   This application will access a DB2 database on an IBM iSeries platform on the back-end, using the IBM DB2 data provider for .NET.  

In a nutshell, the page (UI) classes will create local instances of business-layer classes (order, customer, etc.), which in turn, will contain references to data-layer classes that utilize the IBM .NET data provider to read and write data.  So, the overall design of the program flow will be:
 
Web UI (page classes) --Ref--&amp;gt; Business Classes (DLL) --Ref--&amp;gt; Custom Data Layer (DLL) --Ref--&amp;gt; IBM .NET Data Provider --accesses--&amp;gt;) DB2 database (IBM i Series)
 
With this design model, I need to know what considerations should be addressed regarding thread safety, to avoid problems in a multi-user environment.  I have only a few shared public functions in a global module, but these do not affect data in any way.  They are used to perform fixed calculations or return static information from fixed lists, config file settings, etc.  
 
In my page code-behind, I'll be creating class instances that will handle the actual work and business logic.  These will be private to the page, and destroyed at the completion of the page life cycle.  Example:  The EnterOrder class (EnterOrder.aspx) references three business objects…
 
0
I'm trying to embed an accordion or collapsible text script to my google site, and i'm getting the following error.

failed to load external url jquery.js

Problem is I don't understand how to make the script work, especially in the google sites environment.  This is the second time I've tried to post the request along the lines of this, and thus far no one's been able to assist.

How do I get jquery to work in google docs?
Please help - i'm about to pull my hair out!
0
I would like to hear some feedback on the platform Agriya vs. Cogzidel. Cogzidel is built on CodeIgnitor, an open source platform. Pros and cons of one over the other.

Thank you.
0
i am trying to fix an issue with a certain Coldfusion generated PAGE. In the "How to Apply" section of the page there is meant to be included a URL for a certain website, however the page shows only the first part of the URL in clickable hyperlink format, and everything after the / is shown as plain text. Can you please suggest a solution ?

Please note that these are extracted from the database and displayed dynamically in web pages.

please check this image for how it looks in the database :

image

I have been able to find the specific bit responsible of generating the section, but i don't know what to change there,  if i can get any help on that, that would be greatly appreciated!


&lt;div class="display-item last"&gt;
			&lt;div id="how-to-apply"&gt;
				&lt;h2&gt;How to apply&lt;/h2&gt;
				&lt;p&gt;#formatWithLinks(Arguments.data.ApplicationProcedure)#&lt;/p&gt;
				&lt;dl&gt;
					&lt;dt&gt;Closing date&lt;/dt&gt;
						&lt;cfif Arguments.data.HasClosingDate&gt;
						&lt;dd&gt;#DateFormat(Arguments.data.ClosingDate, "D MMMM YYYY")#&lt;/dd&gt;
						&lt;cfelse&gt;
						&lt;dd&gt;None: ongoing recruitment&lt;/dd&gt;
						&lt;/cfif&gt;
				&lt;/dl&gt;
			&lt;/div&gt;
		&lt;/div&gt; 

Open in new window


thank you
0

Web Components

Web Components are a set of standards currently being produced by Google engineers as a W3C specification that allow for the creation of reusable widgets or components in web documents and web applications. The intention behind them is to bring component-based software engineering to the World Wide Web. The components model allows for encapsulation and interoperability of individual HTML elements. Support for Web Components is present in Chrome and Opera and is in Firefox (with a manual configuration change). Microsoft's Internet Explorer has not implemented any Web Components specifications yet. Web Components consist of 4 main elements: Custom Elements, Shadow DOM, HTML Imports and HTML Templates.

Top Experts In
Web Components
<
Monthly
>