Web DevelopmentSponsored by ConnectWise

74K

Solutions

49K

Contributors

Web development includes all aspects of presenting content on intranets and the Internet, including delivery development, protocols, languages and standards, server software, browser clients, databases and multimedia generation.

Share tech news, updates, or what's on your mind.

Sign up to Post

As the subscription costs really add up over the long haul, we plan to cancel our LinkedIn Recruiter Lite account over the summer months and resume it again in September.

If we do  this then we will get an empty account when we resume in a 4 months' time. This is grossly annoying as we lose all of the data we have paid to generate over the past few years. Of course we can save the primary data by down loading CV's, but we lose items like stats on how many applications, and when, Groups candidates are part of, the ability to filter candidates by; Location, Company, Job title, First name, Last name, Years of experience, Education, etc.  Plus we lose the useful recruitment interface that they provide to view that data.

Although LinkedIn does not advertise the fact, I have a feeling that it is somehow possible to download all of our data.  It is our data after all, plus we have paid significant number of thousands in subscrip
0
hi! I need to create an investment platform for my business company. Some advices?
0
I am new to wordpress and want to get my site up and customise it as quickly as possible. Are there people I can Chat to about this on Experts Exchange? Initially I need to remove the control bar from the Video widget from the Site Origin Widgets Bundle.
0
About Picking the right Magento Development Company
0
Hi  

I have a client who needs a ticket/voucher/coupon management system for handling  

Physiotherapy sessions

 
The client has around 2000 coupons yearly and around 100 partner clinics

I will be referring to the client as company B

This is the current method:

Company A has employees with 10 coupons each,

Employee 1 from Company A calls Clinic A and orders a massage, Clinic A then contacts Company B and informs that Employee 1 from Company A has used 1 coupon.

Company B then registers the remaining coupons in an excel document, and forwards a verification to Clinic A

Clinic A then sends a verification, to Employee 1 from Company A.

 

Requested method:

The client (Company B) needs a system where the clinics can register and remove coupons from the individual employee from the different companies through a website

 
Nice to have:

The ability to send remaining coupons out to companies

A function for The Companies to be able to buy new coupons and see current coupons
0
Hi Experts,

I'm in the process of creating a questionnaire in an asp.net webform. The questions will be database records which I'd then use to create the questionnaire. I think I'll need to use a datagrid to show the questions and then I'd like to have a dropdownlist or radio buttons for the answers. Is this the correct/best approach and if so, does anyone have any examples of the best way to do this?

Many thanks in advance for the help,
0
I am writing a web interface of a custom device. I want to offload checking in the user browser i want to write some computing-intensitive-like algorithm in javascript. Something that can be easy to understand. I have not background in formal programming. I have no skills in theorical topics. I only know C and C++ language. A bit of javascript, html, css and php. I want to write some algorithm that don't stops. Something that keeps performing calculus always.
0
If I set breakpoints on a source using Google developer tools and refresh the page, execution is paused at each breakpoint as I would expect.

However, if I close the tab and reopen it, although my breakpoints still exist when i look at my source tab in developer tools, the actual breakpoint event does not occur.  Only when I refresh the loaded page do the breakpoint events actually occur.

Is this normal?  Is there any way to get those breakpoints to trigger when the tab is initially opened/re-opened?

Thanks!
0
I'm having some trouble accessing a class property from within a callback function. Any help would be greatly appreciated
declare var google;
var service = new google.maps.DistanceMatrixService();

getTravelDetails(branch){
    service.getDistanceMatrix(
      {
        origins: [new google.maps.LatLng(6.870128,79.880340)],
        destinations: [new google.maps.LatLng(branch.lat, branch.lng)],
        travelMode: 'DRIVING'
      }, (response, status) => {
        let travelDetailsObject;
        if (status == 'OK') {
          var origins = response.originAddresses;
          var destinations = response.destinationAddresses;

          for (var i = 0; i < origins.length; i++) {
            var results = response.rows[i].elements;
            for (var j = 0; j < results.length; j++) {
              var element = results[j];
              var distance = element.distance.text;
              var duration = element.duration.text;
              var from = origins[i];
              var to = destinations[j];
              travelDetailsObject = {
                distance: distance,
                duration: duration
              }
            }
          }
          this.travelDetails.push(travelDetailsObject); //works
        }
      });
  }

console.log(this.travelDetails); //prints empty array!!!!

Open in new window


This is just part of the code which I think is relevant.. Can add in more parts if needed.

Thanks!
0
screenshot of sampleI'm looking to add two separate (stacked) text scroller fixed at the bottom of the browser window for my php/MySql WordPress site. An example of what I am trying to achieve can be found at the bottom of http://www.hsx.com or via the attached image.

I've come close with the code below, however, things quickly fall apart when I try to stack the two separate streams.

<!DOCTYPE html><html lang='en' class=''>
<head>
<style>* {
  box-sizing: border-box;
}

@-webkit-keyframes ticker {
  0% {
    -webkit-transform: translate3d(0, 0, 0);
    transform: translate3d(0, 0, 0);
    visibility: visible;
  }
  100% {
    -webkit-transform: translate3d(-100%, 0, 0);
    transform: translate3d(-100%, 0, 0);
  }
}
@keyframes ticker {
  0% {
    -webkit-transform: translate3d(0, 0, 0);
    transform: translate3d(0, 0, 0);
    visibility: visible;
  }
  100% {
    -webkit-transform: translate3d(-100%, 0, 0);
    transform: translate3d(-100%, 0, 0);
  }
}
.ticker-wrap {
  position: fixed;
  bottom: 0;
  width: 100%;
  overflow: hidden;
  height: 4rem;
  background-color: rgba(0, 0, 0, 0.9);
  padding-left: 100%;
  box-sizing: content-box;
}


.ticker-wrap .ticker {
  display: inline-block;
  height: 4rem;
  line-height: 4rem;
  white-space: nowrap;
  padding-right: 100%;
  box-sizing: content-box;
  -webkit-animation-iteration-count: infinite;
  animation-iteration-count: infinite;
  -webkit-animation-timing-function: linear;
  animation-timing-function: linear;
 

Open in new window

0
Looking thru YII documentation I confirmed that to create a link using an anchor this is the correct syntax:
Yii::app()->createUrl("box/update", array("id" => $id, '#' => 'second-tab'))

Open in new window


The corresponding view for the action "box/update" is made like this:
$this->widget(
    'bootstrap.widgets.TbTabs',
    array(
        'type' => 'tabs',
        'placement' => 'top',
        'tabs' => array(
            array(
                'id' => 'first-tab',
                'label' => Yii::t('app', 'First Tab'),
                'content' => $this->renderPartial('_memberFirstTab', array('model'=>$model, 'form'=>$form), true),
                'active' => true
            ),
            array(
                'id' => 'second-tab',
                'label' => Yii::t('app', 'Second Tab'),
                'content' => $this->renderPartial('_memberSecondTab', array('model'=>$model, 'form'=>$form), true),
            ),
        ),
    )
);

Open in new window


The result is that if I am within the box/update action I can move back and forth between the two tabs but if I call it from outside (YII or not) I cannot link directly to something different from the first tab.

Where is the error I cannot see
0
Using IE's F12 Developer Tools I captured some network traffic and exported the capture to Excel.  In the export there's a column titled "Cache read" that only appears in the export.  I've been unable to find any documentation explaining what that column represents.  I'm guessing it's the time the browser spent reading/attempting to read data from cache, but would like to confirm that.

screenshot of the capture
0
Google sheets to enter Amount in a web calculator.

In the Attached image of a Special Web Calculator, I need to Enter Amount, State, Term/Interest Rate & then return the 2 resulting values given by the calculator into a google sheet.

Here is the “Inspect Code” from Chrome:
<div class="slider"><input type="range" step="100" min="0" max="100000" class="range" value="25000"><input type="text" class="mt-4 input-box" value="$ 25,000"></div>

<select class="form-control custom-select" id="addressState"><option value="">Choose a State...</option><option value="CT">Connecticut</option><option value="CO">Colorado</option><option value="FL">Florida</option><option value="MD">Maryland</option><option value="NM">New Mexico</option><option value="NY">New York</option><option value="NV">Nevada</option><option value="PA">Pennsylvania</option><option value="UT">Utah</option><option value="VA">Virginia</option></select>

<select class="form-control"><option class="text-muted" value="0">Select Loan Term...</option><option id="1" value="1">10 Year Loan 2.99%</option><option id="2" value="2">20 Year Loan 3.99%</option></select>

<button class="btn btn-non-active pointer"><span class="icon icon-calculator mr-2"></span><!-- react-text: 45 -->Calculate Payment<!-- /react-text --></button>

<p class="payment">$ 109</p>

<p class="payment">$ 157</p>

 Please note that this a follow on to: Google sheets to use a web calculator posted On 2018-04-22
0
I've implemented a custom PersistedGrantStore storing my refresh tokens in a xml file, however I now have problems refreshing my tokens.

When I remove following lines, the refresh works

services.AddTransient<IPersistedGrantService, PersistedGrantService>();
services.AddTransient<IPersistedGrantStore, PersistedGrantStore>();

Open in new window


When I put those lines back, I get the following in the logs :

2018-04-24 14:14:51.094 +02:00 [DBG] [IdentityServer4.Hosting.EndpointRouter] Endpoint enabled: Token, successfully created handler: IdentityServer4.Endpoints.TokenEndpoint
2018-04-24 14:14:51.095 +02:00 [INF] [IdentityServer4.Hosting.IdentityServerMiddleware] Invoking IdentityServer endpoint: IdentityServer4.Endpoints.TokenEndpoint for /connect/token
2018-04-24 14:14:51.098 +02:00 [VRB] [IdentityServer4.Endpoints.TokenEndpoint] Processing token request.
2018-04-24 14:14:51.108 +02:00 [DBG] [IdentityServer4.Endpoints.TokenEndpoint] Start token request.
2018-04-24 14:14:51.115 +02:00 [DBG] [IdentityServer4.Validation.ClientSecretValidator] Start client validation
2018-04-24 14:14:51.120 +02:00 [DBG] [IdentityServer4.Validation.BasicAuthenticationSecretParser] Start parsing Basic Authentication secret
2018-04-24 14:14:51.123 +02:00 [DBG] [IdentityServer4.Validation.PostBodySecretParser] Start parsing for secret in post body
2018-04-24 14:14:51.145 +02:00 [DBG] [IdentityServer4.Validation.SecretParser] Parser found secret: PostBodySecretParser
2018-04-24
0
I had created asection with multiple columns. Now, I wish to start a new row, so I created a new container as well. But when I run the file, the new row is not added. Instead, another column is being made. Can anyone help me in debugging this code.

How can I make the data appear in a new row below the previous one? Any help will be apreciated! Thanks in advance!

0
I have Dynamics crm 2011 and try to retrieve lead entity record. The code is working except when I try to assign crm value to string.
It complaints to this :  l.lastName = Convert.ToString(lead["lastname"]), and the alert error is below.

Do you know how to fix it?


[b]The given key was not present in the dictionary.[/b]
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

Source Error: 


Line 1033:                        testFirstName = Convert.ToString(lead["firstname"]);
Line 1034:                        l.lastName = Convert.ToString(lead["lastname"]);
Line 1035:                        l.primaryPhoneNo = Convert.ToString(lead["mobilephone"]);
Line 1036:                        #endregion
Line 1037:                        #region optional fields



 public Domain.Lead GetLeadInformation(string phoneNo)
        {
		Domain.Lead l = new Domain.Lead();
		EntityCollection retrieved = orgService.RetrieveMultiple(querybyattribute);
                if (retrieved.Entities.Count > 0)
                {
                    foreach (Entity a in retrieved.Entities)
                    {
                        #region found the phone number and then update records
                        lead.Id = new 

Open in new window

0
I am using a @foreach() loop in razor view to pass variables to a table cell as shown below. using ajax calls, i want to fetch different values from a database and display them on the table cells on a button click event. The ajax calls are successful and i can return the right data to the model but the cell values do not change after initial load. How can i make the cell values update automatically every time the model changes
code sample
0
Need help creating an API call in Power BI to retrieve data from a specific vendor.
They provided the following link:

https://www.esayworkmobile.co.uk/wmbapi3/workmobileintegration.asmx

I previously was able to create a working API call using Power BI to a different vendor.
As follows:

https://training.reliaslearning.com/webservices/elapi.asmx/ExportEnrollments?authorizationID=USERNAME&passcode=PASSWORD&OrganizationID=ORGID&DateRangeType=3&startDate=01/01/2018&endDate=04/03/2028

Note: Username, Password and OrgID were substituted out in the above example.

While there are several way to retrieve this data, we want a consistent method.  We would like to use an API similar to the above to retrieve any data table into Power BI.


MAC
0
I installed open cart for ecommerce website and i want to have multi stores app with web landing page, do i need to install the marketplace module first then buy theme with installation or buy theme then install marketplace module?
0
I'm trying to remember how to add an icon next to a link, for example, I want to add a cart icon next to the text "View My Cart".   This is in the header of a magento website and uses PHP.  I was hoping this can be done with css.  Thanks
0
Hi,

I'm in the process of developing an eBay application in Microsoft Access 2016. So far my project has been fine and the API calls I have made have been successful but I have now come to a stumbling block that I need some help with.

The API calls I have used so far are all for single listings so this is easy and I just pass the XML through an HTTP request. I want to make this much more efficient and use eBay's File Transfer API where I can send more than 1 call at a time but I'm really struggling on trying to understand how to build the call.

The data has to be sent as Binary Base64 which I have a converter to do this. I can build the XML that needs to be sent but I just don't understand how to send the XML from a string as apposed to a physical file.

I've read loads on the internet about having to create it as a multipart request with boundaries but really not sure how to start building that. I can provide code if need be so you can see where I am at.

I hope this makes sense.
0
I am trying to create a virtual domain in wampserver, when i try to create one in the "Add a virtualHost" panel i get the message "c:/users/edkna/desktop/allsites/site1 does not exist or is not a directory", even though there is a directory there.
I tried creating a directory in multiple places on my computer (which i have full admin rights to) I am carefull to correctly copy and past the path to the directory and paste it into the "complete absolute path of the virtualhost" field but I get this error message every time. (see the attached screen capture errorMessage.JPG)

Also another issue that is probably related to the above issue, when I tried to add a second directory in  C:\wamp\www  for a another Wordpress site, I get the following error messages:
( ! ) Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0
( ! ) Fatal error: Unknown: Failed opening required 'C:/wamp/www/site2/index.php' (include_path='.;C:\php\pear') in Unknown on line 0 (see the attached screen capture anothrErrorMessage.JPG)

Can you tell me how to fix this problem?

Hi Dave,
 you said it could be a permissions issue.  Properties/Security show I have full control.  This is also my personal computer which I have all privileges to. are you referring to some other permissions that I am not thinking of? I was able to create virtual domains six months ago, so I don't know of any thing that is different on my computer now.

Hi noci,
 I pasted in the path with …
0
Removed question.
0
Points to keep in mind while picking an Asset Management System
0
I am getting this error:

Missing XML tag
This required tag is missing. Please add it and resubmit.
1
Parent tag: urlset
Tag: url

When I test my sitemap.xml at www.gopherstateevents.com

Can someone help me find what is wrong with it?
0

Web DevelopmentSponsored by ConnectWise

74K

Solutions

49K

Contributors

Web development includes all aspects of presenting content on intranets and the Internet, including delivery development, protocols, languages and standards, server software, browser clients, databases and multimedia generation.