Windows 10





Windows 10 is a personal computer operating system featuring the "universal application architecture" (UAP); apps can be designed to run across multiple devices with nearly identical code, including PCs, tablets, smartphones, embedded systems, Xbox One, Surface Hub and HoloLens. Windows 10 also includes a virtual desktop system, a window and desktop management feature called Task View, the Microsoft Edge web browser, support for fingerprint and face recognition login, voice-based search (Cortana), new security features for enterprise environments, and DirectX 12 and WDDM 2.0 to improve the operating system's graphics capabilities for games.

Share tech news, updates, or what's on your mind.

Sign up to Post

Adding a Windows 10 Hosted VDI on AWS

I thought this would be simple on AWS. But, when I try and "Launch an Instance" and look through the various Windows options, I see only Windows Server?

Isn't a Windows 10 Desktop VDI considered an Instance?

What am I missing?

I have been upgrading all PCs to Windows 10 and I have encountered 2 that would not upgrade to Windows 10. All the PC are the same make and model. But these two recieve the error on the image attached.Win10 Upgrade Error Message
Windows 10 Pro system here acting as a server in a small office. System is connected to internet and is "on" all the time.

All of a sudden a "Microsoft Edge" pop-up appears requesting username and password for "server".

Above this, its claiming "Virus Alert from Microsoft this computer is blocked"

AFAIK, no staff would have been using this server for anything dodgy AND this computer is just not used for internet surfing at all.

Where did this appear from? How did it get installed and how did it know the PC is the actual server?
PowerShell Script Request: Remote Windows 2016 Server Page File and Location.
Hey Experts.  I need to copy data from a directory on a server (serverA) but a Windows service on the server needs to be stopped before the data is copied.  Not sure how to get the script to check for the Windows service (say spooler) to be stopped before the script continues on.  Thank you in advance for any help!
Dear Experts,

My Domain Controller is a Windows Server 2012 Standard.
My Clients are mixed workstations of Win 7 Pro and Win 10 Pro since we are currently upgrading all clients to Win 10 Pro.

The upgraded Win 10 users were complaining that the computer will auto-lock in short period of time (about 20 minutes).
From the other side the existing Win 7 clients are not affected from the auto-lock issue.
If you leave the Win 7 client unlocked it will remain unlocked.
Same applies to Windows Server 2012 Domain Controller.

In addition please be advised that nothing was initially changed from Domain's Group Policy.
Once the Win 10 Client joined the Domain it would automatically receive this 20 minutes auto-lock.

I searched the internet to locate the correct group policy in order to increase the auto-lock from 20minutes to 60minutes.

I found an article indicating the setting "Interactive logon: Machine Inactivity Limit".
In order to test the setting, I entered 30seconds and I confirmed that the Windows 10 would now lock from 20minutes to about 40seconds.
Following I changed again the setting from 30seconds to 3600seconds (1hour) but unfortunately the auto-lock remains at 40seconds.

I have tried with no luck to:
- gpupdate /force domain controller
- reboot domain controller
- disable "Interactive logon: Machine Inactivity Limit" setting
- reboot Win 10 client

Under Group Policy Objects of the Domain Controller I have…
Undetected application removes startup items that are unsigned on my Windows 10, periodically. My guess, about once a week.

I put them back, then after a while they disappear. Those items are internal software that should have nothing to do with any machine cleanup.

I suspect Defender Cleanup, but cannot be sure about that. Maybe some setting?
McKnife recommended the mmc snap-in for non-administrator policies in gpedit.msc and is working fine. The tutorial for exporting and importing the policies into another computer is not as clear or as simple as it appears.
also why does the non-administrator policies do not show up when you open up gpedit.msc?
is there another simpler solution to export the non-administrator policies to another computer?
all are windows 10 pro.
We have three people who are getting the error message IMSLib not found. Acrobat services will not work.

All on Adobe Standard 2017.

The first system was Windows 7, installing the Adobe Application Manager fixed the issue.

On the second system, which is Windows 10, the installation of Adobe Application Manager and Creative Cloud both failed at 5%. I uninstalled Adobe Standard with the adobe uninstall tool and reinstalled, both with an older version of the installer and a newly downloaded installer.

We have downloaded and replaced the OOBE folder within C:/Program Files x86/Common Files/Adobe

Any pointers would be greatly appreciated.

I know this has been an issue in the past but haven't seen any newer issues creep up in the forums, figured a new thread couldn't hurt.
Hi Experts,

my exchange server 2016 restarts each night.
How to troubleshoot this ?
Where to look into ?
On multiple brand new Windows 10 desktops, after joining them to the domain, and after completing all the Windows updates, and after downloading and installing all the updates available in the Microsoft Store, I am getting multiple Event ID: 69 errors in the Event Viewer, in the Administrative Events.

They are logged source is the AppModel-Runtime, and the descriptions are similar, except for the particular package that is generating the error. The text reads similar with the one below:  

Failed with 0x490 modifying AppModel Runtime status for package Microsoft.WindowsStore_12002.1001.1.0_x64__8wekyb3d8bbwe for user [DOMAIN]\[User] (current status = 0x0, desired status = 0x20).

Attached are a couple of screenshots, the first one with all the details for one of these multiple Event ID 69. The second one shows three of the multiple errors that keep appearing in the Event Viewer for all systems.

I've spent a good deal of time trying to figure out what is causing these errors, and how to stop them from appearing in the event log. Unfortunately, I was not able to figure out a solution, so I am hoping that someone in the community will be able to assist. Any feedback or suggestions would be much appreciated.

Thank you.
A customer of mine was running windows 7 and using a UPS Thermal 2844 printer to print out ups shipping labels.  They upgraded their computer to windows 10 and after that the thermal printer goes through the motions of printing but nothing shows up on the paper.  They Deleted the printer driver and re-installed with the latest update but that didn't help.  What do we need to do to get it to print?
Corporate Windows 10 image

Used DISM to load image, image load and all files were successful and can be seen in the C drive.  DiskPart shows everything is as it should be

However; the EFI and Boot BCD were not there.

Manually created the EFI directory copying it from the Windows directory, manually re-created the BCD store.

Still, not working

Can't mark the System partition as active because it is a GPT partition, switching it to a MBR partition causes other problems

So, it is my theory the system cannot find the active partition to allow boot to work.  Automatic Startup Repair does not work.

How can I tell the BIOS of this HP machine to find the boot record so it can start the machine.

Script to list logons on a specific domain controller, which the user actually logged onto that domain controller. Trying to look up examples and I just keep finding ways to find a specific user, I want all of the logons for the past X hours, of any user.
Hello, I'm trying to up an Oracle Database for a customer, and i have a few issues with it.

When i'm on a DOS and type "lsnrctl status <service_name>
i got an answer "Instance <name>, status BLOCKED, comport 1 handler(s) for this service..."
Command Success. (Could be not 100% accurate as I trad myself from french)

In a other hand, when i'm trying to connect with SQLPlus on the DB,  i got the following :
"ORA-01033: ORACLE initialization or shutdown in progress"

All services linked to Oracle are running exept OracleRemExecServiceV2.

As my lsnrctl start, stop and status gives answers, I dont know if problem comes from my listener.ora/tnsnames.ora (that was the previous problem I got and think have pass through).

Also SQLDeveloper send back the ORA-01033 error too.

The oracle DB version is 12c
OS is Windows Server 2016 64 bits

Blocked Message afterr lsnrctl status

ORA 01033 at login attempt
I've tried to shutdown then startup DB, reload services.
The only thing I got is tnsping answer well.

If you need anything more for precision feel free to ask.

Thank by advance if you have an answer, I digged in many sites but no one give a clear answer that applied well for me.
Hey Experts.  Spending a little more time putting together a script for this mini-project.  After copying the files to the network share, I want to delete out any folders that are older than 30 days (last line of code which I'm unsure of).  That should help maintain the size of the backup directory.  

$timeStamp = Get-Date -Format MMddhhmm
$destination = "\\fs01\\Backups\PRTG_Config\BACKUP_$timeStamp"
$source = "\\d10\c$\ProgramData\Paessler\PRTG Network Monitor\Configuration Auto-Backups"
$max_days = 14
$limit = 30

$newerThan = (Get-Date).AddDays(-1 * $max_days)
If (-not (Test-Path -Path $destination)) {
	New-Item -ItemType Directory -Path $destination -Force | Out-Null
Get-ChildItem $Source | ForEach-Object {
	Write-Host "'$($_.FullName)' ..."
	If ($_.LastWriteTime -ge $newerThan) {
		$_ | Copy-Item -Destination $destination -Force 
		Write-Host "  ... copied to '$($Destination)'"
	} Else {
		Write-Host "  ... skipped, too old."

Get-ChildItem -Path $destination -Recurse -Force | Where-Object { !$_.PSIsContainer -and $_.lastwritetime -lt $limit } | Remove-Item -Force

Open in new window

I am trying to create a Windows 10 Pro VM on a 2019 Std server.  The ISO I am using is from the VLSC (SW_DVD9_Win_Pro_10_1903.1_64BIT_English_Pro_Ent_EDU_N_MLF_X22-14064)  I do not want to use 1909 due to search issues.  I have the VM setup so that the OS installs on startup.  The error message I get is "Windows could not complete the installation.  To install Windows on this computer, restart the installation"

I have deleted and recreated the VM, downloaded a new ISO and both receive the same message.
Hey Experts.  Trying to get this script to back up only the files that have a modified date of 12 days or less/newer.  Help is appreciated as I've tried blending together a couple of scripts I found on the web.

$TimeStamp = get-date -f yyyyMMddhhmm
$Destination = "Y:\BACKUP_" + $TimeStamp
$Source = "X:\folder"
$Max_days = "-14"
$Curr_Date = get-date

Foreach($file in (Get-ChildItem $Source))
    if($file.LastWriteTime -gt ($Curr_date).adddays($Max_days))
        New-Item -ItemType directory -Path $Destination -Force
        Copy-Item -Path $Source\*.* -Destination $Destination -Force 
    { "not copying $file"

Open in new window

Hi Experts,

Recently I upgraded to Windows 10 and Access 2016 Plus.  All of my software is totally up-to-date.

I have an Event that is is used to relink the FE to the BE Databases.  This code has been working for years both on a local PC and to network locations including Dropbox.  It still works on the local PC however it no longer works on Dropbox.

I have attaching a copy of the messgae and code for your reference although it is quite long and complex.

I checked Google and found numerous references to this error, none of which I was comfortable with as it is an area I am not well educated in so I have decided to come to you for a specific answer.

Bob C.Windows-10-Access-2016-Plus-Error-3.docx
I look after a company with a Windows Server 2012 Essentials server and Windows 10 Workstations.

All of a sudden, all but one of the workstations and the server is unavailable via the remote desktop connection.

On the dashboard of the Server, they are also listed as Offline (Except one workstation and server) under devices.

They seem to be working OK otherwise.  They can access files on the server and are using re-directed folders that I believe are working fine too.

I am going on-Site on Wednesday and wondering if anybody has any ideas what the issue may be or where to start looking?

Thanks in advance.
Hi All,

We are looking at installing a Server 2016 server (standalone) with the CS role. We are primarily going to be using it to secure our DC's (currently 2008R2 - but will be upgraded soon), for LDAPS but may look to utilise it further for other devices/servers as well. I am looking for opinion / best practices on how to set this up.

I was thinking that we would only need one enterprise server currently for our needs. I have read however that it is better to have two, a root and subordinate with the root turned off. Would this be over kill given our needs?

Secondly what length key would be best and algorithm to use. According to MS SHA2 with a 2048 key should be fine, however I have also read that that SHA256 would be better.

Should we stick with the default 5 year certificate lifespan.

Which template is most suited for securing the DC / LDAPS

Should I create a dedicated account for access to the server / servers

Finally if one Enterprise root server is deployed, should this be turned off when not in use. I read a MS article that says this is not recommended.

Thanks for your help.

Having issues connecting two Windows 10 computers network share. The 'server' won't let one of the computers on the network connect to it. It will however except the IP address share ex. \\ but not \\computername.
The error that comes up is network path not found. Other computers on the same network can still get to this folder with the server name, but not this one.
I have a PDF file with a size of 175 MB that I am trying to send to a recipient from my Downloads folder using right click send to mail recipient and nothing happens when I do so. I tried a different file and it went through. after that I realized it could be the file size which in this case it was a lot larger than the file that got sent. I know Outlook had 25 MB file size but I was reading and I came a cross that there was an increase in limit to 150 MB using cloud based Outlook which I am not familiar with. See Google search hit""Microsoft has increased the maximum size of an e-mail message that can be sent by an organization using its cloud-based Office 365 services to 150MB. Previously, a single Office 365 e-mail message could be 25MB max. ... IT pros can change these settings for individual users via Office 365's Exchange Admin Center..
Can someone advise me on how to go about sending this file? hopefully an easy method if all possible.

Thank you,
Basem Khawaja
I just introduced a new computer into a domain.
It uses static IP addressing.
It is domain-joined.
One can ping the network but can't access the internet with ping or http/browsers.
nslookup seems to be working fine.

I've removed and reinstalled the NIC and made the proper settings.
The rest of the network computers are fine.

The computer is in the domain and in the computer OU it belongs in.

The domain gateway entered on the NIC is the local DC.
The domain gets internet via a firewall - so that's the gateway for the DC.
The DC is NOT a DHCP server as all the domain computers are given static addresses.
There is a gateway on the LAN running DHCP.
IF this one computer is allowed to get an address via DHCP then it reaches the internet just fine.

TRACERT to a connected subnet host normally results in:
- firewall
- local subnet gateway
- remote subnet router
- remote host

However, with this one computer, the traceroute doesn't work and the first response is ****
However, with this one computer, if we add a persistent route pointing to the remote subnet via the local subnet gateway, the TRACERT result is:
- local subnet gateway
- remote subnet router
- remote host

So, skipping the firewall route for this one computer fixes that one thing.

So, either the DC isn't letting this one computer hit the firewall route
Or, the firewall isn't allowing packets to route further on the LAN for this ONE computer.

How to fix?
I can't even update …
How big does AD have to be (and how slow does the link need to be) to justify installing a new domain controller in a regional office using the IFM (Install From Media) method?

I think we'll have a 50 mbps symmetrical site-to-site VPN.

Our NTDS folder is 375 megs in size.

Should I use IFM or just do it the regular way?

I'm no pro so picking the easy method is very much preferable.

Reading about IFM here:

I became concerned reading this passage:

"Important :
The next steps are required to change the SYSVOL folder security settings. These steps change the file hash, which will become the same file hash as in the IFM. If you use DFS Replication, SYSVOL will keep the presided data only if the file hash on the source domain controller and the destination server are the same
On the destination server, right-click the SYSVOL folder, and then click Properties.
Click the Security tab, and then click Advanced.
Click the Auditing tab, and then click Edit.
Clear the Include inheritable auditing entries from this object’s parent check box, and then select it again.
Click Apply, and then click OK.

The existing domain controllers are Server 2012 and the new one will be Server 2016.  The functional level will remain at Server 2008 R2

Windows 10





Windows 10 is a personal computer operating system featuring the "universal application architecture" (UAP); apps can be designed to run across multiple devices with nearly identical code, including PCs, tablets, smartphones, embedded systems, Xbox One, Surface Hub and HoloLens. Windows 10 also includes a virtual desktop system, a window and desktop management feature called Task View, the Microsoft Edge web browser, support for fingerprint and face recognition login, voice-based search (Cortana), new security features for enterprise environments, and DirectX 12 and WDDM 2.0 to improve the operating system's graphics capabilities for games.