Windows 8

Windows 8 is a personal computer operating system developed by Microsoft as part of the Windows NT family of operating systems, with an emphasis on improving its user experience on tablets. In particular, these changes included a touch-optimized Windows shell based on Microsoft's "Metro" design language, the Start screen, a new platform for developing apps with an emphasis on touchscreen input, integration with online services, support for USB 3.0, Advanced Format hard drives, near field communications, and cloud computing. Additional security features were introduced, such as built-in antivirus software, integration with Microsoft SmartScreen phishing filtering service and support for UEFI Secure Boot on supported devices with UEFI firmware.

Share tech news, updates, or what's on your mind.

Sign up to Post

I just upgraded a Windows 8.1 Pro computer to Windows 10 Pro by performing an upgrade that kept the files and applications in tact.

Now around 33% of the time when users logon onto the computer using their local Windows profiles they receive an error that says "C:\Windows\system32\config\systeprofile\Desktop is unavailable. If the location is on this PC, make sure the device or drive is connected or the disc is inserted, and then try again. If the location is on a network, make sure you're connected to the network or Internet, and then try again. If the location still can't be found, it might have been moved or deleted" (see the screenshot).

This computer isn't joined to any domains.

If we log off of the computer and then log on again (with the same or a different local user account) the logon is successful.

I have run the SFC /scannow and the following DISM commands which have all run successfully and reported no errors.

What can I do to fix this issue so that this error will stop occurring?

DISM commands I have run:

DISM.exe /Online /Cleanup-Image /Checkhealth
DISM.exe /Online /Cleanup-Image /Scanhealth
DISM.exe /Online /Cleanup-Image /Restorehealth

Open in new window

Desktop profile not available
i have a packard Bell laptop Easynote LS11-HR-026BE model
it has as latest drivers  on the PB site  the windows 8 -64 bit drivers.
it was upgraded to windows 10 about a year ago, but now update 1803 refuss to install; saying simply :
the system reserved partition cannot been updated

what is the best method to resolve this?

i found the MS translated page full of errors - and don't trust it
the easus page gives a method for enlarging the partition with unallocated space, but my actual partitons (2 : system reserved and OS) are adjacent, so i probably need to free up space at the end of disk, and move that between the 2 existing ones - how much MB should i take?
here my disk management  :
What are the steps to directly upgrade Windows 8.1 to Windows 10 so that all programs, user accounts, and customizations will remain in place after the upgrade to Windows 10 completes?

Is this as easy as downloading the Windows 10 ISO file into Windows 8.1 and then running the Windows 10 setup file within the Windows 8.1 OS and following the prompts to upgrade?
My client's PC (Windows 8.1) shows the Metro interface.  There is absolutely no way to get to the desktop.  Every now and then while running programs and exiting them, the desktop flashes for about maybe 1/4 of a second, and then the Metro interface is displayed.

I've tried system restore twice (with antivirus disabled) and it says it failed to restore, citing perhaps the antivirus as the problem.

Anyone seen this before.

I'd like to know whether it is possible to directly find a device's GUID
if I know the BUS / VID and PID  (or BUS VEN / DEV) of it

The only option that I have so far is to retrieve all devices withWMI (in my case only usb network devices), get their PNPDeviceID and parse for it.

Is there anything faster? WMI is rather slow and my code doesn't really seem elegant.
Are there options using directly the win32 module?

My current code works for python2 and python3, but as mentioned above.
I manually search through all network devices and parse the PNPDeviceID
my code:

import wmi

c = wmi.WMI()

def find_by(bus, vid, pid):
    nw_adapters = (
        + c.Win32_NetworkAdapter(AdapterTypeId=9)
    pnp_string_start = r"%s\VID_%s&PID_%s" % (bus, vid, pid)
    for device in nw_adapters:
        if device.PNPDeviceID.startswith(pnp_string_start):
            return device
    return None

def get_guid(bus, vid, pid):
    device = find_by(bus, vid, pid)
    return None if device is None else device.GUID

Open in new window

Hello Experts,

I did a Windows update and a McAfee update, and since then have two problems. The first is most important: my RDP connection for my job disconnects and then reconnects every 10 seconds to  two minutes. I looked at the Microsoft Windows Terminal Services logs and see all the disconnection events, but there are multiple errors codes/descriptions that seem unrelated and I stopped analyzing those logs hoping you will have guidance for me.

The second problem is the hyperlinks in my Microsoft Outlook email no longer work and display a message that says, 'This operation has been cancelled due to restrictions in effect on this computer...' I attempted to reset my internet options, but that did not resolve the issue. I am reluctant to run the fix tool that is available on the Microsoft support page because Windows 8.1 is not listed in the OS list.  Do you have any advice for me?
Respectfully, Chop


In windows 8.1 my colleague deleted the Icon short cut for Ms Access in titles screen as result we cannot lunch Ms Access to start a new database. For existing database we are still able to work normally because the actual Ms Access is not disturbed.
How do we bring it back the launch icon on the tiles? Any idea? I have checked in the recycle bin still there is nothing.


Had a major power outage on my home network thee weeks ago and found out that my DFS Names space was not working. Which meant all my Folder redirections stopped working.

My GPO's users the DFS share name as the path \\\dfsshare\UsersHomeDirectories

And from all my desktops I could not access the share  So I temporarily sent it to the server \\server01\UserHomeDirectories and that worked

I then created a New DFS Share and that is now working  I then changed my GPO's back to using the DFS Share name

I also changed to using shortcuts to use the share and added them to the desktop  the use to be in network locations

I have Windows 7 windows 8.1 Windows 10 Physical and VM's using VMware ESXI 6.5  
Windows 2008 Windows 2012R2 and Windows 2016

I have made the change to the new dfs share and on most machines they are picking up the new shortcut.

I have a Windows 8.1, Windows 7 and Windows 2012 R2 that are not.

They are getting Event Id 4098

Log Name:      Application
Source:        Group Policy Shortcuts
Date:          5/5/2018 9:47:04 AM
Event ID:      4098
Task Category: (2)
Level:         Warning
Keywords:      Classic
User:          SYSTEM
Computer:      Server007-2012R2
The user 'Home Drive' preference item in the 'Network Drives-Servers {A8A28D61-3A28-4D75-82DB-2E73C158829A}' Group Policy Object did not apply because it failed with error code '0x80070002 The system cannot find the file specified.' This error was …
How do I find the right product key from Windows 10 computers.

I tried running nrisoft, Belrac and magic jelly bean and looks like they are pulling same product key on all 5 laptops in our company. How is that possible ?  Is it because may be these computers were upgraded to Windows 10 at some point from Windows 8 and therefore showing the same key on all computers that I am trying to recover ?
These laptops were purchased from retail in the past 4 years so most likely had windows 8 on them.  

How can I find the OEM key that was shipped with the computer if there is physically no sticker on it. I have to fill out MS audit report and therefore its kind of important I find the right info.

There is a VB6 application that uses ADODB to connect to LDAP and do a lot of operations, there is an LDAP Attribute (field) called "co-unit" and when the application runs specifically on Windows 8 (it has been tested on other OSs and works 100%) generates an "Unspecified error (-2147467259)" error and after analyzing the source code it was discovered that the problem is that when trying to run the Querye it does not accept any field that contains in its name the hyphen, for example co-unit , no-drive, dt-creation, etc ...

I have already searched in numerous forums including MVPs and other professionals but I have not been able to find any solution, because it seems that this problem should never have occurred.

I would like to know if there is anyone who can help me and give a light to solve this problem, I have tried everything, changed components, tried to get the Attribute through ADSPath among other ways and none gave result giving the same error.

You are my last attempt to help.

I'm waiting for some help from someone.

Excerpt from code that generates error:

sqlStmt = "SELECT uid, co-unit, cn" & _
    "FROM 'LDAP: //" & m_LDAPServer & ":" & m_LDAPPort & "/ o =" & m_Org & "/ ou =" & m_OrgPeople &
    "WHERE uid = '" & m_User & "'" & "and objectClass = '*'"
    'executes the data string ...
Unable to login to windows 8.1 pro using Microsoft connected account.
User has somehow set up login to try and use email account as user name.
IE joe which is an Exchange service hosted on office 365.

I can login through the portal with user name and pass ,but the users computer says incorrect password when I try to login locally.

If I try to change pass in admin tools users ,it says The system is not authoritative for the specified account.
Any ideas?
I am developing a windows application with c#. I need to get the file and folder name when I right click on a file to use for other functions. Right now I have made the registry keys to get my application running. When I right click on a file (word, ppt, txt, etc) my context menu shows the option I added, Set Perm. When that is selected my windows application opens up. In a text box on the form, I want to display the full file name and path. Is there a way to do that? I've added %0 and %1 in the registry to the end of the argument to launch my app, but it does not work. I've tried h:\temp\myapp.exe %1 and h:\temp\myapp.exe %0. Putting the %1 or %0 in quotes did not change anything. I am in Windows 8 using Visual Studio 2017. Thanks.
I am running a domain with over 1000 users on 3 domain controllers running windows server 2012. My domain consists of Windows 8 and windows 10 computers. When users try to change their password, they receive the following message ' a device attached to the system is not functioning".  and the system will not allow them to change their password. The same applies to creating new accounts if the option 'user must change password upon next login". If I unselect this option, users can log into he system. Also, if users get the message that your password has expired and they must select a new password, the users get the same message. Right now I am having to users contact me to change their passord on the server since they cannot. I have tried recreating the user account and even removing computers from the domain, the problem still persists. Anyone have any ideas on fixing this? Yes my active directory is replicating  and runningcorrectly
I have a windows 8 laptop that is running IE10. I cannot seem to find any where to upgrade to ie11 how can I do this thanks
Dear all,

Kindly note that I am facing windows 10 update issue for 3 days. I disable the windows 10 from the services.msc and uninstalled it from the program and features. On the second day the service of windows update launch by itself. Again, I disable it, uninstalled it from program and features and block it from the windows firewall.
Today, the service start again. I am pretty sure there is something that enable this service somehow.
I am really annoyed and feeling crazy about.

I have  Web Applications for reset passwords and unlock accounts ( self service). i need to integerate this solution with the users login screen inside the organizations.

by letting the users press on Forgot Password or Self Service link under the login screen then it will open web browser with predefined page for our solution.

is this doable or no ? we have WIndows 10 & Windows 8.1 Machines in the channel.


I've a kid that likes to play with keyboard and power/restart buttons in the case, so, is there a way that I can make windows ask for a password when I try to shut down or restart?

OS: Windows 8.1

Best regards,
Hello, i am using the Windows 10 upgrade assisant on my Win 8.1 pro, and it will say downloading windows 10, hit 100% and then start over from 0 and then the same process over and over again. Any thoughts?
User has Microsoft Word 2013 running on a Windows 8.1 machine.  Whenever they try and open a file that has been emailed to them, they get an error message from Word.  If they receive a .zip file, they can click on the zip to open it, which then shows a list of the files in the archive.  These files can't be opened by double-clicking.

I looked at Windows Update, but I don't see any Office 2013 updates.

Microsoft Word error message
I have been able to work around this file open error in the following way:
  • User saves file to computer (they are saving in DropBox)
  • User then right-clicks on the saved file, and selects  EDIT
  • The file appears on the screen, and can be viewed and printed.

Could this be a Word problem?  Would upgrading to Office 365  or  Office 2016 help?

Any idea why these attachments can't be opened?

I have a 4 year old HP laptop that was originally Windows 8 and then I updated it to Windows 10 when they offered the free upgrade.  It wasn't being used much lately and when it was being used it ran slow (apps slow to respond to being launched, etc), so I decided to clear off all my files and restore it back to original windows 10 settings to see if it would work any better.  When I did that it got stuck early in the Windows install (spent many hours at 10% loading drivers).  I gave up on that and figured I would come back and try to figure out what is going on later.  I pulled it back out this weekend and when I start it up it gives me an error "The computer restarted unexpectedly or encountered an unexpected error.  Windows installation cannot proceed.  To install Windows, click "OK" to restart the computer, and then restart the installation".  I do that and get the same message each time.  Anything that I should try at this point?  Would the fact that it got stuck on the restore indicate that something is wrong with the hardware?  Trying to determine if it is worth much effort to try to get it to work again or if I need to give up on it.
Hi One page is always my startup page. I want to remove it, but I cannot in Firefox and Chrome.

Here are steps I used:

How do I change my start page in Firefox?
Change Startup Page. On any open Mozilla Firefox window, press “Alt-T,” and then select “Options” on the drop-down menu. Under the General tab, insert the URL of a website or Web page into the field next to “Home Page,” and then click “Use Current Page” to make it your default startup page.

After I did above, it is still there when i start Firefox in Win8

Anyone has some suggestion? Thank you
Is there any setup example on sharing files on Microsoft Clouds, main on

1. simply sharing of files across different regions in China
2. approval progress for CAPEX / OPEX (Excel / Word document)

Is it any simple guideline for setting up option 2 ?

Can I say Clouds should provide better performance (Speed) comparing with users access the document in one centralized server through VPN, as Microsoft should provide better network connectivity across different regions / countries through their cloud services ? Window OS are Window 7, 8 and 10.

Hi Wifi adapter disappear in Network Connection in Win8. this might be virus issue. Checking Device manager, I also cannot see it. System restore cannot get it back to normal. Anyone can give some suggestion? Thank you
My dropbox was working fine. Suddenly it stopped synchronizing, I uninstalled it tried to reinstall and I got the following message:

error 2 in the installation tools

I  changed the HD reinstalled a fresh copy of windows 8. No firewall no antivirus installed.

Still same problem

No help in google

Any ideas
I'm looking for a quick and easy way of exporting and importing Windows environment variables.

I have a user who creates a lot of custom Windows environment variables that do things such as launch custom Windows Explorer paths, open different programs, and do other things.

These variables are defined with letters such as u that has a value of C:\Users so that when the user types in %u% within a Windows Explorer browser window or within the run dialog box Windows Explorer will open in the C:\Users folder.

The user also has several programs that will launch if other variables such as %z% or %r% are typed in.

We would like to be able to export these custom Windows Explorer environment variables so that they can be exported into another Windows operating system.

How can this be done?

Windows 8

Windows 8 is a personal computer operating system developed by Microsoft as part of the Windows NT family of operating systems, with an emphasis on improving its user experience on tablets. In particular, these changes included a touch-optimized Windows shell based on Microsoft's "Metro" design language, the Start screen, a new platform for developing apps with an emphasis on touchscreen input, integration with online services, support for USB 3.0, Advanced Format hard drives, near field communications, and cloud computing. Additional security features were introduced, such as built-in antivirus software, integration with Microsoft SmartScreen phishing filtering service and support for UEFI Secure Boot on supported devices with UEFI firmware.