[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x

Windows OS

111K

Solutions

80K

Contributors

This topic area includes legacy versions of Windows prior to Windows 2000: Windows 3/3.1, Windows 95 and Windows 98, plus any other Windows-related versions including Windows Mobile.

Share tech news, updates, or what's on your mind.

Sign up to Post

I have a Windows 7 Pro workstation running Office 2013. The workstation has all of the latest Windows 7 and Office 2013 updates.
-  Its connected to an SBS2008 server
- Everyone is set up to use SBS2008 Exchange server 2007 email. The Microsoft Office 2013 is a full install and not a subscription

When the user opens a spreadsheet saved on the server, he cannot open it up. Excel starts to open by displaying the Excel logo twice and then only opens the Excel template page where it shows all of the recently open files on the left side and all of the available Excel templates to the right
- Confirmed that this issue is true for all of the Office data files (Word, Excel, Powerpoint. .etc
- There are no issues opening any Office data files on the local drive
- No other user is having this issue

Troubleshooting Steps
-      tested and confirmed,  opening any office application files on the local drive, opens fine
-      tested and confirmed,  opening any office application files anywhere on the server, will not open,  
-      Logged off as the user and then logged on as the server administrator from his PC and was able to open any office document on the server as well as local files
-      ran a repair of the Microsoft Office 2013.  No Change
-      restriped the users full control security access to all his data on the server to no avail. User has no issues opening any non-office data files suchs PDF's and JPG's  . .etc
However, if I copy any office related data file from the server to …
0
For some reason, I can't get my Windows batch script to read a file.   The file exists...I've checked a million times. The path is correct...I've checked a million times.  

Yet it does not enter the "for" loop.  If I put double-quotes around the %DataElements%, it goes into the For loop just fine and prints the value of %DataElements%.  I paste that value in the CMD window and up pops the file.  It doesn't make sense.  

@echo off
setlocal enabledelayedexpansion
set DataElements=E:\myDir\Data_Elements.txt
for /f "tokens=*" %%a in (%DataElements%) do (
      set line=%%a
      echo line is !line!
)

What the heck?!
0
Hello Experts!

I have a router with port forwarding turned on for access to a networked printer (port 9100) from external devices.  I want to lock down access to this port to only come from various IP addresses (to avoid spammers from printing to this device).  My router does not seem to have the capability to lock down access to this port from IP addresses, so I'm looking for a way for the Windows OS to only allow certain IPs to access the port.  Is there a way to do this?

Thanks,

-Joe
0
PowerShell Gurus,

PowerShell Version
$psversiontable

Name                           Value
----                           -----
PSVersion                      5.1.17134.407
PSEdition                      Desktop
PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}
BuildVersion                   10.0.17134.407
CLRVersion                     4.0.30319.42000
WSManStackVersion              3.0
PSRemotingProtocolVersion      2.3
SerializationVersion           1.1.0.1

Open in new window


I have a huge conundrum.  Simple AD query for Computer objects with dnsHostName attribute.  Populates in the console correctly:

PS C:\WINDOWS\system32> get-adcomputer -filter * -Property * | Format-Table dNSHostName

dNSHostName
-----------
isserv95.contoso.com
isserv33.contoso.com

ISSERV46.contoso.com
isserv8.contoso.com
ACE-ARCHTICS.contoso.com
ace-test-mub1.contoso.com
ace-host-pc1.contoso.com
ISSERV36.contoso.com
BS-ESTP-LT1.contoso.com
mub1-laptop.contoso.com

Isserv15.contoso.com
ACE-TRAV-MSTR.contoso.com
ACE-TRAV-MSTR1.contoso.com
ISSERV97.contoso.com
IT-MIS-SB1.contoso.com
isserv64.contoso.com
ISSERV96.contoso.com
Coloserv64.contoso.com
ISSERV99.contoso.com
as-acct-lt4.contoso.com
CC-ALTN-AC1.contoso.com
HS-LAUN-PC3.contoso.com...

Open in new window


Populates the variable:

$computers = get-adcomputer -filter * -Property * | Format-Table dNSHostName

Open in new window


$computers

Open in new window


dNSHostName
-----------
isserv95.contoso.com
isserv33.contoso.com

ISSERV46.contoso.com
isserv8.contoso.com
ACE-ARCHTICS.contoso.com
ace-test-mub1.contoso.com
ace-host-pc1.contoso.com
ISSERV36.contoso.com
BS-ESTP-LT1.contoso.com
mub1-laptop.contoso.com

Isserv15.contoso.com
ACE-TRAV-MSTR.contoso.com
ACE-TRAV-MSTR1.contoso.com
ISSERV97.contoso.com
IT-MIS-SB1.contoso.com
isserv64.contoso.com
ISSERV96.contoso.com
Coloserv64.contoso.com
ISSERV99.contoso.com
as-acct-lt4.contoso.com
CC-ALTN-AC1.contoso.com
HS-LAUN-PC3.contoso.com...

Open in new window


When trying to export-csv, no matter if I am on my laptop or domain controller, when I open the output it looks like this... every time:

get-adcomputer -filter * -Property * | Format-Table dNSHostName | export-csv C:\users\mar534\des
ktop\computers.csv -NoTypeInformation -Encoding UTF8

Open in new window


This is what the csv file looks like:

PowerShell Computer Inventory
I have tried attributes Name, OperatingSystem, etc all yield the exact same results.  I even tried removing the arguments at the end, adding -Encoding ASCII, to no avail.

In over 22 years in IT I have never run into this issue before?  Has anyone seen this before, and if so, what was the fix?

Thanks,

Mark
1
I had a Windows 10 machine die on me and now I am trying to set up a replacement. I am running Windows SBS 2011 and used the backup feature for the (now dead) machine. I am now trying to connect the new machine to the server so I can restore the backup, but whenever I run the http://[server]/connect command, the client software installation stops with the message: "Cannot connect the computer to the server because either another software installation is in progress, or, the computer has a restart pending. Either complete the installation process, or, restart the computer and try to connect it again."

I have restarted both the client and the server computers since I first got this message; no joy. I have joined the client computer to the domain; it can see the server and other devices on the network.
0
My Windows 10 system has crashed twice in the last two days. When it happens it just stops completely with my monitor turning off as well and the connected printer recycling. The interesting thing is that this Windows 10 system has not communicated with the 4K seiki monitor and does not go into sleep mode. Even more interesting is my Windows 8.1 system does communicate with an identical Seiki 4K monitor and does enter sleep mode automatically.

No blue screen of death, no warning whatsoever. My battery backup is not doing anything so it must not be a power issue. When I turn my monitor back on and press the start button on my computer it starts back up with no problem.

Both times I was working with a Microsoft Access 2013 application in VBA.
0
in 2016 windows server backup I am able to do a one time backup of the System State of the Domain Controller to a mapped drive, but can not schedule the same job. Are there steps for on how to back up to a share\mapped drive from a DC?
0
Hi Experts,

We have a Windows server that's a domain controller that has been tombstoned, this has now gone over the 60 days tombstone lifetime. We would like to get the DC back up and running as normal and in order to do this I believe this will need a force removal from the domain?. I think a dcpromo /forceremoval needs to be done to demote the DC to a member server

Is my understanding correct?, any other recommended key steps required?  
There are other DC servers in the environment that are working fine.

Thanks
0
New Windows 10 Pro PC cannot access \\SERVERNAME (Error Code: 0x80070035 - The network path was not found.) Windows Server 2008

Hi all

The windows 7 PC's can access the shared folder stored on the server but I get the above error on the new windows 10 pro pc?

Any windows 10 hot fixes etc available...?

I see a solution for WINDOWS 7 but not WINDOWS 10.

Thanks in advance ...D
0
The operating system for my HP Probook 470 laptop G3 laptop  is Windows 7.  A blue screen occurred just a few minutes ago.  
I have attached the dmp file.  Please translate this dump file for me.  What is the problem?
120218-15771-01.dmp
1
SQL 2014 Database Mail stopped working

Windows 2012 R2 Cluster

SQL2014 Failover setup  2 Nodes 3 SQL instances al have SQL Database Email setup

On 2 of the 3 instances Email stopped working all 3 where working great
I do not know what caused this or when it started and I just got some time to look into this   getting this error every time email is attempted to be sent

Se attached for the log

Also tried running this query
ALTER DATABASE MSDB SET ENABLE_BROKER

And it is just not completing   Executing query is taking very long time


Any ideas?

Thanks

TomSQl Log
0
Hi,

I created a new Windows 2008 R2 domain and am migrating applications to a new drive on my Windows 10 workstation.  Installing printer definitions, etc.
I am logged in as the domain admin.

When I click on any link in the Manage your device section for a given printer, I get the following:

Permissions issue
Logging in with a local user account is fine.

Any suggestions on resolving this?

Thanks!

--Ben
0
I have a C# application  and i need to save data  from a
windows form screen to a postgresql database

The connection string and the stored procedure  (spabsecode_Insert)  for inserting into the database  
have been tested  and are working fine.

Below  is my Save Method

public void CreateAbseCode(AbseCodeModel model)
        {
            NpgsqlConnection conn = new NpgsqlConnection("Host = 127.0.0.1; Database = Tournaments; Port = 5432; Username = postgres; Password = manager");
            conn.Open();
            {
                NpgsqlCommand cmd = new NpgsqlCommand("spabsecode_Insert", conn);

                var p = new DynamicParameters();

                cmd.Parameters.Add(new NpgsqlParameter("absecode", model.Absecode));
                cmd.Parameters.Add(new NpgsqlParameter("absedesc", model.Absedesc));

                cmd.ExecuteNonQuery();

                model.Id = p.Get<int>("Id");

            }
        }

When i click  the save button and in the debugger  i get the line  cmd.ExecuteQuery() and then run into a syntax error .



I attached 2 screen shots

1. A screen of the record I am trying to save

2. A screen of the debugger screen showing that execution stopped  on cmd.ExecuteQuery  line

I will be grateful to have an expert look at the syntax of this line and the next line which is trying

to retrieve the model  ID  (An auto increament number)

Thanks

Olukay
Save-Screen021218.PNG
SaveDebugged021218.PNG
0
I recently upgraded from a Windows 7 computer to a Windows 10 computer. I have a Word 2003 file with several complicated macros. They do not run on later versions of Word so I installed Word 2003 on the Windows 10 computer. However the macros run about 3 times slower on the Windows 10 computer than on the old Windows 7 computer. I deleted the normal.dot file, switched to Windows 7 compatibility mode for word and checked that I have no add-ins in Word. None of this helped.

Any ideas?
Thanks
0
I'm doing remote office setup for employees and while doing testing I have remote XP machines that log in to VPN Server but are actually not connected. When I ping or type in router ip I get local router page. Weirdly, this is not the case with windows 2000 virtual machines on os x laptops which ping and login to host router web page.
0
I have one user that can't connect to his work computer using a VPN and MS RDP, This user has been able to connect successfully for a long time and it just stopped all of the sudden, user states nothing was installed or changed on this windows 7 computer.

We use watchguard mobile ssl vpn software and then connect with rdp directly using a local static IP to connect to the work computer. The user can connect successsfully to the firewall using the vpn. The computer gets the correct IP address from the firewall and i can ping network resources like the server and his computer. But when we start the rdp connection using the IP address it says RDP can't connect due to one of the following reasons and give 3 like... the pc isn't on and so forth.

However i can connect to the same work computer successfully from my computer using the same vpn and rdp IP address so i know the work machine is turned on and ready and the issue is specific to this local machine. I have looked at the norton  360 security and it appears that RDP connection and program is allowed fine. i have also tried to turn off the symantec software with no success.

Help is appreciated

matt
0
Hi everyone!

I'd like to know how to implement the following.

This is what I have:

I have a physical server with Windows 2012 R2 and inside it (HyperV) Windows 2016 Advanced Server. The server has 2 NICS. I have one static IP.

The goal: Configure the HyperV machine to be accessed from OUTSIDE/REMOTELY for 10 users. We have 10 User Remote Desktop Services licenses
So far nothing has been configured.

My questions are:
1.) Where should I install Remote Desktop Services, on the physical server or the HyperV, and how is this done? (if you have a link that will be helpful.

2.) How to make sure the 10 users will have access to the HyperV directly from outside?

3.) Anything else I should be aware of?
0
Hello, we have a BIG problem with a SAN (Lenovo DS2200). The new Windows 2016 server failed and we have setup an old Lenovo server, installing once again Windows server 2016.

Problem is, we can't access the storage inside the SAN. The connection is Fiber Channel and we see the partitions, but we only see them as raw partitions and can't find a way to access the data to recover it (it's basically virtual machines for a cluster).

We know the data is whole, because we can see this from the SAN web interface. But we cannot access it.

We never had to deal with something like this, so I was wondering if some kind soul would share some ideas here because we are drowning right now. Customer's at our throat.
0
I'm looking for some method (GPO or otherwise...) to disable the navigation capabilities in the latest version of Windows Open File and Save As File dialog boxes.  This capability poses a serious security risk to my RDP applications and has forced me to revert back to an extremely old NT-style dialog box that, while it resolves the security issue, is very limited in capability and, especially important to me, does not provide for my client users "OneDrive" as a location to save files to or open files from.  The issue is all the navigation capability located at the top of the dialog boxes:
Save As dialog box as it initially appears...The following dialog box shows the same box with "free-form" user-entered commands in this same area at the top of the dialog box:
Save As dialog box with user-entered text...With all the customization that Microsoft provides (primarily using Local or Domain Group Policies), I have to believe that there must be some way to disable this part of these dialog boxes.  Does anyone know how I can accomplish this?
0
Need better solution for backing up data to a network drive.  Powershell or batch script is ok, just the logging is less than desired.  Needs to be able to run on Windows server OS and handle large amounts of data (2 TB - 8 TB).  

FreeFileSync and SyncToy were great applications that worked well for this simple purpose.  Make a folder pair and configure the kind of sync between the folders.  I am fine doing in a script, just do enjoy the ease of use there.
0
Hi Experts,

We have 3 Domain controllers.
Whilst DFSR replication appears to be working fine, there appears to be an issue in the C:\Windows\SYSVOL\sysvol\domain.org\Policies folder
A number of files are identical in the Policies and Scripts folders within sysvol are showing & they all hold the same copy.

In the GUI, however (ie windows Explorer)there is a discrepancy in the size of the policies folder on DC2 compared to the other DC's (1 and 3).
The following event is seen in the DFS even log on all 3 DC's which I suspect is related to the issue:

DFRS event ID 5014
The description for Event ID 5014 from source DFSR cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:
7D733767-68B3-4A0E-839F-4C3162D1BDA9
DCR01
Domain System Volume
1726
The remote procedure call failed.
18713738-3F9D-46DB-B3AF-9613165C9A79


Note the event is recorded on all DC's at various times of the day and regular events (approx an internal of every 9 to 10 minutes on each DC)
The DFSR console is installed on the DC's and looking within the console it looks like replication folders have been setup to replicate the SYSVOL folder. I believe these should not be setup on the SYSVOL …
0
Using Windows Batch Scripting, I'm working to pull certain strings from an error log so I can build a SQL Statement.  

So far, I've gotten what I need into a file on one continuous line.  It should be that way each time I pull in an error.  I'm interested in pulling out only the UPDATE statements and certain elements related to each one.

The line may contain one or several INSERT, UPDATE or DELETE statements peppered throughout so it's very tough to decide what to search for.  

As I pull in the strings I want for each UPDATE statement, I'll build the SQL and call a stored procedure to do what I need to do.  Then return to the Batch Script to get the next UPDATE statement (if there is one).

I've already managed to get a Count of the number of UPDATE statements so I can use that for a loop.

The line below is an example of what I've managed to place in a file (all one continuous line).

} SQL Exception (state )(using SQL: "[UPDATE owner.tableName SET i_unwanted_column1=yyyy,i_unwanted_column2=yyy,i_unwanted_column3=yyyyy,d_unwanted_column4=to_timestamp('1900-01-01 00:00:00','yyyy-mm-dd hh24:mi:ss.ff3') WHERE i_pkey_column = yyyyy , UPDATE owner.tableName SET i_unwanted_column1=xxxx,i_unwanted_column2=xxxx,i_unwanted_column3=xxxxx,d_unwanted_column4=to_timestamp('2018-10-29 00:00:00','yyyy-mm-dd hh24:mi:ss.ff3') WHERE i_pkey_column = xxxxxx ]"):

I need to extract the "owner", "tableName" (found after the UPDATE), the primary key column name and it's value…
0
How to set up two RDS servers on the same subnet on Windows 2012 R2.

I configured a second RDS server with the exact same configuration as the first one and restarted both servers, the first one dropped all settings after restarting it and users weren't able to log in.  Only one connection broker is allowed across multiple RDS servers?
0
We have an unexpected extended domain migration transition period with one of our clients which means that their old Windows Server 2012 Essentials server may start shutting itself down soon. My question is whether it's possible to avoid the shutdowns by passing the FSMO roles back to the Essentials server until we're closer to the point where we can retire the Essentials server?

The current situation is that we've promoted the new 2016 standard server and transferred the FSMO roles to it. DHCP & DNS is still currently served by the old 2012 Essentials server. There is a production SQL application on the old server which needs to stay in place for the next 6 weeks - hence why we need to keep it running.

Is it just a matter of transferring the FSMO roles back? Would that keep the old server happy?
Would we then be able to keep the new server running as a domain controller without the FSMO roles until the migration time?

If not, will we need to demote the new server? Would that be enough to keep the old server happy, or is it simply too late for all that now that it's seen a new DC on its network?

If it does start shutting down, how often will that happen? It might be that we could cope with it as the company is only small.

Any gems of wisdom from your experiences would be appreciated!
0
how to get members of distribution group through windows PowerShell

also how get alias smtp addresses of a shared mailbox through command shell in active directory
0

Windows OS

111K

Solutions

80K

Contributors

This topic area includes legacy versions of Windows prior to Windows 2000: Windows 3/3.1, Windows 95 and Windows 98, plus any other Windows-related versions including Windows Mobile.