We help IT Professionals succeed at work.

Windows Server 2003





Windows Server 2003 was based on Windows XP and was released in four editions: Web, Standard, Enterprise and Datacenter. It also had derivative versions for clusters, storage and Microsoft’s Small Business Server. Important upgrades included integrating Internet Information Services (IIS), improvements to Active Directory (AD) and Group Policy (GP), and the migration to Automated System Recovery (ASR).

hi ,
got a windows 7 computer.(work group- not joined to domain)
got a local admin account- forgot password for it
got another non-admin user- can login to it.

is there any way to reset the password of the admin account ? ?
with non admin account- i cannot do much bcoz of no admin rights, i cannot install any software or make any changes to computer.

any help to reset windows 7 professional admin account ? ?
trying to run the hybrid setup from office365 exchange admin centre console. - giving an error "cannot download the application. application missing some file" tried running in 3 windows 10 computers, server 2012.  same issue.

attached a pic of the error,

could anyone help me how to run the hybrid setup wizard?
got a windows server 2012 . hyper v - running 7 vm
got 2 disks in hyper v “c &d”

all vm vhdx are in “d” drive
but for 3 vm- vmrs&vmcx are in “c” drive.
c drive space is too low. vmrs file has filled up close to 50gb. ( I know they are all ram sizes of each vm)

how do I move vmrs&vmcx files to “d” drive ???  
and second question - how do I find out which vmrs file is associated with which vm ??
How to determine PAE already configured in windows 2003 Enterprise

When i checked Windows system properties, i able to see that the General tab of the System Properties lists Physical Address Extension at the end of the Computer section.

But when i check the actual Boot.ini in notepad, i dont see any extension has been added " /PAE"
As per Application vendor - Require configure "4gt-tuning feature" in windows 2003 server Enterprise Edition

Currently the server having 36 GB Ram installed

Require configure  "4gt-tuning feature"

How to enable 4gt-tuning  in windows 2003 server Enterprise Edition

 The server having 36 GB and still need to use "3/GB" value to edit the boot.ini file.

Went through few ms documentation but its quite confusing.

Require step by step to enable/configure "4gt-tuning feature" in WIndows 2003 with existing assigned physical memory value
How do i run remotely commands on a machine .to let suppose find a file in D Drive if it exists or not from my local machine .

Here are the details
My local machine is in A domain and i connect to jump server through B Domain credentials .from there i connect to Windows Server 2003  through service account credentials.

I need to run a command find /N /I  "String" D;/Man/SC.txt (for example) from my local machine on that remote windows server .How do i achieve that .Everytime I need to RDP to jump server an then onto windows server .How can i acheive this using psexec or some tool .

i got 2 vpshere hosts. - running esxi 6.5.0 in HP Proliant servers.
host 1 running - 5 vm
host 2 running - 5 vm
both hosts are in HA mode.
so when host1 goes down, all 10 vm starts to run on host2 .  - this part is working good as expected.

but again when host1 comes up- the vm are not falling back again to host 1 from host2 .. -- how do i make it to work ? ? ? currently i had to manually move vm from host2 to host1.
hi guys,
i got a setup in one of my client environment and it works good. but just trying to understand it.

data vlan(1)-
all 3 vlans in layer3 switch. and it’s doing inter vlan routing

 connecting switch and router( access ports with vlan(1)
in switch got an default route pointing to router through interface vlan(1)
and got static route in router for vlan2&3 to point

so all working good.
but my question. is :
1- how switch forwards default route traffic through vlan1. I always thought switch and router connection should be trunk. but it works with access ports in between them .
I am migrating a 2003 server to a 2008R2 server in preparation to migrate to a 2019 server. As part of the first phase, I have transferred all 5 FSMO roles to the new 2008R2 server, removed the global catalog from the 2003 server.  I was ready to dcpromo down the 2003 server when I get the message that the 2008R2 cannot be contacted.  I do not have the "This server is the last domain controller in the domain" checked.  I am pulling hair as to what I have missed.

Running dcdiag yields this:

Domain Controller Diagnosis

Performing initial setup:
   Done gathering initial info.

Doing initial required tests
   Testing server: Default-First-Site-Name\FS1
      Starting test: Connectivity
         ......................... FS1 passed test Connectivity

Doing primary tests
   Testing server: Default-First-Site-Name\FS1
      Starting test: Replications
         ......................... FS1 passed test Replications
      Starting test: NCSecDesc
         ......................... FS1 passed test NCSecDesc
      Starting test: NetLogons
         ......................... FS1 passed test NetLogons
      Starting test: Advertising
         ......................... FS1 passed test Advertising
      Starting test: KnowsOfRoleHolders
         ......................... FS1 passed test KnowsOfRoleHolders
      Starting test: RidManager
         ......................... FS1 passed test RidManager
      Starting test: MachineAccount
We have two 2003 domain controllers. I would like to make the backup the primary, and the primary the backup.

What are the steps to do this?

It's 2020 and I'm having a hard time finding any material online that goes over this. Thanks.

I have a batch script that the final exit is:

SET JOB_DESC=Notifying users that %JOB_NAME% data load has been completed.
set emailsubj=%EMAIL_SUCC_SUBJ%
set emailbody=The script '%JOB_NAME%.bat' to export Lev0 data and application artifacts to '%EXPORT_DATA_DIR%' and '%EXPORT_APP_DIR%' was successful.
set emailbody=%emailbody%  See attached log file for details.
cscript %UtilFolder%\sendEmail.vbs "%ADMIN_EMAIL_LIST%" "%emailsubj%" "%emailbody%" "%MSTR_LOG_FILE%"
echo Successfully exiting the program
exit 0

However in the Task Scheduler it stays in 'Running' mode.  If I change the last line to 'exit' only, then Task Scheduler properly resets to 'Ready' mode.   I need an exit code of 0 as I'm moving this to Autosys, but want to make sure I don't have anything improper here or I need to revise how I handle exit codes.

Any help and education on exit codes is appreciated as they seem to differ from system to system....
Links and hints for deploying LAPS would be helpful.
Which procedure available on the web is the one you  prefer?
Or, perhaps you just use Microsoft instructions as you set it up?

I found this:
https://blog.thesysadmins.co.uk/deploying-microsoft-laps-part-1.html ... and -part-2.html
Is it reasonable?  There are clearly a number of things that are needed that could be intrusive.

Particular "hints and kinks" that you suggest?
We are migrating some data and would like to change some of the groups, while preserving the rest of the permissions. What is the best approach to do that? At the moment I am thinking something along the lines of

set the permissions manually at the top level - easy

use robocopy to copy only the contents without affecting the  level folder - basically run it at "\\server\folder\subfolder" level - not ideal as I'd have to copy any files at  "\\server\folder\" level separately, and sometimes there are loads for subfolders, so plenty of robocopy instances.

run some sort of a script to get a list of subfolders where due to blocked inheritance the old group still exists and has been copied across by robocopy. maybe some get-acl/set-acl script that finds a group, removes it and adds a separate group in its place.

finally run some script to get a list of files that have manually - not likely but if it is possible, so someone would have done it.

There is a lot of data, so I am trying to use inheritance to do most of the work, and then just mop up the instances of blocked inherritance, rather than run some script against every single file.

Is it possible to change the standard 10 PCs limit joining to domain, but for one user only?
win 2012 domain
Hi, I have been dealing with a problem that was not set before but now I need to do it. How can I track what and where a user in my AD have been opening, remote log, and log, and file or any change on the network. is there a script or a small app that can show me this?
got server 2021 hyperv
got a virtual machine in it.

recently saw the hyperv space is getting filled up fast. found avhdx files are created by snapshots.
my understanding snapshots are to go back if needed. so if i dont need those snapshots, can i just simply delelte to free up some space. or deleting it- will craete any data loss with my current virtual machine ?
have also attached a pic of it      snapshot.PNG
We have a windows server 2003 Print server , i have added a new ptinter yesterday , since thenwe experiencing a slow printing for some terminals in our sales department  to the

the printers from the same modell hp laserjet M452

I have tried to change the driver to pcl , delete the connection from  client ot server then readd it .

add the printer with ip address , all that have not work .

Restart the spooler , the server,

the print jobs get stuck in the spooler for 3-4 minutes before are printed .

when i connect to other print server , it prints fast

what can the problem be ?
We have 17 or so computers including 1 server 2003, 2 server 2012 r2s, and 2 server 2016s and the rest are windows 10.

Happened a month ago, used malwarebytes free until all the machines scanned clean.
The next day I noticed the 2003 server was reinfected, but the others were not, cleaned it up..

Came back today and noticed virus was back on most of the machines.

Does anyone have experience or suggestions on how to stop emotet / trickbot malware?
Hi Experts,

I am in a migration phase and I need some help please.

I have running an ADMT server and this server was working since end of 11.2019.
But now I have a problem to select the source domain when I like to migrate some users.

ADMT is unable to connect to domain controller....Access is denied.

Open in new window

The trust is tested and ok.
The user is a domain admin in both forests.
The servers are reachable via PING in both directions.
The local firewalls are disabled on both servers.

Do you have any ideas ?
could be a simple one
am changing computers.
so from old computer. i exported passwords from google chrome
in new compueter- i dont have option to import password in chrome again.
same chrome version on both computer Version 78.0.3904.108

i did research, everyone says go to "chrome:flags" - search for password import and export, enable and would get an option to import password.

but if i go to "chrome:flags"- search for password import - nothing comes. no search result.
i tried in different computers running windows 10 windows7 - did chrome stop doing password import ? ?  or am doing something wrong ?

have attached a pic as well
I have 3 domain controllers in my domain wich are windows server server 2003 and one is window server 2008 (all are DNS Servers) .

I want to get rid all the Windows server 2003 Domain controller and to keep them as DNS Servers , what is the best practive .

1- In Place upgrate to window server 2008

uninstall the active directory from them all (if that will that effect the DNS Server Role) ?
in windows server active directory i created a user:
 firstname: joan
last name: t
display name : joan t

then later i change the first name:
last name: t
display name: jo t

but still when i open the user properties: its shows "joan t" at top and in outlook address books, it still shows as joan t
have attached a pic of it to make it more understandable
IMG_0879.jpghow do i change this. ? any ideas ?
hi guys,
just looking for any free softwares to convert ost file to pst ?
ost is about 5gb size
I've recently build two new Windows 2016 DC's (DC01 & DC02) in order to replace my old Windows 2008 DC's (DC1 & DC2).

However, now when I try and open the Group Policy Management in either of the 4 DC's, I'm getting an error The Network name cannot be found.

I'm stuck.  Can anyone help me with this?
I’ve a group policy being applied from a demoted server, how can I remove it?

Windows Server 2003





Windows Server 2003 was based on Windows XP and was released in four editions: Web, Standard, Enterprise and Datacenter. It also had derivative versions for clusters, storage and Microsoft’s Small Business Server. Important upgrades included integrating Internet Information Services (IIS), improvements to Active Directory (AD) and Group Policy (GP), and the migration to Automated System Recovery (ASR).