Windows Server 2003





Windows Server 2003 was based on Windows XP and was released in four editions: Web, Standard, Enterprise and Datacenter. It also had derivative versions for clusters, storage and Microsoft’s Small Business Server. Important upgrades included integrating Internet Information Services (IIS), improvements to Active Directory (AD) and Group Policy (GP), and the migration to Automated System Recovery (ASR).

Share tech news, updates, or what's on your mind.

Sign up to Post

I have a serious issue on one old terminal server (2003).

I have recurring virus, coinminer it seems, which I don't know how it passes into the computer. It is quite isolated environment.

It creates either gfxdrv.exe or gxdrv.exe in windows\temp and coin mines.

Did anyone encountered this problem? I don't know how to get dir of it.

Free Tool: ZipGrep
LVL 12
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.


Please, do you know, what is the impact on the service, if we disable SMBv1 protocol on Domain Controller?

Indeed We have several Operating system : Windows server 2003, 2008, 2012, windows 7 and 10.

I am waiting for your response as soon as possible.

Best regards,
We are unfortunately down to one domain controller and we have a journal wrap error for replication  occurring which is preventing us from replicating to a new DC which we have installed. The DC is a Windows 2003 server.

The following is shown in the eventvwr. It recommends adding the following to the registry but I see multiple folks on the internet that say not to do this if you only have one DC.  Alternatively, I saw the following on the internet about BufFlags.  Is this the better approach?  What is the correct way to solve this issue?

Click down the key path:
Double click on the value name
   "Enable Journal Wrap Automatic Restore"

Here is the event viewer error:

The File Replication Service has detected that the replica set "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.
 Replica set name is    : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)"
 Replica root path is   : "c:\windows\sysvol\domain"
 Replica root volume is : "\\.\C:"
 A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found.  This can occur because of one of the following reasons.
 [1] Volume "\\.\C:" has been formatted.
 [2] The NTFS USN journal on volume "\\.\C:" has been deleted.
 [3] The NTFS USN journal on volume …
Raising Domain and Forest levels from 2003 to 2008R2 or 2016

We have one location.

It has a physical 2008R2 and a VM 2008R2 PDC and BDC
They are set as Domain and Forest functional levels 2003
There are no trust relationships I can see or know about (small possibility of one in past but unlikely and certainly not required)
I have two Hyper V instances of 2016 not joined to the Domain or with any roles

I have run DCdiag /c / e /v and Repadmin /showrpl on both servers along with AD PBA these show no issues. We have no issues with the servers or AD and I have latest updates and they are freshly rebooted last night.

My Plan was to upgrade the 2008R2 servers from 2003 functional levels to 2008R2, reboot recheck overnight. As long as this is OK I would then add the 2016 servers and look to decomission the 2008R2's once the 2016's had been promoted.

Does this all sound simple and relatively low risk? Any other checks or gotchas? This is quite a small simple environment, the only other servers have no DC functions and are 2008R2 terminal services and 2012 running SQL. DNS also looks good and is on PDC.
Hi guys,
I got a server 2008 r2 and applied permission to a folder for one particular user. For some reason permission stopped in mid way and gave error, it could not apply to all child folders and files
How do I fix this issue ?
Should I go around each child folder and see whether he permission applied for that user, and if it’s not applied should I do it manually ?
Is there any other better way ?
The parent folder has around 15 child folders and each child has few more folders inside it . So it’s bit of pain right now, as permission for that particular user is just applied for some child folders only .
Hello Experts

Looking for advice, views, experience for a project our company are working on.

What it is our project consists of is 2 C# executables both being multi-threaded, one being setup as a TCP listener and the other being setup as TCP Client, these 2 do not talk directly to one another, but what they will do is communicate to 20 machines and both the exe’s will be hosted in the application server.

Exe 1 (TCP Listener) - communicates with 10 machine clients this way we are controlling the business process.
Exe 2 (TCP Client) - communicates with the other 10 machines which are listeners(code setup by vendor), this way they are doing the controlling of the business process.

Exe 1 we have completed that's fine.

Exe 2, how this works is we load up from a SQL DB table the 10 IP's of the each of the 10 machines and put each IP into its own thread and we connect directly to them, and the 2 way comms begin sending/receiving based on signal protocols information.

Our company have always setup to be controlling the complete process were we are the listener only and every machine is a client, but due to inexperience people in the project have some doubt using it the other way around.

My question is has anyone set up in this fashion before were 1 TCP client executable connects straight into multiple listeners and how they found it?

I appreciate all advice, views and experiences.


We have an external hard drive which was BitLocker encrypted by a Windows 10 PC.

This external hard drive is used to back up data on our PCs and servers.

Each month, we would back up  this data.

Each time the external hard drive is plugged into a PC, a password is required.

BitLocker does is not supported by our Windows Server 2003 servers so the password would not be unlocked.

Decryption is the first step we would do and then backup data from all PCs and servers.

This time, while the external hard drive was in the decrypting process and over 80% complete, the PC was accidently turned off.

After this happened, when trying to login with password to this drive to continue the decryption process, the password is not accepted.

I tried to unlock the drive by using the correct recovery key and it is also not accepted.

The last thing I tried was unlocking the drive through command line with administrative privilages with recovery key and the message back was; "The password failed to unlock volume E:".

I have researched this an some people have imaged the hard drive.

There is a lot of important data on this external hard drive and we would like to know how to unlock the drive and access the data rather than imaging the drive if possible as we would just have an external hard drive which is unusable.

All help appreciated.

Client server failed to login via domain with error prompt.

Each time when tried to login via domain, error prompt " There are currently no logon servers available to service the logon request".

However able to login via local build in ID. Able to ping server Domain, dns, and gateway successfully.

When tried to perform nltest query, got reply as RPC server not available.

nltest reset secure channel failed.
How I can configure exchange 2007 to accept more recent cypher than RC4.
I have Exchange 2007 installed on windows server 2003
I need to install windows update KB940349 on windows server 2003 as acronis backup requires it to avoid snapshot issues.

Before i go ahead and install and risk having a server that won't come back.

Has anyone encountered any problems with KB940349 on windows server 2003 and did it require a restart?
Get your problem seen by more experts
LVL 12
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions


I need to migrate our current old domain controller from windows server 2003 r2 to another server we bought running windows server 2012 r2.

So i went through some online instructions and as understood i need to do the FSMO option:

I already tried to do that and get this error on the new server which i have joined to the current dc  screenshot here:

Migrating FSMO from 2003 to 2012 R2 -

 So i went through the first step:

Migrating FSMO from 2003 to 2012 R2 -

And i am receiving some problems where i currently have named Server1. as the domain controller running windows server 2003 r2  named as ask.local  and servertwo running server 2012 r2 where i am planing to migrate the domain.

I have attached here some screenshots hoping that someone know what the issue might be?

The server1 / server2003 as dc shows this under the event logs as well:

Event Type Warning
Event Source NETLOGON
Event Category None
Event ID 5781
Date   252018
Time   73049 AM
User   NA
Computer SERVER1
Dynamic registration or deletion of one or more DNS records associated with DNS domain 'ASK.local.' failed. These records are used by other computers to locate this server as a domain controller (if the specified …
I am looking for windows server 2003 in active directory  where I can ping by ip but cannot find through ns look up

it says this 10.x.x.x. is non existent domain

I looked through activerole service but cant find

is it that it has been deleted and crossed tombstone life time period, if so how come it shows as VM powered on on one of vm hosts.
Hi, i have an issue with a share on a 2003 server losing all permissions twice in the past 2 months

I realise its 2003 (we're currently getting server 2012 r2 ready but are waiting on 3rd party company to provide their side etc)

Any reason why permissions should be completely wiped, would like a link to why this is happening if possible
Hi, i just got a windows backup service running in a server 2012R2. its backing up the hole server for approx 700GB to an iscsi target.
target space is 750GB. backup works one day , next day it fails because of no space.  normally backup service deletes itself the old copy before running the next backup. am not sure why it is not happening in my case. if i delete old backups manually its succeeding next day. then again fails because of no space.
Could anyone help me with this

thank you
We're deploying an upgrade to our current system, upon launching the installer, the program/launcher gives us a message: "The application requires .Net Framework 4.5. Please install the .Net Framework 4.5 then run the installer again."

Is there any other way to install/upgrade our current .Net Framework installed?  Is there any alternative updates to consider.

We need your great minds here.

Thank you!

Server status:
Windows 2003 SP2
.Net Framework 4 Client Profile
.Net Framework 4 Extended
Hi Experts,

I am want to copy some of the user accounts from one Windows 2003 AD domain to another Windows 2003 AD domain. I am unable to use ADMT as the two domains are completely independent from each other and it is not possible to establish the trust.

Can you please let me know the best way to copy the user accounts. These accounts have also got a certificate attached with them. Is it possible to copy the certificate along with the account with all of its properties?

Many Thanks,
Disk MgmtHi,
 I have a Windows 2003 server as virtual machine (in VMWare box) that has 3 drives/partitions:
 C Drive (29GB Total / 1.7GB Free) : contains OS and Program Files/Application software. Constantly running out of space.
 E Drive (39GB Total / 29GB Free): has data files for the software. The software knows there are certain files on the E drive.
 F Drive (273GB Total / 269GB Free): Not being used.

 This used to be a physical server a long time ago and I don't remember whether I was doing RAID 1 or 5. But anyway C and E drive were on one set of hard disks (in the raid array) and F drive was on another.
 I moved this to virtual environment in VMWare server and disk structure (Disk0 and Disk1) is carried over to this virtual machine.
 Since C drive is constantly running out of space, I need to do something to provide more space for C.

 Back in the day, I used to use "partition magic" to merge partitions, but I could not have used it to merge F drive into C drive because they were in physically different partitions (or hard drives).
 Now they are in virtual environment (and this VM is on one drive in raid array) and wonder if I can merge them easily.

 (1) Can I merge F drive into C Drive so that I can have new C drive with 300GB of space?
 (2) What software would you recommend for merging? If there is a free software that I can use?

Got a server 2012 R2 which acts as a DC.
The event log, stopped publishing error logs. the last log was an error related to it why it has stopped.
COuld anyone help me to solve this issue why it suddenly happened.
Event ID 30 -Start up type error . please have a look at the attached pic of the event log.
[embed=file 1221365]Hi, I got a USB printer. Configured with port TS009.
When user logs off and log on, it comes as TS009 is inactive and I need to select TS0010 to make it work.
And again if user logs off, 0010 becomes in active and I need to select next port which shows as active ! Could anyone help with it this ?
I have attached a image for it. Please have a look.
Thank you.
[embed=doc 1221365]
Free Tool: Path Explorer
LVL 12
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Hi, guess i been posting multiple questions lately regarding roaming profiles. got one more to it.

 i got roaming profiles deployed using the profile path in AD in server 2008R2

just for one user, the logoff takes 15mins and logoff takes another 15mins.

i did some work, found her profile is about 15GB. issue might be , every time when she tries to login, its taking time to set up profile. and when logoff its trying to sync to server.

how do i solve this time issue? is it something should i ask her to move files to different location or any other way to make  logon/off faster ?
Hi everyone,

I have virtualized a Windows 2003 server into an Hyper-V environment with Disk2VHD. In the physical server I am able to do this:
I am able to see the content of netlogon.

When I do that in the virtual system (exact 100% the same Windows / setting / etc. offcourse) I get:
\\servername\netlogon is not accessible. You might not have the right permissions for this network location. Contact system administrator.

I do not get this permissions error since I cloned the physical to virtual, so everything should be exactly the same.

Can windows server 2003 WSUS version 3.2  deploy patch to windows 2018 and win2012?
I am running WSUS version 3.2.7600.226 on a Windows 2003 SP2 server. Recently, I have been getting an error everytime I try to generate a status report for any computer. The error is "an error occurred while generating the report. Try running the report again or contact your network admin for help" Also, Windows 10 machines are having a hard time getting updates from the same server. This server is pretty old and it only has 1GB RAM, running Pentium 4 2,6GHz processor. Any ideas?

How to enable and configure remote control of a user from another user session in Microsoft Windows Server 2008, from administrator i can get access to any of users which is login but from user to user its getting error (Session (ID 15) remote control failed).
These user have only member of Remote Desktop Users & Users
Members DetailError
I have a virtual Windows 2003 server. If you look at in in VMware the drives are 400GB and 409GB respectively, but my C drive was configured with only 12GB. I see a D drive with 124.54GB and 263.37GB of Unallocated space. The C drive continues to hit 95% and I have to do a disk clean up regularly. It would be so nice if I could just grab 10 or 20 of the unallocated GBs and expand the C drive. I have not extended a drive on Windows 2003 in years though and want to be very careful. Is it even possible if it is the same drive as the OS? I recall using a DISKPART command years ago in a situation similar to this. Is that one of my options. I attached a screenshot of the current drive configuration

Windows Server 2003





Windows Server 2003 was based on Windows XP and was released in four editions: Web, Standard, Enterprise and Datacenter. It also had derivative versions for clusters, storage and Microsoft’s Small Business Server. Important upgrades included integrating Internet Information Services (IIS), improvements to Active Directory (AD) and Group Policy (GP), and the migration to Automated System Recovery (ASR).