We help IT Professionals succeed at work.

Windows Server 2012

19K

Solutions

9K

Contributors

Windows Server 2012 is the server version of Windows 8 and the successor to Windows Server 2008 R2. Windows Server 2012 is the first version of Windows Server to have no support for Itanium-based computers since Windows NT 4.0. Windows Server 2012, now in its second release (Windows Server 2012 Release 2) includes Foundation, Essentials, Standard and Datacenter, and does not support IA-32 or IA-64 processors.

Dear experts, I'm using Veeam 9.5 to backup exchange 2016 server. It said that the log was truncated but when I checked on Mail server, they were not. Vssadmin list writers said that the Exchange writer is on Retryable state. Can you kindly suggest?

Many thanks
0
unable to disconnect a user session,

User informed of getting a black screen.

Now the session is showing  disconnected taking 0 MB.

please advice how to kill the user session.
0
I ran this script. It contacts AD but does not respond with results. It just waits for another entry.

C:\Save> Get-ADUser -Filter {mail -like 'emailaddress'} -Properties * | fl workid
C:\Save> _

It looks like above
0
I know that the general rule is never to perform an in-place upgrade, but I'm at a loss as to the best way to accomplish my objective.

Currently have a 2012r2 hyper-v host with 4 2012r2 guests.  I need to add a couple more guests, win2019.  Current setup is on direct storage.  Since "technically" 2019 is not supported on hyper-v 2012r2 what is the best way to proceed?  Can I upgrade the existing host to hyper-v 2016/2019?  If so, what is the best way to get there?  I do NOT have a cluster setup so I don't think that path works.
0
Dear, my Exchange 2016 server has 1 Database that could not be mounted. I'm restoring pst files for users from Veeam. After that, is it safe to delete that EDB manually?

Many thanks,
0
Windows 2012 R2  domain controllers

I am trying to update the ADMX files on my Domain controller
I downloaded Administrative Templates (.admx) for Windows 10 November 2019 Update.

I ran the installer and it placed the ADMX and ADML file into my Temp folder

I then made a backup copy of my current C:\Windows\SYSVOL\sysvol\mydomain.com\Policies\PolicyDefinitions

Next I copied the new ADMX and ADML files

I did this on one DC

Today the files are gone.

So I tried to install on both DCs at the same time and that did not work either.


I thought it would replicate from one DC to another.

the central Store is replicated I know because my GPO's are fine on both DC's

I guess the question is how do I update the ADMX and ADML files on my DC ?


Thank you

Tom
0
hi ,
got a windows 7 computer.(work group- not joined to domain)
got a local admin account- forgot password for it
got another non-admin user- can login to it.

is there any way to reset the password of the admin account ? ?
with non admin account- i cannot do much bcoz of no admin rights, i cannot install any software or make any changes to computer.

any help to reset windows 7 professional admin account ? ?
0
Hi, i have a server 2012 r2 that fell off the domain, i tried to rejoin it now, and i get the specificed network name is no longer available right after it asks me for creds.

What could be the cause?
0
Hi All.  

This particular VM we are running is reporting HD Controller failures.   Since it is a VM which has many VM's running off the box is there a way to determine whether or not the failure is the physical hard disk on the server or something else reporting?  Here is the error.

The driver detected a controller error on \Device\Harddisk0\DR0.
The driver detected a controller error on \Device\Harddisk2\DR1
The driver detected a controller error on \Device\Harddisk2\DR2.


+ System

  - Provider

   [ Name]  disk
 
  - EventID 11

   [ Qualifiers]  49156
 
   Level 2
 
   Task 0
 
   Keywords 0x80000000000000
 
  - TimeCreated

   [ SystemTime]  2020-03-30T15:00:03.147781900Z
 
   EventRecordID 2202132
 
   Channel System
 
   Computer TMMSage.tmmontante.local
 
   Security
 

- EventData

   \Device\Harddisk0\DR0
   1004800001000000000000000B0004C0030100000000000000000000000000000000000000000000BA20000000000000FFFFFFFF060000005800072200000000E42000000201200000000000F000000000000000000000000000000000000000000000000000000080A78E1600E0FFFF0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000


--------------------------------------------------------------------------------

Binary data:


In Words

0000: 00800410 00000001 00000000 C004000B
0010: 00000103 00000000 00000000 00000000
0020: 00000000 00000000 000020BA 00000000
0030: FFFFFFFF …
0
Hi Teams,

I facing issue with group policy, it is not replicating to other server,

any one can suggest me how can i troubleshoot group policy issue
0
I have tried all the resolutions I could find to be able to view all computers on my domain. I have turned on network discovery file sharing and print sharing,
Started these services "Function Discovery Provider Host" and "Function Discovery Resource Publication"  DNS Client - Automatic, SSDP Discovery - Automatic, UPnP Device Host
Enabled SMB 1.0/CIFS File in Programs and Features both the SMB 1.0/CIFS Client and Server.
Ran this command from admin cmd prompt netsh advfirewall firewall set rule group="Network Discovery" new enable=Yes

I still an unable to see all computers and before win 10 I could even see my servers cannot now.
0
Windows 2012 R2 DC and Member servers.

I have a domain joined member server that I installed Laps on.
updated the schema
ran Set-AdmPwdReadPasswordPermission -OrgUnit …………………………..   on each OU that contains the computers
created a laps GPO
ran gpupdate /force   restarted the server

getting this error

Log Name:      Application
Source:        AdmPwd
Date:          3/29/2020 8:47:48 AM
Event ID:      3
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SERV015.network.com
Description:
Could not get local Administrator account. Error 0x80070534.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="AdmPwd" />
    <EventID Qualifiers="49152">3</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2020-03-29T12:47:48.000000000Z" />
    <EventRecordID>216144</EventRecordID>
    <Channel>Application</Channel>
    <Computer>SERV015.network.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0x80070534</Data>
  </EventData>
</Event>


When I installed Laps on this member server I selected all option during the installation.

The same error and others errors are happening on all the domain member servers but I have not restarted them yet

Any ideas or suggestions

Thank you

Tom
0
Hello Expert, I am having an Issue with a Windows 2012 (Vmware VM).

First I had this error, and I couldn't login with domain users or local users
 First Error
So I have rebooted the server into safe mode, I have unjoined it fron the domain and reboot the server again, and  I was then able to login with the local admin account.

But I had the error below and I fixed it by using the solution in this youtube video ( https://www.youtube.com/watch?v=2-8gOC4BgYw)
I have copied the folder from C:\Windows\Users\Default\Desktop and pasted it  in this location C:\Windows\System32\config\systemprofile\
Second Error
And now , I cannot rejoin the server to the domain
 Third Error
I have tried to fix this issue by removing the network card and adding a new one. I also did a flush dns, and I am also able to ping the domain controller,but still not able to join the server to the domain.

Please help me experts
0
Our Windows Server 2012 STD R2 was hacked and randomware installed. We lost everything. Luckily we have it all backup to tape.
The problem is we were running Backup Exec 2014. I have now reinstalled the server with tried both the Trial versions of BE 2014.1 and and  BE 20.6 as we lost our software and license info on that server. The tape inventory and catalog ran successfully.  It shows the tapes with the data on them and the servers that the data was backed up from.The catalog how ever show not data sets to restore.
We have tried a few different evening backup tapes and they all do the same. I have tried a number of different solutions I found on the net but nothing seems to work.
See images below.

How can we restore the data from the tapes?
Is there another Backup program we can try that will read the tapes.

Tape Library showing Data on tapes.
Server picked up by the Catalog but showing no backup sets.
0
i want to do OS patching on DAG  which has 100 exchange servers  which are windows server 2016.

we are deploying vulnerability patch

do we need to put mailbox servers on maintenance mode as well?, will failover occur as well.

do we need to migrate PAM ?

any steps would help
0
Hello,

I need to use ROBOCOPY to copy all folders from \\SOURCESERVER\d$ (Please screen shot) to a shared drive of a new server \\NEWSERVER\CENTRAL

Can I use something like the below?

ROBOCOPY "\\SOURCESERVER\d$\BE Disaster Recovery Server Files" "\\NEWSERVER\CENTRAL" //MIR /SEC /W:0 /R:0 /IS /LOG:c:\copy.log
ROBOCOPY "\\SOURCESERVER\d$\GPOShare" "\\NEWSERVER\CENTRAL" //MIR /SEC /W:0 /R:0 /IS /LOG:c:\copy.log
...etc...

I want all folders to be shown in \\NEWSERVER\CENTRAL with all original security permission settings.  Please check if the parmeter I use are correct.

Thanks.
fileshares.png
0
Hi all!
Dynamics on premise, exposed with ADFS 3.0 and ADFS PROXY
So i have this scenario:

1 vm x sql (lan)
1 vm x dynamics (lan)
2 vm x dns and dc (lan)
1 vm x adfs (lan)
1 vm x adfs proxy (Dmz)

After windows update for windows 2012 r2 on ADFS and ADFS PROXY vm, it stops to authenticate from external
When i try opening https url, it loops until error
On lan, it works

on browser client this error:

    Activity ID: 00000000-0000-0000-5000-0080000000d0
    Relying party: CRM CLAIMS RELYING PARTY
    Error time: Tue, 24 Mar 2020 07:53:03 GMT
    Cookie: enabled
    User agent string: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0


on ADFS server i can try this log:

Encountered error during federation passive request.

Additional Data

Protocol Name:
wsfed

Relying Party:
https://mydynamics.mydomain.com/ 

Exception details:
Microsoft.IdentityServer.Web.InvalidRequestException: MSIS7042: The same client browser session has made '6' requests in the last '1' seconds. Contact your administrator for details.
   at Microsoft.IdentityServer.Web.Protocols.PassiveProtocolHandler.UpdateLoopDetectionCookie(WrappedHttpListenerContext context)
   at Microsoft.IdentityServer.Web.Protocols.WSFederation.WSFederationProtocolHandler.SendSignInResponse(WSFederationContext context, MSISSignInResponse response)
   at Microsoft.IdentityServer.Web.PassiveProtocolListener.ProcessProtocolRequest(ProtocolContext
0
hi,
trying to run the hybrid setup from office365 exchange admin centre console. - giving an error "cannot download the application. application missing some file" tried running in 3 windows 10 computers, server 2012.  same issue.

attached a pic of the error,

could anyone help me how to run the hybrid setup wizard?
office365.PNG
0
Is there a hierarchy of perhaps the top 5 most powerful default groups in Active Directory. I see domain admins mentioned quite a lot but I wondered if there were others to concern about as we need to review memberships for the high privilege groups across the domain.
0
Good evening experts,
I have a test environment for a small Doctors site. I am only dealing with one Domain Controller and 10 Windows 7 workstations. I would like to share with you the steps that I have already taken to enable my workstations to join the domain. I am just having no luck , and I am probably doing something wrong that a rookie would do. Here are my steps:

1. I added the active directory feature
2. I added the dns feature.

Below you will see an Active Directory domain with an associated DNS.
The next screen shot is me trying to join the domain from one of the office pc's
The next screen shot is the servers IP configuration for the ip, subnet mask, default gateway and DNS.





!

I hope I haven't missed anything. I would appreciate some feedback as soon as possible and I thank you for your anticipated responses.
0
I have a PPTP VPN setup on Windows Server 2012 R2 STD.
How many VPN connections will I be able to run concurrently?
0
Remote Desktop Server 2012R2, using Session Broker and two Hosts. Both hosts are reporting disk errors writting to the UPD, causing user profiles to blank out and become inaccessible.

I'm not sure where to start. The broker, the hosts, and the UPD server are all communicating just fine, no issues with space, no errors in the broker or the UPD server, just on the session hosts. This started happening yesterday, overnight I restarted the hosts and broker, and now more people are seeing this. Any ideas?

Log Name:      System
Source:        disk
Date:          3/13/2020 1:51:56 PM
Event ID:      15
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      *Omitted* (Session Host 2)
Description:
The device, \Device\Harddisk57\DR71, is not ready for access yet.

Log Name:      System
Source:        Ntfs
Date:          3/13/2020 1:51:56 PM
Event ID:      137
Task Category: (2)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:       *Omitted* (Session Host 2)
Description:
The default transaction resource manager on volume \\?\Volume{849bba0d-0f46-11e7-80e6-000d3a01128c} encountered a non-retryable error and could not start.  The data contains the error code.

Log Name:      System
Source:        disk
Date:          3/13/2020 1:51:56 PM
Event ID:      51
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:       *Omitted* (Session Host 2)
0
I have a dell poweredge server And was sent some pictures of a problem that occurred a few moments ago. It looks like the boot device has a problem. The following images were sent to me. Before I go on site, is there any advice you experts have for me looking at the screenshots. I am guessing that I need to reset something in the bios.  This is a windows 2012 server box
[embed=doc 1446600]
[embed=doc 1446601]
[embed=doc 1446602]
[embed=doc 1446603]
0
Folder System Volume Information has consumed 127gb (90% of total space) of the drive. What does this folder contains? Is it safe to remove files from it? Its not even allowing me to get inside the folder. This is not system drive but user profiles are stored here.

Please help? (A non-powershell solution would be helpful)
0
Hi all,  just a question

Now i have 2 replication groups, let's call it RepA and RepB, i wish to add in a new member server to this 2 connection, which i have already added in for RepA.

Replication Group : RepA
Replication Group: Rep B

RepA is mistakenly configure to a share path, let's call it E:\Shared3

RepB, i try to add in the correct path, E:\Shared3\testB

But i got the following error " The Path enter "E:\Shared3\testB conflicts with another replicated folder path "E:\Shared3 for the replication group RepA

So does it means if i change the RepA group path back to E:\Shared3\testA, it should be able to allow me to add?

Thanks.
0

Windows Server 2012

19K

Solutions

9K

Contributors

Windows Server 2012 is the server version of Windows 8 and the successor to Windows Server 2008 R2. Windows Server 2012 is the first version of Windows Server to have no support for Itanium-based computers since Windows NT 4.0. Windows Server 2012, now in its second release (Windows Server 2012 Release 2) includes Foundation, Essentials, Standard and Datacenter, and does not support IA-32 or IA-64 processors.