We help IT Professionals succeed at work.

Windows Server 2012





Windows Server 2012 is the server version of Windows 8 and the successor to Windows Server 2008 R2. Windows Server 2012 is the first version of Windows Server to have no support for Itanium-based computers since Windows NT 4.0. Windows Server 2012, now in its second release (Windows Server 2012 Release 2) includes Foundation, Essentials, Standard and Datacenter, and does not support IA-32 or IA-64 processors.

Windows 2012 R2  domain controllers

I am trying to update the ADMX files on my Domain controller
I downloaded Administrative Templates (.admx) for Windows 10 November 2019 Update.

I ran the installer and it placed the ADMX and ADML file into my Temp folder

I then made a backup copy of my current C:\Windows\SYSVOL\sysvol\mydomain.com\Policies\PolicyDefinitions

Next I copied the new ADMX and ADML files

I did this on one DC

Today the files are gone.

So I tried to install on both DCs at the same time and that did not work either.

I thought it would replicate from one DC to another.

the central Store is replicated I know because my GPO's are fine on both DC's

I guess the question is how do I update the ADMX and ADML files on my DC ?

Thank you

hi ,
got a windows 7 computer.(work group- not joined to domain)
got a local admin account- forgot password for it
got another non-admin user- can login to it.

is there any way to reset the password of the admin account ? ?
with non admin account- i cannot do much bcoz of no admin rights, i cannot install any software or make any changes to computer.

any help to reset windows 7 professional admin account ? ?
Hi, i have a server 2012 r2 that fell off the domain, i tried to rejoin it now, and i get the specificed network name is no longer available right after it asks me for creds.

What could be the cause?
Hi All.  

This particular VM we are running is reporting HD Controller failures.   Since it is a VM which has many VM's running off the box is there a way to determine whether or not the failure is the physical hard disk on the server or something else reporting?  Here is the error.

The driver detected a controller error on \Device\Harddisk0\DR0.
The driver detected a controller error on \Device\Harddisk2\DR1
The driver detected a controller error on \Device\Harddisk2\DR2.

+ System

  - Provider

   [ Name]  disk
  - EventID 11

   [ Qualifiers]  49156
   Level 2
   Task 0
   Keywords 0x80000000000000
  - TimeCreated

   [ SystemTime]  2020-03-30T15:00:03.147781900Z
   EventRecordID 2202132
   Channel System
   Computer TMMSage.tmmontante.local

- EventData



Binary data:

In Words

0000: 00800410 00000001 00000000 C004000B
0010: 00000103 00000000 00000000 00000000
0020: 00000000 00000000 000020BA 00000000
0030: FFFFFFFF …
I have tried all the resolutions I could find to be able to view all computers on my domain. I have turned on network discovery file sharing and print sharing,
Started these services "Function Discovery Provider Host" and "Function Discovery Resource Publication"  DNS Client - Automatic, SSDP Discovery - Automatic, UPnP Device Host
Enabled SMB 1.0/CIFS File in Programs and Features both the SMB 1.0/CIFS Client and Server.
Ran this command from admin cmd prompt netsh advfirewall firewall set rule group="Network Discovery" new enable=Yes

I still an unable to see all computers and before win 10 I could even see my servers cannot now.
Windows 2012 R2 DC and Member servers.

I have a domain joined member server that I installed Laps on.
updated the schema
ran Set-AdmPwdReadPasswordPermission -OrgUnit …………………………..   on each OU that contains the computers
created a laps GPO
ran gpupdate /force   restarted the server

getting this error

Log Name:      Application
Source:        AdmPwd
Date:          3/29/2020 8:47:48 AM
Event ID:      3
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SERV015.network.com
Could not get local Administrator account. Error 0x80070534.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="AdmPwd" />
    <EventID Qualifiers="49152">3</EventID>
    <TimeCreated SystemTime="2020-03-29T12:47:48.000000000Z" />
    <Security />

When I installed Laps on this member server I selected all option during the installation.

The same error and others errors are happening on all the domain member servers but I have not restarted them yet

Any ideas or suggestions

Thank you

i want to do OS patching on DAG  which has 100 exchange servers  which are windows server 2016.

we are deploying vulnerability patch

do we need to put mailbox servers on maintenance mode as well?, will failover occur as well.

do we need to migrate PAM ?

any steps would help

I need to use ROBOCOPY to copy all folders from \\SOURCESERVER\d$ (Please screen shot) to a shared drive of a new server \\NEWSERVER\CENTRAL

Can I use something like the below?

ROBOCOPY "\\SOURCESERVER\d$\BE Disaster Recovery Server Files" "\\NEWSERVER\CENTRAL" //MIR /SEC /W:0 /R:0 /IS /LOG:c:\copy.log

I want all folders to be shown in \\NEWSERVER\CENTRAL with all original security permission settings.  Please check if the parmeter I use are correct.

Hi all!
Dynamics on premise, exposed with ADFS 3.0 and ADFS PROXY
So i have this scenario:

1 vm x sql (lan)
1 vm x dynamics (lan)
2 vm x dns and dc (lan)
1 vm x adfs (lan)
1 vm x adfs proxy (Dmz)

After windows update for windows 2012 r2 on ADFS and ADFS PROXY vm, it stops to authenticate from external
When i try opening https url, it loops until error
On lan, it works

on browser client this error:

    Activity ID: 00000000-0000-0000-5000-0080000000d0
    Error time: Tue, 24 Mar 2020 07:53:03 GMT
    Cookie: enabled
    User agent string: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

on ADFS server i can try this log:

Encountered error during federation passive request.

Additional Data

Protocol Name:

Relying Party:

Exception details:
Microsoft.IdentityServer.Web.InvalidRequestException: MSIS7042: The same client browser session has made '6' requests in the last '1' seconds. Contact your administrator for details.
   at Microsoft.IdentityServer.Web.Protocols.PassiveProtocolHandler.UpdateLoopDetectionCookie(WrappedHttpListenerContext context)
   at Microsoft.IdentityServer.Web.Protocols.WSFederation.WSFederationProtocolHandler.SendSignInResponse(WSFederationContext context, MSISSignInResponse response)
   at Microsoft.IdentityServer.Web.PassiveProtocolListener.ProcessProtocolRequest(ProtocolContext
trying to run the hybrid setup from office365 exchange admin centre console. - giving an error "cannot download the application. application missing some file" tried running in 3 windows 10 computers, server 2012.  same issue.

attached a pic of the error,

could anyone help me how to run the hybrid setup wizard?
Is there a hierarchy of perhaps the top 5 most powerful default groups in Active Directory. I see domain admins mentioned quite a lot but I wondered if there were others to concern about as we need to review memberships for the high privilege groups across the domain.
Good evening experts,
I have a test environment for a small Doctors site. I am only dealing with one Domain Controller and 10 Windows 7 workstations. I would like to share with you the steps that I have already taken to enable my workstations to join the domain. I am just having no luck , and I am probably doing something wrong that a rookie would do. Here are my steps:

1. I added the active directory feature
2. I added the dns feature.

Below you will see an Active Directory domain with an associated DNS.
The next screen shot is me trying to join the domain from one of the office pc's
The next screen shot is the servers IP configuration for the ip, subnet mask, default gateway and DNS.


I hope I haven't missed anything. I would appreciate some feedback as soon as possible and I thank you for your anticipated responses.
I have a PPTP VPN setup on Windows Server 2012 R2 STD.
How many VPN connections will I be able to run concurrently?
Remote Desktop Server 2012R2, using Session Broker and two Hosts. Both hosts are reporting disk errors writting to the UPD, causing user profiles to blank out and become inaccessible.

I'm not sure where to start. The broker, the hosts, and the UPD server are all communicating just fine, no issues with space, no errors in the broker or the UPD server, just on the session hosts. This started happening yesterday, overnight I restarted the hosts and broker, and now more people are seeing this. Any ideas?

Log Name:      System
Source:        disk
Date:          3/13/2020 1:51:56 PM
Event ID:      15
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      *Omitted* (Session Host 2)
The device, \Device\Harddisk57\DR71, is not ready for access yet.

Log Name:      System
Source:        Ntfs
Date:          3/13/2020 1:51:56 PM
Event ID:      137
Task Category: (2)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:       *Omitted* (Session Host 2)
The default transaction resource manager on volume \\?\Volume{849bba0d-0f46-11e7-80e6-000d3a01128c} encountered a non-retryable error and could not start.  The data contains the error code.

Log Name:      System
Source:        disk
Date:          3/13/2020 1:51:56 PM
Event ID:      51
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:       *Omitted* (Session Host 2)
I have a dell poweredge server And was sent some pictures of a problem that occurred a few moments ago. It looks like the boot device has a problem. The following images were sent to me. Before I go on site, is there any advice you experts have for me looking at the screenshots. I am guessing that I need to reset something in the bios.  This is a windows 2012 server box
[embed=doc 1446600]
[embed=doc 1446601]
[embed=doc 1446602]
[embed=doc 1446603]
Folder System Volume Information has consumed 127gb (90% of total space) of the drive. What does this folder contains? Is it safe to remove files from it? Its not even allowing me to get inside the folder. This is not system drive but user profiles are stored here.

Please help? (A non-powershell solution would be helpful)
Hi all,  just a question

Now i have 2 replication groups, let's call it RepA and RepB, i wish to add in a new member server to this 2 connection, which i have already added in for RepA.

Replication Group : RepA
Replication Group: Rep B

RepA is mistakenly configure to a share path, let's call it E:\Shared3

RepB, i try to add in the correct path, E:\Shared3\testB

But i got the following error " The Path enter "E:\Shared3\testB conflicts with another replicated folder path "E:\Shared3 for the replication group RepA

So does it means if i change the RepA group path back to E:\Shared3\testA, it should be able to allow me to add?

I'm trying to demote a server 2008 domain controller and it says, you can't proceed because there is Active Directory certificate authority is installed. This is one remote site domain controller out of 5. How can I demote this domain controller? I'm reluctant to uninstall AD certificate service, as it might create problems?
I am having a problem with my DHCP server or should I say my network. I have had an old Windows 2003 DC on my network which used to control DNS, DHCP, WINS, Etc.. but over the years I have moved those services off that server and on to new servers (Windows 2008 R2 and Windows 2012 R2) and everything has been working great.

Over the weekend I decided to decommsion that server and move the FSMO roles over to one of the newer servers (Windows 2012R2) and raise the domain from 2003 to 2008R2 since I still have 2008R2 DC's on my network. Everything seemed to go fine but now I am experiencing issues with some of the workstations.

When I look at the configuration of the workstation it is set to DHCP but when I run ipconfig /all it shows the old DC that I decommissioned as the DHCP server and the DNS servers that are on those workstations are incorrect. When I manually add the DNS to the network config it works fine but if I remove then we are back to square one. I have ipconfig /release and ipconfig /renew with no success. I looked at my DHCP scope options and Reservations and found that some of the problem machines were on the reservations list so I deleted those machines, restarted/powered off but when they come back up still the same symptoms.  

What can I do to fix this issue or where do I start?
I am finding that a server I am responsible for is having utilization problems but by the time I get notified and pop on it remotely the problem is gone. Is there a simple logger/notifier that will record high utilization by processes and store the info so I can see it?
The Google Cloud Print Connector service is stuck "starting." I found the command to kill the service but I need to find the Process ID. I found a command:

sc queryex [servicename]

I type "sc queryex Cloud Print Connector" but it returns a invalid option error.

If I drop the service name, it shows all services BUT the list is too long and it only shows the services from R to Z.

Can anyone tell me how to find the PID or a way to pause the sc queryex to show the a-c services?

Thank you

I have successfully V2V a windows 2012 (64 bit) server to VMware. After has been assigned NIC and assigned IP, the VM can get the IP but in the TCP/IPV4 setting in empty. It will still show "Obtain an IP address automatically". Please refer  the attachment.
got a windows server 2012 . hyper v - running 7 vm
got 2 disks in hyper v “c &d”

all vm vhdx are in “d” drive
but for 3 vm- vmrs&vmcx are in “c” drive.
c drive space is too low. vmrs file has filled up close to 50gb. ( I know they are all ram sizes of each vm)

how do I move vmrs&vmcx files to “d” drive ???  
and second question - how do I find out which vmrs file is associated with which vm ??
Cumulative Updates Vs Update Rollups.

I have run int these terms a lot but cannot tell the difference : Cumulative Updates and Update Rollups.

Any clarifications ?

Thank you

Trying to add user to built in print operaters group in AD when added unable to manage documents or manage printers permissions keeps asking for admin password using server 2012 std. Would like certain users to be able to manage printers and print. Any idea what I could be doing wrong please?

Thanks in advance.

Windows Server 2012





Windows Server 2012 is the server version of Windows 8 and the successor to Windows Server 2008 R2. Windows Server 2012 is the first version of Windows Server to have no support for Itanium-based computers since Windows NT 4.0. Windows Server 2012, now in its second release (Windows Server 2012 Release 2) includes Foundation, Essentials, Standard and Datacenter, and does not support IA-32 or IA-64 processors.