WSUS

Windows Server Update Services (WSUS), previously known as Software Update Services (SUS), is a computer program developed by Microsoft that enables administrators to manage the distribution of updates and hotfixes released for Microsoft products to computers.

I am running wsus in 2012 r2 server. My wsus server is in 10.1.1.x subnet. I have 3 subnet running on client machines . While PC group in 101.1.x reporting successfully in wsus other two sinners 10.2.1.x and 10.3.1.x not reporting in wsus. Wsus picking up this machine how ever last report dates showing as “not yet reported”. I have tried the troubleshooting like restarting windows update service , stopping firewall, windows updates readiness tool, reset windows update component, Sfax scan.

What could be the reason ?
0
I installed WSUS service on my server and it was working completely fine. But today, when I opened to check of all the users are getting update from WSUS or not it gave me an "Error: Connection Error".

I've checked various comments on internet, they say that remove the role and re-install it again.

Can someone please suggest me some better way to tackle this issue rather then just uninstall and reinstall it again.

Thank You.

WSUS - Connection Error
0
I have 600 machines where windows 7 standard is installed. All machines are getting updates from wsus. All of sudden 30 machines are skipping to detect monthly roll up, security only update and IE11 updates. But these machines successfully detected.net updates and installing it successfully.

I am not sure if this strange behaviour. How comes these machines not willing to take the monthly roll up and ie patches. Wsus report says not applicable. Mabel install days not applicable as well. Preview patch is not installed
1
Hi,

I just start using WSUS 2016. What happen if on a server I update from online and after use WSUS... Is WSUS will be able to see the new updates installed and just push what is missing?

Thanks
0
Hi,

My Windows 2008 r2 can't detect new update from WSUS. It gives me this error:

Windows Update Client failed to detect with error 0x80244010

I delete the folder C:\Windows\SoftwareDistribution
Run:
  • wuauclt /resetauthorization
  • wuauclt /detectnow
  • wuauclt /reportnow

Same error.

What can I do?
0
Hi,

In WSUS except going to each computer groups, is there a way to search a computer and see in which computer group it's part of?

Thanks
0
Hello all,

I have multiple computers in a workgroup environment (50 PCs) all not connected to the internet. I have downloaded the updates and I have the execution files, the question is can I use WSUS to push the updates to all PCs? How do I add the downloaded updates to WSUS.
0
I am currently with Ivanti formally known as Shavlik patch management.  My 3 year is about to expire, what I was paying for 3 years is now what I will have to pay for 1 year so we can not continue with Ivanti.   Does anyone have any recommendations on a patch management system that has a reasonably  price structure?

Thanks.
0
Hello ,

I am looking help on WSUS issue ,Where my WSUS client (windows server 2016 ) not able to report on my WSUS server running Windows 2012 R2  (WSUS 6.3.9600.18228).
On WSUS client name showing windows 10 and status showing NOT reported.

I have performed some basic troubleshooting as mentioned below but it didn't help me.

1. Stop the Automatic Updates service and BITS service.                        
net stop wuauserv                        
net stop bits                        
2. Delete “%windir%\softwaredistribution” directory.                        
3. Start the Automatic Updates service and BITS service. When these two services                         
have been started, they will auto-create “softwaredistribution” and its subfolder                         
at system directory.                        
net start wuauserv                        
net start bits                        
4. Stop the Cryptographic Services                        
5. Rename the C:\windows\System32\catroot2 folder                        
6. After the “%windir%\softwaredistribution” directory has been generated, please                         
let the client contact the WSUS server immediately.                        
wuauclt.exe /resetauthorization /detectnow       

Thanks
0
I have a fresh install of WSUS on a fresh install of Windows Server 2012R2.  I have edited group policy to have our desktops use our internal WSUS server for updates.  The only client showing in the WSUS console is the WSUS server itself.  I tried reinstalling WSUS on Windows Server 2016 and I get identical behavior.  I ran the Solarwinds Diagnostic Tool for the WSUS and the first two sections are fine. The last section, WSUS Server Connectivity, fails with "Cannot Connect - caused by a network infrastructure fault making the Windows Update unavailable ..."

Any assistance would be appreciated.
0
Working on a SBS2011 experiencing the usual SBS WSUS errors that create disk space issues. I decided to clean up the WSUS database by following two articles.

Reinstall WSUS on SBS tried removing from add and remove programs and it errors out. As mentioned in this article I proceeded to the document below to remove the role but have a database question prior to deleting.  

WSUS uninstall is failing I made the changes to the registry mentioned in this article and removed the role which completed successfully. Step 10 states, once WSUS is uninstalled, manually remove the WSUS content and/or database files from the hard drive. This is where I would like to clarify before deleting data. For obvious reasons I want to make sure what I’m deleting will not cause an instability.

My understanding of SQL is it’s installed on the C: partition below where the system databases are displayed. Rather than tamper with the SQL installation the only data I removed here was the log files which grew over 12G. FYI I copied them for further review.

SQL system files located C:\Windows\SYSMSI\SSEE\MSSQL.2005\MSSQL\ with the following folders:
Backup
Binn
Data
Install
LOG (12.8G) cleaned up the log files
SchemaSig

On the D: partition there is D:\WSUS with the following folders:
UpdateServicesPackages
WsusConent
SUSDB.mdb (26.5G)
SUSDB_log.ldf (2.6G)

I opened SQL Studio and see the following SUSDB database
sql
0
Hi I have a test rig. The wsus server is online and we export the files and database to three separate. But identical rigs
Two work.
The other one remains at downloading updates for many days.

The permissions are the same. It’s the same database etc

Also if I rebuild the box it works fine with that export just won’t update next time

Any ideas ?

Windows 2012 r2
0
MSExchageFrontEndTransport Event 1020

¿where should I give permission to the administrator?

Nombre de registro:Application
Origen:        MSExchangeFrontEndTransport
Fecha:         20/11/2018 12:18:07
Id. del evento:1020
Categoría de la tarea:SmtpReceive
Nivel:         Advertencia
Palabras clave:Clásico
Usuario:       No disponible
Equipo:        SRV.contoso.lan
Descripción:
The account 'Contoso\Administrador' provided valid credentials, but is not authorized to use the server; failing authentication.
XML de evento:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="MSExchangeFrontEndTransport" />
    <EventID Qualifiers="32772">1020</EventID>
    <Level>3</Level>
    <Task>1</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2018-11-20T11:18:07.682983400Z" />
    <EventRecordID>14647036</EventRecordID>
    <Channel>Application</Channel>
    <Computer>SVR.contoso.lan</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Contoso\Administrador</Data>
    <Data>Default Frontend SRV</Data>
  </EventData>
</Event>
0
I have an issue with only some updates trying to download to E:\WSUS\WsusContent\WsusContent. The SoftwareDistribution.log says that there is an error creating sub-directories in this path.

The actual path to the content directory is E:\WSUS\WsusContent   *NOT*  E:\WSUS\WsusContent\WsusContent.  All other updates are writing to the correct path.

It's not clear to me where I can "tell" WSUS that it needs to write the updates in question to the correct path or why it's even doing this in the first place.

For grins, I thought I'd run wsusutil.exe and point to E:\WSUS\WsusContent, however, the log file generated indicates that "The new content file location is the same as the old location: E:\WSUS\WsusContent.

Any suggestions?
0
I am very new to scripting. I need a fair wsus powershell report script. The default wsus does not have the option to see installed updates alone for group of machines. It always shows installed / not applicable result.

Can you pls post a working script which produces a decent output ?
0
I have WSUS running on a ConfigMgr server, and ConfigMgr is currently patching clients and servers through ADR's. We're in the process of removing our servers from ConfigMgr management due to costs, clients will remain within ConfigMgr.

My question is, can I use the existing WSUS feature to patch the servers via GPO's? I ask because with ConfigMgr, you basically install WSUS and then don't touch it again. All patch management is done within ConfigMgr. I'm concerned that approving updates within WSUS might start to break things for ConfigMgr.
0
Hello all,
I have a client that has several Windows 7 Pro computers (around 50) that get their updates from WSUS.  
One of the computers refuses to install any updates and give me a 0x80073712 error every time.
Here is what I did to rectify this:
1)   Ran the SUR (System Update Readiness) program.  At first it stated that there were 484 errors (8 from the CSI Manifest Missing and 476 from the CSI payload file Missing).
I went to another computer and copied the c:\windows\winsxs directory to this computer.  Then I ran the SUR and it said that everything was fine.
2)   Rebooted the computer and tried to do the updates and still get the error above.
3)   Ran a Windows fix and it stated that it fixed the 0x80073712 error.  Rebooted the computer and tried to do the updates and still get the same error above.
4)   I went into the CBS log and I get a lot of Failed to internally open package [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE] errors
I have no idea what to do next to fix this error.
Any help would be greatly appreciated.
Thanks,
Kelly W.
0
I have build up a new VM with WSUS role on Windows 2012 (Old WSUS server was on 2008).
On the new server under Administrative Console for WSUS its not showing any computers.
I have named the new server the same as old server, what do i have to do to start seeing computers under WSUS?
All computers are pointing to new server on group policy.

Thanks
0
Hello Experts,

I am having trouble implementing a Group Policy for a WSUS Server.


C:\Users\mzadmin>gpresult /H GPReport.html
INFO: The user does not have RSoP data.

I need to know how to fix that?  Where to and what to check.

Thank you
0
Hi

I have approved all the available updates in wsus. But still my client machines showing needed updates count.

The installed % is always 99. I want to show each client machine is 100%.

What could be wrong .
0
Hello experts

I would like get details if windows update history for multiple desktops. Is there any way to do ?

I mean for windows 7, open windows update -) windows update history. I want to get this details. How do we get it ?


Thanks
0
Hey fellow experts!

With WSUS, I need to deploy a ton of patches to computers in a test OU. If the updates run fine, how do I 'Re-deploy' the same set of updates to my users? I don't know of a way to go back in and approve them again, or how to find the EXACT updates? Any help is appreciated. Thanks in advance, guys.
0
I'm experiencing several issue with computer in my environment receiving updates from WSUS. The updates download but remain at 0%. When rebooting, the computer attempts to install updates taking a while longer than expected and shows windows is updating. I have to manually shut this down as the it is sometimes hours and no updates are installed. I've completed the following:


1. Run Windows Troubleshooter for Windows Updates
2. Checked the BITS, which continuously switched from automatic to manual and stops servers. Windows Updates remains at manual and services are started for this worked.
3. Settings for Updates have been verified on the workstation for how updates are selected with other pc on the network.
4. Should Windows defender remain enabled although we use a third party anti virus program (Trend Micro Worry Free Business security)?


What other information I can offer is this workstation was upgraded from Windows 7 to 10. I appreciate any feedback with this inquiry as it will help with future install of Windows 10 in our environment.
0
when can I expect to see an update appear as available on windows update and WSUS? MS released cumulative update KB4458469 on September 20, I check for updates from a computer and it finds nothing , my WSUS syncs everyday but it's not there but the update is available in the windows update catalogue and installs manually just fine.

Do they delay the release to windows update and wsus?

Thanks
0
I'm deploying WSUS via GPO.
- WSUS is working well including ccorrespondig download packages.
- GPO for Automatic Update on Domain controler setting as following :
  1) Configure automatic updating: 4- Auto download and schedule the install
  2) Schedule install day: 0- Every day, Schedule time: 10:00
  RESULT: ALL clients was affected/managed by GPO, but the TIME check update incorrect. They always showed last checked update at 7:50 AM everyday. (See attached file)
What am i missing ?
Anyone can help me ? Thanks.

Enviroment:
DC and WSUS: Windows Server 2012 Std
Clients: Windows 10, 7 and Server 2012 Std.
0

WSUS

Windows Server Update Services (WSUS), previously known as Software Update Services (SUS), is a computer program developed by Microsoft that enables administrators to manage the distribution of updates and hotfixes released for Microsoft products to computers.

Top Experts In
WSUS
<
Monthly
>