Visio Viewer not working

techtook
techtook used Ask the Experts™
on
Hi,

I have installed the Visio 2003 viewer from the Microsoft website and the install seems to have gone fine. The VSD files in the "My Documents" now show up with a Visio icon instead of a unknown icon (which I had before installing the viewer).

However, when i double click any file, it opens up IE and shows a tiny icon(not the contents of the file but a unrelated icon) on the top left hand side of the page but no diagram.

Any help will be greatly appreciated.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Will SzymkowskiSenior Solution Architect
Most Valuable Expert 2015
Top Expert 2015

Commented:
Hello there,

Might be a long shot but, have you tried to open Visio and then from there click File>Open and choose one of the files you want to view. Also try holding shift and right click the file you want to view then go to "Open With.." and reselect the Visio viewer. If all else fails you could try reinstalling the program.

Keep us updated
Commented:
The Visio viewer is nothing more than an Internet Explorer plugin - I am guessing the activeX associated with the viewer was blocked or broken.  You may also have a conflict with any other IE-toolbars or security addons too.  Try and disable these extras if there are any...

Check Control Panel > Internet Options (Or in IE, Tools > Internet Options) > Programs tab > Manage Add ons > look for 'Microsoft Visio Document', and ensure it's Enabled.  (can also look around here for toolbars that can be disabled)

If still not working, try going into Add/remove programs, select the Visio viewer, click change > and try reinstalling the applicaton.

When you open up the Visio document, you may receive an IE security pop-up, to which you have to approve the active content.  My IE7 testing did not do this, but IE6 did.

Good luck!
- Mike (OB)

Commented:
This issue is due to the following Windows Update:
MS09-055: Cumulative Security Update of ActiveX Kill Bits

Here is the REAL solution:
Locate the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility
Find the {279D6C9A-652E-4833-BEFC-312CA8887857} subkey and then delete it

However if you reinstall KB973525 or it repairs itself, the above reg key will be put back and the problem will reoccur meaning you have to delete the key again.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
this isn't my question, but I came across it while trying to resolve the same problem with visio viewer 2007 on XP SP2 with IE6.  I tried reinstall, reparir, updates etc, nothing worked.  WOW-DS's resolution above resolved the problem though so thanks so much for that.  Much apprecaited

Commented:
WOW-DS' fix worked to allow Visio Viewer to work as normal.
It had previously shown a red x in the corner and not worked.

quote
"Here is the REAL solution:
Locate the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility
Find the {279D6C9A-652E-4833-BEFC-312CA8887857} subkey and then delete it"
Doing this worked for me....thanks WOW-DS.

Here is the REAL solution:
Locate the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility
Find the {279D6C9A-652E-4833-BEFC-312CA8887857} subkey and then delete it

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial